<!DOCTYPE html><html lang="en-US"><head ><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /><title>Ex-Solus Dev is Creating a Truly Modern Linux Distribution</title><meta name="dc.title" content="Ex-Solus Dev is Creating a Truly Modern Linux Distribution" /><meta name="dc.description" content="The ex-developer of Solus Linux has announced Serpent Linux, a truly modern Linux distribution which is not dependent on GNU toolchain." /><meta name="dc.relation" content="https://itsfoss.com/serpent-os-announcement/" /><meta name="dc.source" content="https://itsfoss.com/" /><meta name="dc.language" content="en_US" /><meta name="description" content="The ex-developer of Solus Linux has announced Serpent Linux, a truly modern Linux distribution which is not dependent on GNU toolchain." /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://itsfoss.com/serpent-os-announcement/" /><meta name="author" content="Abhishek Prakash"><meta property="og:url" content="https://itsfoss.com/serpent-os-announcement/" /><meta property="og:site_name" content="It&#039;s FOSS" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Ex-Solus Dev is Now Creating a Truly Modern Linux Distribution Called Serpent Linux" /><meta property="og:description" content="The ex-developer of Solus Linux has announced Serpent Linux, a truly modern Linux distribution which is not dependent on GNU toolchain." /><meta property="og:image" content="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?fit=800%2C450&ssl=1" /><meta property="og:image:secure_url" content="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?fit=800%2C450&ssl=1" /><meta name="twitter:card" content="summary_large_image"><meta name="twitter:site" content="@itsfoss2" /><meta name="twitter:creator" content="@itsfoss2" /><meta name="twitter:title" content="Ex-Solus Dev is Now Creating a Truly Modern Linux Distribution Called Serpent Linux" /><meta name="twitter:description" content="The ex-developer of Solus Linux has announced Serpent Linux, a truly modern Linux distribution which is not dependent on GNU toolchain." /><meta name="twitter:image:src" content="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?fit=800%2C450&ssl=1" /><link rel='dns-prefetch' href='//static.apester.com' /><link rel='dns-prefetch' href='//a.omappapi.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Feed" href="http://feeds.feedburner.com/ItsFoss" /><link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Comments Feed" href="https://itsfoss.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Ex-Solus Dev is Now Creating a Truly Modern Linux Distribution Called Serpent Linux Comments Feed" href="https://itsfoss.com/serpent-os-announcement/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='atomic-blocks-fontawesome-css' href='https://itsfoss.com/wp-content/plugins/atomic-blocks/dist/assets/fontawesome/css/all.min.css?ver=1591844478' type='text/css' media='all' /><link rel='stylesheet' id='genesis-sample-css' href='https://itsfoss.com/wp-content/themes/genesis-sample/style.css?ver=3.0.1' type='text/css' media='all' /><style id='genesis-sample-inline-css' type='text/css'>a,.entry-title a:focus,.entry-title a:hover,.genesis-nav-menu a:focus,.genesis-nav-menu a:hover,.genesis-nav-menu .current-menu-item>a,.genesis-nav-menu .sub-menu .current-menu-item>a:focus,.genesis-nav-menu .sub-menu .current-menu-item>a:hover,.menu-toggle:focus,.menu-toggle:hover,.sub-menu-toggle:focus,.sub-menu-toggle:hover{color:#00b6ba}button:focus,button:hover,input[type="button"]:focus,input[type="button"]:hover,input[type="reset"]:focus,input[type="reset"]:hover,input[type="submit"]:focus,input[type="submit"]:hover,input[type="reset"]:focus,input[type="reset"]:hover,input[type="submit"]:focus,input[type="submit"]:hover,.site-container div.wpforms-container-full .wpforms-form input[type="submit"]:focus,.site-container div.wpforms-container-full .wpforms-form input[type="submit"]:hover,.site-container div.wpforms-container-full .wpforms-form button[type="submit"]:focus,.site-container div.wpforms-container-full .wpforms-form button[type="submit"]:hover,.button:focus,.button:hover{background-color:#00b6ba;color:#333}@media only screen and (min-width:960px){.genesis-nav-menu>.menu-highlight>a:hover,.genesis-nav-menu>.menu-highlight>a:focus,.genesis-nav-menu>.menu-highlight.current-menu-item>a{background-color:#00b6ba;color:#333}}</style><link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify}</style><link rel='stylesheet' id='atomic-blocks-style-css-css' href='https://itsfoss.com/wp-content/plugins/atomic-blocks/dist/blocks.style.build.css?ver=1591844478' type='text/css' media='all' /><link rel='stylesheet' id='ugb-style-css-css' href='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks.css?ver=2.6.1' type='text/css' media='all' /><style id='ugb-style-css-inline-css' type='text/css'>:root{--content-width:px}</style><link rel='stylesheet' id='ugb-style-css-deprecated-css' href='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks_deprecated.css?ver=2.6.1' type='text/css' media='all' /><link rel='stylesheet' id='ugb-style-css-premium-css' href='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks__premium_only.css?ver=2.6.1' type='text/css' media='all' /><link rel='stylesheet' id='ugb-style-css-premium-deprecated-css' href='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks_deprecated__premium_only.css?ver=2.6.1' type='text/css' media='all' /><link rel='stylesheet' id='siq_icon_css-css' href='https://itsfoss.com/wp-content/plugins/searchiq/assets/3.5/css/frontend/icon-moon.css?ver=1593607807' type='text/css' media='all' /><link rel='stylesheet' id='siq_front_css-css' href='https://itsfoss.com/wp-content/plugins/searchiq/assets/3.5/css/frontend/stylesheet.css?ver=1593607807' type='text/css' media='all' /><link rel='stylesheet' id='socialsnap-styles-css' href='https://itsfoss.com/wp-content/plugins/socialsnap-plus/assets/css/socialsnap.css?ver=1.1.8.3' type='text/css' media='all' /><link rel='stylesheet' id='wp-coupons-styles-css' href='https://itsfoss.com/wp-content/plugins/wp-coupons/css/style.css?ver=1.7.1' type='text/css' media='all' /><link rel='stylesheet' id='wp-fs-publisher-plugin-css' href='https://itsfoss.com/wp-content/plugins/wp-fs-publisher-plugin-master/public/css/wp-fs-publisher-plugin-public.css?ver=1.1.4' type='text/css' media='all' /><link rel='stylesheet' id='genesis-sample-fonts-css' href='https://fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C400i%2C600%2C700&#038;display=swap&#038;ver=3.0.1' type='text/css' media='all' /><link rel='stylesheet' id='dashicons-css' href='https://c0.wp.com/c/5.4.2/wp-includes/css/dashicons.min.css' type='text/css' media='all' /><link rel='stylesheet' id='genesis-sample-gutenberg-css' href='https://itsfoss.com/wp-content/themes/genesis-sample/lib/gutenberg/front-end.css?ver=3.0.1' type='text/css' media='all' /><style id='genesis-sample-gutenberg-inline-css' type='text/css'>.ab-block-post-grid .ab-post-grid-items h2 a:hover{color:#00b6ba}.site-container .wp-block-button .wp-block-button__link{background-color:#00b6ba}.wp-block-button .wp-block-button__link:not(.has-background),.wp-block-button .wp-block-button__link:not(.has-background):focus,.wp-block-button .wp-block-button__link:not(.has-background):hover{color:#333}.site-container .wp-block-button.is-style-outline .wp-block-button__link{color:#00b6ba}.site-container .wp-block-button.is-style-outline .wp-block-button__link:focus,.site-container .wp-block-button.is-style-outline .wp-block-button__link:hover{color:#23d9dd}.site-container .has-small-font-size{font-size:12px}.site-container .has-normal-font-size{font-size:18px}.site-container .has-large-font-size{font-size:20px}.site-container .has-larger-font-size{font-size:24px}.site-container .has-theme-primary-color,.site-container .wp-block-button .wp-block-button__link.has-theme-primary-color,.site-container .wp-block-button.is-style-outline .wp-block-button__link.has-theme-primary-color{color:#00b6ba}.site-container .has-theme-primary-background-color,.site-container .wp-block-button .wp-block-button__link.has-theme-primary-background-color,.site-container .wp-block-pullquote.is-style-solid-color.has-theme-primary-background-color{background-color:#00b6ba}.site-container .has-theme-secondary-color,.site-container .wp-block-button .wp-block-button__link.has-theme-secondary-color,.site-container .wp-block-button.is-style-outline .wp-block-button__link.has-theme-secondary-color{color:#00b6ba}.site-container .has-theme-secondary-background-color,.site-container .wp-block-button .wp-block-button__link.has-theme-secondary-background-color,.site-container .wp-block-pullquote.is-style-solid-color.has-theme-secondary-background-color{background-color:#00b6ba}</style><link rel='stylesheet' id='aawp-styles-css' href='https://itsfoss.com/wp-content/plugins/aawp/public/assets/css/styles.min.css?ver=3.12.3' type='text/css' media='all' /><link rel='stylesheet' id='forget-about-shortcode-buttons-css' href='https://itsfoss.com/wp-content/plugins/forget-about-shortcode-buttons/public/css/button-styles.css?ver=2.1.2' type='text/css' media='all' /><link rel='stylesheet' id='tcm-front-styles-css-css' href='https://itsfoss.com/wp-content/plugins/thrive-comments/assets/css/styles.css?ver=1.4.3.1' type='text/css' media='all' /><link rel='stylesheet' id='wp-auth-check-css' href='https://c0.wp.com/c/5.4.2/wp-includes/css/wp-auth-check.min.css' type='text/css' media='all' /><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://itsfoss.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}.wp-has-aspect-ratio .rll-youtube-player{position:absolute;padding-bottom:0;width:100%;height:100%;top:0;bottom:0;left:0;right:0}</style><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.6.1/css/jetpack.css' type='text/css' media='all' /> <script type='text/javascript'>/* <![CDATA[ */ var stackable = {"restUrl":"https:\/\/itsfoss.com\/wp-json\/"}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks.js?ver=2.6.1'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/frontend_blocks__premium_only.js?ver=2.6.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var configuration = {"rendererBaseUrl":"https:\/\/renderer.apester.com"}; /* ]]> */</script> <script type='text/javascript' async="async" src='https://static.apester.com/js/sdk/latest/apester-javascript-sdk.min.js?ver=5.4.2'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery-migrate.min.js'></script> <script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/thrive-comments/assets/js/libs-frontend.min.js?ver=1.4.3.1'></script> <style>.eaa-clean{padding:0!important;border:none!important}.eaa-ad.alignleft{margin-right:10px}.eaa-ad.alignright{margin-left:10px}.eaa-ad.debug{background:peachpuff;border:solid 2px red;box-sizing:border-box}</style><link rel='https://api.w.org/' href='https://itsfoss.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://itsfoss.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://itsfoss.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='13 Things To Do After Installing Linux Mint 20' href='https://itsfoss.com/things-to-do-after-installing-linux-mint-20/' /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://itsfoss.com/?p=80536' /><style type="text/css">.aawp .aawp-tb__row--highlight{background-color:#256aaf}.aawp .aawp-tb__row--highlight{color:#256aaf}.aawp .aawp-tb__row--highlight a{color:#256aaf}</style> <script type="text/javascript">(function () {
                            window.siqConfig = {
                                engineKey: "f72c700acb39b7cb641df8a9ef845ffc"
                            };
                            window.siqConfig.baseUrl = "//pub.searchiq.co/";
                            var script = document.createElement("SCRIPT");
                            script.src = window.siqConfig.baseUrl + 'js/container/siq-container-2.js?cb=' + (Math.floor(Math.random()*999999)) + '&engineKey=' + siqConfig.engineKey;
                            script.id = "siq-container";
                            document.getElementsByTagName("HEAD")[0].appendChild(script);
                        })();</script><style>#thrive-comments .tcm-color-ac,#thrive-comments .tcm-color-ac span{color:#00b6ba}#thrive-comments .tcm-background-color-ac,#thrive-comments .tcm-background-color-ac-h:hover span,#thrive-comments .tcm-background-color-ac-active:active{background-color:#00b6ba}#thrive-comments .tcm-border-color-ac{border-color:#00b6ba;outline:none}#thrive-comments .tcm-border-color-ac-h:hover{border-color:#00b6ba}#thrive-comments .tcm-border-bottom-color-ac{border-bottom-color:#00b6ba}#thrive-comments .tcm-svg-fill-ac{fill:#00b6ba}#thrive-comments textarea:focus,#thrive-comments input:focus{border-color:#00b6ba;box-shadow:inset 0 0 3px #00b6ba}#thrive-comments a{color:#00b6ba}#thrive-comments button,#thrive-comments #tcm-login-up,#thrive-comments #tcm-login-down{color:#00b6ba;border-color:#00b6ba}#thrive-comments button:hover,#thrive-comments button:focus,#thrive-comments button:active{background-color:#00b6ba}</style><style type="text/css"></style><link rel='dns-prefetch' href='//c0.wp.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/> <script data-cfasync="false" type="text/javascript">var freestar = freestar || {};
    freestar.hitTime = Date.now();
    freestar.queue = freestar.queue || [];
    freestar.config = freestar.config || {};
    freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;

    // Tag IDs set here, must match Tags served in the Body for proper setup
    freestar.config.enabled_slots = [
        "itsfoss_728x90_320x50_ATF",
        "itsfoss_300x250_Sidebar1",
        "itsfoss_300x250_300x600_Sidebar2"
    ];

    !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/itsfoss";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);</script> <meta name="ahrefs-site-verification" content="f8a49089ffadfb2c5b3f7b2e1c37e30d9c7a78c3c78a2d2950300ce64ed9cd27"> <script type="text/javascript" src="https://a.pub.network/unumcarta/unumcarta.js"></script><meta property="article:publisher" content="https://www.facebook.com/itsfoss" /><style type="text/css" id="tve_global_variables"></style><style type="text/css">html:not(.jetpack-lazy-images-js-enabled):not(.js) .jetpack-lazy-image{display:none}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <style type="text/css" id="thrive-default-styles"></style><link rel="icon" href="https://i1.wp.com/itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name.png?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name.png?fit=192%2C192&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name.png?fit=180%2C180&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name.png?fit=270%2C270&#038;ssl=1" /><style type="text/css" id="wp-custom-css">.entry-content code{background-color:#00B6BA;color:#fff;padding:0 .2em}.entry-content pre{background-color:#00B6BA;color:#fff;padding:.5em 1em;overflow:auto;word-wrap:normal}::-moz-selection{background-color:#B2D531;color:#fff}::selection{background-color:#B2D531;color:#fff}.highlight>a{background-color:#ff0;color:#000}.wp-caption-text{text-align:center}:target::before{content:"";display:block;height:150px;margin:-150px 0 0}.wp-block-image img{vertical-align:middle}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body class="post-template-default single single-post postid-80536 single-format-standard wp-embed-responsive aawp-custom header-full-width content-sidebar genesis-breadcrumbs-visible genesis-footer-widgets-visible first-block-core-paragraph" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li><li><a href="#genesis-footer-widgets" class="screen-reader-shortcut"> Skip to footer</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://itsfoss.com/">It&#039;s FOSS</a></p><p class="site-description" itemprop="description">A Linux and Open Source Web Portal</p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-one-menu-for-all" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-10108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10108"><a href="https://itsfoss.com/about/" itemprop="url"><span itemprop="name">About</span></a><ul class="sub-menu"><li id="menu-item-17559" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17559"><a href="https://itsfoss.com/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li><li id="menu-item-17560" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17560"><a href="https://itsfoss.com/get-featured-on-its-foss/" itemprop="url"><span itemprop="name">Get Featured On It&#8217;s FOSS</span></a></li></ul></li><li id="menu-item-10119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10119"><a href="https://itsfoss.com/category/linux/" itemprop="url"><span itemprop="name">Linux</span></a><ul class="sub-menu"><li id="menu-item-10121" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10121"><a href="https://itsfoss.com/category/news/" itemprop="url"><span itemprop="name">Linux News</span></a></li><li id="menu-item-10112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10112"><a href="https://itsfoss.com/category/apps/" itemprop="url"><span itemprop="name">Software</span></a></li><li id="menu-item-10116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10116"><a href="https://itsfoss.com/category/gadgets/" itemprop="url"><span itemprop="name">Gadgets</span></a></li><li id="menu-item-10113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10113"><a href="https://itsfoss.com/category/desktop/" itemprop="url"><span itemprop="name">Desktop Customization</span></a></li></ul></li><li id="menu-item-10118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10118"><a href="https://itsfoss.com/category/how-to/" itemprop="url"><span itemprop="name">Linux Tutorials</span></a></li><li id="menu-item-17561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17561"><a href="https://itsfoss.com/category/list/" itemprop="url"><span itemprop="name">Top X</span></a></li><li id="menu-item-63693" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-63693"><a href="https://shop.itsfoss.com/" itemprop="url"><span itemprop="name">Shop</span></a></li><li id="menu-item-10130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10130"><a href="http://itsfoss.tradepub.com/category/information-technology-servers-and-linux-server-os/806/" itemprop="url"><span itemprop="name">eBooks in $0</span></a></li><li id="menu-item-54578" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54578"><a href="https://itsfoss.com/deals/" itemprop="url"><span itemprop="name">Linux Deals</span></a></li><li id="menu-item-27195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27195"><a title="If you see a grammatical or technical error, please notify us on this link." href="https://itsfoss.com/feedback/" itemprop="url"><span itemprop="name">Article needs update?</span></a></li><li id="menu-item-siq-selectbox" class="menu-item " style=" top:15px; "><div id="siq-menu-searchbox-wrap" class="siq-menu-searchbox-wrap " ><div id="siq-expsearch-cont" class="siq-expsearch-cont"><form class="siq-expsearch" action="https://itsfoss.com"> <input type="search" placeholder="Search" name="s" class="siq-expsearch-input"> <span class="siq-expsearch-icon" style='color:#000000'></span></form></div></div></li></ul></div></nav></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://itsfoss.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://itsfoss.com/category/news/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">News</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> Ex-Solus Dev is Now Creating a Truly Modern Linux Distribution Called Serpent Linux</div><article class="post-80536 post type-post status-publish format-standard has-post-thumbnail category-news entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Ex-Solus Dev is Now Creating a Truly Modern Linux Distribution Called Serpent Linux</h1><p class="entry-meta">Last updated <time class="entry-modified-time" itemprop="dateModified" datetime="2020-07-01T09:36:18+05:30">July 1, 2020</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://itsfoss.com/author/abhishek/" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">Abhishek Prakash</span></a></span> <span class="entry-comments-link"><a href="https://itsfoss.com/serpent-os-announcement/#comments">17 Comments</a></span></p></header><div class="entry-content" itemprop="text"><p><a rel="noreferrer noopener" href="https://itsfoss.com/ikey-doherty-serpent-interview/" target="_blank">Ikey Doherty</a>, the developer who once created the independent Linux distribution Solus has announced his new project: Serpent OS.</p><p><a href="https://www.serpentos.com/" target="_blank" rel="noreferrer noopener">Serpent OS</a> is a Linux distribution that DOES NOT want to be categorized as &#8220;lightweight, user-friendly, privacy-focused Linux desktop distribution&#8221;.</p><p>Instead, Serpent OS has &#8220;different goals from the mainstream offering&#8221;. How? Read on.</p><h2>Serpent OS: The making of a &#8220;truly modern&#8221; Linux distribution</h2><div class="wp-block-image"><figure class="aligncenter size-full"><img data-attachment-id="80542" data-permalink="https://itsfoss.com/serpent-os-announcement/serpent-linux/" data-orig-file="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="serpent-linux" data-image-description data-medium-file="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?fit=800%2C450&amp;ssl=1" src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?ssl=1" alt="Serpent Linux" class="wp-image-80542 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?w=800&amp;ssl=1 800w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?resize=768%2C432&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="80542" data-permalink="https://itsfoss.com/serpent-os-announcement/serpent-linux/" data-orig-file="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="serpent-linux" data-image-description="" data-medium-file="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?fit=800%2C450&amp;ssl=1" src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?ssl=1" alt="Serpent Linux" class="wp-image-80542" srcset="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?w=800&amp;ssl=1 800w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/07/serpent-linux.png?resize=768%2C432&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" data-recalc-dims="1" /></noscript></figure></div><p>Serpent takes distro-first, compatibility-later approach. This lets them take some really bold decisions.</p><p>Ikey says that it this project will not tolerate for negative actors holding Linux back. For example, NVIDIA&#8217;s lack of support for accelerated Wayland support on their GPUs will not be tolerated and NVIDIA proprietary drivers will be blacklisted from the distribution.</p><p>Here&#8217;s a proposed plan for the Serpent Linux project (taken from <a href="https://www.serpentos.com/about/" target="_blank" rel="noreferrer noopener">their website</a>):</p><div id="eaa_after_nth_p" class="eaa-wrapper eaa_after_nth_p eaa_desktop"><div class="eaa-ad " style=""> <script type="text/javascript" language="javascript" src="https://live.sekindo.com/live/liveView.php?s=95336&cbuster=[CACHE_BUSTER]&pubUrl=[PAGE_URL_ENCODED]&x=800&y=542&vp_content=plembedbc1rugspthjo&vp_template=3379"></script> </div></div><ul><li>No more usrbin split</li><li>100% clang-built throughout (including kernel)</li><li>musl as libc, relying on compiler optimisations instead of inline asm</li><li>libc++ instead of libstdc++</li><li>LLVM’s binutils variants (lld, as, etc.)</li><li>Mixed source/binary distribution</li><li>Moving away from x86_64-generic baseline to newer CPUs, including Intel and AMD specific optimisations</li><li>Capability based subscriptions in package manager (Hardware/ user choice / etc)</li><li><code>UEFI</code> only. No more legacy boot.</li><li>Completely open source, down to the bootstrap / rebuild scripts</li><li>Seriously optimised for serious workloads.</li><li>Third party applications reliant on containers only. No compat-hacks</li><li>Wayland-only. X11 compatibility via containers will be investigated</li><li>Fully stateless with management tools and upstreaming of patches</li></ul><p>Ikey boldly claims that Serpent Linux is not Serpent GNU/Linux because it is not going to be dependent on a GNU toolchain or runtime.</p><p>The development for Serpent OS project starts by the end of July. There is no definite timeline of the final stable release.</p><h2>Too high claims? But Ikey has done it in the past</h2><p>You may doubt if Serpent OS will see the light of the day and if it would be able to keep all the promises it made.</p><p>But Ikey Doherty has done it in the past. If I remember correctly, he first created SolusOS based on Debian. He discontinued the <a rel="noreferrer noopener" href="https://distrowatch.com/table.php?distribution=solusos" target="_blank">Debian-based SolusOS</a> in 2013 before it even reached the beta stage.</p><p>He then went out to create <a rel="noreferrer noopener" href="https://itsfoss.com/beta-evolve-os-released/" target="_blank">evolve OS</a> from scratch instead of using another distribution as base. Due to some naming copyright issues, the project name was changed to Solus (yes, the same old name). <a rel="noreferrer noopener" href="https://itsfoss.com/ikey-leaves-solus/" target="_blank">Ikey quit the Solus projec</a><a href="https://itsfoss.com/ikey-leaves-solus/" target="_blank" rel="noreferrer noopener">t</a><a rel="noreferrer noopener" href="https://itsfoss.com/ikey-leaves-solus/" target="_blank"> in 2018</a> and other devs now handle the project.</p><p>Solus is an independent Linux distribution that gave us the beautiful Budgie desktop environment.</p><p>Ikey has done it in the past (with the help of other developers, of course). He should be able to pull this one off as well.</p><p class="has-large-font-size"><strong>Yay or Nay?</strong></p><p>What do you think of this Serpent Linux? Do you think it is time for developers to take a bold stand and develop the operating system with the future in the mind rather than holding on to the past? Do share your views.</p> <br><div class="apester-media" data-random="5caa056167b3b4fc52f9ace9" data-context="true" data-fallback="true" ></div><span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span><span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span></p><div class="ss-inline-share-wrapper ss-hover-animation-fade ss-with-counter-border ss-inline-total-counter-left ss-left-inline-content ss-regular-icons ss-with-spacing ss-slanted-icons ss-both-labels"><p class="ss-social-share-label"> <span>Like what you read? Please share it with others.</span></p><div class="ss-inline-share-content"><div class="ss-inline-counter"> <span class="ss-total-counter ss-total-shares ss-share-inline_content-total-shares" data-ss-ss-post-id="80536"> <span>22</span> <span>Shares</span> </span></div><ul class="ss-social-icons-container"><li class=""> <a href="#" data-ss-ss-link="https://www.facebook.com/sharer.php?t=Ex-Solus%20Dev%20is%20Now%20Creating%20a%20Truly%20Modern%20Linux%20Distribution%20Called%20Serpent%20Linux&u=https%3A%2F%2Fitsfoss.com%2Fserpent-os-announcement%2F" class="ss-facebook-color" rel="nofollow noopener" data-ss-ss-network-id="facebook" data-ss-ss-post-id="80536" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://itsfoss.com/serpent-os-announcement/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss ss-facebook"></i> <span class="ss-network-label">Facebook</span> <span class="ss-network-count"> 0 </span> </span> </a></li><li class=""> <a href="#" data-ss-ss-link="https://twitter.com/intent/tweet?text=Ex-Solus+Dev+is+Now+Creating+a+Truly+Modern+Linux+Distribution+Called+Serpent+Linux&url=https%3A%2F%2Fitsfoss.com%2Fserpent-os-announcement%2F&via=itsfoss2" class="ss-twitter-color" rel="nofollow noopener" data-ss-ss-network-id="twitter" data-ss-ss-post-id="80536" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://itsfoss.com/serpent-os-announcement/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss ss-twitter"></i> <span class="ss-network-label">Twitter</span> <span class="ss-network-count"> 20 </span> </span> </a></li><li class=""> <a href="#" data-ss-ss-link="https://www.linkedin.com/shareArticle?title=Ex-Solus%20Dev%20is%20Now%20Creating%20a%20Truly%20Modern%20Linux%20Distribution%20Called%20Serpent%20Linux&url=https%3A%2F%2Fitsfoss.com%2Fserpent-os-announcement%2F&mini=true" class="ss-linkedin-color" rel="nofollow noopener" data-ss-ss-network-id="linkedin" data-ss-ss-post-id="80536" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://itsfoss.com/serpent-os-announcement/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss ss-linkedin"></i> <span class="ss-network-label">LinkedIn</span> <span class="ss-network-count"> 0 </span> </span> </a></li><li class=""> <a href="#" data-ss-ss-link="https://www.reddit.com/submit?title=Ex-Solus%20Dev%20is%20Now%20Creating%20a%20Truly%20Modern%20Linux%20Distribution%20Called%20Serpent%20Linux&url=https%3A%2F%2Fitsfoss.com%2Fserpent-os-announcement%2F" class="ss-reddit-color" rel="nofollow noopener" data-ss-ss-network-id="reddit" data-ss-ss-post-id="80536" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://itsfoss.com/serpent-os-announcement/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss ss-reddit"></i> <span class="ss-network-label">Reddit</span> <span class="ss-network-count"> 0 </span> </span> </a></li></ul></div></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://itsfoss.com/category/news/" rel="category tag">News</a></span></p></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt src="https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=90&#038;d=mm&#038;r=g" class="avatar avatar-90 photo jetpack-lazy-image" height="90" width="90" data-lazy-srcset="https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=180&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=90&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=90&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=180&#038;d=mm&#038;r=g 2x' class='avatar avatar-90 photo' height='90' width='90' /></noscript><h4 class="author-box-title">About <span itemprop="name">Abhishek Prakash</span></h4><div class="author-box-content" itemprop="description"><p>I am a professional software developer, and founder of <i>It's FOSS</i>. I am an avid Linux lover and open source enthusiast. I use Ubuntu and believe in sharing knowledge. Apart from Linux, I love classic detective mysteries. I'm a huge fan of Agatha Christie's work.</p></div></section><div id="comments" class="comments-compat-genesis-sample"><div id="thrive-comments" class="clearfix"><div class="tcm-dot-loader"> <span class="inner1"></span> <span class="inner2"></span> <span class="inner3"></span></div><div class="thrive-comments-content"><div class="tcm-comments-filter"></div><div class="tcm-comments-create" id="respond"></div><div class="tcm-comments-list"><li id="comment-338372" class="comment even thread-even depth-1"><article id="div-comment-338372" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <img alt src="https://secure.gravatar.com/avatar/e09a2cd73f960c16782d1f264728e320?s=32&#038;d=mm&#038;r=g" class="avatar avatar-32 photo jetpack-lazy-image" height="32" width="32" data-lazy-srcset="https://secure.gravatar.com/avatar/e09a2cd73f960c16782d1f264728e320?s=64&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/e09a2cd73f960c16782d1f264728e320?s=32&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/e09a2cd73f960c16782d1f264728e320?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e09a2cd73f960c16782d1f264728e320?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript> <b class="fn">Beerloverme</b> <span class="says">says:</span></div><div class="comment-metadata"> <a href="https://itsfoss.com/serpent-os-announcement/#comments/338372"> <time datetime="2020-07-01T16:41:07+05:30"> July 1, 2020 at 4:41 pm </time> </a></div></footer><div class="comment-content"><p>It sounds promising! I am looking forward to see how this project develops.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://itsfoss.com/serpent-os-announcement/?replytocom=338372#respond' data-commentid="338372" data-postid="80536" data-belowelement="div-comment-338372" data-respondelement="respond" aria-label='Reply to Beerloverme'>Reply</a></div></article></li></div><div class="tcm-lazy-comments"></div></div></div></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="socialsnap-social-followers-widget-4" class="widget socialsnap-social-followers-widget"><div class="widget-wrap"><h4 class="ss-follow-total-counter"> <strong>193.8K</strong> Followers</h4><div class="ss-follow-wrapper ss-clearfix ss-regular-buttons ss-columns-1 ss-network-style"><div class="ss-follow-column" data-ss-sf-network-id="facebook"> <a href="https://facebook.com/itsfoss/" class="ss-follow-network ss-facebook-color" rel="nofollow noopener" aria-label="facebook" target="_blank"> <i class="ss ss-facebook"></i> <span class="ss-follow-network-label">Follow us on Facebook</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">115K</span> <span class="ss-follow-network-count-label">Followers</span> </span> </a></div><div class="ss-follow-column" data-ss-sf-network-id="youtube"> <a href="https://www.youtube.com/channel/UCEU9D6KIShdLeTRyH3IdSvw" class="ss-follow-network ss-youtube-color" rel="nofollow noopener" aria-label="youtube" target="_blank"> <i class="ss ss-youtube"></i> <span class="ss-follow-network-label">Follow us on YouTube</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">38.3K</span> <span class="ss-follow-network-count-label">Followers</span> </span> </a></div><div class="ss-follow-column" data-ss-sf-network-id="twitter"> <a href="https://twitter.com/itsfoss2/" class="ss-follow-network ss-twitter-color" rel="nofollow noopener" aria-label="twitter" target="_blank"> <i class="ss ss-twitter"></i> <span class="ss-follow-network-label">Follow us on Twitter</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">19K</span> <span class="ss-follow-network-count-label">Followers</span> </span> </a></div><div class="ss-follow-column" data-ss-sf-network-id="instagram"> <a href="https://instagram.com/itsfoss/" class="ss-follow-network ss-instagram-color" rel="nofollow noopener" aria-label="instagram" target="_blank"> <i class="ss ss-instagram"></i> <span class="ss-follow-network-label">Follow us on Instagram</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">21K</span> <span class="ss-follow-network-count-label">Followers</span> </span> </a></div><div class="ss-follow-column" data-ss-sf-network-id="reddit"> <a href="https://www.reddit.com/user/itsfoss2/" class="ss-follow-network ss-reddit-color" rel="nofollow noopener" aria-label="reddit" target="_blank"> <i class="ss ss-reddit"></i> <span class="ss-follow-network-label">Follow us on Reddit</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">480</span> <span class="ss-follow-network-count-label">Followers</span> </span> </a></div></div></div></section><section id="optin-monster-api-2" class="widget optin-monster-api"><div class="widget-wrap"><h3 class="widgettitle widget-title">Subscribe to Weekly Newsletter</h3><div id="om-ltbe6wbed1qxhxmpvyv8-holder"></div><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="ltbe6wbed1qxhxmpvyv8" data-user="447" async></script></div></section><section id="siq_search_widget-6" class="widget widget_siq_search_widget"><div class="widget-wrap"><h3 class="widgettitle widget-title">Don&#8217;t find what you are looking for?</h3><div id="siq-expandwdgt-cont" class="siq-expandwdgt-cont"><form class="siq-expandwdgt" action="https://itsfoss.com"> <input type="search" placeholder="Search the website here" value="" name="s" class="siq-expandwdgt-input"><input type="hidden" value="post,page" name="postTypes" /><span class="siq-expandwdgt-icon"></span></form></div></div></section><section id="media_image-16" class="widget widget_media_image"><div class="widget-wrap"><h3 class="widgettitle widget-title">Still have questions? Clear your doubt</h3> <a href="https://itsfoss.community/" target="_blank" rel="noopener noreferrer"><img width="350" height="100" src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/02/ask-here.jpg?fit=350%2C100&amp;ssl=1" class="image wp-image-73823 attachment-full size-full jetpack-lazy-image" alt="Ask Here" style="max-width: 100%; height: auto;" title="Still have questions? Clear your doubt" data-attachment-id="73823" data-permalink="https://itsfoss.com/ask-here/" data-orig-file="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/02/ask-here.jpg?fit=350%2C100&amp;ssl=1" data-orig-size="350,100" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="ask-here" data-image-description="" data-medium-file="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/02/ask-here.jpg?fit=300%2C86&amp;ssl=1" data-large-file="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/02/ask-here.jpg?fit=350%2C100&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/02/ask-here.jpg?w=350&amp;ssl=1 350w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/02/ask-here.jpg?resize=300%2C86&amp;ssl=1 300w" data-lazy-sizes="(max-width: 350px) 100vw, 350px" data-lazy-src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2020/02/ask-here.jpg?fit=350%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section><section id="text-3" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div id="itsfoss_300x250_300x600_Sidebar2" align="center"><script data-cfasync="false" type='text/javascript'>freestar.queue.push(function () { googletag.display('itsfoss_300x250_300x600_Sidebar2'); });</script></div></div></div></section></aside></div></div><div class="footer-widgets" id="genesis-footer-widgets"><h2 class="genesis-sidebar-title screen-reader-text">Footer</h2><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="linkcat-2014" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">About Pages</h3><ul class='xoxo blogroll'><li><a href="https://itsfoss.com/about/" title="Know more about us">About It&#039;s FOSS</a></li><li><a href="https://itsfoss.com/its-foss-team/" title="Team behind It&#8217;s FOSS">Meet the team</a></li><li><a href="https://itsfoss.com/donations-foss/" title="Check out donations made by us to Open Source projects">We Donate to FOSS Projects</a></li></ul></div></section><section id="linkcat-1482" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">Contact Pages</h3><ul class='xoxo blogroll'><li><a href="https://itsfoss.com/contact-us/">Contact Us</a></li><li><a href="https://itsfoss.com/get-featured-on-its-foss/" title="Want your product to be featured on It&#8217;s FOSS?">Get Featured on It&#039;s FOSS</a></li><li><a href="https://itsfoss.com/request-tutorial/" title="Can&#8217;t find what you are looking for? Tell us.">Request a tutorial</a></li></ul></div></section><section id="media_image-15" class="widget widget_media_image"><div class="widget-wrap"><a href="https://itsfoss.com/copyright/"><img width="300" height="105" src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2020/01/cc-by-sa.png?fit=300%2C105&amp;ssl=1" class="image wp-image-72526 attachment-medium size-medium jetpack-lazy-image" alt="CC By SA" style="max-width: 100%; height: auto;" data-attachment-id="72526" data-permalink="https://itsfoss.com/cc-by-sa/" data-orig-file="https://i1.wp.com/itsfoss.com/wp-content/uploads/2020/01/cc-by-sa.png?fit=403%2C141&amp;ssl=1" data-orig-size="403,141" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cc-by-sa" data-image-description="" data-medium-file="https://i1.wp.com/itsfoss.com/wp-content/uploads/2020/01/cc-by-sa.png?fit=300%2C105&amp;ssl=1" data-large-file="https://i1.wp.com/itsfoss.com/wp-content/uploads/2020/01/cc-by-sa.png?fit=403%2C141&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2020/01/cc-by-sa.png?w=403&amp;ssl=1 403w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2020/01/cc-by-sa.png?resize=300%2C105&amp;ssl=1 300w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2020/01/cc-by-sa.png?fit=300%2C105&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></section></div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="linkcat-2015" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">Stay in Touch with It's FOSS</h3><ul class='xoxo blogroll'><li><a href="https://www.facebook.com/itsfoss/" title="The best Linux related page on the entire Facebook">Follow us on Facebook</a></li><li><a href="https://www.instagram.com/itsfoss/" title="Follow us for Linux related images">Follow us on Instagram</a></li><li><a href="https://www.pinterest.fr/its_foss/" title="Follow us on Pinterest">Follow us on Pinterest</a></li><li><a href="https://twitter.com/itsfoss2" title="Follow us on Twitter">Follow us on Twitter</a></li><li><a href="https://itsfoss.com/feed/" target="_blank">Follow us via RSS Feed</a></li><li><a href="https://itsfoss.com/subscribe-to-newsletter/" title="Subscribe to daily or weekly newsletter">Subscribe to Newsletter</a></li><li><a href="https://www.youtube.com/c/itsfoss?sub_confirmation=1" title="Subscribe to our rapidly growing YouTube channel">Subscribe to YouTube Channel</a></li></ul></div></section></div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="linkcat-2012" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">Communities</h3><ul class='xoxo blogroll'><li><a href="https://t.me/joinchat/AAAAAEPRGUJrEE1itjpH6A" title="Join our private Telegram Channel with over 500 members to get the updates instantly">Exclusive Telegram Channel</a></li><li><a href="https://www.linkedin.com/groups/8597839" title="A community for FOSS Professionals">Join LinkedIn Community</a></li><li><a href="https://www.facebook.com/groups/LinuxUsersGroupOfficial/" title="Join our exclusive Linux Users Group with over 90,000 Linux enthusiasts">Linux Users Group on Facebook</a></li><li><a href="https://www.reddit.com/r/LinuxUsersGroup/" title="Join our Subreddit and interact with a passionate Linux community">Linux Users Group on Reddit</a></li></ul></div></section><section id="linkcat-2013" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">Policies</h3><ul class='xoxo blogroll'><li><a href="https://itsfoss.com/affiliate-policy/" title="Affiliate Policy" target="_blank">Affiliate Policy</a></li><li><a href="https://itsfoss.com/privacy-policy/">Privacy Policy</a></li></ul></div></section></div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>It's F.O.S.S is Part of chmod777 Media Tech (OPC) Pvt Ltd· Built on <a href="http://www.shareasale.com/r.cfm?b=346198&amp;u=747593&amp;m=28169&amp;urllink=&amp;afftrack=">Genesis Framework</a> and Powered by <a href="https://www.upcloud.com/register/?promo=itsfoss">UpCloud</a></p></div></footer></div><script type="text/template" id="comments-conversion"><# if ( html_switch === 'tcm_live_update' ) { #>
	<div class="tcm-thank-you-submited tcm-border-color-ac">
		<#= custom_message #>
	</div>
<# } #>
<# if ( html_switch === 'tcm_related_posts' ) { #>
	<div class="tcm-posts tcm-border-color-ac">
	        <#= custom_message #>
	        <div class="tcm-posts-list <# if ( ! show_featured_image ) { #> no-featured-image <# } #> clear-this posts-length-<#= ThriveComments.related_posts.length #>">
		        <# ThriveComments.related_posts.forEach( function ( value ) { #>
			        <div class="tcm-post tcm-color-ac <# if ( ! show_featured_image ) { #> tcm-border-bottom-color-ac <# } #>">
				        <# if ( show_featured_image ) { #>
				            <div>
		                         <a href="<#= value.guid #>" style="background-image: url(<#= value.featured_image #>)" class="tcm-related-thumbnail <# if ( ! value.featured_image ) { #>tcm-no-featured-image<# } #>">
	                            </a>
				            </div>
					    <# } #>
				        <h3><a href="<#= value.guid #>">

								<span>
									<svg class="related-posts-arrow tcm-svg-fill-ac"><use xlink:href="#tcm-related-posts-arrow"></use></svg>								</span>


								<#= value.post_title #>

								</#></a></h3>
			        </div>
		        <# } ) #>
	        </div>
	</div>
<# } #>
<# if ( html_switch === 'tcm_social_share' ) { #>
	<div class="tcm-share-post tcm-border-color-ac">
		<#= custom_message #>
		<div class="share-buttons">
			<# if ( share_btns.fb_share ) { #><div class="fb-button" data-href="http://www.facebook.com/share.php"></div><# } #>
			<# if ( share_btns.tw_share ) { #><div class="tw-button" data-href="https://twitter.com/intent/tweet"></div><# } #>
			<# if ( share_btns.lk_share ) { #><div class="in-button" data-href="https://www.linkedin.com/cws/share"></div><# } #>
			<# if ( share_btns.pt_share ) { #><div class="pt-button" data-href="http://pinterest.com/pin/create/button"></div><# } #>
			<# if ( share_btns.gg_share ) { #><div class="gm-button" data-href="https://plus.google.com/share"></div><# } #>
			<# if ( share_btns.xi_share ) { #><div class="xi-button" data-href="https://www.xing.com/spi/shares/new"></div><# } #>
		</div>
	</div>
<# } #></script><script type="text/template" id="comments-create">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</script><script type="text/template" id="comments-deleted"><div class="tcm-deleted-comment clear-this">
	<div class="deleted-header">
		<div class="moderation-img no-image" data-social-avatar="<#= comment.get('social_avatar') #>" data-email="<#= comment.get('comment_author_email') #>" data-src="<#= comment.get('photo_src') #>" style="background-image: url(<#= comment.get('author_avatar_urls') #>);"></div>
		<div class="deleted-header-text">
			<strong>
				<#= comment.get('author_name') #>
			</strong>
			<span>
				<#= comment.get('formatted_date') #>
			</span>
		</div>
	</div>
	<div class="deleted-text">
		<p class="deleted-info-text tcm-color-ac">
			<# if ( comment.get('status') === 'spam' ) { #>
			<span>This comment was marked as spam</span>
			<# } else { #>
			<span>This comment was marked as trash</span>
			<# } #>
			<a href="#" data-key="z" class="undo-action">Undo</a>
		</p>

		<p>
			<#= comment.get('comment_content') #>
		</p>
	</div>
</div></script><script type="text/template" id="comments-item">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</script><script type="text/template" id="comments-lazy-loading"><button class="tcm-loader">
	<div style="display: inline-block" class="tcm-dot-loader done">
		<span class="inner1"></span>
		<span class="inner2"></span>
		<span class="inner3"></span>
	</div>
	<p>
		<#= ThriveComments.util.render_label('load_comments') #>
	</p>
</button>
<# if ( comments_rendered > 2 && ! ThriveComments.close_comments ) { #>
<div class="add-comment tcm-background-color-ac">
	<p>
			<span class="add-comment-icon">
				<svg class="add-comment-svg"><use xlink:href="#tcm-add-comment"></use></svg>			</span>
		<#= ThriveComments.util.render_label('add_comment') #></#></p>
</div>
<# } #>
<# if ( showPoweredBy ) { #>
<div class="tcm-powered-by">
    	<a href="https://thrivethemes.com/comments/" title="Powered by Thrive Comments" target="_blank">
			<span class="tcm-footer-logo">
				<svg class="logo-footer-svg"><use xlink:href="#tcm-logo-footer"></use></svg>			</span>

		<span>
			Powered by 		</span>
		<span>
			Thrive Comments		</span>
	</a>
</div>
<# } #>

<# if ( ! ThriveComments.close_comments && ThriveComments.email_services.length !== 0 ) { #>
	<div class="tcm-align-right">

		<a href="javascript:void(0)" class="tcm-link-unsubscribe" title="<#= ThriveComments.util.render_label('unsubscribe') #>"
		<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) || ( typeof ThriveComments.current_user.ID === 'undefined' ) ) { #> hidden <# } #> >
		<#= ThriveComments.util.render_label('unsubscribe') #></a>

		<a href="javascript:void(0)" class="tcm-link-subscribe" title="<#= ThriveComments.util.render_label('subscribe') #>"
		<# if ( - 1 !== ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) ) { #> hidden <# } #> >
		<#= ThriveComments.util.render_label('subscribe') #></a>

		<div id="tcm-subscribe-form" class="tcm-subscribe-form" hidden>
			<div class="tcm-error-message"></div>
			<input class="form-input tcm-subscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
			<button class="submit-subscribe-post"><#= ThriveComments.util.render_label('subscribe') #></a></button>
		</div>

		<# if ( typeof ThriveComments.current_user.ID === 'undefined' ) { #>
			<div id="tcm-unsubscribe-form" class="tcm-subscribe-form"
			<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID )  ) { #> hidden <# } #> >
				<div class="tcm-error-message"></div>
				<input class="form-input tcm-unsubscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
				<button class="submit-unsubscribe-post"><#= ThriveComments.util.render_label('unsubscribe') #></a></button>
			</div>
		<# } #>
        <p class="tcm-already-subscribed" hidden> Already subscribed! </p>

    </div>
<# } #>
<div class="clear"></div></script><script type="text/template" id="comments-list"><div id="tcm-comments-filter" class="tcm-comments-filter">
	<div class="tcm-lazy-loader"></div>
</div></script><script type="text/template" id="comments-moderation"><div class="tcm-moderate-dots tcm-background-color-ac-h">
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
</div>

<div class="tcm-dropdown-moderate">
	<# _.each( actions, function( action, key ){ #>
	<div class="tcm-dropdown-moderate-element" data-fn="<#= action.fn #>" data-value="<#= action.value #>"><#= action.text #></div>
	<# }) #>
</div></script><script type="text/template" id="comments-sort"><div class="tcm-comments-filters">
	<div class="left">
		<div class="tcm-comments-number">
			<#= ThriveComments.util.render_label( 'number_of_comments', 'comment_count' ) #>
		</div>
	</div>
	<div class="right">
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','before') #>
		</label>
		<div name="sort-by" id="tcm-sort-by" class="tcm-dropdown tcm-filter-dropdown tcm-really-random">
            <span class="tcm-toggle-button current-sorting">
                <# if ( ThriveComments.settings.comment_order === 'desc') { #>
					<#= ThriveComments.util.render_label( 'newest') #>
					<# } else if( ThriveComments.settings.comment_order === 'asc') { #>
					<#= ThriveComments.util.render_label( 'oldest') #>
					<# } else {#>
				<# if( ThriveComments.settings.tcm_vote_type != 'no_vote' ) {#>
					<#= ThriveComments.util.render_label( 'top_rated') #>
					<# } #>
				<# } #>
			</span>

			<span class="dropdown-arrow-comments">
						<svg class="sort-by-dropdown-svg"><use xlink:href="#tcm-sort-by-dropdown"></use></svg>			</span>

			<div class="tcm-dropdown-content">

				<div data-value="desc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'newest') #>
				</div>
				<div data-value="asc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'oldest') #>
				</div>
				<# if(ThriveComments.settings.tcm_vote_type != 'no_vote'){#>
				<div data-value="top-rated" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'top_rated') #>
				</div>

				<# } #>

			</div>
		</div>
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','after') #>
		</label>
	</div>
</div>
<div class="clear"></div>
<# if ( ThriveComments.close_comments ) { #>
<div class="tcm-closed-comments" style="text-align: center">
	<p>
		<#= ThriveComments.util.render_label('close_comments') #>
	</p>
</div>
<# } #></script> <div id="wp-auth-check-wrap" class="hidden"><div id="wp-auth-check-bg"></div><div id="wp-auth-check"> <button type="button" class="wp-auth-check-close button-link"><span class="screen-reader-text">Close dialog</span></button><div id="wp-auth-check-form" class="loading" data-src="https://itsfoss.com/wp-login.php?interim-login=1&#038;wp_lang=en_US"></div><div class="wp-auth-fallback"><p><b class="wp-auth-fallback-expired" tabindex="0">Session expired</b></p><p><a href="https://itsfoss.com/wp-login.php" target="_blank">Please log in again.</a> The login page will open in a new tab. After logging in you can close it and return to this page.</p></div></div></div>  <script type="text/javascript">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</script> <div style="display: none;"> <svg style="position: absolute; width: 0; height: 0; overflow: hidden;" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"xml:space="preserve"> <defs> <symbol id="tcm-reply" viewBox="0 0 100 100"> <g> <path d="M69.9,38.1L69.9,38.1c-1.5-3.7-4.7-6.4-7.4-9.2c-2.8-2.8-6.3-4.7-9.9-6.3c-3.7-1.6-7.7-2.4-11.7-2.4h-11 l4.7-4.8c3.4-3.4,3.4-9,0-12.4c-3.4-3.4-8.9-3.4-12.2,0L2.8,22.7c-3.4,3.4-3.4,9,0,12.4l19.4,19.7c1.7,1.7,3.9,2.6,6.1,2.6 c2.2,0,4.4-0.9,6.1-2.6c3.4-3.4,3.4-9,0-12.4l-4.6-4.6h10.9c3.4,0,6.6,1.4,9.1,3.8l4.8,4.8c1.2,2,3,3.4,5.1,4.1 c2.1,0.6,4.5,0.4,6.6-0.7C70.5,47.5,72,42.3,69.9,38.1z"/> <ellipse cx="81.1" cy="60.8" rx="8.5" ry="8.6"/> </g> </symbol> <symbol id="tcm-icon-thumb_down" viewBox="0 0 24 24"> <g> <path d="M18.984 3h4.031v12h-4.031v-12zM15 3c1.078 0 2.016 0.938 2.016 2.016v9.984c0 0.563-0.234 1.031-0.609 1.406l-6.563 6.609-1.078-1.078c-0.281-0.281-0.422-0.609-0.422-1.031v-0.328l0.984-4.594h-6.328c-1.078 0-2.016-0.891-2.016-1.969l0.047-0.094h-0.047v-1.922c0-0.281 0.047-0.516 0.141-0.75l3.047-7.031c0.281-0.703 0.984-1.219 1.828-1.219h9z" /> </g> </symbol> <symbol id="tcm-icon-thumb_up" viewBox="0 0 24 24"> <g> <path d="M23.016 9.984l-0.047 0.094h0.047v1.922c0 0.281-0.047 0.516-0.141 0.75l-3.047 7.031c-0.281 0.703-0.984 1.219-1.828 1.219h-9c-1.078 0-2.016-0.938-2.016-2.016v-9.984c0-0.563 0.234-1.031 0.609-1.406l6.563-6.609 1.078 1.078c0.281 0.281 0.422 0.609 0.422 1.031v0.328l-0.984 4.594h6.328c1.078 0 2.016 0.891 2.016 1.969zM0.984 21v-12h4.031v12h-4.031z" /> </g>> </symbol> <symbol id="tcm-add-comment" viewBox="0 0 267.3 245"> <path style="fill:#FFFFFF;" class="st0" d="M265.7,61C259.6,27.5,230.3,2,195.1,2H72.5C33,2,0.8,34.2,0.8,73.8v77c0,0.1,0,0.1,0,0.2v81.6 c0,0-1.8,11.1,9.7,11.1c0,0,4.2,1,13.1-4.6l46.8-43.2h124.6c39.5,0,71.7-32.2,71.7-71.7V83.8L265.7,61z M78.4,114 c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6S93,91.4,93,99.5C93,107.5,86.5,114,78.4,114z M137.5,114 c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C152.1,107.5,145.5,114,137.5,114z M196.5,114 c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C211.1,107.5,204.6,114,196.5,114z"/> </symbol> <symbol id="tcm-logo-footer" viewBox="0 0 130 100"> <path style="fill:#434343;" class="st0" d="M108.8,26.5C106.7,14.9,96.5,6.1,84.4,6.1H41.9C28.2,6.1,17,17.2,17,30.9v26.7c0,0,0,0,0,0.1v28.2 c0,0-0.6,3.8,3.4,3.8c0,0,1.5,0.4,4.6-1.6l16.2-14.9h12.1c0.1-0.2,0.3-0.4,0.4-0.6l2.2-3.1c0.4-0.6,1.9-2.3,3.1-3.6H37.6 c-1.1,0-2.1,0.6-2.8,1.4l0,0L24.1,78.6V58.2c0-0.2,0.1-0.4,0.1-0.6V30.9c0-9.7,7.9-17.6,17.6-17.6h42.5c9.7,0,17.6,7.9,17.6,17.6 v16.9c2.6-0.4,5.3-0.6,7.2-0.7V34.4L108.8,26.5z"/> <path style="fill:#57A245;" class="st1" d="M43.7,39.9c-3.3,0-6-2.7-6-6c0-3.3,2.7-6,6-6h38.9c3.3,0,6,2.7,6,6c0,3.3-2.7,6-6,6H43.7z"/> <path style="fill:#434343;" class="st0" d="M43.7,52.2h38.9c2.4,0,4.3-1.9,4.3-4.3s-1.9-4.3-4.3-4.3H43.7c-2.4,0-4.3,1.9-4.3,4.3S41.3,52.2,43.7,52.2"/> <path style="fill-rule:evenodd;clip-rule:evenodd;fill:#57A245;" class="st2" d="M118.2,52.4c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4 c-3.4,4.2-4.1,4.9-6.8,10.2c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5 c-0.6,0.5-1.3,1-1.9,1.5c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2 c-0.2,0.1-0.4,0.2-0.5,0.2c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7 c0.6-1.4,1.3-2.8,2.1-4.1c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6l0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7 c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7l4.1-1.9 c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3 c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4 c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6 c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8 c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9 c3.5-0.7,12.3-2.3,16.6-2.3h0.9C114,51.2,117.4,51.2,118.2,52.4z"/> <path style="fill:none;" class="st3" d="M99.5,58.5c0.4,0,0.2,0,0.2-0.1C99.4,58.4,99.6,58.4,99.5,58.5z M99.5,58.5c0.1-0.1-0.1-0.1,0.2-0.1 C99.7,58.5,99.9,58.5,99.5,58.5 M99.9,58.3l-0.1,0.1 M99.5,58.5c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3 c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3 c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5 c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3 c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8 c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9c3.5-0.7,12.3-2.3,16.6-2.3h0h0.2h0.6c2.2,0,5.6,0.1,6.4,1.3 c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4c-3.4,4.2-4.1,4.9-6.8,10.2 c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5c-0.6,0.5-1.3,1-1.9,1.5 c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2c-0.2,0.1-0.4,0.2-0.5,0.2 c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7c0.6-1.4,1.3-2.8,2.1-4.1 c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6c0.1-0.1,0.2-0.2,0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7 c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7L99.5,58.5"/> </symbol> <symbol id="tcm-related-posts-arrow" viewBox="0 0 16 16"> <path class="st0" d="M8,15.9c-4.4,0-7.9-3.5-7.9-7.9S3.6,0.1,8,0.1s7.9,3.5,7.9,7.9S12.4,15.9,8,15.9z M8,2.4C4.9,2.4,2.4,4.9,2.4,8 s2.5,5.6,5.6,5.6s5.6-2.5,5.6-5.6S11.1,2.4,8,2.4z M11.9,8.3l-3.3,3.3c-0.1,0.1-0.2,0.1-0.2,0.1c-0.2,0-0.3-0.2-0.3-0.3v-2H4.4 C4.2,9.3,4.1,9.2,4.1,9V7c0-0.2,0.2-0.3,0.3-0.3H8v-2c0-0.2,0.1-0.3,0.3-0.3c0.1,0,0.2,0,0.2,0.1l3.3,3.3C11.9,7.9,12,7.9,12,8 S11.9,8.2,11.9,8.3z"/> </symbol> <symbol id="tcm-sort-by-dropdown" viewBox="0 0 12 7"> <path style="fill:#6E767D;" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4 C0.1,0.5-0.2,1,0.3,1.5z"/> </symbol> <symbol id="tcm-author-icon" viewBox="0 0 1020 1080"> <polygon style="fill:#474F57" class="st0" points="44.5,882.9 251.4,1081 251.4,889.8 "/> <path style="fill:#6E767D" class="st1" d="M937.8,891.8H81.2c-44.3,0-80.6-36.3-80.6-80.6V82.7c0-44.3,36.3-80.6,80.6-80.6h856.6 c44.3,0,80.6,36.3,80.6,80.6v728.5C1018.4,855.5,982.1,891.8,937.8,891.8z"/> <g> <path style="fill:#6E767D" class="st2" d="M732,688.3c-0.5,0.1-2.7,0.5-6.3,1.1c-142.4,25.4-168.6,29.8-171.6,30.1c-7,0.8-12.3,0.4-16-1.3 c-2.4-1-3.6-2.3-4-2.8c0.2-1,1.4-3.3,2.2-4.7c0.7-1.4,1.6-3,2.3-4.6c4.9-11.1,1.5-22.4-8.9-29.5c-7.8-5.3-18.1-7.4-30.6-6.3 c-7.5,0.6-138.9,22.6-211.1,34.7l-35.4,27.7c82.6-13.9,240.1-40.2,248.4-41c7.4-0.6,13.2,0.3,16.7,2.7c2,1.4,1.8,1.8,1.3,3.1 c-0.4,0.9-1,2-1.6,3.2c-2.4,4.4-5.6,10.5-4.5,18c1.2,8.2,7.3,15.3,16.7,19.4c5.3,2.3,11.4,3.5,18.4,3.5c2.8,0,5.7-0.2,8.8-0.5 c5.7-0.7,63.8-10.9,172.9-30.3c3.6-0.6,5.8-1,6.3-1.1c5.9-1,9.8-6.6,8.7-12.5C743.4,691.2,737.8,687.3,732,688.3L732,688.3z M732,688.3"/> <path style="fill:#FFFFFF" class="st2" d="M349.8,583.9l-91.7,95.5c-10.1,10.5-17.2,23.5-20.6,37.7l130.2-102c40.8,18,73.3,23.7,98.3,23.7 c43.8,0,64.2-17.7,64.2-17.7c-40.8-21.2-46.6-60.6-46.6-60.6c31.3,13.2,96.4,28.7,96.4,28.7c86.5-57.5,131.7-181.9,131.7-181.9 c-9,2.5-17.5,3.5-25.6,3.5c-40.6,0-68.5-25.9-68.5-25.9l113-24.5c37.6-76.7,41.2-211.1,41.2-211.1L428.2,453.5 C389.2,487.9,361.9,533.4,349.8,583.9L349.8,583.9z M349.8,583.9"/> </g> </symbol> <symbol id="tcm-bulk-action-arrow" viewBox="0 0 12 7"> <path style="fill:#6E767D" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4 C0.1,0.5-0.2,1,0.3,1.5z"/> </symbol> </defs> </svg></div> <script type="text/javascript">function atomicBlocksShare( url, title, w, h ){
			var left = ( window.innerWidth / 2 )-( w / 2 );
			var top  = ( window.innerHeight / 2 )-( h / 2 );
			return window.open(url, title, 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=600, height=600, top='+top+', left='+left);
		}</script>  <script type='text/javascript'>var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-24863836-4']);
_gaq.push(['_trackPageview']);
_gaq.push(['_gat._anonymizeIp']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();</script> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-6384374914382766",
          enable_page_level_ads: false
     });</script> <style>body .widget.extendedwopts-col.col-md-12{float:none;clear:both}</style><div id="amzn-assoc-ad-f6247784-85fd-4210-a7a4-187f89319a74"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=f6247784-85fd-4210-a7a4-187f89319a74"></script><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="oxh34p6lqtpejie9xlgt" data-user="447" async></script><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="cp7zniloxza8mcagx085" data-user="447" async></script><div id="om-by19m9tmzfns6oco-holder"></div><script>var by19m9tmzfns6oco,by19m9tmzfns6oco_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){by19m9tmzfns6oco_poll(function(){if(window['om_loaded']){if(!by19m9tmzfns6oco){by19m9tmzfns6oco=new OptinMonsterApp();return by19m9tmzfns6oco.init({"u":"447.470037","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;by19m9tmzfns6oco=new OptinMonsterApp();by19m9tmzfns6oco.init({"u":"447.470037","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><div id="om-pztb1uabhcye9ksm-holder"></div><script>var pztb1uabhcye9ksm,pztb1uabhcye9ksm_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){pztb1uabhcye9ksm_poll(function(){if(window['om_loaded']){if(!pztb1uabhcye9ksm){pztb1uabhcye9ksm=new OptinMonsterApp();return pztb1uabhcye9ksm.init({"u":"447.408081","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;pztb1uabhcye9ksm=new OptinMonsterApp();pztb1uabhcye9ksm.init({"u":"447.408081","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script> <script type="text/javascript">var ltbe6wbed1qxhxmpvyv8_shortcode = true;var oxh34p6lqtpejie9xlgt_shortcode = true;var cp7zniloxza8mcagx085_shortcode = true;var by19m9tmzfns6oco_shortcode = true;var pztb1uabhcye9ksm_shortcode = true;</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/_inc/build/photon/photon.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var eafl_public = {"home_url":"https:\/\/itsfoss.com\/","ajax_url":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","nonce":"38423e547d"}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/easy-affiliate-links/dist/public.js?ver=3.4.1'></script> <script type='text/javascript'>/* <![CDATA[ */ var socialsnap_script = {"ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","on_media_width":"250","on_media_height":"250","nonce":"b0602c0542","post_id":"80536","click_tracking":""}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/socialsnap-plus/assets/js/socialsnap.js?ver=1.1.8.3'></script> <script type='text/javascript'>/* <![CDATA[ */ var wp_template = {"template_name":"single.php","template_dir":"genesis","all_files":"[\"themes-controller.php\",\"themes-exchange.php\",\"themes\\\/divi.php\",\"themes\\\/avada.php\",\"themes\\\/studiopress.php\",\"themes\\\/uncode.php\",\"themes.php\",\"themes\\\/genesis-sample\\\/functions.php\",\"themes\\\/genesis\\\/lib\\\/init.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/requirements.php\",\"themes\\\/genesis\\\/lib\\\/classes\\\/class-genesis-requirements-views.php\",\"themes\\\/genesis\\\/config\\\/requirements.php\",\"themes\\\/genesis\\\/lib\\\/framework.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/version.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/upgrade.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/compat.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/general.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/options.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/image.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/markup.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/breadcrumb.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/menu.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/layout.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/formatting.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/seo.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/open-graph.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/widgetize.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/feed.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/toolbar.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/head.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/post-meta.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/rest.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/deprecated.php\",\"themes\\\/genesis\\\/lib\\\/shortcodes\\\/post.php\",\"themes\\\/genesis\\\/lib\\\/shortcodes\\\/footer.php\",\"themes\\\/genesis\\\/lib\\\/structure\\\/header.php\",\"themes\\\/genesis\\\/lib\\\/structure\\\/footer.php\",\"themes\\\/genesis\\\/lib\\\/structure\\\/menu.php\",\"themes\\\/genesis\\\/lib\\\/structure\\\/layout.php\",\"themes\\\/genesis\\\/lib\\\/structure\\\/post.php\",\"themes\\\/genesis\\\/lib\\\/structure\\\/loops.php\",\"themes\\\/genesis\\\/lib\\\/structure\\\/comments.php\",\"themes\\\/genesis\\\/lib\\\/structure\\\/sidebar.php\",\"themes\\\/genesis\\\/lib\\\/structure\\\/archive.php\",\"themes\\\/genesis\\\/lib\\\/admin\\\/term-meta.php\",\"themes\\\/genesis\\\/lib\\\/admin\\\/user-meta.php\",\"themes\\\/genesis\\\/lib\\\/js\\\/load-scripts.php\",\"themes\\\/genesis\\\/lib\\\/classes\\\/class-genesis-script-loader.php\",\"themes\\\/genesis\\\/lib\\\/css\\\/load-styles.php\",\"themes\\\/genesis\\\/lib\\\/widgets\\\/widgets.php\",\"themes\\\/genesis\\\/lib\\\/widgets\\\/user-profile-widget.php\",\"themes\\\/genesis\\\/lib\\\/widgets\\\/featured-post-widget.php\",\"themes\\\/genesis\\\/lib\\\/widgets\\\/featured-page-widget.php\",\"themes\\\/genesis\\\/config\\\/layouts.php\",\"themes\\\/genesis-sample\\\/lib\\\/theme-defaults.php\",\"themes\\\/genesis-sample\\\/lib\\\/helper-functions.php\",\"themes\\\/genesis-sample\\\/lib\\\/customize.php\",\"themes\\\/genesis-sample\\\/lib\\\/output.php\",\"themes\\\/genesis-sample\\\/lib\\\/woocommerce\\\/woocommerce-setup.php\",\"themes\\\/genesis-sample\\\/lib\\\/woocommerce\\\/woocommerce-output.php\",\"themes\\\/genesis-sample\\\/lib\\\/woocommerce\\\/woocommerce-notice.php\",\"themes\\\/genesis-sample\\\/config\\\/responsive-menus.php\",\"themes\\\/genesis\\\/lib\\\/classes\\\/class-genesis-menu-handler.php\",\"themes\\\/genesis\\\/functions.php\",\"themes\\\/genesis-sample\\\/config\\\/theme-supports.php\",\"themes\\\/genesis\\\/lib\\\/functions\\\/schema.php\",\"themes\\\/genesis-sample\\\/lib\\\/gutenberg\\\/init.php\",\"themes\\\/genesis-sample\\\/config\\\/appearance.php\",\"themes\\\/genesis-sample\\\/lib\\\/gutenberg\\\/inline-styles.php\",\"themes\\\/genesis\\\/single.php\",\"themes\\\/genesis\\\/header.php\",\"themes\\\/genesis\\\/lib\\\/classes\\\/class-genesis-menu.php\",\"themes\\\/genesis\\\/config\\\/breadcrumbs.php\",\"themes\\\/genesis\\\/lib\\\/classes\\\/class-genesis-breadcrumb.php\",\"themes\\\/genesis\\\/sidebar.php\",\"themes\\\/genesis\\\/footer.php\"]"}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/wp-fs-publisher-plugin-master/public/js/wp-fs-publisher-plugin-public.js?ver=1.1.4'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/atomic-blocks/dist/assets/js/dismiss.js?ver=1591844478'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/comment-reply.min.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/hoverIntent.min.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.2'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.2'></script> <script type='text/javascript'>/* <![CDATA[ */ var tve_dash_front = {"ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","force_ajax_send":"1","is_crawler":""}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/thrive-quiz-builder/thrive-dashboard/js/dist/frontend.min.js?ver=2.2.17.2'></script> <script type='text/javascript'>/* <![CDATA[ */ var q2w3_sidebar_options = [{"sidebar":"sidebar","margin_top":10,"margin_bottom":0,"stop_id":"genesis-footer-widgets","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["optin-monster-api-2","siq_search_widget-6","media_image-16","text-3"]}]; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.9'></script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/_inc/build/lazy-images/js/lazy-images.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var genesis_responsive_menu = {"mainMenu":"Menu","menuIconClass":"dashicons-before dashicons-menu","subMenu":"Submenu","subMenuIconClass":"dashicons-before dashicons-arrow-down-alt2","menuClasses":{"others":[".nav-primary"]}}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/themes/genesis/lib/js/menu/responsive-menus.min.js?ver=1.1.3'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/aawp/public/assets/js/scripts.min.js?ver=3.12.3'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/underscore.min.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/backbone.min.js'></script> <script type='text/javascript'>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</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/thrive-comments/assets/js/frontend.min.js?ver=1.4.3.1'></script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/_inc/build/spin.min.js'></script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/_inc/build/jquery.spin.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","nonce":"196ca90bfd","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/itsfoss.com\/wp-login.php?redirect_to=https%3A%2F%2Fitsfoss.com%2Fserpent-os-announcement%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"}; /* ]]> */</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.6.1/_inc/build/carousel/jetpack-carousel.min.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/optinmonster/assets/js/helper.js?ver=1.9.9'></script> <script type="text/javascript">var tcb_post_lists=JSON.parse('[]');</script> <script type="text/javascript">if(typeof jQuery != "undefined") {
					jQuery('.siq-expsearch-icon').each(function(){
					var searchBox = (jQuery(this).parents('.siq-icon-searchbox-wrap').size() > 0) ? jQuery(this).parents('.siq-icon-searchbox-wrap') : jQuery('.siq-menu-searchbox-wrap') ;
					var inputBox = searchBox.find('.siq-expsearch-input');
					
					jQuery(this).on('click', function () {
						if (!searchBox.hasClass('siq-search-open')) {
							searchBox.addClass('siq-search-open');
							inputBox.focus();
						} else {
							searchBox.removeClass('siq-search-open');
							inputBox.focusout();
						}
					});
					jQuery('body').click(function (evt) {
						if (evt.target.id == "siq-menu-searchbox-wrap")
							return;
						if (jQuery(evt.target).closest('#siq-menu-searchbox-wrap').length || jQuery(evt.target).closest('.siq-icon-searchbox-wrap').length)
							return;

						if (searchBox.hasClass('siq-search-open')) {
							searchBox.removeClass('siq-search-open');
						}
					});
				});
			}</script> <div id="ss-copy-popup" class="ss-popup-overlay"><div class="ss-popup"><div class="ss-popup-heading"> <span>Copy link</span> <a href="#" id="ss-close-share-networks-modal" class="ss-close-modal" rel="nofollow noopener"><i class="ss ss-close"></i></a></div><div class="ss-popup-content"><div class="ss-copy-action"> <input type="text" readonly="readonly" value="https://itsfoss.com/serpent-os-announcement/" class="ss-copy-action-field" aria-label="Copy" /> <a href="#" class="ss-button" rel="nofollow noopener">Copy<span class="ss-share-network-tooltip">Copied</span></a> <i class="ss ss-copy"></i></div></div></div></div>  <script type="text/javascript">var SocialSnapURL 				= window.location.href;
			var SocialSnapShareCacheExpired = 0;
				
			if ( -1 !== SocialSnapURL.indexOf('?ss_cache_refresh') ) {

				SocialSnapShareCacheExpired = true;

			} else {

				var SocialSnapServerTimestamp 	= 1593607807;
				var SocialSnapBrowserTimestamp 	= Date.now();

				if ( ! SocialSnapBrowserTimestamp ) {
					SocialSnapBrowserTimestamp = new Date().getTime();
				}

				SocialSnapBrowserTimestamp = Math.floor( SocialSnapBrowserTimestamp / 1000 );

				SocialSnapShareCacheExpired = SocialSnapShareCacheExpired && ( SocialSnapBrowserTimestamp - SocialSnapServerTimestamp < 60 );
			}</script>  <script type="text/javascript">/* <![CDATA[ */ var aawp_geotargeting_api = "";
        var aawp_geotargeting_settings = {"store":"com","mode":"title"};
        var aawp_geotargeting_localized_stores = {"ca":"ca","de":"de","at":"de","ch":"de","es":"es","fr":"fr","in":"in","it":"it","jp":"co.jp","gb":"co.uk","ie":"co.uk"};
        var aawp_geotargeting_tracking_ids = {"ca":"itsfoss09-20","de":"itsfoss0e-21","es":"itsfoss04-21","fr":"itsfoss02-21","in":" itsfoss0d-21","it":"itsfoss05-21","co.jp":"itsfoss-22","co.uk":"itsfoss03-21"}; /* ]]> */</script> <script type='text/javascript' src='https://stats.wp.com/e-202027.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'37237282',post:'80536',tz:'5.5',srv:'itsfoss.com'} ]);
	_stq.push([ 'clickTrackerInit', '37237282', '80536' ]);</script> <script type="text/javascript">var omapi_localized = { ajax: 'https://itsfoss.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '2173c9b035', slugs: {"ltbe6wbed1qxhxmpvyv8":{"slug":"ltbe6wbed1qxhxmpvyv8","mailpoet":false},"oxh34p6lqtpejie9xlgt":{"slug":"oxh34p6lqtpejie9xlgt","mailpoet":false},"cp7zniloxza8mcagx085":{"slug":"cp7zniloxza8mcagx085","mailpoet":false},"by19m9tmzfns6oco":{"slug":"by19m9tmzfns6oco","mailpoet":false},"pztb1uabhcye9ksm":{"slug":"pztb1uabhcye9ksm","mailpoet":false}} };</script> <script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":80536,"object_key":"post","object_type":"post","term_ids":[4]};</script> <script>window.lazyLoadOptions={elements_selector:"iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://itsfoss.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360">',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1593607807 -->