<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Difference Between apt vs apt-get Explained</title><meta name="description" content="Explaining how apt command is similar yet different than apt-get and why you should be using apt instead of apt-get." />
		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="revised" content="Tuesday, July 11, 2017, 10:30 am" />
<script>var et_site_url='https://itsfoss.com';var et_post_id='16244';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script>
<!-- AdPushup Begins -->		
<noscript>
    _ap_ufes{"success":true,"siteUrl":"itsfoss.com","urls":{"Home":"https://itsfoss.com","Category":"https://itsfoss.com/category/apps/","Archive":"https://itsfoss.com/2017/07/","Post":"https://itsfoss.com/fedora-26-release/","Page":"https://itsfoss.com/affiliate-policy/","Attachment":"https://itsfoss.com/fedora-26-release/fedora-26-release/","Nav_menu_item":"https://itsfoss.com/free-ebooks/","Custom_css":"https://itsfoss.com/vibrant-pro/","Wpforms":"https://itsfoss.com/?post_type=wpforms&p=14032","Job_listing":"https://itsfoss.com/job/javascript-developer-open-source/","Easy_affiliate_link":"https://itsfoss.com/recommends/unixstickers/","Ks_giveaway":"https://itsfoss.com/giveaways/raspberry-pi-3-giveaway-2017/","Omapi":"https://itsfoss.com/?omapi=bt6u6v82dqbotdun","Tmm":"https://itsfoss.com/tmm/its-foss-team/","Poll":"https://itsfoss.com/poll/will-you-buy-a-litebook/","Wp_quiz":"https://itsfoss.com/wp_quiz/linux-desktop-environments-logo/","Feedback":"https://itsfoss.com/?post_type=feedback&p=12055"}}_ap_ufee
</noscript>
		
<script data-cfasync="false" type="text/javascript">
	(function(w,d){(w.adpushup=w.adpushup||{}).configure={config:{e3Called:false,jqLoaded:0,apLoaded:0,e3Loaded:0,rand:Math.random()}};var adp=w.adpushup,json=null,config=adp.configure.config,tL=adp.timeline={},apjQuery=null;tL.tl_adpStart=+new Date;adp.utils={uniqueId:function(appendMe){var d=+new Date,r,appendMe=((!appendMe||(typeof appendMe=="number"&&appendMe<0))?Number(1).toString(16):Number(appendMe).toString(16));appendMe=("0000000".substr(0,8-appendMe.length)+appendMe).toUpperCase();return appendMe+"-xxxxxxxx-xxxx-4xxx-yxxx-xxxxxxxxxxxx".replace(/[xy]/g,function(c){r=((d=Math.floor(d / 16))+Math.random()*16)%16|0;return(c=="x"?r:(r&0x3|0x8)).toString(16);});},loadScript:function(src,sC,fC){var s=d.createElement("script");s.src=src;s.type="text/javascript";s.async=true;s.onerror=function(){if(typeof fC=="function"){fC.call();}};if(typeof d.attachEvent==="object"){s.onreadystatechange=function(){(s.readyState=="loaded"||s.readyState=="complete")?(s.onreadystatechange=null&&(typeof sC=="function"?sC.call():null)):null};}else{s.onload=function(){(typeof sC=="function"?sC.call():null)};} (d.getElementsByTagName("head")[0]||d.getElementsByTagName("body")[0]).appendChild(s);}};adp.configure.push=function(obj){for(var key in obj){this.config[key]=obj[key];} if(!this.config.e3Called&&this.config.siteId&&this.config.pageGroup&&this.config.packetId){var c=this.config,ts=+new Date;adp.utils.loadScript("//e3.adpushup.com/E3WebService/e3?ver=2&callback=e3Callback&siteId=12121&url="+encodeURIComponent(c.pageUrl)+"&pageGroup="+c.pageGroup+"&referrer="+encodeURIComponent(d.referrer)+"&cms="+c.cms+"&pluginVer="+c.pluginVer+"&rand="+c.rand+"&packetId="+c.packetId+"&_="+ts);c.e3Called=true;tL.tl_e3Requested=ts;init();} adp.ap&&typeof adp.ap.configure=="function"&&adp.ap.configure(obj);};function init(){(w.jQuery&&w.jQuery.fn.jquery.match(/^1.11./))&&!config.jqLoaded&&(tL.tl_jqLoaded=+new Date)&&(config.jqLoaded=1)&&(apjQuery=w.jQuery.noConflict(true));(typeof adp.runAp=="function")&&!config.apLoaded&&(tL.tl_apLoaded=+new Date)&&(config.apLoaded=1);if(!adp.configure.config.apRun&&adp.configure.config.pageGroup&&apjQuery&&typeof adp.runAp=="function"){adp.runAp(apjQuery);adp.configure.push({apRun:true});} if(!adp.configure.config.e3Run&&w.apjQuery&&typeof adp.ap!="undefined"&&typeof adp.ap.triggerAdpushup=="function"&&json&&typeof json!="undefined"){adp.ap.triggerAdpushup(json);adp.configure.push({e3Run:true});}};w.e3Callback=function(){(arguments[0])&&!config.e3Loaded&&(tL.tl_e3Loaded=+new Date)&&(config.e3Loaded=1);json=arguments[0];init();};adp.utils.loadScript("//optimize.adpushup.com/12121/apv2.js",init);tL.tl_apRequested=+new Date;adp.utils.loadScript("//ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js",init);tL.tl_jqRequested=+new Date;adp.configure.push({siteId:"12121",packetId:adp.utils.uniqueId(12121),pageGroup:"Post",siteDomain:"itsfoss.com",pageUrl:"https://itsfoss.com/apt-vs-apt-get-difference",referrer:"",cms:"wordpress",pluginVer:"0.9.6"});})(window,document);
</script>
<!-- AdPushup Ends -->
			<script>
						</script>
		
<!-- Social Warfare v2.2.10 https://warfareplugins.com -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Difference Between apt vs apt-get Explained" />
<meta property="og:description" content="Explaining how apt command is similar yet different than apt-get" />
<meta property="og:image" content="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-featured.png" />
<meta property="og:url" content="https://itsfoss.com/apt-vs-apt-get-difference/" />
<meta property="og:site_name" content="It&#039;s FOSS" />
<meta property="article:author" content="https://www.facebook.com/itsfoss/" />
<meta property="article:publisher" content="http://facebook.com/itsfoss" />
<meta property="article:published_time" content="2017-07-09T10:49:43+00:00" />
<meta property="article:modified_time" content="2017-07-11T10:30:56+00:00" />
<meta property="og:updated_time" content="2017-07-11T10:30:56+00:00" />
<meta property="fb:app_id" content="529576650555031" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Difference Between apt vs apt-get Explained">
<meta name="twitter:description" content="Explaining how apt command is similar yet different than apt-get">
<meta name="twitter:image" content="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-featured.png">
<meta name="twitter:site" content="@itsfoss2">
<meta name="twitter:creator" content="@abhishek_foss">
<style>@font-face {font-family: "sw-icon-font";src:url("https://itsfoss.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.eot?ver=2.2.10");src:url("https://itsfoss.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.eot?ver=2.2.10#iefix") format("embedded-opentype"),url("https://itsfoss.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.woff?ver=2.2.10") format("woff"), url("https://itsfoss.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.ttf?ver=2.2.10") format("truetype"),url("https://itsfoss.com/wp-content/plugins/social-warfare/fonts/sw-icon-font.svg?ver=2.2.10#1445203416") format("svg");font-weight: normal;font-style: normal;}</style>
<!-- Social Warfare v2.2.10 https://warfareplugins.com -->

<link rel='dns-prefetch' href='//d9etzk30b05yg.cloudfront.net' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//a.optnmstr.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//maxcdn.icons8.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Feed" href="http://feeds.feedburner.com/ItsFoss" />
<link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Comments Feed" href="https://itsfoss.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Difference Between apt vs apt-get Explained Comments Feed" href="https://itsfoss.com/apt-vs-apt-get-difference/feed/" />
<link rel="canonical" href="https://itsfoss.com/apt-vs-apt-get-difference/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/itsfoss.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='decomments-css'  href='https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom.css' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='decomments-ie-css'  href='https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/css/decom-ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='default-fonts-css'  href='https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/css/fonts-def.css' type='text/css' media='all' />
<link rel='stylesheet' id='vibrant-pro-css'  href='https://itsfoss.com/wp-content/themes/vibrant-pro/style.css' type='text/css' media='all' />
<style id='vibrant-pro-inline-css' type='text/css'>


	a,
	.entry-title a:focus,
	.entry-title a:hover,
	.genesis-nav-menu a:focus,
	.genesis-nav-menu a:hover,
	.genesis-nav-menu .current-menu-item > a,
	.genesis-nav-menu .sub-menu .current-menu-item > a:focus,
	.genesis-nav-menu .sub-menu .current-menu-item > a:hover,
	.nav-primary .genesis-nav-menu a:focus,
	.nav-primary .genesis-nav-menu a:hover,
	.nav-primary .genesis-nav-menu .current-menu-item > a,
	.nav-primary .genesis-nav-menu .sub-menu .current-menu-item > a:focus,
	.nav-primary .genesis-nav-menu .sub-menu .current-menu-item > a:hover,
	.nav-secondary .genesis-nav-menu a:focus,
	.nav-secondary .genesis-nav-menu a:hover,
	.nav-secondary .genesis-nav-menu .current-menu-item > a,
	.nav-secondary .genesis-nav-menu .sub-menu .current-menu-item > a:focus,
	.nav-secondary .genesis-nav-menu .sub-menu .current-menu-item > a:hover,
	.featured-product-carousel .product-price .price,
	.featured-product-carousel .product-cart .button,
	.featured-post-carousel .entry .entry-categories a:hover,
	.blog .content > .entry .entry-categories a:hover,
	.blog .content > .entry .entry-categories a:focus,
	.archive .content > .entry .entry-categories a:hover,
	.archive .content > .entry .entry-categories a:focus,
	.search .content > .entry .entry-categories a:hover,
	.search .content > .entry .entry-categories a:focus,
	.front-page-2 .widget:nth-of-type(2n+2) .entry .entry-categories a:hover,
	.front-page-4 .entry .entry-categories a:hover,
	.front-page-shop .owl-nav [class*="owl-"]:hover,
	.front-page-shop .owl-nav [class*="owl-"]:focus,
	.menu-toggle:focus,
	.menu-toggle:hover,
	.sub-menu-toggle:focus,
	.sub-menu-toggle:hover {
		color: #00b6ba;
	}

	.genesis-nav-menu .menu-woo-cart a .cart-quantity,
	.featured-post-slider .entry-inner .entry-title a:hover,
	.owl-slider-carousel .owl-dots .owl-dot.active span,
	.owl-slider-carousel .owl-dots .owl-dot:hover span,
	.owl-slider-carousel .owl-nav [class*="owl-"]:hover,
	.sidebar .widget.enews-widget,
	.featured-product-carousel .product-carousel-icon a:focus,
	.featured-product-carousel .product-carousel-icon a:hover,
	.featured-product-carousel .product-cart .button:hover,
	.featured-product-carousel .product-cart .button:focus,
	.front-page-instagram .clear a,
	.footer-widgets .enews-widget input[type="submit"],
	.scroll-up button:hover,
	.scroll-up button:focus,
	button,
	input[type="button"],
	input[type="reset"],
	input[type="submit"],
	input[type="reset"],
	input[type="submit"],
	.archive-pagination a:focus,
	.archive-pagination a:hover,
	.archive-pagination .active a,
	.button {
		background-color: #00b6ba;
		color: #333333;
	}

	.front-page-shop .owl-nav [class*="owl-"]:hover,
	.front-page-shop .owl-nav [class*="owl-"]:focus {
		background-color: transparent;
		color: #00b6ba;
	}

	.genesis-nav-menu .sub-menu,
	.nav-secondary .genesis-nav-menu a:focus,
	.nav-secondary .genesis-nav-menu a:hover,
	.nav-secondary .genesis-nav-menu .current-menu-item > a,
	.nav-secondary .genesis-nav-menu .sub-menu .current-menu-item > a:focus,
	.nav-secondary .genesis-nav-menu .sub-menu .current-menu-item > a:hover,
	.front-page-2 .widget .widget-title,
	.front-page-3 .widget .widget-title,
	.front-page-4 .widget .widget-title,
	.front-page-shop .widget-title,
	.featured-product-carousel .product-cart .button:hover,
	.featured-product-carousel .product-cart .button:focus,
	.sidebar .widget-title,
	.related-content h3,
	.comment-respond h3,
	.archive-pagination a:focus,
	.archive-pagination a:hover,
	.archive-pagination .active a {
		border-color: #00b6ba;
	}

	.featured-post-slider .entry-inner .entry-title a:hover {
		box-shadow: 10px 0 0 #00b6ba, -10px 0 0 #00b6ba;
		-webkit-box-shadow: 10px 0 0 #00b6ba, -10px 0 0 #00b6ba;
	}

	
</style>
<link rel='stylesheet' id='tm_clicktotweet-css'  href='https://itsfoss.com/wp-content/plugins/click-to-tweet-by-todaymade/assets/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-notice-front-css'  href='https://itsfoss.com/wp-content/plugins/cookie-notice/css/front.css' type='text/css' media='all' />
<link rel='stylesheet' id='siq_front_css-css'  href='https://itsfoss.com/wp-content/plugins/searchiq/assets/1.5.7/css/frontend/stylesheet.css' type='text/css' media='all' />
<link rel='stylesheet' id='custom-style-css'  href='https://itsfoss.com/wp-content/plugins/stackcommerce-deal-feed/wp/includes/css/custom_script.css' type='text/css' media='all' />
<style id='custom-style-inline-css' type='text/css'>

                .stackCommerceWidgetSidebar .singlestackCommerceItem .stackCommerceItemPrice{
                        background: #2db500;
                        color: #ffffff;
                }
                .stackCommerceWidgetSidebar .singlestackCommerceItem {
                    background: #f7f7f7;
                }
                .stackCommerceWidgetSidebar .singlestackCommerceItem .singlestackCommerceItemDiscount {
                    background: ;
                    color: ;
                    display: block;
                }
                .stackCommerceSeeAllDeals {
                    display: block;
                }
                .stackCommerceInlineDisplayHeader .stackCommerceInlineHeaderText {
                    font-size: 40px;
                }
                .singlestackCommerceItem {
                    background: #f7f7f7;
                }
                
</style>
<link rel='stylesheet' id='tmm-css'  href='https://itsfoss.com/wp-content/plugins/team-members/css/tmm_custom_style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='chosen-css'  href='https://itsfoss.com/wp-content/plugins/wp-job-manager/assets/css/chosen.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-job-manager-frontend-css'  href='https://itsfoss.com/wp-content/plugins/wp-job-manager/assets/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='et-gf-open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='et_monarch-css-css'  href='https://itsfoss.com/wp-content/plugins/monarch/css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='social_warfare-css'  href='https://itsfoss.com/wp-content/plugins/social-warfare/css/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='vibrant-font-muli-css'  href='//fonts.googleapis.com/css?family=Muli%3A300%2C400' type='text/css' media='all' />
<link rel='stylesheet' id='vibrant-font-montserrat-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C500' type='text/css' media='all' />
<link rel='stylesheet' id='vibrant-font-awesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='vibrant-line-awesome-css'  href='//maxcdn.icons8.com/fonts/line-awesome/1.1/css/line-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='gca-column-styles-css'  href='https://itsfoss.com/wp-content/plugins/genesis-columns-advanced/css/gca-column-styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='forget-about-shortcode-buttons-css'  href='https://itsfoss.com/wp-content/plugins/forget-about-shortcode-buttons/public/css/button-styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://itsfoss.com/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />

			<style> .decomments-button, .decomments-head i:before, .decomments-button-submit { background: #b2d531 !important; } .selectrics, .selectricsItems, .decomments-comment-section .decomments-footer-nav .decomments-buttons-moderate.active,
			.decomments-comment-section .decomments-footer-nav .moderate-action, .de-select.de-select-filter dt,.de-select.de-select-filter dd, .modal-wrap .flipper .login-form .btn{ border-color:#b2d531 !important; } .decomments-comments-number, .modal-wrap .flipper .login-form .close-modal:hover, .decomments-comment-list [id^="safe-comments-result-"] > a:hover { color:#b2d531 !important; } .decomments-gif:after{ border-left-color:#b2d531 !important; } .loader-ball-scale > div, .modal-wrap .flipper .login-form .btn{background:#b2d531 !important;} .decomments-file-uploaded .decomments-icon-insert-photo .svg *{stroke:#b2d531 !important;}
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon path{fill:#b2d531 !important; }
#decomments-comment-section.decomments-comment-section.decomments-comment-section .decomments-pictures-holder .decomments-gif:hover .svg-icon circle{stroke:#b2d531 !important; }
			 </style>
			<script type='text/javascript'>
/* <![CDATA[ */
var appp_ajax_login = {"processing":"Logging in....","required":"Fields are required","error":"Error Logging in"};
/* ]]> */
</script>
<script type='text/javascript' src='https://itsfoss.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var configuration = {"rendererBaseUrl":"\/\/renderer.qmerce.com","randomBaseUrl":"\/\/random.qmerce.com"};
/* ]]> */
</script>
<script type='text/javascript' async="async" src='//d9etzk30b05yg.cloudfront.net/js/sdk/v2.0/apester-javascript-sdk.min.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/css-hero/assets/js/prefixfree.min.js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://itsfoss.com/wp-content/themes/genesis/lib/js/html5shiv.js'></script>
<![endif]-->
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='//a.optnmstr.com/app/js/api.min.js'></script>
<link rel='https://api.w.org/' href='https://itsfoss.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://itsfoss.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://itsfoss.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fitsfoss.com%2Fapt-vs-apt-get-difference%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://itsfoss.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fitsfoss.com%2Fapt-vs-apt-get-difference%2F&#038;format=xml" />
	<link rel="canonical" href="https://itsfoss.com/apt-vs-apt-get-difference/"/>

<!-- Start CSSHero.org Dynamic CSS & Fonts Loading -->
	 <link rel="stylesheet" type="text/css" media="all" href="https://itsfoss.com/?wpcss_action=show_css" data-apply-prefixfree />
	  <!-- End CSSHero.org Dynamic CSS & Fonts Loading -->    
	                    <script type="text/javascript">
                        (function () {
                            window.siqConfig = {
                                engineKey: "0b787e72d31e4985feb8ed23cbbec78d"
                            };
                            window.siqConfig.baseUrl = "//pub.searchiq.xyz/";
                            var script = document.createElement("SCRIPT");
                            script.src = window.siqConfig.baseUrl + 'js/container/siq-container-2.js?cb=' + (Math.floor(Math.random()*999999)) + '&engineKey=' + siqConfig.engineKey;
                            script.id = "siq-container";
                            document.getElementsByTagName("HEAD")[0].appendChild(script);
                        })();
                    </script><style type="text/css" id="et-social-custom-css">
				 
			</style>		<style>
		.gist table {
			margin-bottom: 0 !important;
			table-layout: auto !important;
		}
		.gist .line-numbers
		{
			width: 4em !important;
		}
		.gist .line,
		.gist .line-number
		{
			font-size: 12px !important;
			height: 18px !important;
			line-height: 18px !important;
		}
		.gist .line
		{
			white-space: pre !important;
			width: auto !important;
			word-wrap: normal !important;
		}
		.gist .line span
		{
			word-wrap: normal !important;
		}
		</style>
		
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel="pingback" href="https://itsfoss.com/xmlrpc.php" />
<meta name="google-site-verification" content="FKkNWkNiaaJgRU-J9AhubMInij3kRYtmjdeTVLkaphE" />
<link href="https://plus.google.com/itsfoss" rel="publisher" />
<meta property="fb:pages" content="115098615297581" />

<script data-cfasync="false">
    !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://pub.freestar.io/itsfoss/";e+=window.location.search.indexOf("fsdebug")==-1?"pubfig.min.js":"pubfig.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
    window.freestar = window.freestar || {};
    window.freestar.queue = window.freestar.queue || [];
</script>

<script type="text/javascript" src="http://classic.avantlink.com/affiliate_app_confirm.php?mode=js&authResponse=f4bbc1c72f84359626ae0f69c9c14eb300ebe864"></script><meta property="article:publisher" content="https://www.facebook.com/itsfoss" /> <link rel="amphtml" href="https://itsfoss.com/apt-vs-apt-get-difference/amp/" /><link rel="icon" href="https://itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name-32x32.png" sizes="32x32" />
<link rel="icon" href="https://itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name-180x180.png" />
<meta name="msapplication-TileImage" content="https://itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name-270x270.png" />
			<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.

Click the help icon above to learn more.
*/
.entry-content code {
	background-color: #007678 ;
  padding: 0 .2em;
}
.entry-content pre {
  background-color: #007678 ;
  padding: .5em 1em;
  overflow: auto;
  word-wrap: normal;
}			</style>
		</head>
<body class="post-template-default single single-post postid-16244 single-format-standard et_monarch unknown content-sidebar  vibrant-pro" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><h2 class="screen-reader-text">Main navigation</h2><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary" aria-label="Main navigation"><div class="wrap"><ul id="menu-one-menu-for-all" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-10108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10108"><a href="https://itsfoss.com/about/" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-10121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10121"><a href="https://itsfoss.com/category/news/" itemprop="url"><span itemprop="name">News</span></a></li>
<li id="menu-item-10119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10119"><a href="https://itsfoss.com/category/linux/" itemprop="url"><span itemprop="name">Linux</span></a>
<ul  class="sub-menu">
	<li id="menu-item-10116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10116"><a href="https://itsfoss.com/category/gadgets/" itemprop="url"><span itemprop="name">Gadgets</span></a></li>
	<li id="menu-item-10117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10117"><a href="https://itsfoss.com/category/games/" itemprop="url"><span itemprop="name">Games</span></a></li>
	<li id="menu-item-10113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10113"><a href="https://itsfoss.com/category/desktop/" itemprop="url"><span itemprop="name">Desktop</span></a></li>
	<li id="menu-item-10112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10112"><a href="https://itsfoss.com/category/apps/" itemprop="url"><span itemprop="name">Apps</span></a></li>
</ul>
</li>
<li id="menu-item-10118" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10118"><a href="https://itsfoss.com/category/how-to/" itemprop="url"><span itemprop="name">How To</span></a></li>
<li id="menu-item-10129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10129"><a href="https://shop.itsfoss.com/" itemprop="url"><span itemprop="name">Shop</span></a></li>
<li id="menu-item-10130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10130"><a href="http://itsfoss.tradepub.com/" itemprop="url"><span itemprop="name">Free eBooks</span></a></li>
</ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://itsfoss.com/">It&#039;s FOSS</a></p><p class="site-description" itemprop="description">A Linux and Open Source Web Portal</p></div><div class="widget-area header-widget-area"><h2 class="genesis-sidebar-title screen-reader-text">Header Right</h2><section id="media_image-5" class="widget widget_media_image"><div class="widget-wrap"><a href="http://unixstickers.refr.cc/X6J38PP" class="" rel="" target="_blank"><img width="728" height="90" src="https://itsfoss.com/wp-content/uploads/2017/06/unixsticker-web-banner-1.jpg" class="image wp-image-16534  attachment-full size-full" alt="Unixstickers web banner" style="max-width: 100%; height: auto;" srcset="https://itsfoss.com/wp-content/uploads/2017/06/unixsticker-web-banner-1.jpg 728w, https://itsfoss.com/wp-content/uploads/2017/06/unixsticker-web-banner-1-300x37.jpg 300w, https://itsfoss.com/wp-content/uploads/2017/06/unixsticker-web-banner-1-720x90.jpg 720w" sizes="(max-width: 728px) 100vw, 728px" data-attachment-id="16534" data-permalink="https://itsfoss.com/unixsticker-web-banner-1/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/06/unixsticker-web-banner-1.jpg" data-orig-size="728,90" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="unixsticker-web-banner-1" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/06/unixsticker-web-banner-1-300x37.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/06/unixsticker-web-banner-1.jpg" /></a></div></section>
</div></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-16244 post type-post status-publish format-standard has-post-thumbnail category-how-to tag-apt-vs-apt-get tag-apt-get tag-difference-between-apt-and-apt-get tag-guide entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Difference Between apt vs apt-get Explained</h1>
<p class="entry-meta">Last updated <time class="entry-modified-time" itemprop="dateModified" datetime="2017-07-11T10:30:56+00:00">July 11, 2017</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://itsfoss.com/author/abhishek/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Abhishek Prakash</span></a></span> <span class="entry-comments-link"><a href="https://itsfoss.com/apt-vs-apt-get-difference/#comments">28 Comments</a></span> </p></header><div class="entry-content" itemprop="text"><div class='code-block code-block-1' style='margin: 8px auto; text-align: center;'>
<div align="center" id="div-gpt-ad-728x90-ATF">
    <script data-cfasync="false" type='text/javascript'>
        freestar.queue.push(function () { googletag.display('div-gpt-ad-728x90-ATF'); });
    </script>
</div></div>
<div class="nc_socialPanel swp_flatFresh swp_d_fullColor swp_i_fullColor swp_o_fullColor scale-100 scale-fullWidth" data-position="above" data-float="floatBottom" data-count="6" data-floatColor="#ffffff" data-emphasize="0"><div class="nc_tweetContainer swp_fb" data-id="4" data-network="facebook"><a rel="nofollow" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fitsfoss.com%2Fapt-vs-apt-get-difference%2F%3Futm_source%3Dfacebook%26utm_medium%3Dsocial%26utm_campaign%3DSocialWarfare" data-link="http://www.facebook.com/share.php?u=https%3A%2F%2Fitsfoss.com%2Fapt-vs-apt-get-difference%2F%3Futm_source%3Dfacebook%26utm_medium%3Dsocial%26utm_campaign%3DSocialWarfare" class="nc_tweet external"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-facebook"></i><span class="swp_share"> Share</span></span></span><span class="swp_count">762</span></a></div><div class="nc_tweetContainer twitter" data-id="3" data-network="twitter"><a rel="nofollow" target="_blank" href="https://twitter.com/share?original_referer=/&text=Difference+Between+apt+vs+apt-get+Explained&url=https://itsfoss.com/apt-vs-apt-get-difference/%3Futm_source%3Dtwitter%26utm_medium%3Dsocial%26utm_campaign%3DSocialWarfare&via=abhishek_foss" data-link="https://twitter.com/share?original_referer=/&text=Difference+Between+apt+vs+apt-get+Explained&url=https://itsfoss.com/apt-vs-apt-get-difference/%3Futm_source%3Dtwitter%26utm_medium%3Dsocial%26utm_campaign%3DSocialWarfare&via=abhishek_foss" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-twitter"></i><span class="swp_share"> Tweet</span></span></span></span></a></div><div class="nc_tweetContainer googlePlus" data-id="2" data-network="google_plus"><a rel="nofollow" target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fitsfoss.com%2Fapt-vs-apt-get-difference%2F%3Futm_source%3DgooglePlus%26utm_medium%3Dsocial%26utm_campaign%3DSocialWarfare" data-link="https://plus.google.com/share?url=https%3A%2F%2Fitsfoss.com%2Fapt-vs-apt-get-difference%2F%3Futm_source%3DgooglePlus%26utm_medium%3Dsocial%26utm_campaign%3DSocialWarfare" class="nc_tweet external"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-google-plus"></i><span class="swp_share"> +1</span></span></span></span></a></div><div class="nc_tweetContainer linkedIn" data-id="5" data-network="linked_in"><a rel="nofollow" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fitsfoss.com%2Fapt-vs-apt-get-difference%2F%3Futm_source%3DlinkedIn%26utm_medium%3Dsocial%26utm_campaign%3DSocialWarfare" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fitsfoss.com%2Fapt-vs-apt-get-difference%2F%3Futm_source%3DlinkedIn%26utm_medium%3Dsocial%26utm_campaign%3DSocialWarfare" class="nc_tweet external"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-linkedin"></i><span class="swp_share"> Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_reddit" data-id="6" data-network="reddit"><a rel="nofollow" target="_blank" href="https://www.reddit.com/submit?url=https://itsfoss.com/apt-vs-apt-get-difference/&title=Difference+Between+apt+vs+apt-get+Explained" data-link="https://www.reddit.com/submit?url=https://itsfoss.com/apt-vs-apt-get-difference/&title=Difference+Between+apt+vs+apt-get+Explained" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-reddit"></i><span class="swp_share"> Reddit</span></span></span></span></a></div><div class="nc_tweetContainer totes totesalt" data-id="7" ><span class="swp_count"><span class="swp_label">Shares</span> 762</span></div></div><div id="_ap_wp_content_start" style="display:none"></div><p><em><strong>Brief</strong>: This article explains the <strong>difference between apt and apt-get</strong> commands of Linux. It also lists some of the most commonly used apt commands that replace the older apt-get commands.</em></p>
<p>One of the noticeable <a href="https://itsfoss.com/features-ubuntu-1604/" target="_blank" rel="noopener">new features of Ubuntu 16.04</a> was the &#8216;introduction&#8217; of apt command. The reality is that the first stable version of apt was released in the year 2014 but people started noticing it in 2016 with the release of Ubuntu 16.04.</p>
<p>It became common to see <code>apt install package</code> instead of the usual <code>apt-get install package</code>. Eventually, many other distributions followed Ubuntu&#8217;s footsteps and started to encourage users to use apt instead of apt-get.</p>
<p>You might be wondering what&#8217;s the difference between apt-get and apt? And if they have a similar command structure, what was the need for the new apt command? You might also be thinking if apt is better than apt-get? Should you be using the new apt command or stick with the good old apt-get commands?</p>
<p>I&#8217;ll explain all these questions in this article and I hope that by the end of this article, you&#8217;ll have a clearer picture.</p>
<h2>apt vs apt-get</h2>
<p><img data-attachment-id="16787" data-permalink="https://itsfoss.com/apt-vs-apt-get-difference/apt-vs-apt-get-featured/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-featured.png" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="apt-vs-apt-get-featured" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-featured-300x169.png" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-featured-800x450.png" class="aligncenter size-large wp-image-16787" src="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-featured-800x450.png" alt="What's the difference between apt vs apt-get" width="800" height="450" srcset="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-featured.png 800w, https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-featured-300x169.png 300w, https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-featured-768x432.png 768w" sizes="(max-width: 800px) 100vw, 800px" /></p>
<p>Before we see the <em>difference between apt and apt-get</em>, let&#8217;s go into the backdrop of these commands and what exactly they try to achieve.</p>
<h3>Why apt was introduced in the first place?</h3>
<p><a href="https://www.debian.org/" target="_blank" rel="noopener nofollow" class="external">Debian</a>, mother Linux of distributions like Ubuntu, Linux Mint, elementary OS etc, has a robust packaging system and every component and application is built into a package that is installed on your system. Debian uses a set of tools called <a href="https://wiki.debian.org/Apt" target="_blank" rel="noopener nofollow" class="external">Advanced Packaging Tool</a> (APT) to manage this packaging system. Don&#8217;t confuse it with the command apt, it&#8217;s not the same.</p>
<p>There are various tools that interact with APT and allow you to install, remove and manage packages in Debian based Linux distributions. apt-get is one such command-line tool which is widely popular. Another popular tool is <a href="https://wiki.debian.org/Aptitude?action=show&amp;redirect=aptitude" target="_blank" rel="noopener nofollow" class="external">Aptitude</a> with both GUI and command-line options.</p>
<p>If you have read my <a href="https://itsfoss.com/apt-get-linux-guide/" target="_blank" rel="noopener">guide on apt-get commands</a>, you might have come across a number of similar commands such as apt-cache. And this is where the problem arises.</p>
<p>You see, these commands are way too low level and they have so many functionalities which are perhaps never used by an average Linux user. On the other hand, the most commonly used package management commands are scattered across apt-get and apt-cache.</p>
<p>The <a href="https://manpages.debian.org/jessie/apt/apt.8.en.html" target="_blank" rel="noopener nofollow" class="external">apt commands</a> have been introduced to solve this problem. apt consists some of the most widely used features from apt-get and apt-cache leaving aside obscure and seldom used features. It can also manage <a href="https://linux.die.net/man/5/apt.conf" target="_blank" rel="noopener nofollow" class="external">apt.conf</a> file.</p>
<p>With apt, you don&#8217;t have to fiddle your way from apt-get commands to apt-cache. apt is more structured and provides you with necessary options needed to manage packages.</p>
<p>Bottom line: apt=most common used command options from apt-get and apt-cache.</p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://itsfoss.com/use-snap-packages-ubuntu-16-04/" target="_blank" class="IRPP_button"><style> .IRPP_button , .IRPP_button .postImageUrl , .IRPP_button .centered-text-area { min-height: 86px; position: relative; } .IRPP_button , .IRPP_button:hover , .IRPP_button:visited , .IRPP_button:active { border:0!important; } .IRPP_button { display: block; transition: background-color 250ms; webkit-transition: background-color 250ms; width: 100%; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; background-color: #141414; box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -moz-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -o-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); -webkit-box-shadow: 0 1px 2px rgba(0, 0, 0, 0.17); } .IRPP_button:active , .IRPP_button:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .IRPP_button .postImageUrl { background-position: center; background-size: cover; float: right; margin: 0; padding: 0; width: 30%; } .IRPP_button .centered-text-area { float: left; width: 70%; padding:0; margin:0; } .IRPP_button .ctaText { border-bottom: 0 solid #fff; color: #FFFFFF; font-size: 13px; font-weight: bold; letter-spacing: .125em; margin: 0; padding: 0; } .IRPP_button .postTitle { color: #ECF0F1; font-size: 16px; font-weight: 600; margin: 0; padding: 0; width: 100%; } .IRPP_button .ctaButton { background: #1ABC9C; color: #FFFFFF; border: none; border-radius: 3px; box-shadow: none; font-size: 14px; font-weight: bold; line-height: 26px; margin: 18px 14px 18px 14px; moz-border-radius: 3px; padding: 12px 0; text-align: center; text-decoration: none; text-shadow: none; webkit-border-radius: 3px; width: 80px; position: absolute; } .IRPP_button:hover .ctaButton { background: #16A085; } .IRPP_button .centered-text { display: table; height: 86px; padding:0; margin:0; padding-left: 108px!important; top: 0; } .IRPP_button .IRPP_button-content { display: table-cell; margin: 0; padding: 0; padding-right: 10px; position: relative; vertical-align: middle; width: 100%; } .IRPP_button:after { content: ""; display: block; clear: both; } </style><div class="centered-text-area"><div class="ctaButton" style="float: left;">Suggested Read</div><div class="centered-text" style="float: left;"><div class="IRPP_button-content"><div class="postTitle">Using Snap Packages In Ubuntu [Complete Beginners Guide]</div></div></div></div><div class="postImageUrl" style="background-image:url(https://itsfoss.com/wp-content/uploads/2016/04/Using-Snap-Packaging-Ubuntu-300x169.jpg);"></div></a></div>
<h3>Difference between apt and apt-get</h3>
<p>So with apt, you get all the necessary tools in one place. You won&#8217;t be lost under tons of command options. The main aim of apt is to provide an efficient way of handling package in a way &#8220;pleasant for end users&#8221;.</p>
<p>When Debian says &#8220;pleasant for end users&#8221;, it actually means that. It has fewer but sufficient command options but in a more organized way. On top of that, it enables a few options by default that is actually helpful for the end users.</p>
<p>For example, you get to see the progress bar while installing or removing a program in apt.</p>
<figure id="attachment_16756" style="width: 732px" class="wp-caption aligncenter"><img data-attachment-id="16756" data-permalink="https://itsfoss.com/apt-vs-apt-get-difference/apt-vs-apt-get-1/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-1.png" data-orig-size="732,438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="apt-vs-apt-get-1" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-1-300x180.png" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-1.png" class="size-full wp-image-16756" src="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-1.png" alt="apt vs apt-get difference" width="732" height="438" srcset="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-1.png 732w, https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-1-300x180.png 300w" sizes="(max-width: 732px) 100vw, 732px" /><figcaption class="wp-caption-text">apt shows the progress bar</figcaption></figure>
<p>apt also prompts you with the number of packages that can be upgraded when you update the repository database.</p>
<figure id="attachment_16757" style="width: 732px" class="wp-caption aligncenter"><img data-attachment-id="16757" data-permalink="https://itsfoss.com/apt-vs-apt-get-difference/apt-vs-apt-get-2/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-2.png" data-orig-size="732,438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="apt-vs-apt-get-2" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-2-300x180.png" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-2.png" class="size-full wp-image-16757" src="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-2.png" alt="difference apt and apt-get " width="732" height="438" srcset="https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-2.png 732w, https://itsfoss.com/wp-content/uploads/2017/07/apt-vs-apt-get-2-300x180.png 300w" sizes="(max-width: 732px) 100vw, 732px" /><figcaption class="wp-caption-text">apt shows the number of packages that can be upgraded</figcaption></figure>
<p>You can achieve the same with apt-get as well if you use additional command options. apt enables them by default and takes the pain away.</p>
<h3>Difference between apt and apt-get commands</h3>
<p>While apt does have some similar command options as apt-get, it&#8217;s not backward compatible with apt-get. That means it won&#8217;t always work if you just replace the apt-get part of an <code>apt-get</code> command with apt.</p>
<p>Let&#8217;s see which apt command replaces which apt-get and apt-cache command options.</p>
<style type="text/css">
.tg  {border-collapse:collapse;border-spacing:0;}.tg td{padding:10px 5px;border-style:solid;border-width:1px;overflow:hidden;word-break:normal;background-color:#89D7E6;}.tg th{padding:10px 5px;border-style:solid;border-width:1px;overflow:hidden;word-break:normal;background-color:#DBDBDB;}.tg .tg-9hbo{font-weight:bold;vertical-align:top}.tg .tg-yw4l{vertical-align:top}</style>
<table class="tg">
<tbody>
<tr>
<th class="tg-9hbo">apt command</th>
<th class="tg-9hbo">the command it replaces</th>
<th class="tg-9hbo">function of the command</th>
</tr>
<tr>
<td class="tg-yw4l">apt install</td>
<td class="tg-yw4l">apt-get install</td>
<td class="tg-yw4l">Installs a package</td>
</tr>
<tr>
<td class="tg-yw4l">apt remove</td>
<td class="tg-yw4l">apt-get remove</td>
<td class="tg-yw4l">Removes a package</td>
</tr>
<tr>
<td class="tg-yw4l">apt purge</td>
<td class="tg-yw4l">apt-get purge</td>
<td class="tg-yw4l">Removes package with configuration</td>
</tr>
<tr>
<td class="tg-yw4l">apt update</td>
<td class="tg-yw4l">apt-get update</td>
<td class="tg-yw4l">Refreshes repository index</td>
</tr>
<tr>
<td class="tg-yw4l">apt upgrade</td>
<td class="tg-yw4l">apt-get upgrade</td>
<td class="tg-yw4l">Upgrades all upgradable packages</td>
</tr>
<tr>
<td class="tg-yw4l">apt autoremove</td>
<td class="tg-yw4l">apt-get autoremove</td>
<td class="tg-yw4l">Removes unwanted packages</td>
</tr>
<tr>
<td class="tg-yw4l">apt full-upgrade</td>
<td class="tg-yw4l">apt-get dist-upgrade</td>
<td class="tg-yw4l">Upgrades packages with auto-handling of dependencies</td>
</tr>
<tr>
<td class="tg-yw4l">apt search</td>
<td class="tg-yw4l">apt-cache search</td>
<td class="tg-yw4l">Searches for the program</td>
</tr>
<tr>
<td class="tg-yw4l">apt show</td>
<td class="tg-yw4l">apt-cache show</td>
<td class="tg-yw4l">Shows package details</td>
</tr>
</tbody>
</table>
<p>apt has a few commands of its own as well.</p>
<style type="text/css">
.tg  {border-collapse:collapse;border-spacing:0;}.tg td{padding:10px 5px;border-style:solid;border-width:1px;overflow:hidden;word-break:normal;background-color:#F2F2F2;}.tg th{padding:10px 5px;border-style:solid;border-width:1px;overflow:hidden;word-break:normal;background-color:#DBDBDB;}.tg .tg-9hbo{font-weight:bold;vertical-align:top}.tg .tg-yw4l{vertical-align:top}</style>
<table class="tg">
<tbody>
<tr>
<th class="tg-9hbo">new apt command</th>
<th class="tg-9hbo">function of the command</th>
</tr>
<tr>
<td class="tg-yw4l">apt list</td>
<td class="tg-yw4l">Lists packages with criteria (installed, upgradable etc)</td>
</tr>
<tr>
<td class="tg-yw4l">apt edit-sources</td>
<td class="tg-yw4l">Edits sources list</td>
</tr>
</tbody>
</table>
<p>One point to note here is that apt is under continuous development. So you may see a few new options added to the command in the future versions.</p>
<h3>Is apt-get deprecated?</h3>
<p>I didn&#8217;t find any information that says that apt-get will be discontinued. And it actually shouldn&#8217;t be. It still has a lot more functionalities to offer than apt.</p>
<p>For low-level operations, in scripting etc, apt-get will still be used.</p>
<h3>Should I use apt or apt-get?</h3>
<p>You might be thinking if you should use apt or apt-get. And as a regular Linux user, my answer is to go with apt.</p>
<p>apt is the command that is being recommended by the Linux distributions. It provides the necessary option to manage the packages. Most important of all, it is easier to use with its fewer but easy to remember options.</p>
<p>I see no reason to stick with apt-get unless you are going to do specific operations that utilizes more features of apt-get.</p>
<h3>Conclusion</h3>
<p>I hope I was able to explain the difference between apt and apt-get. In the end, to summarize the apt vs apt-get debate:</p>
<ul>
<li>apt is a subset of apt-get and apt-cache commands providing necessary commands for package management</li>
<li>while apt-get won&#8217;t be deprecated, as a regular user, you should start using apt more often</li>
</ul>
<p>So what do you think? Are you already using apt or do you want to stick with the good old apt-get? Share your views in the comment section below.</p>
<div id="_ap_wp_content_end" style="display:none"></div><div class="swp-content-locator"></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="https://itsfoss.com/apt-vs-apt-get-difference/"
    dc:identifier="https://itsfoss.com/apt-vs-apt-get-difference/"
    dc:title="Difference Between apt vs apt-get Explained"
    trackback:ping="https://itsfoss.com/apt-vs-apt-get-difference/trackback/" />
</rdf:RDF>-->
<?php if(is_singular()) { ?>
    <script data-cfasync="false" type='text/javascript'>
        freestar.queue.push(function () { googletag.display('div-gpt-ad-728x90-ATF'); });
    </script>
<?php } ?></div><footer class="entry-footer"></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=70&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=140&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /><h4 class="author-box-title">About <span itemprop="name">Abhishek Prakash</span></h4><div class="author-box-content" itemprop="description"><p>I am a professional software developer, and founder of It's FOSS. I am an avid Linux lover and Open Source enthusiast. I use Ubuntu and believe in sharing knowledge. Apart from Linux, I love classic detective mysteries. I'm also a huge fan of Agatha Christie's work.</p>
</div></section><div class="after-entry"><section id="stackcommerce_widget-3" class="widget widget_stackcommerce_widget"><div class="widget-wrap"><h3 class="widgettitle widget-title">Deals from It's FOSS Shop</h3>
        <div class="stackCommerceWidgetSidebar stackCommerceShortcode horizontal stackCommerceHeightFix  col3"
             data-sc-hide-price=""
             data-sc-hide-ribon=""
             data-sc-hide-button=""
             data-sc-column-count="3"
             data-sc-view-design="1"
             data-sc-widget="2"
             data-sc-widget-title="After Entry"
             data-sc-image-width="50"
             data-sc-publisher-id="159"
             data-sc-sort="best_sellers"
             data-sc-per-page="3"
             data-sc-header-color="#FF3131"
             data-sc-title-sizes="14"
             data-sc-open-new-tab="on"
             data-sc-utm="itsfoss.com"
             data-sc-utm-medium=""
             data-sc-utm-additional=""
             data-sc-affiliate-id=""
             data-sc-medium-item-name="1"
        >
        </div>
        <div class="allDealsLink stackCommerceSeeAllDeals">
            <a target='_blank'                href="#">
                See all deals            </a>
        </div>
        <div class="stackCommerceHelper"></div>
        </div></section>
</div><div class="related-content"><h3>Related Posts</h3><div class="related-content-inner"><article class="one-third first post-10437 post type-post status-publish format-standard has-post-thumbnail category-how-to tag-editor tag-install tag-light-table tag-ubuntu tag-ubuntu-16-04 entry"><div class="related-post-overlay"></div><div class="entry-thumbnail"><a href="https://itsfoss.com/install-lighttable-ubuntu/" ><img width="440" height="248" src="https://itsfoss.com/wp-content/uploads/2016/05/install-light-table-ubuntu.jpg" class="attachment-blog size-blog" alt="How to Easily Install Light Table on Ubuntu Linux" srcset="https://itsfoss.com/wp-content/uploads/2016/05/install-light-table-ubuntu.jpg 800w, https://itsfoss.com/wp-content/uploads/2016/05/install-light-table-ubuntu-300x169.jpg 300w, https://itsfoss.com/wp-content/uploads/2016/05/install-light-table-ubuntu-768x432.jpg 768w" sizes="(max-width: 440px) 100vw, 440px" data-attachment-id="10459" data-permalink="https://itsfoss.com/install-lighttable-ubuntu/install-light-table-ubuntu/" data-orig-file="https://itsfoss.com/wp-content/uploads/2016/05/install-light-table-ubuntu.jpg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="install-light-table-ubuntu" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2016/05/install-light-table-ubuntu-300x169.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2016/05/install-light-table-ubuntu.jpg" /></a><div class="entry-thumbnail-overlay"></div></div><div class="entry-inner"><header class="entry-header"><h4 class="entry-title"><a href="https://itsfoss.com/install-lighttable-ubuntu/">How to Easily Install Light Table on Ubuntu Linux</a></h4><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2016-05-16T23:06:02+00:00">May 16, 2016</time> <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://itsfoss.com/author/abhishek/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Abhishek Prakash</span></a></span></p></header></div></article><article class="one-third  post-5821 post type-post status-publish format-standard has-post-thumbnail category-apps category-how-to tag-kodi tag-linux-mint-17 tag-ubuntu-14-04 tag-xbmc entry"><div class="related-post-overlay"></div><div class="entry-thumbnail"><a href="https://itsfoss.com/install-kodi-14-xbmc-in-ubuntu-14-04-linux-mint-17/" ><img width="440" height="246" src="https://itsfoss.com/wp-content/uploads/2015/01/Kodi_Xmas.jpg" class="attachment-blog size-blog" alt="How To Install Kodi 14 (XBMC) In Ubuntu 14.04 &#038; Linux Mint 17" srcset="https://itsfoss.com/wp-content/uploads/2015/01/Kodi_Xmas.jpg 700w, https://itsfoss.com/wp-content/uploads/2015/01/Kodi_Xmas-300x168.jpg 300w" sizes="(max-width: 440px) 100vw, 440px" data-attachment-id="5823" data-permalink="https://itsfoss.com/install-kodi-14-xbmc-in-ubuntu-14-04-linux-mint-17/kodi_xmas/" data-orig-file="https://itsfoss.com/wp-content/uploads/2015/01/Kodi_Xmas.jpg" data-orig-size="700,392" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Kodi_Xmas" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2015/01/Kodi_Xmas-300x168.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2015/01/Kodi_Xmas.jpg" /></a><div class="entry-thumbnail-overlay"></div></div><div class="entry-inner"><header class="entry-header"><h4 class="entry-title"><a href="https://itsfoss.com/install-kodi-14-xbmc-in-ubuntu-14-04-linux-mint-17/">How To Install Kodi 14 (XBMC) In Ubuntu 14.04 &#038; Linux Mint 17</a></h4><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2015-01-02T21:57:29+00:00">Jan 02, 2015</time> <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://itsfoss.com/author/abhishek/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Abhishek Prakash</span></a></span></p></header></div></article><article class="one-third  post-7481 post type-post status-publish format-standard has-post-thumbnail category-how-to tag-error tag-fix tag-ubuntu tag-update entry"><div class="related-post-overlay"></div><div class="entry-thumbnail"><a href="https://itsfoss.com/fix-exec-locale-file-directory/" ><img width="440" height="280" src="https://itsfoss.com/wp-content/uploads/2015/06/Ubuntu_Update_Error.jpg" class="attachment-blog size-blog" alt="Fix: Can&#8217;t exec &#8220;locale&#8221;: No such file or directory at /usr/share/perl5/Debconf/Encoding.pm" srcset="https://itsfoss.com/wp-content/uploads/2015/06/Ubuntu_Update_Error.jpg 700w, https://itsfoss.com/wp-content/uploads/2015/06/Ubuntu_Update_Error-300x190.jpg 300w" sizes="(max-width: 440px) 100vw, 440px" data-attachment-id="7482" data-permalink="https://itsfoss.com/fix-exec-locale-file-directory/ubuntu_update_error-2/" data-orig-file="https://itsfoss.com/wp-content/uploads/2015/06/Ubuntu_Update_Error.jpg" data-orig-size="700,444" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ubuntu_Update_Error" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2015/06/Ubuntu_Update_Error-300x190.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2015/06/Ubuntu_Update_Error.jpg" /></a><div class="entry-thumbnail-overlay"></div></div><div class="entry-inner"><header class="entry-header"><h4 class="entry-title"><a href="https://itsfoss.com/fix-exec-locale-file-directory/">Fix: Can&#8217;t exec &#8220;locale&#8221;: No such file or directory at /usr/share/perl5/Debconf/Encoding.pm</a></h4><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2015-06-24T23:18:28+00:00">Jun 24, 2015</time> <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://itsfoss.com/author/abhishek/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Abhishek Prakash</span></a></span></p></header></div></article></div></div><div class="decom_dop_bloc"><a name="comments"></a>
<div id="decomments-comment-section" class="decomments-comment-section"
	 data-modal-alert='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Attention</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" >
				<div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>'
	 data-modal-addimage='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a picture</div>
		<div id="deco_modal_closeAjaxWindow">
			<a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">
			<form enctype="multipart/form-data" method="post" action="" id="decomments-add-picture-form" class="decomments-add-picture-form">

				<div class="decomments-load-img">
					<img src="" alt="" />
				</div>

				<div class="decomments-addfile-field" >
					<input type="file" name="decom_pictures[]" />
					<span class="decomments-addfile-cover">Choose file</span>
				</div>
				<button class="decomments-button decomments-button-addfile-send">Submit</button>
				<button onclick="decom.closeModal(); return false;" class="decomments-button decomments-button-addfile-cancel">Cancel</button>
                <button onclick="decom.removeAttachment(this); return false;" class="decomments-button decomments-button-del-image"><i class="icon-bin"></i></button>

			</form>
		</div>
	</div>
</div>'
	 data-modal-quote='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
	<div id="deco_modal_title">
		<div id="deco_modal_ajaxWindowTitle">Add a quote</div>
		<div id="deco_modal_closeAjaxWindow" onclick="decom.closeModal(); return false;">
			<a href="#" id="deco_modal_closeWindowButton">
				<div class="deco_modal-close-icon"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a>
		</div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-popup-style">

			<div id="decomments-add-blockquote-form">

				<textarea></textarea>

				<button class="decomments-button decomments-button-quote-send" >Submit</button>
				<button class="decomments-button decomments-button-quote-cancel" onclick="decom.closeModal(); return false;">Cancel</button>

			</div>

		</div>
	</div>
</div>'
	 data-modal-preview='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window" class="without_title" >
	<div id="deco_modal_title">
		<div id="deco_modal_closeAjaxWindow"><a href="#" id="deco_modal_closeWindowButton" onclick="decom.closeModal(); return false;">
				<div class="deco_modal-close-icon"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
			</a></div>
	</div>
	<div id="deco_modal_ajaxContent">
		<div class="decomments-picture-full decomments-popup-style">
			<img src="" class="decom-attachment-full" alt="">
		</div>
	</div>
</div>'
	 data-modal-sub='<div id="deco_modal_overlay" class="deco_modal_overlayBG" onclick="decom.closeModal(); return false;"></div>
<div id="deco_modal_window">
    <div id="deco_modal_title">
        <div id="deco_modal_ajaxWindowTitle">Subscribe</div>
        <div id="deco_modal_closeAjaxWindow">
            <a href="#" id="deco_modal_closeWindowButton">
                <div class="deco_modal-close-icon" onclick="decom.closeModal(); return false;"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/close_modal.svg"/></div>
            </a>
        </div>
    </div>
    <div id="deco_modal_ajaxContent">
        <div class="decomments-popup-style modal-sub-content">
            <form class="modal-sub-form">
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">All comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>
                <a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_my_comment">Replies to my
                    comments</a>

                <button class="decomments-button">Submit</button>
                <button class="decomments-button" onclick="decom.closeModal(); return false;">Cancel</button>

            </form>
        </div>


    </div>
</div>'
	 data-post_id="16244"
	 data-user_id="0"
	 data-is_need_logged="0"
	 data-lang="en"
	 data-decom_comment_single_translate=" comment"
	 data-decom_comment_twice_translate=" comments"
	 data-decom_comment_plural_translate=" comments"
	 data-multiple_vote="1"
	 data-text_lang_comment_deleted='Comment deleted'
	 data-text_lang_edited="Edited at"
	 data-text_lang_delete="Delete"
	 data-text_lang_not_zero="Field is not null"
	 data-text_lang_required="This field is required."
	 data-text_lang_checked="Mark one of the points"
	 data-text_lang_completed="Operation completed"
	 data-text_lang_items_deleted="The items have been deleted"
	 data-text_lang_close="Close"
	 data-text_lang_loading="Loading...">
	<span id="decom_default_position_form_add" style="display: none"></span>
<div id="decomments-form-add-comment" class="decomments-addform" data-site-url="https://itsfoss.com">

	<div class="decomments-social-login-widget">
			</div>

	<div class="decomments-addform-title">

		<h3>Add comment</h3>

	</div>

			<div class="decomments-enter-row">

			<form id="decomments-enterform" class="decomments-enterform" action="#" method="post" >
				<fieldset>
					<div class="de-form-field">
						<label for="decom-name-author">Name<em>*</em></label>
						<input id="decom-name-author" type="text" value="" />
					</div>
					<div class="de-form-field">
						<label for="decom-mail-author">E-mail<em>*</em></label>
						<input id="decom-mail-author" type="text" value="" />
					</div>

					
				</fieldset>

				<p class="decomments-enterform-message decomments-error-message">
					<i class="decomments-icon-warning"></i>
					<span id="decomments-login-form-message">E-mail is already registered on the site. Please use the </span>
					<a href="#" id="decomments-show-loginform">Login form</a>
					 or 					<a href="#" id="decomments-show-enterform">enter another</a>.
				</p>

			</form>

			<form id="decomments-loginform" class="decomments-loginform" method="post" >
				<p class="decomments-loginform-message decomments-error-message">
					<i class="decomments-icon-warning"></i> You entered an incorrect username or password				</p>
				<fieldset>
					<div class="de-form-field">
						<label for="log">Name:</label>
						<input type="text" name="username" id="log" value="" size="20" />
					</div>
					<div class="de-form-field">
						<label for="pwd">Password:</label>
						<input type="password" name="password" id="pwd" size="20" />
					</div>
				</fieldset>
				<button type="submit" class="decomments-button decomments-button-submit">Log in</button>
									<button type="button" id="decomments-login-form-another" class="decomments-button decomments-button-submit">Enter another</button>
								<input type="hidden" id="security" name="security" value="cd3c697ead" /><input type="hidden" name="_wp_http_referer" value="/apt-vs-apt-get-difference/" />			</form>
		</div>
		

	<div class="decomments-addform-head">

					<a href="https://decomments.com?ref=714" class="decomments-affilate-link">
				<img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/logo.svg" width="78" height="21" />
			</a>
		
					
			<nav class="decomments-subscribe-block">

				<span class="decomments-subscribe-show"><i class="decomments-icon-quick-contacts-mail"></i>Subscribe</span>

				<span class="decomments-subscribe-links">
					<a class="decomments-checkbox active" href="javascript:void(0)" name="subscribe_my_comment">Replies to my comments</a><a class="decomments-checkbox" href="javascript:void(0)" name="subscribe_all_comments">All comments</a>				</span>
			</nav>


		

		<nav class="descomments-form-nav">
			<a title="Add a quote" class="decomments-add-blockquote " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-quote')); return false;"><i class="decomments-icon-format-quote"></i></a>
			<a title="Add a picture" class="decomments-add-image " onclick="decom.showModal(this,jQuery('.decomments-comment-section').attr('data-modal-addimage')); return false;" data-width="500" data-height="120"><i class="decomments-icon-insert-photo"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/photo.svg" width="28" height="23" /></i></a>
		</nav>
	</div>


	<div class="decomments-addform-body">

		
		<input type="hidden" name="social_icon" id="decomments-social-icon" value="">

		<textarea rows="5" cols="30" class="decomments-editor"></textarea>

		<div class="decomments-commentform-message">
			<i class="decomments-icon-warning"></i>
			<span>Sorry, you must be logged in to post a comment.</span>
		</div>

		<span class="decomments-loading"><div class="loader-ball-scale">
				<div></div>
				<div></div>
				<div></div>
			</div></span>
		<div class="decomments-comment-form-custom-inputs">
					</div>
		<div class="decomments-comment-form-custom-inputs" style="display: none;">
					</div>
		<button class="decomments-button decomments-button-send">Submit</button>
		<button class="decomments-button decomments-button-cancel">Cancel</button>

	</div>

</div>

<div class="decomments-form-popup">


	<div id="decom_alert_void-block" class="decomments-popup-style" style="display:none;">
		<div class="decomments-popup-style">
			<div id="decom-alert-void-text" class="decom-popup-box decom-quote-box">
				<p></p>
			</div>
		</div>
	</div>
</div>
		<div class="decomments-head">

			<h3><i><span class="decomments-comments-number decomments-block">28</span><span class="decomments-comment-title"> comments</span></i></h3>			<form class=" decom_comments_sort decomments-comment-sort" action="#comments" method="post" >
				<label>Sort:</label>
				<dl class="de-select de-select-filter">
					<dt>by Newest</dt>
					<dd name="decom_comments_sort" class="decomments-select">
						<a onclick="decom.sortComments(this)"  href="#" data-sort="rate">
							<i class="decomments-icon-thumb-down"></i> by Best						</a>
						<a onclick="decom.sortComments(this)" class="current" href="#" data-sort="newer">
							<i class="decomments-icon-thumb-down"></i> by Newest						</a>
						<a onclick="decom.sortComments(this)"  href="#" data-sort="older">
							<i class="decomments-icon-thumb-down"></i> by Oldest						</a>
					</dd>
				</dl>
			</form>
		</div>
		<div class="decomments-comment-list" style="min-height: 250px;">
			<div class="loader-ball-scale lbs-remove">
				<div></div>
				<div></div>
				<div></div>
			</div>
			<div class="comment even thread-even depth-1 decomments-comment-block" id="comment-281873" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/3828e1430c75be4bfb250829be71e7e9?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/3828e1430c75be4bfb250829be71e7e9?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281873" class="decomments-date-link">
				
			<time datetime="7:52 pm July 11, 2017">7:52 pm<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">Kartik</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281873"><p>Good article. Thank you.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281873"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div><div class="comment odd alt thread-odd thread-alt depth-1 decomments-comment-block" id="comment-281844" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/967af64481317fbdb4f028235b0274b6?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/967af64481317fbdb4f028235b0274b6?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281844" class="decomments-date-link">
				
			<time datetime="1:14 am July 11, 2017">1:14 am<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">Omar Ruiz de Huidobro</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281844"><p>Nice article. <br />I'd like to add that apt isn't recommended for Docker images. <br />If you use apt in a Dockerfile, it works, but you'll get a warning message stating apt isn't suitable for scripts in its current state of development.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281844">+2</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment even depth-2 decomments-comment-block" id="comment-281868" parent-id="281844" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/1cc128540d142356370367d6f225bb04?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/1cc128540d142356370367d6f225bb04?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281868" class="decomments-date-link">
				
			<time datetime="3:21 pm July 11, 2017">3:21 pm<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">goldyfruit</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281868"><p>Just a quick update, apt it not recommended at all for scripting.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281868"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div><div class="comment byuser comment-author-abhishek bypostauthor odd alt depth-2 decomments-comment-block" id="comment-281862" parent-id="281844" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281862" class="decomments-date-link">
				
			<time datetime="1:10 pm July 11, 2017">1:10 pm<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281862"><p>Thanks for the info Omar :)</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281862"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div><div class="comment even depth-2 decomments-comment-block" id="comment-281859" parent-id="281844" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/603e550cd2cdc1059cb785a3b1075964?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/603e550cd2cdc1059cb785a3b1075964?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281859" class="decomments-date-link">
				
			<time datetime="11:34 am July 11, 2017">11:34 am<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">Edouard</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281859"><p>Thanks for this because that's one of the first use case I thought of.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281859"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div></div>
</div><div class="comment odd alt thread-even depth-1 decomments-comment-block" id="comment-281840" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/f65e256bb04beaf79fe8e77882bbe1cb?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/f65e256bb04beaf79fe8e77882bbe1cb?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281840" class="decomments-date-link">
				
			<time datetime="7:50 pm July 10, 2017">7:50 pm<i>July 10, 2017</i></time>			</a>
			<span class="decomments-autor-name">Mike Lippert</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281840"><p>Thanks for this article. Unlike some articles of this type, you did an excellent job of comparing the 2 commands both similarities and differences and gave an opinion of which you felt the general user should use with your reasoning, leaving those who might feel otherwise able to consider your reasons before disagreeing.</p>
<p>Personally I now feel comfortable using apt rather than apt-get for my general needs, knowing that apt-get provides additional options if I need to do something esoteric. And the few times I've needed apt-cache I've had to google to remember what tool it was I needed and how to use it, now apt may already have the functionality I need.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281840">+2</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment byuser comment-author-abhishek bypostauthor even depth-2 decomments-comment-block" id="comment-281863" parent-id="281840" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281863" class="decomments-date-link">
				
			<time datetime="1:56 pm July 11, 2017">1:56 pm<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281863"><p>Thanks for the feedback Mike.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281863"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div></div>
</div><div class="comment odd alt thread-odd thread-alt depth-1 decomments-comment-block" id="comment-281834" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/1f8988a614c00df58bcc8e5c622097dd?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/1f8988a614c00df58bcc8e5c622097dd?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281834" class="decomments-date-link">
				
			<time datetime="4:03 pm July 10, 2017">4:03 pm<i>July 10, 2017</i></time>			</a>
			<span class="decomments-autor-name">Paulo Dias</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281834"><p>Hi. How are you?<br />Thanks for this post. My question is: What is the best performance? Apt or apt-get ( apt-cache ) ?</p>
</div><div class="decomments-pictures-holder"><div id="decomments-picture-full-16799" style="display: none;"><div class="decomments-picture-full decomments-popup-style"><img width="92" height="92" src="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" class="decom-attachment-full" alt="" data-attachment-id="16799" data-permalink="https://itsfoss.com/decom_dd41cb18c930753cbecf993f828603dc_596389397440a-jpg/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" data-orig-size="92,92" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" /></div></div><a onclick='decom.showModal(this,jQuery(".decomments-comment-section").attr("data-modal-preview")); return false;' class="addedimg " title="Preview image" data-img-width="92" data-img-height="92" rel="92x92" href="/#TB_inline?width=92&height=122&inlineId=decomments-picture-full-16799"><img width="92" height="92" src="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" class="decomments-picture-img" alt="" rel="16799" data-attachment-id="16799" data-permalink="https://itsfoss.com/decom_dd41cb18c930753cbecf993f828603dc_596389397440a-jpg/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" data-orig-size="92,92" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" /><img width="92" height="92" src="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" class="hiddenpic" alt="" data-attachment-id="16799" data-permalink="https://itsfoss.com/decom_dd41cb18c930753cbecf993f828603dc_596389397440a-jpg/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" data-orig-size="92,92" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/decom_dd41cb18c930753cbecf993f828603dc_596389397440a.jpg" /></a></div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281834"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment byuser comment-author-abhishek bypostauthor even depth-2 decomments-comment-block" id="comment-281865" parent-id="281834" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281865" class="decomments-date-link">
				
			<time datetime="1:57 pm July 11, 2017">1:57 pm<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281865"><p>I didn't notice any such difference.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281865"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div></div>
</div><div class="comment odd alt thread-even depth-1 decomments-comment-block" id="comment-281829" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/52ea599339dd92419e8f2559cb767e7b?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/52ea599339dd92419e8f2559cb767e7b?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281829" class="decomments-date-link">
				
			<time datetime="2:19 pm July 10, 2017">2:19 pm<i>July 10, 2017</i></time>			</a>
			<span class="decomments-autor-name">Vineet</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281829"><p>Great post! Thanks.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281829"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment byuser comment-author-abhishek bypostauthor even depth-2 decomments-comment-block" id="comment-281864" parent-id="281829" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281864" class="decomments-date-link">
				
			<time datetime="1:56 pm July 11, 2017">1:56 pm<i>July 11, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281864"><p>Welcome Vineet</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281864"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div></div>
</div><div class="comment odd alt thread-odd thread-alt depth-1 decomments-comment-block" id="comment-281805" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/4767231bb98cfd3f7f88b3f27980ae29?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/4767231bb98cfd3f7f88b3f27980ae29?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281805" class="decomments-date-link">
				
			<time datetime="7:56 pm July 9, 2017">7:56 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">Satish</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281805"><p>You missed "apt policy XXX" which is replacement for "apt-cache policy".</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281805"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment byuser comment-author-abhishek bypostauthor even depth-2 decomments-comment-block" id="comment-281807" parent-id="281805" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281807" class="decomments-date-link">
				
			<time datetime="10:56 pm July 9, 2017">10:56 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281807"><p>Interesting because man page of apt doesn't mention apt policy and yet it is there.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281807"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div></div>
</div><div class="comment odd alt thread-even depth-1 decomments-comment-block" id="comment-281804" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/77e456af4a6fbb97ef9363330f98fa2b?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/77e456af4a6fbb97ef9363330f98fa2b?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281804" class="decomments-date-link">
				
			<time datetime="7:54 pm July 9, 2017">7:54 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">glassofcola</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281804"><p>sudo pacman -Syu</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281804">+3</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div><div class="comment even thread-odd thread-alt depth-1 decomments-comment-block" id="comment-281802" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/3fb9548bc8e43dc499e2cce8e261482d?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/3fb9548bc8e43dc499e2cce8e261482d?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281802" class="decomments-date-link">
				
			<time datetime="7:06 pm July 9, 2017">7:06 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">Muaad</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281802"><p>That was a spot on! Thanks for this great post!<br />Would you publish an apt cheat sheet soon?</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281802"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment byuser comment-author-abhishek bypostauthor odd alt depth-2 decomments-comment-block" id="comment-281808" parent-id="281802" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281808" class="decomments-date-link">
				
			<time datetime="10:56 pm July 9, 2017">10:56 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281808"><p>Yes, a detailed article with apt cheat sheet will be coming soon :)</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281808"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div></div>
</div><div class="comment even thread-even depth-1 decomments-comment-block" id="comment-281800" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/2bb6f6978ae94060e228e99c6ca6a55b?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/2bb6f6978ae94060e228e99c6ca6a55b?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281800" class="decomments-date-link">
				
			<time datetime="2:50 pm July 9, 2017">2:50 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">malkov</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281800"><p>thanks sir</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281800"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment byuser comment-author-abhishek bypostauthor odd alt depth-2 decomments-comment-block" id="comment-281809" parent-id="281800" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281809" class="decomments-date-link">
				
			<time datetime="10:56 pm July 9, 2017">10:56 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281809"><p>You're welcome Malkov.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281809"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div></div>
</div><div class="comment even thread-odd thread-alt depth-1 decomments-comment-block" id="comment-281799" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/a6dae2e73262446f17b3fcc71c90068b?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/a6dae2e73262446f17b3fcc71c90068b?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281799" class="decomments-date-link">
				
			<time datetime="2:25 pm July 9, 2017">2:25 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">Steve Spence</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281799"><p>Since I already know and love apt-get, why would I want to switch. Your article did not convince.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281799">+1</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment byuser comment-author-abhishek bypostauthor odd alt depth-2 decomments-comment-block" id="comment-281810" parent-id="281799" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281810" class="decomments-date-link">
				
			<time datetime="10:57 pm July 9, 2017">10:57 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281810"><p>It saves you 4 keystrokes :P</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281810">+2</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment even depth-3 decomments-comment-block" id="comment-281812" parent-id="281810" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/f341949914ddead6ba341c679221c627?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/f341949914ddead6ba341c679221c627?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281812" class="decomments-date-link">
				
			<time datetime="3:31 am July 10, 2017">3:31 am<i>July 10, 2017</i></time>			</a>
			<span class="decomments-autor-name">Fani</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281812"><p>That is a very poor reply. I can create an alias called "a" that is "apt-get". </p>
<p>Your article points out some differences but nothing to really convince any one why you'd draw a conclusion that the "avg user" should use apt over apt-get. I'd actually argue the opposite - knowing fundamental things like how apt-get, apt-cache etc. works means you then understand apt better. Knowledge of these allow you to advance beyond "avg user" if you so choose. </p>
<p>If you're an average user, you'd likely just copy/paste whatever whoever tells you - in that case apt-get and apt might as well be the same. </p>
<p>Also, a progress bar is quite useless if you're doing automated work. Not everyone is a Joe Schmoe end user sitting at their ubuntu desktop.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281812"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment odd alt depth-4 decomments-comment-block" id="comment-281836" parent-id="281812" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/ca8013574439fad95b6fbb63a2275a72?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/ca8013574439fad95b6fbb63a2275a72?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281836" class="decomments-date-link">
				
			<time datetime="4:54 pm July 10, 2017">4:54 pm<i>July 10, 2017</i></time>			</a>
			<span class="decomments-autor-name">Luiz Amaral</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281836"><p>Owo man! Shots fired! Even I understood that that was a joke!</p>
<p>I don't think this post was to convince you to use one or another, but to show the differences. If you google it, you will see many people asking the same question. You want to get convinced? From Debian Wiki: "apt is a second command-line based front end provided by APT which overcomes some design mistakes of apt-get."<br />If you want to keep using apt-get, that's your choice. Like which distro you use, GUI or not GUI, stable or backports, Firefox or Chrome...<br />"knowing fundamental things like how apt-get, apt-cache etc. works means you then understand APT better". Sure, if you already know how APT works, you can install the package anyway you want and it won't make a difference. Plus, you can have the same output as apt-cache with apt search and apt show.</p>
<p>Moreover, like not everyone is a Joe Shmoe end user, not everyone is an advanced user. Because I do not always check the changelog, I usually do the update manually and check each package being updated, and the progress bar is a nice feature. If you don't like, well, apt-get and aptitude is there for you.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281836">+2</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div><div class="comment byuser comment-author-abhishek bypostauthor even depth-4 decomments-comment-block" id="comment-281821" parent-id="281812" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281821" class="decomments-date-link">
				
			<time datetime="10:34 am July 10, 2017">10:34 am<i>July 10, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281821"><p>Fani, my reply was a joke.</p>
<p>Second, as far as why an 'average user' should use apt over apt-get is because of the apt is simpler with fewer options. It provides you the necessary options under one command instead of looking though apt-get, apt-cache, apt-config and several other apt commands.</p>
<p>If you are going scripting use apt-get. man pages are with you and you can do whatever you want. And yes, at this point, you are not an average user anymore.</p>
<blockquote><p><cite>I'd actually argue the opposite - knowing fundamental things like how apt-get, apt-cache etc. works means you then understand apt better. Knowledge of these allow you to advance beyond "avg user" if you so choose. </cite></p></blockquote>
<p>In that case, you should opt for dpkg because at the end of the day, apt-get uses dpkg. It's even more low level.</p>
<p>See, knowledge has no end. If you already know apt-get very well and are comfortable with it, stick with it.  But for many other people, who are going to use just a few limited functionalities of apt-get and other related commands, apt is a better option.</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281821">+4</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div></div>
</div></div>
</div></div>
</div><div class="comment odd alt thread-even depth-1 decomments-comment-block" id="comment-281798" parent-id="0" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/4ffc99a91d921235396b03f66304ea1d?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/4ffc99a91d921235396b03f66304ea1d?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281798" class="decomments-date-link">
				
			<time datetime="12:21 pm July 9, 2017">12:21 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">Robert Vits</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281798"><p>Thanks  Abhishek   on my other laptop have Peppermint installed  and have problems with terminal commands  he not accept my password  altough grafical it accepts???? i look on the blogs  but no solution found now i hope with using apt  it maybe works     anyway thanks for great articles  it helped me on several issues   bonne journee a vous   Robert</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281798">+2</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment byuser comment-author-abhishek bypostauthor even depth-2 decomments-comment-block" id="comment-281811" parent-id="281798" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body decomments-bypostauthor"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/20749c268f5d3e4d2c785499eb6a17c0?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="1" data-pai="1""><span class="decomments-author active">Author</span></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281811" class="decomments-date-link">
				
			<time datetime="11:02 pm July 9, 2017">11:02 pm<i>July 9, 2017</i></time>			</a>
			<span class="decomments-autor-name">Abhishek Prakash</span><img width="20" title="" src="https://itsfoss.com/wp-content/uploads/2017/02/king-penguin-152-178484.png" /> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281811"><p>That is most weird. I know you might have already look, but this post discusses several fixes for your issue: <a href="https://askubuntu.com/questions/248853/graphical-authentication-works-why-does-sudo-say-my-password-is-wrong" rel="nofollow" target="_blank">https://askubuntu.com/questions/248853/graphical-authentication-works-why-does-sudo-say-my-password-is-wrong</a></p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote" style="display:none;" ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281811"></b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div><div class="decomments-comment-reply" style="margin-left: 75px;"><div class="comment odd alt depth-3 decomments-comment-block" id="comment-281823" parent-id="281811" >
                 <div  style="padding-left: 75px;" class="decomments-comment-body"> <figure style="width:60px; height:60px;" class="decomments-author-block decomments-round-avatar"><span class="round-wrap"><img alt='' src='https://secure.gravatar.com/avatar/4ffc99a91d921235396b03f66304ea1d?s=60&#038;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&#038;r=g' srcset='https://secure.gravatar.com/avatar/4ffc99a91d921235396b03f66304ea1d?s=120&amp;d=https%3A%2F%2Fitsfoss.com%2Fwp-content%2Fuploads%2F2017%2F01%2Flinux-e1484957306792.png&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' /></span>
                     	<figcaption data-cui="0" data-pai="1""></figcaption>
                     </figure>
                     <div class="decomments-description-block">	<div class="decomments-title-block" style="min-height:37px;">
					<a href="https://itsfoss.com/apt-vs-apt-get-difference/#comment-281823" class="decomments-date-link">
				
			<time datetime="12:03 pm July 10, 2017">12:03 pm<i>July 10, 2017</i></time>			</a>
			<span class="decomments-autor-name">Robert Vits</span> 			</div>
       <div class="decomments-comment-main"><div class="decomments-text-holder decomments-content-281823"><p>Thanks Abhishek  to take time to respond to my problem   i gonna try these fixes and hope  i can solve   i am still green on linux  but as they say   en forgeant devient forgeron   :)   grts Robert        keep you updated if it works out</p>
</div></div>
                         <nav class="decomments-footer-nav"><span class="decomments-vote"><div class="loader-ball-scale"><div></div><div></div><div></div></div><a class="decomments-like-link decomments-voted-likee" data-res="like" href="javascript:void(0)">
		<i class="decomments-icon-like"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/plus.svg"/></i><b></b></a><a class="decomments-dislike-link decomments-voted-dislike " data-res="dislike" href="javascript:void(0)"><i class="decomments-icon-dislike"><img class="svg" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/minus.svg"/></i><b></b></a><span class="decomments-biggest-vote"  ><i class="decomments-icon-bvote"><img class="" src="https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/images/svg/rate.svg"/></i><b id="decomments-vote-id-281823">+1</b></span></span><a href="javascript:void(0)" class="decomments-button decomments-button-reply">Reply</a></nav>
                     </div>
                 </div></div></div>
</div></div>
</div>		</div><!-- .commentlist -->
		</div>
</div>
<div class='code-block code-block-2' style='margin: 8px 0;'>
<div align="center" id="div-gpt-ad-300x250-1">
    <script data-cfasync="false" type='text/javascript'>
        freestar.queue.push(function () { googletag.display('div-gpt-ad-300x250-1'); });
    </script>
</div></div>
</main><span class='ai-sidebar'></span>
<aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="siq_search_widget-4" class="widget widget_siq_search_widget"><div class="widget-wrap"><div id="siq-expandwdgt-cont" class="siq-expandwdgt-cont">
		  <form class="siq-expandwdgt" action="https://itsfoss.com">
		    <input type="search" placeholder="Search" value="" name="s" class="siq-expandwdgt-input"><span class="siq-expandwdgt-icon"></span>
		  </form>
		</div></div></section>
<section id="monarchwidget-5" class="widget widget_monarchwidget"><div class="widget-wrap"><div class="et_social_networks et_social_2col et_social_slide et_social_rounded et_social_top et_social_withcounts et_social_withtotalcount et_social_mobile_on et_social_withnetworknames et_social_outer_dark widget_monarchwidget">
					
					<div class="et_social_totalcount">
						<span class="et_social_totalcount_count et_social_follow_total"></span>
						<span class="et_social_totalcount_label">Follows</span>
					</div>
					<ul class="et_social_icons_container"><li class="et_social_twitter">
						<a href="https://twitter.com/itsfoss2" class="et_social_follow" data-social_name="twitter" data-social_type="follow" data-post_id="16244" target="_blank">
							<i class="et_social_icon et_social_icon_twitter"></i>
							<div class="et_social_network_label"><div class="et_social_networkname">Twitter</div><div class="et_social_count">
						<span>1.2k</span>
						<span class="et_social_count_label">Followers</span>
					</div></div>
							<span class="et_social_overlay"></span>
						</a>
					</li><li class="et_social_youtube">
						<a href="https://www.youtube.com/c/itsfoss" class="et_social_follow" data-social_name="youtube" data-social_type="follow" data-post_id="16244" target="_blank">
							<i class="et_social_icon et_social_icon_youtube"></i>
							<div class="et_social_network_label"><div class="et_social_networkname">YouTube</div><div class="et_social_count">
						<span>2.2k</span>
						<span class="et_social_count_label">Followers</span>
					</div></div>
							<span class="et_social_overlay"></span>
						</a>
					</li><li class="et_social_instagram">
						<a href="https://www.instagram.com/itsfoss/" class="et_social_follow" data-social_name="instagram" data-social_type="follow" data-post_id="16244" target="_blank">
							<i class="et_social_icon et_social_icon_instagram"></i>
							<div class="et_social_network_label"><div class="et_social_networkname">Instagram</div><div class="et_social_count">
						<span>5k</span>
						<span class="et_social_count_label">Followers</span>
					</div></div>
							<span class="et_social_overlay"></span>
						</a>
					</li><li class="et_social_facebook">
						<a href="https://www.facebook.com/itsfoss/" class="et_social_follow" data-social_name="facebook" data-social_type="follow" data-post_id="16244" target="_blank">
							<i class="et_social_icon et_social_icon_facebook"></i>
							<div class="et_social_network_label"><div class="et_social_networkname">Facebook</div><div class="et_social_count">
						<span>102.4k</span>
						<span class="et_social_count_label">Followers</span>
					</div></div>
							<span class="et_social_overlay"></span>
						</a>
					</li></ul>
				</div></div></section>
<section id="text-22" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div align="center" id="div-gpt-ad-300x250-2">
    <script data-cfasync="false" type='text/javascript'>
        freestar.queue.push(function () { googletag.display('div-gpt-ad-300x250-2'); });
    </script>
</div></div>
		</div></section>
<section id="featured-post-6" class="widget featured-content featuredpost"><div class="widget-wrap"><h3 class="widgettitle widget-title">Recent Articles</h3>
<article class="post-16833 post type-post status-publish format-standard has-post-thumbnail category-news tag-fedora tag-fedora-26 tag-linux tag-release entry"><a href="https://itsfoss.com/fedora-26-release/" class="alignleft" aria-hidden="true"><img width="150" height="150" src="https://itsfoss.com/wp-content/uploads/2017/07/Fedora-26-release-150x150.jpg" class="entry-image attachment-post" alt="Fedora 26 Is Released! Check Out The New Features" itemprop="image" data-attachment-id="16840" data-permalink="https://itsfoss.com/fedora-26-release/fedora-26-release/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/Fedora-26-release.jpg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fedora-26-release" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/Fedora-26-release-300x169.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/Fedora-26-release-800x450.jpg" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://itsfoss.com/fedora-26-release/">Fedora 26 Is Released! Check Out The New Features</a></h4></header></article><article class="post-16663 post type-post status-publish format-standard has-post-thumbnail category-apps category-terminal-tricks tag-cmus tag-console tag-music-player tag-terminal tag-tui entry"><a href="https://itsfoss.com/cmus-linux-terminal-music-player/" class="alignleft" aria-hidden="true"><img width="150" height="150" src="https://itsfoss.com/wp-content/uploads/2017/07/cmus-listen-music-linux-terminal-150x150.jpg" class="entry-image attachment-post" alt="cmus: The Ultimate Music Player For Linux Terminal Lovers" itemprop="image" data-attachment-id="16792" data-permalink="https://itsfoss.com/cmus-linux-terminal-music-player/cmus-listen-music-linux-terminal/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/cmus-listen-music-linux-terminal.jpg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cmus-listen-music-linux-terminal" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/cmus-listen-music-linux-terminal-300x169.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/cmus-listen-music-linux-terminal-800x450.jpg" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://itsfoss.com/cmus-linux-terminal-music-player/">cmus: The Ultimate Music Player For Linux Terminal Lovers</a></h4></header></article><article class="post-16710 post type-post status-publish format-standard has-post-thumbnail category-desktop tag-desktop-customization tag-pop-gtk-theme tag-pop-icon-theme tag-pop-os tag-system76 entry"><a href="https://itsfoss.com/pop-icon-gtk-theme-ubuntu/" class="alignleft" aria-hidden="true"><img width="150" height="150" src="https://itsfoss.com/wp-content/uploads/2017/07/system76-pop-os-icon-theme-desktop-150x150.jpeg" class="entry-image attachment-post" alt="Give Your Ubuntu Linux A Stunning Makeover With Pop Icon and GTK Theme" itemprop="image" data-attachment-id="16727" data-permalink="https://itsfoss.com/pop-icon-gtk-theme-ubuntu/system76-pop-os-icon-theme-desktop/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/system76-pop-os-icon-theme-desktop.jpeg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="system76-pop-os-icon-theme-desktop" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/system76-pop-os-icon-theme-desktop-300x169.jpeg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/system76-pop-os-icon-theme-desktop-800x450.jpeg" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://itsfoss.com/pop-icon-gtk-theme-ubuntu/">Give Your Ubuntu Linux A Stunning Makeover With Pop Icon and GTK Theme</a></h4></header></article><article class="post-16666 post type-post status-publish format-standard has-post-thumbnail category-news tag-debian tag-debian-linux tag-intel-kaby-lake tag-intel-skylake entry"><a href="https://itsfoss.com/debian-bug-intel-processor/" class="alignleft" aria-hidden="true"><img width="150" height="150" src="https://itsfoss.com/wp-content/uploads/2017/07/debian-bug-intel-processors-150x150.jpg" class="entry-image attachment-post" alt="Debian Reveals Bug That Causes Unpredictable System Behavior In Some Intel Processors" itemprop="image" data-attachment-id="16736" data-permalink="https://itsfoss.com/debian-bug-intel-processor/debian-bug-intel-processors/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/debian-bug-intel-processors.jpg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="debian-bug-intel-processors" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/debian-bug-intel-processors-300x169.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/debian-bug-intel-processors-800x450.jpg" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://itsfoss.com/debian-bug-intel-processor/">Debian Reveals Bug That Causes Unpredictable System Behavior In Some Intel Processors</a></h4></header></article><article class="post-16688 post type-post status-publish format-standard has-post-thumbnail category-news tag-pop_os tag-pop_os-alpha tag-system76 entry"><a href="https://itsfoss.com/system76-popos-linux/" class="alignleft" aria-hidden="true"><img width="150" height="150" src="https://itsfoss.com/wp-content/uploads/2017/07/pop-os-by-system76-150x150.jpg" class="entry-image attachment-post" alt="Linux Machine Vendor System76 Announces Its Own Linux Distribution" itemprop="image" data-attachment-id="16702" data-permalink="https://itsfoss.com/system76-popos-linux/pop-os-by-system76/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/07/pop-os-by-system76.jpg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="pop-os-by-system76" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/07/pop-os-by-system76-300x169.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/07/pop-os-by-system76-800x450.jpg" /></a><header class="entry-header"><h4 class="entry-title" itemprop="headline"><a href="https://itsfoss.com/system76-popos-linux/">Linux Machine Vendor System76 Announces Its Own Linux Distribution</a></h4></header></article></div></section>
<section id="text-27" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- Sidebar Responsive --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-7412881080628184"
     data-ad-slot="4099615486"
     data-ad-format="auto"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div></section>
<section id="swp_popular_posts_widget-2" class="widget widget_swp_popular_posts_widget"><div class="widget-wrap"><div class="widget-text swp_widget_box" style="padding:15px;background:#EEEEEE;"><h4 class="widgettitle widget-title swp_popular_posts_title" style="color:#30394F;">Recent Popular Posts</h4><div class="swp_popular_post"><a href="https://itsfoss.com/microsoft-using-git/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://itsfoss.com/wp-content/uploads/2017/06/Linus-torvalds-with-Microsoft-150x150.jpg" title="Microsoft Is Now Using Linus Torvalds&#8217; Open Source Tool For Windows Development" alt="Microsoft Is Now Using Linus Torvalds&#8217; Open Source Tool For Windows Development" nopin="nopin" /></a><a style="font-size:100%;color:#30394F;" class="swp_popularity" href="https://itsfoss.com/microsoft-using-git/"><b>Microsoft Is Now Using Linus Torvalds&#8217; Open Source Tool For Windows Development</b><span class="swp_pop_count">2K Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://itsfoss.com/myths-about-linux/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://itsfoss.com/wp-content/uploads/2017/05/Linux-Myths-busted-150x150.jpg" title="5 Myths About Linux That Scares Away New Users" alt="5 Myths About Linux That Scares Away New Users" nopin="nopin" /></a><a style="font-size:100%;color:#30394F;" class="swp_popularity" href="https://itsfoss.com/myths-about-linux/"><b>5 Myths About Linux That Scares Away New Users</b><span class="swp_pop_count">960 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://itsfoss.com/debian-9-stretch-features/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://itsfoss.com/wp-content/uploads/2017/05/debian-9-stretch-150x150.png" title="Debian 9 Stretch Stable Is Released! Check Out The New Features" alt="Debian 9 Stretch Stable Is Released! Check Out The New Features" nopin="nopin" /></a><a style="font-size:100%;color:#30394F;" class="swp_popularity" href="https://itsfoss.com/debian-9-stretch-features/"><b>Debian 9 Stretch Stable Is Released! Check Out The New Features</b><span class="swp_pop_count">912 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://itsfoss.com/how-to-exit-vim/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://itsfoss.com/wp-content/uploads/2017/05/exit-vim-150x150.jpg" title="How To Exit Vim? Multiple Ways To Quit Vim Editor" alt="How To Exit Vim? Multiple Ways To Quit Vim Editor" nopin="nopin" /></a><a style="font-size:100%;color:#30394F;" class="swp_popularity" href="https://itsfoss.com/how-to-exit-vim/"><b>How To Exit Vim? Multiple Ways To Quit Vim Editor</b><span class="swp_pop_count">820 Total Shares</span></a></div><div class="swp_clearfix"></div><div class="swp_popular_post"><a href="https://itsfoss.com/antergos-linux-review/"><img style="width:100px;height:100px;" class="swp_pop_thumb" src="https://itsfoss.com/wp-content/uploads/2017/05/antergos-linux-review-150x150.jpg" title="[Review] Antergos Is More Than Just A Noob&#8217;s Arch Linux" alt="[Review] Antergos Is More Than Just A Noob&#8217;s Arch Linux" nopin="nopin" /></a><a style="font-size:100%;color:#30394F;" class="swp_popularity" href="https://itsfoss.com/antergos-linux-review/"><b>[Review] Antergos Is More Than Just A Noob&#8217;s Arch Linux</b><span class="swp_pop_count">566 Total Shares</span></a></div><div class="swp_clearfix"></div></div></div></section>
<section id="text-26" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- Sidebar Skyscrapper --><br />
<ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 600px;" data-ad-client="ca-pub-7412881080628184" data-ad-slot="2622882288"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div></section>
<section id="media_image-6" class="widget widget_media_image"><div class="widget-wrap"><a href="https://www.patreon.com/itsfoss" class="" rel="" target="_blank"><img width="300" height="59" src="https://itsfoss.com/wp-content/uploads/2017/06/patreon-medium-button-300x59.png" class="image wp-image-16504  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://itsfoss.com/wp-content/uploads/2017/06/patreon-medium-button-300x59.png 300w, https://itsfoss.com/wp-content/uploads/2017/06/patreon-medium-button-e1499780017871.png 301w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="16504" data-permalink="https://itsfoss.com/patreon-medium-button/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/06/patreon-medium-button-e1499780017871.png" data-orig-size="301,59" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="patreon-medium-button" data-image-description="" data-medium-file="https://itsfoss.com/wp-content/uploads/2017/06/patreon-medium-button-300x59.png" data-large-file="https://itsfoss.com/wp-content/uploads/2017/06/patreon-medium-button-e1499780017871.png" /></a></div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2017 It's F.O.S.S · Built on <a href="http://www.shareasale.com/r.cfm?b=346198&u=747593&m=28169&urllink=&afftrack=">Genesis Framework</a></p><div class="scroll-up"><button class="scrollup"></button></div></div></footer></div>	<script type="text/javascript">

	jQuery('body').on('geo_timeout_error', onGeo_timeout_error);

	function onGeo_timeout_error() {
		console.warn('The geolocationGetCurrent timed out');

		var html  = '<h2 style="margin-top:36px;">GPS Failed</h2>';
			html += '<p>Your GPS did not respond. Be sure you have your GPS enabled and try again.</p>';
			html += '<button onclick="AppGeo_getLoc()">Try Again</button>';
			html += '<div style="height:1000px"></div>'; // a little hack to hide the checkin button without really tampering with it.

		jQuery('#map-canvas').html(html);

	}

	</script>
			<div style="display:none">
	<div class="grofile-hash-map-20749c268f5d3e4d2c785499eb6a17c0">
	</div>
	<div class="grofile-hash-map-3828e1430c75be4bfb250829be71e7e9">
	</div>
	<div class="grofile-hash-map-3a764c2bb096c330ad8739c615aae534">
	</div>
	<div class="grofile-hash-map-1cc128540d142356370367d6f225bb04">
	</div>
	<div class="grofile-hash-map-20749c268f5d3e4d2c785499eb6a17c0">
	</div>
	<div class="grofile-hash-map-603e550cd2cdc1059cb785a3b1075964">
	</div>
	<div class="grofile-hash-map-f65e256bb04beaf79fe8e77882bbe1cb">
	</div>
	<div class="grofile-hash-map-1f8988a614c00df58bcc8e5c622097dd">
	</div>
	<div class="grofile-hash-map-52ea599339dd92419e8f2559cb767e7b">
	</div>
	<div class="grofile-hash-map-4767231bb98cfd3f7f88b3f27980ae29">
	</div>
	<div class="grofile-hash-map-77e456af4a6fbb97ef9363330f98fa2b">
	</div>
	<div class="grofile-hash-map-3fb9548bc8e43dc499e2cce8e261482d">
	</div>
	<div class="grofile-hash-map-2bb6f6978ae94060e228e99c6ca6a55b">
	</div>
	<div class="grofile-hash-map-e99ffa0d8b97589c4eab146577561c96">
	</div>
	<div class="grofile-hash-map-f341949914ddead6ba341c679221c627">
	</div>
	<div class="grofile-hash-map-ca8013574439fad95b6fbb63a2275a72">
	</div>
	<div class="grofile-hash-map-4ffc99a91d921235396b03f66304ea1d">
	</div>
	</div>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-24863836-4', 'auto');
  ga('send', 'pageview');

</script><!-- This site is converting visitors into subscribers and customers with OptinMonster - http://optinmonster.com --><div id="om-dedealwmjro3tx5v-holder"></div><script>var dedealwmjro3tx5v,dedealwmjro3tx5v_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){dedealwmjro3tx5v_poll(function(){if(window['om_loaded']){if(!dedealwmjro3tx5v){dedealwmjro3tx5v=new OptinMonsterApp();return dedealwmjro3tx5v.init({"u":"447.195704","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="//a.optnmnstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;dedealwmjro3tx5v=new OptinMonsterApp();dedealwmjro3tx5v.init({"u":"447.195704","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - http://optinmonster.com --><div id="om-by19m9tmzfns6oco-holder"></div><script>var by19m9tmzfns6oco,by19m9tmzfns6oco_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){by19m9tmzfns6oco_poll(function(){if(window['om_loaded']){if(!by19m9tmzfns6oco){by19m9tmzfns6oco=new OptinMonsterApp();return by19m9tmzfns6oco.init({"u":"447.470037","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="//a.optnmnstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;by19m9tmzfns6oco=new OptinMonsterApp();by19m9tmzfns6oco.init({"u":"447.470037","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - http://optinmonster.com --><div id="om-pztb1uabhcye9ksm-holder"></div><script>var pztb1uabhcye9ksm,pztb1uabhcye9ksm_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){pztb1uabhcye9ksm_poll(function(){if(window['om_loaded']){if(!pztb1uabhcye9ksm){pztb1uabhcye9ksm=new OptinMonsterApp();return pztb1uabhcye9ksm.init({"u":"447.408081","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="//a.optnmnstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;pztb1uabhcye9ksm=new OptinMonsterApp();pztb1uabhcye9ksm.init({"u":"447.408081","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster -->	    <script type="text/javascript">var dedealwmjro3tx5v_shortcode = true;var by19m9tmzfns6oco_shortcode = true;var pztb1uabhcye9ksm_shortcode = true;</script>
	    <!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://itsfoss.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='dashicons-css'  href='https://itsfoss.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://itsfoss.com/wp-includes/js/thickbox/thickbox.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_login_object = {"ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","redirecturl":"\/apt-vs-apt-get-difference\/","loadingmessage":"Verifying data..."};
/* ]]> */
</script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/decomments/templates/decomments/assets/js/decom.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cnArgs = {"ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","hideEffect":"fade","onScroll":"no","onScrollOffset":"100","cookieName":"cookie_notice_accepted","cookieValue":"TRUE","cookieTime":"2592000","cookiePath":"\/","cookieDomain":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/cookie-notice/js/front.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/monarch/js/idle-timer.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monarchSettings = {"ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/itsfoss.com\/apt-vs-apt-get-difference\/","stats_nonce":"c89f476106","share_counts":"39873f8356","follow_counts":"a8b99f7d66","total_counts":"ce5d08be2c","media_single":"2d30779561","media_total":"856bc25ad4","generate_all_window_nonce":"83f9890bcc","no_img_message":"No images available for sharing on this page"};
/* ]]> */
</script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/monarch/js/custom.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/social-warfare/js/script.min.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/jetpack/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-includes/js/hoverIntent.min.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/themes/genesis/lib/js/menu/superfish.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/themes/vibrant-pro/js/superfish.args.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/themes/genesis/lib/js/skip-links.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/themes/vibrant-pro/js/match-height.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/themes/vibrant-pro/js/vibrant.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","subMenu":"Submenu","menuClasses":{"others":[".nav-primary",".nav-secondary"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/themes/vibrant-pro/js/responsive-menus.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/themes/vibrant-pro/js/owl.carousel.min.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/themes/vibrant-pro/js/post-slider.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/jetpack/_inc/spin.js'></script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/jetpack/_inc/jquery.spin.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","nonce":"bf938f3787","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/itsfoss.com\/wp-login.php?redirect_to=https%3A%2F%2Fitsfoss.com%2Fapt-vs-apt-get-difference%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://itsfoss.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js'></script>
<script type='text/javascript' src='https://widgets.stackcommerce.com/deal-feed/stackCommerceWidget-v2.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/itsfoss.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://itsfoss.com/wp-includes/js/thickbox/thickbox.js'></script>
		<script type="text/javascript">
			if(typeof jQuery != "undefined") {
					jQuery('.siq-expsearch-icon').each(function(){
					var searchBox = (jQuery(this).parents('.siq-icon-searchbox-wrap').size() > 0) ? jQuery(this).parents('.siq-icon-searchbox-wrap') : jQuery('.siq-menu-searchbox-wrap') ;
					var inputBox = searchBox.find('.siq-expsearch-input');
					
					jQuery(this).on('click', function () {
						if (!searchBox.hasClass('siq-search-open')) {
							searchBox.addClass('siq-search-open');
							inputBox.focus();
						} else {
							searchBox.removeClass('siq-search-open');
							inputBox.focusout();
						}
					});
					jQuery('body').click(function (evt) {
						if (evt.target.id == "siq-menu-searchbox-wrap")
							return;
						if (jQuery(evt.target).closest('#siq-menu-searchbox-wrap').length || jQuery(evt.target).closest('.siq-icon-searchbox-wrap').length)
							return;

						if (searchBox.hasClass('siq-search-open')) {
							searchBox.removeClass('siq-search-open');
						}
					});
				});
			}
		</script>
		<script type="text/javascript"> swpPinIt={"enabled":false};var swpClickTracking = true; var swp_nonce = "758e816141";
function parentIsEvil() { var html = null; try { var doc = top.location.pathname; } catch(err){ }; if(typeof doc === "undefined") { return true } else { return false }; }; if (parentIsEvil()) { top.location = self.location.href; };var url = "https://itsfoss.com/apt-vs-apt-get-difference/";if(url.indexOf("stfi.re") != -1) { var canonical = ""; var links = document.getElementsByTagName("link"); for (var i = 0; i < links.length; i ++) { if (links[i].getAttribute("rel") === "canonical") { canonical = links[i].getAttribute("href")}}; canonical = canonical.replace("?sfr=1", "");top.location = canonical; console.log(canonical);};</script><script type='text/javascript' src='https://stats.wp.com/e-201728.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.1',blog:'37237282',post:'16244',tz:'2',srv:'itsfoss.com'} ]);
	_stq.push([ 'clickTrackerInit', '37237282', '16244' ]);
</script>

			<div id="cookie-notice" role="banner" class="cn-bottom bootstrap" style="color: #fff; background-color: #00b6ba;"><div class="cookie-notice-container"><span id="cn-notice-text">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie button bootstrap">Ok</a><a href="https://itsfoss.com/privacy-policy/" target="_blank" id="cn-more-info" class="button bootstrap">Read more</a>
				</div>
			</div>	    <script type="text/javascript">var omapi_localized = { ajax: 'https://itsfoss.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: 'a08f5d3ae3' };</script>
	    </body></html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced (SSL caching disabled)
Fragment Caching 16/16 fragments using disk

 Served from: itsfoss.com @ 2017-07-12 07:48:22 by W3 Total Cache -->