<!DOCTYPE html><html lang="en-US"><head ><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /><title>Top 8 Best Open Source CRM Software [2019]</title><meta name="dc.title" content="Top 8 Best Open Source CRM Software [2019]" /><meta name="dc.description" content="Here are the best open source CRM software available for small and medium sized businesses. You may host them on your own or opt for their hosted versions." /><meta name="dc.relation" content="https://itsfoss.com/best-open-source-crm/" /><meta name="dc.source" content="https://itsfoss.com/" /><meta name="dc.language" content="en_US" /><meta name="description" content="Here are the best open source CRM software available for small and medium sized businesses. You may host them on your own or opt for their hosted versions." /><link rel="canonical" href="https://itsfoss.com/best-open-source-crm/" /><meta property="og:url" content="https://itsfoss.com/best-open-source-crm/" /><meta property="og:site_name" content="It&#039;s FOSS" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Top 8 Best Open Source CRM Software [2019]" /><meta property="og:description" content="Here are the best open source CRM software available for small and medium sized businesses. You may host them on your own or opt for their hosted versions." /><meta property="og:image" content="https://itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png" /><meta property="og:image:secure_url" content="https://itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png" /><meta property="og:image:width" content="800" /><meta property="og:image:height" content="450" /><meta property="og:image:alt" content="Open Source Crm Software" /><meta name="twitter:card" content="summary_large_image"><meta name="twitter:site" content="@itsfoss2" /><meta name="twitter:creator" content="@itsfoss2" /><meta name="twitter:title" content="Top 8 Best Open Source CRM Software [2019]" /><meta name="twitter:description" content="Here are the best open source CRM software available for small and medium sized businesses. You may host them on your own or opt for their hosted versions." /><meta name="twitter:image:src" content="https://itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png" /><link rel='dns-prefetch' href='//static.apester.com' /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//a.opmnstr.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Feed" href="http://feeds.feedburner.com/ItsFoss" /><link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; Comments Feed" href="https://itsfoss.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="It&#039;s FOSS &raquo; 8 Best Open Source CRM Software Comments Feed" href="https://itsfoss.com/best-open-source-crm/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='atomic-blocks-fontawesome-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/atomic-blocks/dist/assets/fontawesome/css/all.min-1561608676.css' type='text/css' media='all' /><link rel='stylesheet' id='genesis-sample-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/themes/genesis-sample/style-3.0.1.css' type='text/css' media='all' /><style id='genesis-sample-inline-css' type='text/css'>a,.entry-title a:focus,.entry-title a:hover,.genesis-nav-menu a:focus,.genesis-nav-menu a:hover,.genesis-nav-menu .current-menu-item>a,.genesis-nav-menu .sub-menu .current-menu-item>a:focus,.genesis-nav-menu .sub-menu .current-menu-item>a:hover,.menu-toggle:focus,.menu-toggle:hover,.sub-menu-toggle:focus,.sub-menu-toggle:hover{color:#00b6ba}button:focus,button:hover,input[type="button"]:focus,input[type="button"]:hover,input[type="reset"]:focus,input[type="reset"]:hover,input[type="submit"]:focus,input[type="submit"]:hover,input[type="reset"]:focus,input[type="reset"]:hover,input[type="submit"]:focus,input[type="submit"]:hover,.site-container div.wpforms-container-full .wpforms-form input[type="submit"]:focus,.site-container div.wpforms-container-full .wpforms-form input[type="submit"]:hover,.site-container div.wpforms-container-full .wpforms-form button[type="submit"]:focus,.site-container div.wpforms-container-full .wpforms-form button[type="submit"]:hover,.button:focus,.button:hover{background-color:#00b6ba;color:#333}@media only screen and (min-width:960px){.genesis-nav-menu>.menu-highlight>a:hover,.genesis-nav-menu>.menu-highlight>a:focus,.genesis-nav-menu>.menu-highlight.current-menu-item>a{background-color:#00b6ba;color:#333}}</style><link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.2.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='atomic-blocks-style-css-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/atomic-blocks/dist/blocks.style.build-1561608676.css' type='text/css' media='all' /><link rel='stylesheet' id='socialsnap-styles-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/socialsnap-pro/assets/css/socialsnap-1.1.5.2.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-coupons-styles-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/wp-coupons/css/style-1.6.0.css' type='text/css' media='all' /><link rel='stylesheet' id='ufwp_styles-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/wp-udemy/public/css/styles.min-1.1.3.css' type='text/css' media='all' /><link rel='stylesheet' id='ufwp_pro_styles-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/wp-udemy-pro/public/css/styles.min-1.0.8.css' type='text/css' media='all' /><link rel='stylesheet' id='genesis-sample-fonts-css'  href='https://fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C400i%2C600%2C700&#038;display=swap&#038;ver=3.0.1' type='text/css' media='all' /><link rel='stylesheet' id='dashicons-css'  href='https://c0.wp.com/c/5.2.2/wp-includes/css/dashicons.min.css' type='text/css' media='all' /><link rel='stylesheet' id='genesis-sample-gutenberg-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/themes/genesis-sample/lib/gutenberg/front-end-3.0.1.css' type='text/css' media='all' /><style id='genesis-sample-gutenberg-inline-css' type='text/css'>.ab-block-post-grid .ab-post-grid-items h2 a:hover{color:#00b6ba}.site-container .wp-block-button .wp-block-button__link{background-color:#00b6ba}.wp-block-button .wp-block-button__link:not(.has-background),.wp-block-button .wp-block-button__link:not(.has-background):focus,.wp-block-button .wp-block-button__link:not(.has-background):hover{color:#333}.site-container .wp-block-button.is-style-outline .wp-block-button__link{color:#00b6ba}.site-container .wp-block-button.is-style-outline .wp-block-button__link:focus,.site-container .wp-block-button.is-style-outline .wp-block-button__link:hover{color:#23d9dd}.site-container .has-small-font-size{font-size:12px}.site-container .has-normal-font-size{font-size:18px}.site-container .has-large-font-size{font-size:20px}.site-container .has-larger-font-size{font-size:24px}.site-container .has-theme-primary-color,.site-container .wp-block-button .wp-block-button__link.has-theme-primary-color,.site-container .wp-block-button.is-style-outline .wp-block-button__link.has-theme-primary-color{color:#00b6ba}.site-container .has-theme-primary-background-color,.site-container .wp-block-button .wp-block-button__link.has-theme-primary-background-color,.site-container .wp-block-pullquote.is-style-solid-color.has-theme-primary-background-color{background-color:#00b6ba}.site-container .has-theme-secondary-color,.site-container .wp-block-button .wp-block-button__link.has-theme-secondary-color,.site-container .wp-block-button.is-style-outline .wp-block-button__link.has-theme-secondary-color{color:#00b6ba}.site-container .has-theme-secondary-background-color,.site-container .wp-block-button .wp-block-button__link.has-theme-secondary-background-color,.site-container .wp-block-pullquote.is-style-solid-color.has-theme-secondary-background-color{background-color:#00b6ba}</style><link rel='stylesheet' id='forget-about-shortcode-buttons-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/forget-about-shortcode-buttons/public/css/button-styles-2.1.2.css' type='text/css' media='all' /><link rel='stylesheet' id='aawp-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/aawp/public/assets/css/styles.min-3.8.9.css' type='text/css' media='all' /><link rel='stylesheet' id='tcm-front-styles-css-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/thrive-comments/assets/css/styles-1.2.8.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-auth-check-css'  href='https://c0.wp.com/c/5.2.2/wp-includes/css/wp-auth-check.min.css' type='text/css' media='all' /><link rel='stylesheet' id='__EPYT__style-css'  href='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min-13.1.css' type='text/css' media='all' /><style id='__EPYT__style-inline-css' type='text/css'>.epyt-gallery-thumb{width:33.333%}</style><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://itsfoss.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}.wp-has-aspect-ratio .rll-youtube-player{position:absolute;padding-bottom:0;width:100%;height:100%;top:0;bottom:0;left:0;right:0}</style><link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/7.5.3/css/jetpack.css' type='text/css' media='all' /> <script type='text/javascript'>/* <![CDATA[ */ var configuration = {"rendererBaseUrl":"https:\/\/renderer.apester.com"}; /* ]]> */</script> <script type='text/javascript' async="async" src='https://static.apester.com/js/sdk/latest/apester-javascript-sdk.min.js?ver=5.2.2'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/jquery/jquery-migrate.min.js'></script> <script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='https://a.opmnstr.com/app/js/api.min.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/thrive-comments/assets/js/libs-frontend.min-1.2.8.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var _EPYT_ = {"ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","security":"8b0986789c","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/itsfoss.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","eppath":"https:\/\/itsfoss.com\/wp-content\/plugins\/youtube-embed-plus\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"13.1","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min-13.1.js'></script> <style>.eaa-clean{padding:0!important;border:none!important}.eaa-ad.alignleft{margin-right:10px}.eaa-ad.alignright{margin-left:10px}.eaa-ad.debug{background:peachpuff;border:solid 2px red;box-sizing:border-box}</style><link rel='https://api.w.org/' href='https://itsfoss.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://itsfoss.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://itsfoss.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Ubuntu 18.10 Reaches End of Life! Existing Users Must Upgrade Now' href='https://itsfoss.com/ubuntu-18-10-reaches-end-of-life/' /><link rel='next' title='WPS Office on Linux is a Free Alternative to Microsoft Office' href='https://itsfoss.com/wps-office-linux/' /><meta name="generator" content="WordPress 5.2.2" /><link rel='shortlink' href='https://wp.me/p2wf7k-fKr' /><style type="text/css">#ss-share-hub>a::after{background-color:#4f89e1}#ss-share-hub>a{color:#fff}</style><style>#thrive-comments .tcm-color-ac,#thrive-comments .tcm-color-ac span{color:#00b6ba}#thrive-comments .tcm-background-color-ac,#thrive-comments .tcm-background-color-ac-h:hover span,#thrive-comments .tcm-background-color-ac-active:active{background-color:#00b6ba}#thrive-comments .tcm-border-color-ac{border-color:#00b6ba;outline:none}#thrive-comments .tcm-border-color-ac-h:hover{border-color:#00b6ba}#thrive-comments .tcm-border-bottom-color-ac{border-bottom-color:#00b6ba}#thrive-comments .tcm-svg-fill-ac{fill:#00b6ba}#thrive-comments textarea:focus,#thrive-comments input:focus{border-color:#00b6ba;box-shadow:inset 0 0 3px #00b6ba}#thrive-comments a{color:#00b6ba}#thrive-comments button,#thrive-comments #tcm-login-up,#thrive-comments #tcm-login-down{color:#00b6ba;border-color:#00b6ba}#thrive-comments button:hover,#thrive-comments button:active{background-color:#00b6ba}</style><style type="text/css">.aawp .aawp-tb__row--highlight{background-color:#256aaf}.aawp .aawp-tb__row--highlight{color:#256aaf}.aawp .aawp-tb__row--highlight a{color:#256aaf}</style><link rel='dns-prefetch' href='//c0.wp.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/> <script data-cfasync="false" type="text/javascript">var freestar = freestar || {};
    freestar.hitTime = Date.now();
    freestar.queue = freestar.queue || [];
    freestar.config = freestar.config || {};
    freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;

    // Tag IDs set here, must match Tags served in the Body for proper setup
    freestar.config.enabled_slots = [
        "itsfoss_728x90_320x50_ATF",
        "itsfoss_300x250_Sidebar1",
        "itsfoss_300x250_300x600_Sidebar2"
    ];

    !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/itsfoss";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);</script> <script type="text/javascript" src="https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js" async="true"></script> <meta name="ahrefs-site-verification" content="f8a49089ffadfb2c5b3f7b2e1c37e30d9c7a78c3c78a2d2950300ce64ed9cd27"> <script type="text/javascript" src="https://a.pub.network/unumcarta/unumcarta.js"></script> <meta property="article:publisher" content="https://www.facebook.com/itsfoss" /><meta name="description" content="Here are some of the best open source CRM software available for small &amp; medium sized businesses. You can host them on your own or opt for their hosted versions." /><style type="text/css">html:not(.jetpack-lazy-images-js-enabled):not(.js) .jetpack-lazy-image{display:none}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="icon" href="https://i0.wp.com/itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name.png?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i0.wp.com/itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name.png?fit=192%2C192&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name.png?fit=180%2C180&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i0.wp.com/itsfoss.com/wp-content/uploads/2017/06/cropped-Logo-redsigned-without-name.png?fit=270%2C270&#038;ssl=1" /><style type="text/css" id="wp-custom-css">.entry-content code{background-color:#00B6BA;color:#fff;padding:0 .2em}.entry-content pre{background-color:#00B6BA;color:#fff;padding:.5em 1em;overflow:auto;word-wrap:normal}::-moz-selection{background-color:#B2D531;color:#fff}::selection{background-color:#B2D531;color:#fff}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body class="post-template-default single single-post postid-60539 single-format-standard wp-embed-responsive aawp-custom header-full-width content-sidebar first-block-core-paragraph" itemscope itemtype="https://schema.org/WebPage"><script type="text/javascript">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</script> <div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li><li><a href="#genesis-footer-widgets" class="screen-reader-shortcut"> Skip to footer</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://itsfoss.com/">It&#039;s FOSS</a></p><p class="site-description" itemprop="description">A Linux and Open Source Web Portal</p></div><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-one-menu-for-all" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-10108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10108"><a href="https://itsfoss.com/about/" itemprop="url"><span itemprop="name">About</span></a><ul class="sub-menu"><li id="menu-item-17559" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17559"><a href="https://itsfoss.com/contact-us/" itemprop="url"><span itemprop="name">Contact Us</span></a></li><li id="menu-item-17560" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17560"><a href="https://itsfoss.com/get-featured-on-its-foss/" itemprop="url"><span itemprop="name">Get Featured On It&#8217;s FOSS</span></a></li></ul></li><li id="menu-item-10119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10119"><a href="https://itsfoss.com/category/linux/" itemprop="url"><span itemprop="name">Linux</span></a><ul class="sub-menu"><li id="menu-item-10121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10121"><a href="https://itsfoss.com/category/news/" itemprop="url"><span itemprop="name">Linux News</span></a></li><li id="menu-item-10112" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10112"><a href="https://itsfoss.com/category/apps/" itemprop="url"><span itemprop="name">Apps</span></a></li><li id="menu-item-10116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10116"><a href="https://itsfoss.com/category/gadgets/" itemprop="url"><span itemprop="name">Gadgets</span></a></li><li id="menu-item-10113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10113"><a href="https://itsfoss.com/category/desktop/" itemprop="url"><span itemprop="name">Desktop Customization</span></a></li></ul></li><li id="menu-item-10118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10118"><a href="https://itsfoss.com/category/how-to/" itemprop="url"><span itemprop="name">Linux Tutorials</span></a></li><li id="menu-item-17561" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-17561"><a href="https://itsfoss.com/category/list/" itemprop="url"><span itemprop="name">Top X</span></a></li><li id="menu-item-10130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10130"><a href="http://itsfoss.tradepub.com/category/information-technology-servers-and-linux-server-os/806/" itemprop="url" class="external" rel="nofollow" target="_blank"><span itemprop="name">eBooks in $0</span></a></li><li id="menu-item-10129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10129"><a href="https://shop.itsfoss.com/" itemprop="url"><span itemprop="name">Shop</span></a></li><li id="menu-item-54578" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54578"><a href="https://itsfoss.com/deals/" itemprop="url"><span itemprop="name">Linux Deals</span></a></li><li id="menu-item-27195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27195"><a title="If you see a grammatical or technical error, please notify us on this link." href="https://itsfoss.com/feedback/" itemprop="url"><span itemprop="name">Article needs update?</span></a></li></ul></div></nav></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="breadcrumb" itemscope itemtype="https://schema.org/BreadcrumbList">You are here: <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://itsfoss.com/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Home</span></a><meta itemprop="position" content="1"></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap" itemprop="itemListElement" itemscope itemtype="https://schema.org/ListItem"><a class="breadcrumb-link" href="https://itsfoss.com/category/apps/" itemprop="item"><span class="breadcrumb-link-text-wrap" itemprop="name">Apps</span></a><meta itemprop="position" content="2"></span> <span aria-label="breadcrumb separator">/</span> 8 Best Open Source CRM Software</div><article class="post-60539 post type-post status-publish format-standard has-post-thumbnail category-apps category-list tag-crm entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">8 Best Open Source CRM Software</h1><p class="entry-meta">Last updated <time class="entry-modified-time" itemprop="dateModified" datetime="2019-07-23T12:01:59+02:00">July 23, 2019</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://itsfoss.com/author/ankush/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Ankush Das</span></a></span> <span class="entry-comments-link"><a href="https://itsfoss.com/best-open-source-crm/#comments">3 Comments</a></span></p></header><div align="center" id="itsfoss_728x90_320x50_ATF"> <script data-cfasync="false" type='text/javascript'>freestar.queue.push(function () { googletag.display('itsfoss_728x90_320x50_ATF'); });</script> </div><div class="entry-content" itemprop="text"><p><strong><em>In this article, we list some of the best open source CRM software available for small and medium sized businesses.</em></strong></p><h2>What is CRM?</h2><p>CRM stands for <a href="https://en.wikipedia.org/wiki/Customer_relationship_management" target="_blank" rel="noreferrer noopener nofollow" aria-label="Customer Relationship Management (opens in a new tab)" class="external">Customer Relationship Management</a>. A CRM software enables the companies to interact with their potential and existing customers, understand and manage their requirement. This improved the relation of the organization with customer and you know that a happy customer brings profitability to the business.</p><p>No matter how big your team is (small business or a big firm), a CRM software always comes in handy when you want to keep things organized in your business.</p><p>You may avoid a CRM software for a couple of employees when you start a business. However, to streamline the process and make the work efficient and fast &#8211; you will eventually need a CRM software.</p><div id="eaa_after_nth_p" class="eaa-wrapper eaa_after_nth_p eaa_desktop"><div class="eaa-ad  " style=""> <script type="text/javascript" language="javascript" src="https://live.sekindo.com/live/liveView.php?s=97824&vid_viewAction=player&cbuster=[CACHE_BUSTER]&x=500&y=280&vid_outPause=0"></script> </div></div><p>But, what about the level of control (or security) in a CRM software? Do you want a transparent CRM software which you can take control of?</p><p>Well, that is when an open source CRM software comes into play. You can host it yourself, and you can customize it as per your requirements. You may also opt for the hosted version where you don&#8217;t have to manage it yourself.</p><p>In this article, we talk about some of the best open-source CRM tools I have found.</p><h2>Best Free and Open Source CRM Software</h2><div class="wp-block-image"><figure class="aligncenter"><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?resize=800%2C450&#038;ssl=1" alt="Open Source Crm Software" class="wp-image-62129 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?w=800&amp;ssl=1 800w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?resize=768%2C432&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?resize=800%2C450&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?resize=800%2C450&#038;ssl=1" alt="Open Source Crm Software" class="wp-image-62129" srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?w=800&amp;ssl=1 800w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?resize=300%2C169&amp;ssl=1 300w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?resize=768%2C432&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" data-recalc-dims="1" /></noscript></figure></div><p>Let me clarify something. CRM is intended for businesses and when there is a software created for business organizations, the developers would also like to make money. This is why almost all of the free and open source software also have their paid &#8216;enterprise versions&#8217; available.</p><p>While you can download the open source version and host it on your own Linux based server, the &#8216;enterprise versions&#8217; are hosted by the developers themselves so that you don&#8217;t have to manage it. Some enterprise versions also provide premium features that are not available for the open source versions. Ticket support is also a feature available only for the enterprise versions.</p><p>I have tried to highlight their &#8216;premium features&#8217; in the list. Of course, t<em>he list below is in no particular order of ranking.</em></p><h3>1. SuiteCRM</h3><div class="wp-block-image"><figure class="aligncenter"><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/05/suitecrm-hosting.jpg?resize=800%2C457&#038;ssl=1" alt="Suitecrm Hosting" class="wp-image-56735 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/05/suitecrm-hosting.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/05/suitecrm-hosting.jpg?resize=300%2C171&amp;ssl=1 300w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/05/suitecrm-hosting.jpg?resize=768%2C439&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/05/suitecrm-hosting.jpg?resize=800%2C457&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/05/suitecrm-hosting.jpg?resize=800%2C457&#038;ssl=1" alt="Suitecrm Hosting" class="wp-image-56735" srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/05/suitecrm-hosting.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/05/suitecrm-hosting.jpg?resize=300%2C171&amp;ssl=1 300w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/05/suitecrm-hosting.jpg?resize=768%2C439&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" data-recalc-dims="1" /></noscript><figcaption>Suitecrm Hosting</figcaption></figure></div><p>Key Highlights:</p><ul><li>Sever-basis charge instead of per-user subscription for hosted service</li><li>Open-source</li><li>Affordable managed hosting plans</li><li>Supports third party integration</li><li>7-days free trial</li></ul><p>SuiteCRM was originally inspired (and forked) from SugarCRM&#8217;s open-source version. Well, that is no longer available. So, SuiteCRM is the open source alternative for organizations who utilized SugarCRM earlier.</p><p>In addition to all the essential features a CRM has to offer, SuiteCRM offers some great affordable managed hosting deals for organizations. With an impressive pricing plan (on server-basis with unlimited users), <a href="https://itsfoss.com/suitecrm-ondemand/">SuiteCRM takes aim at Salesforce </a>&#8211; which is promising.</p><div class="wp-block-button aligncenter"><a class="wp-block-button__link external" href="https://suitecrm.com/" rel="nofollow" target="_blank">SuiteCRM</a></div><h3>2. Odoo</h3><div class="wp-block-image"><figure class="aligncenter"><img src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/odoocrm.jpg?fit=800%2C384&amp;ssl=1" alt="Odoocrm" class="wp-image-60837 jetpack-lazy-image" data-lazy-srcset="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/odoocrm.jpg?w=800&amp;ssl=1 800w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/odoocrm.jpg?resize=300%2C144&amp;ssl=1 300w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/odoocrm.jpg?resize=768%2C369&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/odoocrm.jpg?fit=800%2C384&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/odoocrm.jpg?fit=800%2C384&amp;ssl=1" alt="Odoocrm" class="wp-image-60837" srcset="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/odoocrm.jpg?w=800&amp;ssl=1 800w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/odoocrm.jpg?resize=300%2C144&amp;ssl=1 300w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/odoocrm.jpg?resize=768%2C369&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></figure></div><p>Key Highlights:</p><ul><li>Open-source edition available</li><li>Enterprise edition pricing on a per-user basis</li><li>Wide variety of third party integrations</li><li>15-days free trial</li></ul><div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://itsfoss.com/reduce-computer-eye-strain-linux/" target="_blank" class="u4b1958a271dd06d8f67943758093e3ac"><style>.u4b1958a271dd06d8f67943758093e3ac{padding:0;margin:0;padding-top:1em!important;padding-bottom:1em!important;width:100%;display:block;font-weight:700;background-color:#eaeaea;border:0!important;border-left:4px solid #34495E!important;box-shadow:0 1px 2px rgba(0,0,0,.17);-moz-box-shadow:0 1px 2px rgba(0,0,0,.17);-o-box-shadow:0 1px 2px rgba(0,0,0,.17);-webkit-box-shadow:0 1px 2px rgba(0,0,0,.17);text-decoration:none}.u4b1958a271dd06d8f67943758093e3ac:active,.u4b1958a271dd06d8f67943758093e3ac:hover{opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms;text-decoration:none}.u4b1958a271dd06d8f67943758093e3ac{transition:background-color 250ms;webkit-transition:background-color 250ms;opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms}.u4b1958a271dd06d8f67943758093e3ac .ctaText{font-weight:700;color:inherit;text-decoration:none;font-size:16px}.u4b1958a271dd06d8f67943758093e3ac .postTitle{color:#000;text-decoration:underline!important;font-size:16px}.u4b1958a271dd06d8f67943758093e3ac:hover .postTitle{text-decoration:underline!important}</style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">Suggested read</span>&nbsp; <span class="postTitle">Reduce Computer Eye Strain With This Nifty Tool In Linux</span></div></a></div><p>Odoo is yet another popular open-source CRM solution. However, in contrast to SuitCRM, you will observe the pricing plan per user. So, if you are just starting out with a lot of users &#8211; you might find it a bit pricey.</p><p>The third-party integrations can be done easily and you can find the pricing for each app/integration when purchasing a subscription. You can either opt for the open source community edition or purchase the enterprise edition.</p><div class="wp-block-button aligncenter"><a class="wp-block-button__link external" href="https://www.odoo.com/page/crm" rel="nofollow" target="_blank">Odoo</a></div><h3>3. Vtiger</h3><div class="wp-block-image"><figure class="aligncenter"><img src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/vtiger.jpg?fit=800%2C419&amp;ssl=1" alt="Vtiger" class="wp-image-60849 jetpack-lazy-image" data-lazy-srcset="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/vtiger.jpg?w=800&amp;ssl=1 800w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/vtiger.jpg?resize=300%2C157&amp;ssl=1 300w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/vtiger.jpg?resize=768%2C402&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/vtiger.jpg?fit=800%2C419&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/vtiger.jpg?fit=800%2C419&amp;ssl=1" alt="Vtiger" class="wp-image-60849" srcset="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/vtiger.jpg?w=800&amp;ssl=1 800w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/vtiger.jpg?resize=300%2C157&amp;ssl=1 300w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/vtiger.jpg?resize=768%2C402&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></figure></div><p>Key Highlights:</p><ul><li>Open source edition based on SugarCRM</li><li>Separate pricing plans for Marketing, Sales, Help desk or all-in-one</li><li>Regional pricing available for some countries like India</li><li>Per-user pricing</li></ul><p>Vtiger offers a cloud version and an open source version. Of course, if you opt for the open source version, you get to host it yourself and manage it all by yourself or hire a team.</p><p>After observing the pricing plan, the managed cloud version obviously looks promising. &#8211; with separate pricing plans for sales, marketing, and help desk. However, if you have the required technical expertise, the open-source version is good enough as well. Also, it was interesting to see a regional pricing plan for India because they have an office here.</p><div class="wp-block-button aligncenter"><a class="wp-block-button__link external" href="https://www.vtiger.com/" rel="nofollow" target="_blank">Vtiger</a></div><h3>4. ConcourseSuite</h3><div class="wp-block-image"><figure class="aligncenter"><img src="https://i0.wp.com/itsfoss.com/wp-content/uploads/2019/07/concoursesuite-crm.jpg?fit=800%2C629&amp;ssl=1" alt="Concoursesuite Crm" class="wp-image-60900 jetpack-lazy-image" data-lazy-srcset="https://i0.wp.com/itsfoss.com/wp-content/uploads/2019/07/concoursesuite-crm.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/itsfoss.com/wp-content/uploads/2019/07/concoursesuite-crm.jpg?resize=300%2C236&amp;ssl=1 300w, https://i0.wp.com/itsfoss.com/wp-content/uploads/2019/07/concoursesuite-crm.jpg?resize=768%2C604&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i0.wp.com/itsfoss.com/wp-content/uploads/2019/07/concoursesuite-crm.jpg?fit=800%2C629&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i0.wp.com/itsfoss.com/wp-content/uploads/2019/07/concoursesuite-crm.jpg?fit=800%2C629&amp;ssl=1" alt="Concoursesuite Crm" class="wp-image-60900" srcset="https://i0.wp.com/itsfoss.com/wp-content/uploads/2019/07/concoursesuite-crm.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/itsfoss.com/wp-content/uploads/2019/07/concoursesuite-crm.jpg?resize=300%2C236&amp;ssl=1 300w, https://i0.wp.com/itsfoss.com/wp-content/uploads/2019/07/concoursesuite-crm.jpg?resize=768%2C604&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></figure></div><p>Key Highlights:</p><ul><li>Offers a separate (but outdated) open source community edition</li><li>Provides a 5-user trial plan for the latest version</li></ul><p>ConcourseSuite is a simple CRM which offers open-source version as well. The community edition (or the open-source version) is outdated &#8211; which you can still utilize as a basic CRM.</p><p>In case you want the latest version (which is the enhanced version of the community edition), you will have to opt for a 5-user trial or purchase the enterprise/cloud version. I couldn&#8217;t find a clear pricing plan but its pricing page did mention $10,000 for unlimited users. So, you will probably find out about it after trying out the trial.</p><div class="wp-block-button aligncenter"><a class="wp-block-button__link external" href="https://www.concursive.com/show/concoursesuite/wiki/How+to+Get+ConcourseSuite" rel="nofollow" target="_blank">ConcourseSuite</a></div><h3>5. EspoCRM</h3><div class="wp-block-image"><figure class="aligncenter"><img src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/espo-crm.jpg?ssl=1" alt="Espo Crm" class="wp-image-60925 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/espo-crm.jpg?w=597&amp;ssl=1 597w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/espo-crm.jpg?resize=300%2C214&amp;ssl=1 300w" data-lazy-sizes="(max-width: 597px) 100vw, 597px" data-lazy-src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/espo-crm.jpg?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/espo-crm.jpg?ssl=1" alt="Espo Crm" class="wp-image-60925" srcset="https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/espo-crm.jpg?w=597&amp;ssl=1 597w, https://i2.wp.com/itsfoss.com/wp-content/uploads/2019/07/espo-crm.jpg?resize=300%2C214&amp;ssl=1 300w" sizes="(max-width: 597px) 100vw, 597px" data-recalc-dims="1" /></noscript></figure></div><p>Key Highlights:</p><ul><li>The ability to switch to on-premise anytime.</li><li>Actively maintained open source (self-hosted) package.</li></ul><p>EspoCRM is new to the scene and it is an impressive CRM software. You can download it for free and host it yourself or opt for the cloud solution where they do it for you.</p><div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://itsfoss.com/best-free-open-source-alternatives-microsoft-office/" target="_blank" class="u382182a8fbfe19de5f8c8b07636fee92"><style>.u382182a8fbfe19de5f8c8b07636fee92{padding:0;margin:0;padding-top:1em!important;padding-bottom:1em!important;width:100%;display:block;font-weight:700;background-color:#eaeaea;border:0!important;border-left:4px solid #34495E!important;box-shadow:0 1px 2px rgba(0,0,0,.17);-moz-box-shadow:0 1px 2px rgba(0,0,0,.17);-o-box-shadow:0 1px 2px rgba(0,0,0,.17);-webkit-box-shadow:0 1px 2px rgba(0,0,0,.17);text-decoration:none}.u382182a8fbfe19de5f8c8b07636fee92:active,.u382182a8fbfe19de5f8c8b07636fee92:hover{opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms;text-decoration:none}.u382182a8fbfe19de5f8c8b07636fee92{transition:background-color 250ms;webkit-transition:background-color 250ms;opacity:1;transition:opacity 250ms;webkit-transition:opacity 250ms}.u382182a8fbfe19de5f8c8b07636fee92 .ctaText{font-weight:700;color:inherit;text-decoration:none;font-size:16px}.u382182a8fbfe19de5f8c8b07636fee92 .postTitle{color:#000;text-decoration:underline!important;font-size:16px}.u382182a8fbfe19de5f8c8b07636fee92:hover .postTitle{text-decoration:underline!important}</style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">Suggested read</span>&nbsp; <span class="postTitle">6 Best Open Source Alternatives to Microsoft Office for Linux</span></div></a></div><p>They have got a detailed <a href="https://github.com/espocrm/documentation" class="external" rel="nofollow" target="_blank">documentation</a> &#8211; in case you want to try it yourself. Also, if you want to go with the cloud solution &#8211; you can always switch to on-premise anytime you want. I guess that makes it a bit more appealing.</p><div class="wp-block-button aligncenter"><a class="wp-block-button__link external" href="https://www.espocrm.com/" rel="nofollow" target="_blank">EspoCRM</a></div><h3>6. Axelor CRM</h3><div class="wp-block-image"><figure class="aligncenter"><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?fit=800%2C526&amp;ssl=1" alt="Axelor Crm" class="wp-image-60935 jetpack-lazy-image" data-lazy-srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?w=824&amp;ssl=1 824w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?resize=300%2C197&amp;ssl=1 300w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?resize=768%2C505&amp;ssl=1 768w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?resize=800%2C526&amp;ssl=1 800w" data-lazy-sizes="(max-width: 824px) 100vw, 824px" data-lazy-src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?fit=800%2C526&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?fit=800%2C526&amp;ssl=1" alt="Axelor Crm" class="wp-image-60935" srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?w=824&amp;ssl=1 824w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?resize=300%2C197&amp;ssl=1 300w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?resize=768%2C505&amp;ssl=1 768w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/axelor-crm.jpg?resize=800%2C526&amp;ssl=1 800w" sizes="(max-width: 824px) 100vw, 824px" /></noscript><figcaption>Axelor Crm</figcaption></figure></div><p>Key Highlights:</p><ul><li>A complete suite of ERP, CRM, and BPM.</li><li>Mobile apps for Android and iOS</li></ul><p><a href="https://www.axelor.com/crm-open-source-software/" class="external" rel="nofollow" target="_blank">Axelor</a> is normally a complete suite of ERP, CRM, and BPM. Here, we talk about the CRM which is an incredible open source CRM available out there.</p><p>In addition to the web app, it also offers mobiles apps for Android and iOS. So, no matter you host it yourself or purchase a subscription for managed hosting &#8211; Axelor CRM is a great choice to keep up across multiple platforms.</p><div class="wp-block-button aligncenter"><a class="wp-block-button__link external" href="https://www.axelor.com/crm-open-source-software/" rel="nofollow" target="_blank">Axelor</a></div><h3>7. Crust CRM (Corteza)</h3><div class="wp-block-image"><figure class="aligncenter"><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/corteza.jpg?resize=800%2C417&#038;ssl=1" alt="Corteza" class="wp-image-60930 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/corteza.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/corteza.jpg?resize=300%2C156&amp;ssl=1 300w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/corteza.jpg?resize=768%2C400&amp;ssl=1 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/corteza.jpg?resize=800%2C417&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/corteza.jpg?resize=800%2C417&#038;ssl=1" alt="Corteza" class="wp-image-60930" srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/corteza.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/corteza.jpg?resize=300%2C156&amp;ssl=1 300w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/corteza.jpg?resize=768%2C400&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" data-recalc-dims="1" /></noscript></figure></div><p>Key Highlights:</p><ul><li>A unified open source solution</li><li>Recently launched with latest features on board</li></ul><p><a href="https://www.crust.tech/products/crust-crm/" class="external" rel="nofollow" target="_blank">Crust CRM</a> is one of the best enterprise-level Slack/Salesforce alternatives. Well, the primary aim of Crust CRM is to provide you a unified platform.</p><p>Crust CRM offers a community edition &#8220;Corteza&#8221; which is open-source in nature with all the latest features that you get with Crust CRM. It has been recently launched &#8211; so you can expect it to be compatible with a lot of services. You need to go through the<a href="https://github.com/cortezaproject/corteza-docs" class="external" rel="nofollow" target="_blank"> technical documentation</a> to set it up.</p><div class="wp-block-button aligncenter"><a class="wp-block-button__link external" href="https://cortezaproject.org/" rel="nofollow" target="_blank">Corteza</a></div><h3>8. X2CRM</h3><div class="wp-block-image"><figure class="aligncenter"><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/x2crm.png?ssl=1" alt="X2crm" class="wp-image-60924 jetpack-lazy-image" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/x2crm.png?w=696&amp;ssl=1 696w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/x2crm.png?resize=300%2C167&amp;ssl=1 300w" data-lazy-sizes="(max-width: 696px) 100vw, 696px" data-lazy-src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/x2crm.png?ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/x2crm.png?ssl=1" alt="X2crm" class="wp-image-60924" srcset="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/x2crm.png?w=696&amp;ssl=1 696w, https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/x2crm.png?resize=300%2C167&amp;ssl=1 300w" sizes="(max-width: 696px) 100vw, 696px" data-recalc-dims="1" /></noscript></figure></div><p>Key Highlights:</p><ul><li>The open-source package is no longer actively maintained &#8211; but available.</li><li>On-premise and hosted options available</li></ul><p>X2CRM is yet another convincing open source solution. The open source package includes all the modules (Sales, Marketing, and Support).</p><p>However, do note that the open source package isn&#8217;t actively maintained anymore &#8211; so if you want the latest and greatest features, you will have to purchase it. You can let them manage everything (hosted solution) or you get to manage everything and opt for their support and optimization services (on-premise).</p><div class="wp-block-button aligncenter"><a class="wp-block-button__link external" href="https://x2crm.com/download" rel="nofollow" target="_blank">X2CRM</a></div><h2>Wrapping Up</h2><p>I had made the <a href="https://itsfoss.com/open-source-cms/" target="_blank" rel="noreferrer noopener" aria-label="list of best open source CMS (opens in a new tab)">list of best open source CMS</a> earlier. You may read that to get some ideas about which open source technology to use for creating your business website.</p><p>Coming back to CRM, if you would ever consider trying out an open source CRM, these are the best ones I would recommend. Did I miss one of your favorites? Let us know about it in the comments down below.</p> <br><div class="apester-media" data-random="5caa056167b3b4fc52f9ace9" data-context="true"  data-fallback="true" ></div><span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span><span class="tve-leads-two-step-trigger tl-2step-trigger-0"></span></p><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?fit=800%2C450&amp;ssl=1" class="ss-hidden-pin-image jetpack-lazy-image" data-pin-url="https://itsfoss.com/best-open-source-crm/" data-pin-media="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?fit=800%2C450&amp;ssl=1" data-pin-description="8 Best Open Source CRM Software" data-lazy-src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?fit=800%2C450&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?fit=800%2C450&ssl=1" class="ss-hidden-pin-image" data-pin-url="https://itsfoss.com/best-open-source-crm/" data-pin-media="https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?fit=800%2C450&ssl=1" data-pin-description="8 Best Open Source CRM Software"/></noscript><div class="ss-inline-share-wrapper ss-hover-animation-fade ss-with-counter-border ss-inline-total-counter-left ss-left-inline-content ss-regular-icons ss-with-spacing ss-slanted-icons ss-both-labels"><p class="ss-social-share-label"> <span>Like what you read? Please share it with others.</span></p><div class="ss-inline-share-content"><div class="ss-inline-counter"> <span class="ss-total-counter ss-total-shares ss-share-inline_content-total-shares" data-ss-ss-post-id="60539"> <span>3</span> <span>Shares</span> </span></div><ul class="ss-social-icons-container"><li class=""> <a href="#" data-ss-ss-link="https://www.facebook.com/sharer.php?t=8%20Best%20Open%20Source%20CRM%20Software&#038;u=https%3A%2F%2Fitsfoss.com%2Fbest-open-source-crm%2F" class="ss-facebook-color" rel="nofollow"  data-ss-ss-network-id="facebook" data-ss-ss-post-id="60539" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://itsfoss.com/best-open-source-crm/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss ss-facebook"></i><span class="ss-network-label">Facebook</span> <span class="ss-network-count"> 0 </span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://twitter.com/intent/tweet?text=8+Best+Open+Source+CRM+Software&#038;url=https%3A%2F%2Fitsfoss.com%2Fbest-open-source-crm%2F&#038;via=itsfoss2" class="ss-twitter-color" rel="nofollow"  data-ss-ss-network-id="twitter" data-ss-ss-post-id="60539" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://itsfoss.com/best-open-source-crm/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss ss-twitter"></i><span class="ss-network-label">Twitter</span> <span class="ss-network-count"> 1 </span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://www.linkedin.com/shareArticle?title=8%20Best%20Open%20Source%20CRM%20Software&#038;url=https%3A%2F%2Fitsfoss.com%2Fbest-open-source-crm%2F&#038;mini=true" class="ss-linkedin-color" rel="nofollow"  data-ss-ss-network-id="linkedin" data-ss-ss-post-id="60539" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://itsfoss.com/best-open-source-crm/" data-ss-ss-type="share"> <span class="ss-share-network-content"> <i class="ss ss-linkedin"></i><span class="ss-network-label">LinkedIn</span> <span class="ss-network-count"> 0 </span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="https://www.reddit.com/submit?title=8%20Best%20Open%20Source%20CRM%20Software&#038;url=https%3A%2F%2Fitsfoss.com%2Fbest-open-source-crm%2F" class="ss-reddit-color" rel="nofollow"  data-ss-ss-network-id="reddit" data-ss-ss-post-id="60539" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://itsfoss.com/best-open-source-crm/" data-ss-ss-type="share" data-has-api="true"> <span class="ss-share-network-content"> <i class="ss ss-reddit"></i><span class="ss-network-label">Reddit</span> <span class="ss-network-count"> 0 </span> </span></a></li><li class=""> <a href="#" data-ss-ss-link="#" class="ss-pinterest-color" rel="nofollow"  data-ss-ss-network-id="pinterest" data-ss-ss-post-id="60539" data-ss-ss-location="inline_content" data-ss-ss-permalink="https://itsfoss.com/best-open-source-crm/" data-ss-ss-type="share" data-has-api="true" data-ss-ss-link="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fitsfoss.com%2Fbest-open-source-crm%2F&#038;media=https://i1.wp.com/itsfoss.com/wp-content/uploads/2019/07/open-source-crm-software.png?fit=800%2C450&#038;ssl=1&#038;description=8%20Best%20Open%20Source%20CRM%20Software"> <span class="ss-share-network-content"> <i class="ss ss-pinterest"></i><span class="ss-network-label">Pinterest</span> <span class="ss-network-count"> 1 </span> </span></a></li></ul></div></div><p> <script type="text/javascript" language="javascript" src="https://live.sekindo.com/live/liveView.php?s=95336&cbuster=[CACHE_BUSTER]&pubUrl=[PAGE_URL_ENCODED]&x=800&y=542&vp_content=plembedbc1rugspthjo&vp_template=3379"></script> </p></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://itsfoss.com/category/apps/" rel="category tag">Apps</a>, <a href="https://itsfoss.com/category/list/" rel="category tag">List</a></span> <span class="entry-tags">Tagged With: <a href="https://itsfoss.com/tag/crm/" rel="tag">CRM</a></span></p></footer></article><section class="author-box" itemprop="author" itemscope itemtype="https://schema.org/Person"><img alt src="https://secure.gravatar.com/avatar/a67d403a75f2c9c4244bf47af021a911?s=90&#038;d=mm&#038;r=g" class="avatar avatar-90 photo jetpack-lazy-image" height="90" width="90" data-lazy-srcset="https://secure.gravatar.com/avatar/a67d403a75f2c9c4244bf47af021a911?s=180&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/a67d403a75f2c9c4244bf47af021a911?s=90&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/a67d403a75f2c9c4244bf47af021a911?s=90&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a67d403a75f2c9c4244bf47af021a911?s=180&#038;d=mm&#038;r=g 2x' class='avatar avatar-90 photo' height='90' width='90' /></noscript><h4 class="author-box-title">About <span itemprop="name">Ankush Das</span></h4><div class="author-box-content" itemprop="description"><p>A passionate technophile who also happens to be a Computer Science graduate. He has had bylines at a variety of publications that include Ubergizmo &amp; Tech Cocktail. You will usually see cats dancing to the beautiful tunes sung by him.</p></div></section><div id="comments" class="comments-compat-genesis-sample"><div id="thrive-comments" class="clearfix"><div class="tcm-dot-loader"> <span class="inner1"></span> <span class="inner2"></span> <span class="inner3"></span></div><div class="thrive-comments-content"><div class="tcm-comments-filter"></div><div class="tcm-comments-create" id="respond"></div><div class="tcm-comments-list"><li id="comment-323064" class="comment even thread-even depth-1"><article id="div-comment-323064" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <img alt src="https://secure.gravatar.com/avatar/3bf5d3a63ce8fc0c1f0a9fb6ef90148b?s=32&#038;d=mm&#038;r=g" class="avatar avatar-32 photo jetpack-lazy-image" height="32" width="32" data-lazy-srcset="https://secure.gravatar.com/avatar/3bf5d3a63ce8fc0c1f0a9fb6ef90148b?s=64&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/3bf5d3a63ce8fc0c1f0a9fb6ef90148b?s=32&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/3bf5d3a63ce8fc0c1f0a9fb6ef90148b?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/3bf5d3a63ce8fc0c1f0a9fb6ef90148b?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript> <b class="fn">Jo-jo fini</b> <span class="says">says:</span></div><div class="comment-metadata"> <a href="https://itsfoss.com/best-open-source-crm/#comments/323064"> <time datetime="2019-07-22T19:17:05+02:00"> July 22, 2019 at 7:17 pm </time> </a></div></footer><div class="comment-content"><p>what about the yetiforce?</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='/best-open-source-crm/?replytocom=323064#respond' data-commentid="323064" data-postid="60539" data-belowelement="div-comment-323064" data-respondelement="respond" aria-label='Reply to Jo-jo fini'>Reply</a></div></article></li><li id="comment-323054" class="comment odd alt thread-odd thread-alt depth-1"><article id="div-comment-323054" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <img alt src="https://secure.gravatar.com/avatar/d26c0e5ddf82c22438c5d6ea63dba42a?s=32&#038;d=mm&#038;r=g" class="avatar avatar-32 photo jetpack-lazy-image" height="32" width="32" data-lazy-srcset="https://secure.gravatar.com/avatar/d26c0e5ddf82c22438c5d6ea63dba42a?s=64&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/d26c0e5ddf82c22438c5d6ea63dba42a?s=32&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/d26c0e5ddf82c22438c5d6ea63dba42a?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d26c0e5ddf82c22438c5d6ea63dba42a?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript> <b class="fn">BWPanda</b> <span class="says">says:</span></div><div class="comment-metadata"> <a href="https://itsfoss.com/best-open-source-crm/#comments/323054"> <time datetime="2019-07-22T13:31:59+02:00"> July 22, 2019 at 1:31 pm </time> </a></div></footer><div class="comment-content"><p>CiviCRM: <a href="https://civicrm.org/" rel="nofollow" class="external" target="_blank">https://civicrm.org/</a></p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='/best-open-source-crm/?replytocom=323054#respond' data-commentid="323054" data-postid="60539" data-belowelement="div-comment-323054" data-respondelement="respond" aria-label='Reply to BWPanda'>Reply</a></div></article></li><li id="comment-323047" class="comment even thread-even depth-1"><article id="div-comment-323047" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <img alt src="https://secure.gravatar.com/avatar/cea11aea8bd496bbb2ed7d6acd478e62?s=32&#038;d=mm&#038;r=g" class="avatar avatar-32 photo jetpack-lazy-image" height="32" width="32" data-lazy-srcset="https://secure.gravatar.com/avatar/cea11aea8bd496bbb2ed7d6acd478e62?s=64&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/cea11aea8bd496bbb2ed7d6acd478e62?s=32&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/cea11aea8bd496bbb2ed7d6acd478e62?s=32&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/cea11aea8bd496bbb2ed7d6acd478e62?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></noscript> <b class="fn">Miguel Mayol</b> <span class="says">says:</span></div><div class="comment-metadata"> <a href="https://itsfoss.com/best-open-source-crm/#comments/323047"> <time datetime="2019-07-22T10:03:09+02:00"> July 22, 2019 at 10:03 am </time> </a></div></footer><div class="comment-content"><p>What about Apache OfBiz?</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='/best-open-source-crm/?replytocom=323047#respond' data-commentid="323047" data-postid="60539" data-belowelement="div-comment-323047" data-respondelement="respond" aria-label='Reply to Miguel Mayol'>Reply</a></div></article></li></div><div class="tcm-lazy-comments"></div></div></div></div></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-3" class="widget widget_search"><div class="widget-wrap"><h3 class="widgettitle widget-title">Don&#8217;t find what you are looking for?</h3><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="https://itsfoss.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" itemprop="query-input" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta itemprop="target" content="https://itsfoss.com/?s={s}"></form></div></section><section id="socialsnap-social-followers-widget-3" class="widget socialsnap-social-followers-widget"><div class="widget-wrap"><h4 class="ss-follow-total-counter"> <strong>166.1K</strong> Followers</h4><div class="ss-follow-wrapper ss-clearfix ss-regular-buttons ss-columns-1 ss-network-style"><div class="ss-follow-column" data-ss-sf-network-id="facebook"> <a href="https://facebook.com/itsfoss/" class="ss-follow-network ss-facebook-color external" rel="nofollow" target="_blank"> <i class="ss ss-facebook"></i><span class="ss-follow-network-label">Follow us on Facebook</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">114.3K</span> <span class="ss-follow-network-count-label">Followers</span> </span></a></div><div class="ss-follow-column" data-ss-sf-network-id="youtube"> <a href="https://www.youtube.com/channel/UCEU9D6KIShdLeTRyH3IdSvw" class="ss-follow-network ss-youtube-color external" rel="nofollow" target="_blank"> <i class="ss ss-youtube"></i><span class="ss-follow-network-label">Follow us on YouTube</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">25.7K</span> <span class="ss-follow-network-count-label">Followers</span> </span></a></div><div class="ss-follow-column" data-ss-sf-network-id="twitter"> <a href="https://twitter.com/itsfoss2/" class="ss-follow-network ss-twitter-color external" rel="nofollow" target="_blank"> <i class="ss ss-twitter"></i><span class="ss-follow-network-label">Follow us on Twitter</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">9.7K</span> <span class="ss-follow-network-count-label">Followers</span> </span></a></div><div class="ss-follow-column" data-ss-sf-network-id="instagram"> <a href="https://instagram.com/itsfoss/" class="ss-follow-network ss-instagram-color external" rel="nofollow" target="_blank"> <i class="ss ss-instagram"></i><span class="ss-follow-network-label">Follow us on Instagram</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">16.3K</span> <span class="ss-follow-network-count-label">Followers</span> </span></a></div><div class="ss-follow-column" data-ss-sf-network-id="reddit"> <a href="https://www.reddit.com/user/itsfoss2/" class="ss-follow-network ss-reddit-color external" rel="nofollow" target="_blank"> <i class="ss ss-reddit"></i><span class="ss-follow-network-label">Follow us on Reddit</span> <span class="ss-follow-network-count"> <span class="ss-follow-network-count-number">102</span> <span class="ss-follow-network-count-label">Followers</span> </span></a></div></div></div></section><section id="optin-monster-api-2" class="widget optin-monster-api"><div class="widget-wrap"><h3 class="widgettitle widget-title">Subscribe to Weekly Newsletter</h3><div id="om-jbvb9zpk6f-sidebar-holder"></div><script>var jbvb9zpk6f_sidebar,jbvb9zpk6f_sidebar_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){jbvb9zpk6f_sidebar_poll(function(){if(window['om_loaded']){if(!jbvb9zpk6f_sidebar){jbvb9zpk6f_sidebar=new OptinMonsterApp();return jbvb9zpk6f_sidebar.init({"u":"447.189213","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.opmnstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;jbvb9zpk6f_sidebar=new OptinMonsterApp();jbvb9zpk6f_sidebar.init({"u":"447.189213","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script></div></section><section id="text-3" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><div id="itsfoss_300x250_300x600_Sidebar2" align="center"><script data-cfasync="false" type='text/javascript'>freestar.queue.push(function () { googletag.display('itsfoss_300x250_300x600_Sidebar2'); });</script></div></div></div></section></aside></div></div><div class="footer-widgets" id="genesis-footer-widgets"><h2 class="genesis-sidebar-title screen-reader-text">Footer</h2><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="linkcat-2014" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">About Pages</h3><ul class='xoxo blogroll'><li><a href="https://itsfoss.com/about/" title="Know more about us">About It&#039;s FOSS</a></li><li><a href="https://itsfoss.com/its-foss-team/" title="Team behind It&#8217;s FOSS">Meet the team</a></li><li><a href="https://itsfoss.com/donations-foss/" title="Check out donations made by us to Open Source projects">We Donate to FOSS Projects</a></li></ul></div></section><section id="linkcat-1482" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">Contact Pages</h3><ul class='xoxo blogroll'><li><a href="https://itsfoss.com/contact-us">Contact Us</a></li><li><a href="https://itsfoss.com/get-featured-on-its-foss/" title="Want your product to be featured on It&#8217;s FOSS?">Get Featured on It&#039;s FOSS</a></li><li><a href="https://itsfoss.com/request-tutorial/" title="Can&#8217;t find what you are looking for? Tell us.">Request a tutorial</a></li></ul></div></section></div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="linkcat-2015" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">Stay in Touch with It's FOSS</h3><ul class='xoxo blogroll'><li><a href="https://www.facebook.com/itsfoss/" title="The best Linux related page on the entire Facebook" class="external" rel="nofollow" target="_blank">Follow us on Facebook</a></li><li><a href="https://www.instagram.com/itsfoss/" title="Follow us for Linux related images" class="external" rel="nofollow" target="_blank">Follow us on Instagram</a></li><li><a href="https://www.pinterest.fr/its_foss/" title="Follow us on Pinterest" class="external" rel="nofollow" target="_blank">Follow us on Pinterest</a></li><li><a href="https://twitter.com/itsfoss2" title="Follow us on Twitter" class="external" rel="nofollow" target="_blank">Follow us on Twitter</a></li><li><a href="https://itsfoss.com/feed" target="_blank">Follow us via RSS Feed</a></li><li><a href="https://itsfoss.com/subscribe-to-newsletter/" title="Subscribe to daily or weekly newsletter">Subscribe to Newsletter</a></li><li><a href="https://www.youtube.com/c/itsfoss?sub_confirmation=1" title="Subscribe to our rapidly growing YouTube channel" class="external" rel="nofollow" target="_blank">Subscribe to YouTube Channel</a></li></ul></div></section></div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="linkcat-2012" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">Communities</h3><ul class='xoxo blogroll'><li><a href="https://t.me/joinchat/AAAAAEPRGUJrEE1itjpH6A" title="Join our private Telegram Channel with over 500 members to get the updates instantly" class="external" rel="nofollow" target="_blank">Exclusive Telegram Channel</a></li><li><a href="https://www.linkedin.com/groups/8597839" title="A community for FOSS Professionals" class="external" rel="nofollow" target="_blank">Join LinkedIn Community</a></li><li><a href="https://www.facebook.com/groups/LinuxUsersGroupOfficial/" title="Join our exclusive Linux Users Group with over 90,000 Linux enthusiasts" class="external" rel="nofollow" target="_blank">Linux Users Group on Facebook</a></li><li><a href="https://www.reddit.com/r/LinuxUsersGroup/" title="Join our Subreddit and interact with a passionate Linux community" class="external" rel="nofollow" target="_blank">Linux Users Group on Reddit</a></li></ul></div></section><section id="linkcat-2013" class="widget widget_links"><div class="widget-wrap"><h3 class="widgettitle widget-title">Policies</h3><ul class='xoxo blogroll'><li><a href="https://itsfoss.com/affiliate-policy/" title="Affiliate Policy" target="_blank">Affiliate Policy</a></li><li><a href="https://itsfoss.com/privacy-policy/">Privacy Policy</a></li></ul></div></section></div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2019 It's F.O.S.S  (Part of chmod777 Media Tech Pvt Ltd)· Built on <a href="http://www.shareasale.com/r.cfm?b=346198&u=747593&m=28169&urllink=&afftrack=">Genesis Framework</a> and Powered by <a href="https://www.upcloud.com/register/?promo=itsfoss" class="external" rel="nofollow" target="_blank">UpCloud</a></p></div></footer></div><script type="text/template" id="comments-conversion"><# if ( html_switch === 'tcm_live_update' ) { #>
	<div class="tcm-thank-you-submited tcm-border-color-ac">
		<#= custom_message #>
	</div>
<# } #>
<# if ( html_switch === 'tcm_related_posts' ) { #>
	<div class="tcm-posts tcm-border-color-ac">
	        <#= custom_message #>
	        <div class="tcm-posts-list <# if ( ! show_featured_image ) { #> no-featured-image <# } #> clear-this posts-length-<#= ThriveComments.related_posts.length #>">
		        <# ThriveComments.related_posts.forEach( function ( value ) { #>
			        <div class="tcm-post tcm-color-ac <# if ( ! show_featured_image ) { #> tcm-border-bottom-color-ac <# } #>">
				        <# if ( show_featured_image ) { #>
				            <div>
		                         <a href="<#= value.guid #>" style="background-image: url(<#= value.featured_image #>)" class="tcm-related-thumbnail <# if ( ! value.featured_image ) { #>tcm-no-featured-image<# } #>">
	                            </a>
				            </div>
					    <# } #>
				        <h3><a href="<#= value.guid #>">

								<span>
									<svg class="related-posts-arrow tcm-svg-fill-ac"><use xlink:href="#tcm-related-posts-arrow"></use></svg>								</span>


								<#= value.post_title #>

								</#></a></h3>
			        </div>
		        <# } ) #>
	        </div>
	</div>
<# } #>
<# if ( html_switch === 'tcm_social_share' ) { #>
	<div class="tcm-share-post tcm-border-color-ac">
		<#= custom_message #>
		<div class="share-buttons">
			<# if ( share_btns.fb_share ) { #><div class="fb-button" data-href="http://www.facebook.com/share.php"></div><# } #>
			<# if ( share_btns.tw_share ) { #><div class="tw-button" data-href="https://twitter.com/intent/tweet"></div><# } #>
			<# if ( share_btns.lk_share ) { #><div class="in-button" data-href="https://www.linkedin.com/cws/share"></div><# } #>
			<# if ( share_btns.pt_share ) { #><div class="pt-button" data-href="http://pinterest.com/pin/create/button"></div><# } #>
			<# if ( share_btns.gg_share ) { #><div class="gm-button" data-href="https://plus.google.com/share"></div><# } #>
			<# if ( share_btns.xi_share ) { #><div class="xi-button" data-href="https://www.xing.com/spi/shares/new"></div><# } #>
		</div>
	</div>
<# } #></script><script type="text/template" id="comments-create">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</script><script type="text/template" id="comments-deleted"><div class="tcm-deleted-comment clear-this">
	<div class="deleted-header">
		<div class="moderation-img no-image" data-social-avatar="<#= comment.get('social_avatar') #>" data-email="<#= comment.get('comment_author_email') #>" data-src="<#= comment.get('photo_src') #>" style="background-image: url(<#= comment.get('author_avatar_urls') #>);"></div>
		<div class="deleted-header-text">
			<strong>
				<#= comment.get('author_name') #>
			</strong>
			<span>
				<#= comment.get('formatted_date') #>
			</span>
		</div>
	</div>
	<div class="deleted-text">
		<p class="deleted-info-text tcm-color-ac">
			<# if ( comment.get('status') === 'spam' ) { #>
			<span>This comment was marked as spam</span>
			<# } else { #>
			<span>This comment was marked as trash</span>
			<# } #>
			<a href="#" data-key="z" class="undo-action">Undo</a>
		</p>

		<p>
			<#= comment.get('comment_content') #>
		</p>
	</div>
</div></script><script type="text/template" id="comments-item">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</script><script type="text/template" id="comments-lazy-loading"><button class="tcm-loader">
	<div style="display: inline-block" class="tcm-dot-loader done">
		<span class="inner1"></span>
		<span class="inner2"></span>
		<span class="inner3"></span>
	</div>
	<p>
		<#= ThriveComments.util.render_label('load_comments') #>
	</p>
</button>
<# if ( comments_rendered > 2 && ! ThriveComments.close_comments ) { #>
<div class="add-comment tcm-background-color-ac">
	<p>
			<span class="add-comment-icon">
				<svg class="add-comment-svg"><use xlink:href="#tcm-add-comment"></use></svg>			</span>
		<#= ThriveComments.util.render_label('add_comment') #></#></p>
</div>
<# } #>
<# if ( showPoweredBy ) { #>
<div class="tcm-powered-by">
    	<a href="https://thrivethemes.com/comments/" title="Powered by Thrive Comments" target="_blank">
			<span class="tcm-footer-logo">
				<svg class="logo-footer-svg"><use xlink:href="#tcm-logo-footer"></use></svg>			</span>

		<span>
			Powered by 		</span>
		<span>
			Thrive Comments		</span>
	</a>
</div>
<# } #>

<# if ( ! ThriveComments.close_comments && ThriveComments.email_services.length !== 0 ) { #>
	<div class="tcm-align-right">

		<a href="javascript:void(0)" class="tcm-link-unsubscribe" title="<#= ThriveComments.util.render_label('unsubscribe') #>"
		<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) || ( typeof ThriveComments.current_user.ID === 'undefined' ) ) { #> hidden <# } #> >
		<#= ThriveComments.util.render_label('unsubscribe') #></a>

		<a href="javascript:void(0)" class="tcm-link-subscribe" title="<#= ThriveComments.util.render_label('subscribe') #>"
		<# if ( - 1 !== ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID ) ) { #> hidden <# } #> >
		<#= ThriveComments.util.render_label('subscribe') #></a>

		<div id="tcm-subscribe-form" class="tcm-subscribe-form" hidden>
			<div class="tcm-error-message"></div>
			<input class="form-input tcm-subscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
			<button class="submit-subscribe-post"><#= ThriveComments.util.render_label('subscribe') #></a></button>
		</div>

		<# if ( typeof ThriveComments.current_user.ID === 'undefined' ) { #>
			<div id="tcm-unsubscribe-form" class="tcm-subscribe-form"
			<# if ( - 1 === ThriveComments.util.get_cookie( 'subscribed_posts' ).indexOf( ThriveComments.post.ID )  ) { #> hidden <# } #> >
				<div class="tcm-error-message"></div>
				<input class="form-input tcm-unsubscriber-email" type="text" name="Email" placeholder="<#= ThriveComments.util.render_label('email') #>"/>
				<button class="submit-unsubscribe-post"><#= ThriveComments.util.render_label('unsubscribe') #></a></button>
			</div>
		<# } #>
        <p class="tcm-already-subscribed" hidden> Already subscribed! </p>

    </div>
<# } #>
<div class="clear"></div></script><script type="text/template" id="comments-list"><div id="tcm-comments-filter" class="tcm-comments-filter">
	<div class="tcm-lazy-loader"></div>
</div></script><script type="text/template" id="comments-moderation"><div class="tcm-moderate-dots tcm-background-color-ac-h">
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
	<span class="moderate-dot"></span>
</div>

<div class="tcm-dropdown-moderate">
	<# _.each( actions, function( action, key ){ #>
	<div class="tcm-dropdown-moderate-element" data-fn="<#= action.fn #>" data-value="<#= action.value #>"><#= action.text #></div>
	<# }) #>
</div></script><script type="text/template" id="comments-sort"><div class="tcm-comments-filters">
	<div class="left">
		<div class="tcm-comments-number">
			<#= ThriveComments.util.render_label( 'number_of_comments', 'comment_count' ) #>
		</div>
	</div>
	<div class="right">
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','before') #>
		</label>
		<div name="sort-by" id="tcm-sort-by" class="tcm-dropdown tcm-filter-dropdown tcm-really-random">
            <span class="tcm-toggle-button current-sorting">
                <# if ( ThriveComments.settings.comment_order === 'desc') { #>
					<#= ThriveComments.util.render_label( 'newest') #>
					<# } else if( ThriveComments.settings.comment_order === 'asc') { #>
					<#= ThriveComments.util.render_label( 'oldest') #>
					<# } else {#>
				<# if( ThriveComments.settings.tcm_vote_type != 'no_vote' ) {#>
					<#= ThriveComments.util.render_label( 'top_rated') #>
					<# } #>
				<# } #>
			</span>

			<span class="dropdown-arrow-comments">
						<svg class="sort-by-dropdown-svg"><use xlink:href="#tcm-sort-by-dropdown"></use></svg>			</span>

			<div class="tcm-dropdown-content">

				<div data-value="desc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'newest') #>
				</div>
				<div data-value="asc" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'oldest') #>
				</div>
				<# if(ThriveComments.settings.tcm_vote_type != 'no_vote'){#>
				<div data-value="top-rated" class="tcm-dropdown-element tcm-sort-by">
					<#= ThriveComments.util.render_label( 'top_rated') #>
				</div>

				<# } #>

			</div>
		</div>
		<label for="sort-by">
			<#= ThriveComments.util.render_label('show_comments_first','','after') #>
		</label>
	</div>
</div>
<div class="clear"></div>
<# if ( ThriveComments.close_comments ) { #>
<div class="tcm-closed-comments" style="text-align: center">
	<p>
		<#= ThriveComments.util.render_label('close_comments') #>
	</p>
</div>
<# } #></script> <div id="wp-auth-check-wrap" class="hidden"><div id="wp-auth-check-bg"></div><div id="wp-auth-check"> <button type="button" class="wp-auth-check-close button-link"><span class="screen-reader-text">Close dialog</span></button><div id="wp-auth-check-form" class="loading" data-src="https://itsfoss.com/wp-login.php?interim-login=1&#038;wp_lang=en_US"></div><div class="wp-auth-fallback"><p><b class="wp-auth-fallback-expired" tabindex="0">Session expired</b></p><p><a href="https://itsfoss.com/wp-login.php" target="_blank">Please log in again.</a> The login page will open in a new tab. After logging in you can close it and return to this page.</p></div></div></div>  <script type="text/javascript">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</script> <div style="display: none;"> <svg style="position: absolute; width: 0; height: 0; overflow: hidden;" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"xml:space="preserve"> <defs><symbol id="tcm-reply" viewBox="0 0 100 100"> <g> <path d="M69.9,38.1L69.9,38.1c-1.5-3.7-4.7-6.4-7.4-9.2c-2.8-2.8-6.3-4.7-9.9-6.3c-3.7-1.6-7.7-2.4-11.7-2.4h-11
l4.7-4.8c3.4-3.4,3.4-9,0-12.4c-3.4-3.4-8.9-3.4-12.2,0L2.8,22.7c-3.4,3.4-3.4,9,0,12.4l19.4,19.7c1.7,1.7,3.9,2.6,6.1,2.6
c2.2,0,4.4-0.9,6.1-2.6c3.4-3.4,3.4-9,0-12.4l-4.6-4.6h10.9c3.4,0,6.6,1.4,9.1,3.8l4.8,4.8c1.2,2,3,3.4,5.1,4.1
c2.1,0.6,4.5,0.4,6.6-0.7C70.5,47.5,72,42.3,69.9,38.1z"/> <ellipse cx="81.1" cy="60.8" rx="8.5" ry="8.6"/> </g> </symbol><symbol id="tcm-icon-thumb_down" viewBox="0 0 24 24"> <g> <path d="M18.984 3h4.031v12h-4.031v-12zM15 3c1.078 0 2.016 0.938 2.016 2.016v9.984c0 0.563-0.234 1.031-0.609
1.406l-6.563 6.609-1.078-1.078c-0.281-0.281-0.422-0.609-0.422-1.031v-0.328l0.984-4.594h-6.328c-1.078 0-2.016-0.891-2.016-1.969l0.047-0.094h-0.047v-1.922c0-0.281
0.047-0.516 0.141-0.75l3.047-7.031c0.281-0.703 0.984-1.219 1.828-1.219h9z" /> </g> </symbol><symbol id="tcm-icon-thumb_up" viewBox="0 0 24 24"> <g> <path d="M23.016 9.984l-0.047 0.094h0.047v1.922c0 0.281-0.047 0.516-0.141 0.75l-3.047 7.031c-0.281 0.703-0.984
1.219-1.828 1.219h-9c-1.078 0-2.016-0.938-2.016-2.016v-9.984c0-0.563 0.234-1.031 0.609-1.406l6.563-6.609 1.078
1.078c0.281 0.281 0.422 0.609 0.422 1.031v0.328l-0.984 4.594h6.328c1.078 0 2.016 0.891 2.016 1.969zM0.984 21v-12h4.031v12h-4.031z" /> </g>></symbol><symbol id="tcm-add-comment" viewBox="0 0 267.3 245"> <path style="fill:#FFFFFF;" class="st0" d="M265.7,61C259.6,27.5,230.3,2,195.1,2H72.5C33,2,0.8,34.2,0.8,73.8v77c0,0.1,0,0.1,0,0.2v81.6
c0,0-1.8,11.1,9.7,11.1c0,0,4.2,1,13.1-4.6l46.8-43.2h124.6c39.5,0,71.7-32.2,71.7-71.7V83.8L265.7,61z M78.4,114
c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6S93,91.4,93,99.5C93,107.5,86.5,114,78.4,114z M137.5,114
c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C152.1,107.5,145.5,114,137.5,114z M196.5,114
c-8.1,0-14.6-6.5-14.6-14.6c0-8.1,6.5-14.6,14.6-14.6c8.1,0,14.6,6.5,14.6,14.6C211.1,107.5,204.6,114,196.5,114z"/> </symbol><symbol id="tcm-logo-footer" viewBox="0 0 130 100"> <path style="fill:#434343;" class="st0" d="M108.8,26.5C106.7,14.9,96.5,6.1,84.4,6.1H41.9C28.2,6.1,17,17.2,17,30.9v26.7c0,0,0,0,0,0.1v28.2
c0,0-0.6,3.8,3.4,3.8c0,0,1.5,0.4,4.6-1.6l16.2-14.9h12.1c0.1-0.2,0.3-0.4,0.4-0.6l2.2-3.1c0.4-0.6,1.9-2.3,3.1-3.6H37.6
c-1.1,0-2.1,0.6-2.8,1.4l0,0L24.1,78.6V58.2c0-0.2,0.1-0.4,0.1-0.6V30.9c0-9.7,7.9-17.6,17.6-17.6h42.5c9.7,0,17.6,7.9,17.6,17.6
v16.9c2.6-0.4,5.3-0.6,7.2-0.7V34.4L108.8,26.5z"/> <path style="fill:#57A245;" class="st1" d="M43.7,39.9c-3.3,0-6-2.7-6-6c0-3.3,2.7-6,6-6h38.9c3.3,0,6,2.7,6,6c0,3.3-2.7,6-6,6H43.7z"/> <path style="fill:#434343;" class="st0" d="M43.7,52.2h38.9c2.4,0,4.3-1.9,4.3-4.3s-1.9-4.3-4.3-4.3H43.7c-2.4,0-4.3,1.9-4.3,4.3S41.3,52.2,43.7,52.2"/> <path style="fill-rule:evenodd;clip-rule:evenodd;fill:#57A245;" class="st2" d="M118.2,52.4c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4
c-3.4,4.2-4.1,4.9-6.8,10.2c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5
c-0.6,0.5-1.3,1-1.9,1.5c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2
c-0.2,0.1-0.4,0.2-0.5,0.2c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7
c0.6-1.4,1.3-2.8,2.1-4.1c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6l0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7
c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7l4.1-1.9
c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3
c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4
c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6
c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8
c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9
c3.5-0.7,12.3-2.3,16.6-2.3h0.9C114,51.2,117.4,51.2,118.2,52.4z"/> <path style="fill:none;" class="st3" d="M99.5,58.5c0.4,0,0.2,0,0.2-0.1C99.4,58.4,99.6,58.4,99.5,58.5z M99.5,58.5c0.1-0.1-0.1-0.1,0.2-0.1
C99.7,58.5,99.9,58.5,99.5,58.5 M99.9,58.3l-0.1,0.1 M99.5,58.5c-0.6,0.1-1.4,0.4-1.9,0.6c-0.6,0.2-1.3,0.4-1.9,0.6l-3.8,1.3
c-1.8,0.6-3.6,1.4-5.5,2.1l-3.5,1.5c-1.3,0.5-3.3,1.6-4.7,2.3c-1.5,0.8-2.9,1.8-4.3,2.6l-4.8,3.4c-0.1,0.1-0.2,0.2-0.4,0.3l-2.7,2.3
c-0.8,0.8-1.8,1.7-2.5,2.5c-0.2,0.2-0.2,0.2-0.3,0.4c-0.7,0.7-1.3,1.6-1.9,2.4c-0.9,1.2-1.8,2.5-2.5,3.8l-1.3,2.5
c-0.5,1-2.7,6-2.8,7.4h-0.2c0-0.2-0.5-2.5-0.7-4.4v-1.6c0-0.1,0-0.1,0-0.2c0.2-1.1,0.1-1.8,0.3-3.1c0.6-3.6,2.2-7.4,4.2-10.4l2.1-3
c0.6-0.8,2.8-3.4,3.5-3.8c0.6-0.5,1.2-1.3,1.9-1.8c0.3-0.2,0.6-0.5,0.9-0.8c0.4-0.2,0.6-0.5,1-0.8l2-1.5c2-1.5,4.2-2.8,6.4-3.8
c2.4-1.2,4.7-2.1,7.2-3.1c3.2-1.3,7.6-2.2,10.9-2.9c3.5-0.7,12.3-2.3,16.6-2.3h0h0.2h0.6c2.2,0,5.6,0.1,6.4,1.3
c-1.2,0-1.6,0.2-2.4,0.5c-0.9,0.3-1.9,1-2.6,1.7l-1.8,1.7c-0.2,0.2-0.2,0.2-0.3,0.4c-3.4,4.2-4.1,4.9-6.8,10.2
c-1.2,2.5-2.7,4.8-4.2,7.1c-1,1.6-2,3.2-3.2,4.6c-0.1,0.2-0.2,0.2-0.3,0.4c-0.7,0.9-1.7,1.7-2.5,2.5c-0.6,0.5-1.3,1-1.9,1.5
c-0.6,0.4-1.1,0.8-1.7,1.1l-0.9,0.5c-0.2,0.1-0.3,0.2-0.5,0.3c-0.1,0-0.3,0.2-0.4,0.2c-0.2,0.1-0.4,0.2-0.5,0.2
c-3.7,1.8-8.5,3-12.7,3.4L72.7,89c-0.8,0.1-2.8,0.2-4.7,0.2c-1.6,0-3,0-3.5-0.2l0.3-0.7c0.6-1.4,1.3-2.8,2.1-4.1
c0.1-0.2,0.2-0.4,0.4-0.6l1.5-2.6l3.9-5.3l3.5-3.6c0.1-0.1,0.2-0.2,0.2-0.2c0.2-0.1,0.2-0.1,0.3-0.2l0.8-0.7
c0.1-0.1,0.2-0.1,0.3-0.2c0.2-0.2,0.3-0.3,0.5-0.4l3.7-2.5c1.3-0.8,2.6-1.6,3.8-2.3l4-2.1c1.5-0.8,4-2.1,5.5-2.7L99.5,58.5"/> </symbol><symbol id="tcm-related-posts-arrow" viewBox="0 0 16 16"> <path class="st0" d="M8,15.9c-4.4,0-7.9-3.5-7.9-7.9S3.6,0.1,8,0.1s7.9,3.5,7.9,7.9S12.4,15.9,8,15.9z M8,2.4C4.9,2.4,2.4,4.9,2.4,8
s2.5,5.6,5.6,5.6s5.6-2.5,5.6-5.6S11.1,2.4,8,2.4z M11.9,8.3l-3.3,3.3c-0.1,0.1-0.2,0.1-0.2,0.1c-0.2,0-0.3-0.2-0.3-0.3v-2H4.4
C4.2,9.3,4.1,9.2,4.1,9V7c0-0.2,0.2-0.3,0.3-0.3H8v-2c0-0.2,0.1-0.3,0.3-0.3c0.1,0,0.2,0,0.2,0.1l3.3,3.3C11.9,7.9,12,7.9,12,8
S11.9,8.2,11.9,8.3z"/> </symbol><symbol id="tcm-sort-by-dropdown" viewBox="0 0 12 7"> <path style="fill:#6E767D;" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4
C0.1,0.5-0.2,1,0.3,1.5z"/> </symbol><symbol id="tcm-author-icon" viewBox="0 0 1020 1080"> <polygon style="fill:#474F57" class="st0" points="44.5,882.9 251.4,1081 251.4,889.8 "/> <path style="fill:#6E767D" class="st1" d="M937.8,891.8H81.2c-44.3,0-80.6-36.3-80.6-80.6V82.7c0-44.3,36.3-80.6,80.6-80.6h856.6
c44.3,0,80.6,36.3,80.6,80.6v728.5C1018.4,855.5,982.1,891.8,937.8,891.8z"/> <g> <path style="fill:#6E767D" class="st2" d="M732,688.3c-0.5,0.1-2.7,0.5-6.3,1.1c-142.4,25.4-168.6,29.8-171.6,30.1c-7,0.8-12.3,0.4-16-1.3
c-2.4-1-3.6-2.3-4-2.8c0.2-1,1.4-3.3,2.2-4.7c0.7-1.4,1.6-3,2.3-4.6c4.9-11.1,1.5-22.4-8.9-29.5c-7.8-5.3-18.1-7.4-30.6-6.3
c-7.5,0.6-138.9,22.6-211.1,34.7l-35.4,27.7c82.6-13.9,240.1-40.2,248.4-41c7.4-0.6,13.2,0.3,16.7,2.7c2,1.4,1.8,1.8,1.3,3.1
c-0.4,0.9-1,2-1.6,3.2c-2.4,4.4-5.6,10.5-4.5,18c1.2,8.2,7.3,15.3,16.7,19.4c5.3,2.3,11.4,3.5,18.4,3.5c2.8,0,5.7-0.2,8.8-0.5
c5.7-0.7,63.8-10.9,172.9-30.3c3.6-0.6,5.8-1,6.3-1.1c5.9-1,9.8-6.6,8.7-12.5C743.4,691.2,737.8,687.3,732,688.3L732,688.3z
M732,688.3"/> <path style="fill:#FFFFFF" class="st2" d="M349.8,583.9l-91.7,95.5c-10.1,10.5-17.2,23.5-20.6,37.7l130.2-102c40.8,18,73.3,23.7,98.3,23.7
c43.8,0,64.2-17.7,64.2-17.7c-40.8-21.2-46.6-60.6-46.6-60.6c31.3,13.2,96.4,28.7,96.4,28.7c86.5-57.5,131.7-181.9,131.7-181.9
c-9,2.5-17.5,3.5-25.6,3.5c-40.6,0-68.5-25.9-68.5-25.9l113-24.5c37.6-76.7,41.2-211.1,41.2-211.1L428.2,453.5
C389.2,487.9,361.9,533.4,349.8,583.9L349.8,583.9z M349.8,583.9"/> </g> </symbol><symbol id="tcm-bulk-action-arrow" viewBox="0 0 12 7"> <path style="fill:#6E767D" class="st0" d="M0.3,1.5l5.2,5.2c0,0,0.5,0.5,1.1,0l5.2-5.2c0,0,0.4-0.4,0.2-0.9c0,0-0.1-0.4-0.7-0.4H0.8c0,0-0.5,0-0.7,0.4
C0.1,0.5-0.2,1,0.3,1.5z"/> </symbol></defs> </svg></div> <script type="text/javascript">function atomicBlocksShare( url, title, w, h ){
			var left = ( window.innerWidth / 2 )-( w / 2 );
			var top  = ( window.innerHeight / 2 )-( h / 2 );
			return window.open(url, title, 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=600, height=600, top='+top+', left='+left);
		}</script>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-24863836-4"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-24863836-4');</script> <style>body .widget.extendedwopts-col.col-md-12{float:none;clear:both}</style><div id="amzn-assoc-ad-f6247784-85fd-4210-a7a4-187f89319a74"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=f6247784-85fd-4210-a7a4-187f89319a74"></script><script type="text/javascript" src="https://a.opmnstr.com/app/js/api.min.js" data-campaign="cp7zniloxza8mcagx085" data-user="447" data-env="production"></script><div id="om-by19m9tmzfns6oco-holder"></div><script>var by19m9tmzfns6oco,by19m9tmzfns6oco_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){by19m9tmzfns6oco_poll(function(){if(window['om_loaded']){if(!by19m9tmzfns6oco){by19m9tmzfns6oco=new OptinMonsterApp();return by19m9tmzfns6oco.init({"u":"447.470037","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.opmnstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;by19m9tmzfns6oco=new OptinMonsterApp();by19m9tmzfns6oco.init({"u":"447.470037","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><div id="om-pztb1uabhcye9ksm-holder"></div><script>var pztb1uabhcye9ksm,pztb1uabhcye9ksm_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){pztb1uabhcye9ksm_poll(function(){if(window['om_loaded']){if(!pztb1uabhcye9ksm){pztb1uabhcye9ksm=new OptinMonsterApp();return pztb1uabhcye9ksm.init({"u":"447.408081","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.opmnstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;pztb1uabhcye9ksm=new OptinMonsterApp();pztb1uabhcye9ksm.init({"u":"447.408081","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script> <script type="text/javascript">var jbvb9zpk6f_sidebar_shortcode = true;var cp7zniloxza8mcagx085_shortcode = true;var by19m9tmzfns6oco_shortcode = true;var pztb1uabhcye9ksm_shortcode = true;</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.5.3/_inc/build/photon/photon.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var eafl_public = {"home_url":"https:\/\/itsfoss.com\/","ajax_url":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","nonce":"a18fdb67ef"}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/easy-affiliate-links/assets/js/public-3.0.0.js'></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201930'></script> <script type='text/javascript'>/* <![CDATA[ */ var socialsnap_script = {"ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","on_media_width":"250","on_media_height":"250","nonce":"cd26beb54a","post_id":"60539","click_tracking":""}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/socialsnap-pro/assets/js/socialsnap-1.1.5.2.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/atomic-blocks/dist/assets/js/dismiss-1561608676.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/wp-udemy-pro/public/js/scripts.min-1.0.8.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/comment-reply.min.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/hoverIntent.min.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/themes/genesis/lib/js/menu/superfish.min-1.7.10.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/themes/genesis/lib/js/menu/superfish.args.min-3.0.2.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/themes/genesis/lib/js/skip-links.min-3.0.2.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var tve_dash_front = {"ajaxurl":"https:\/\/itsfoss.com\/wp-admin\/admin-ajax.php","force_ajax_send":"1","is_crawler":""}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/thrive-comments/thrive-dashboard/js/dist/frontend.min-2.1.9.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var q2w3_sidebar_options = [{"sidebar":"sidebar","margin_top":10,"margin_bottom":0,"stop_id":"genesis-footer-widgets","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["text-3"]}]; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min-5.1.9.js'></script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.5.3/_inc/build/lazy-images/js/lazy-images.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var genesis_responsive_menu = {"mainMenu":"Menu","menuIconClass":"dashicons-before dashicons-menu","subMenu":"Submenu","subMenuIconClass":"dashicons-before dashicons-arrow-down-alt2","menuClasses":{"others":[".nav-primary"]}}; /* ]]> */</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/themes/genesis/lib/js/menu/responsive-menus.min-1.1.3.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/aawp/public/assets/js/scripts.min-3.8.9.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/underscore.min.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.2.2/wp-includes/js/backbone.min.js'></script> <script type='text/javascript'>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</script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/thrive-comments/assets/js/frontend.min-1.2.8.js'></script> <script type='text/javascript' src='https://itsfoss.com/wp-content/cache/busting/1/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min-13.1.js'></script>  <script type="text/javascript">var SocialSnapURL 				= window.location.href;
			var SocialSnapShareCacheExpired = 0;
				
			if ( -1 !== SocialSnapURL.indexOf('?ss_cache_refresh') ) {

				SocialSnapShareCacheExpired = true;

			} else {

				var SocialSnapServerTimestamp 	= 1563915104;
				var SocialSnapBrowserTimestamp 	= Date.now();

				if ( ! SocialSnapBrowserTimestamp ) {
					SocialSnapBrowserTimestamp = new Date().getTime();
				}

				SocialSnapBrowserTimestamp = Math.floor( SocialSnapBrowserTimestamp / 1000 );

				SocialSnapShareCacheExpired = SocialSnapShareCacheExpired && ( SocialSnapBrowserTimestamp - SocialSnapServerTimestamp < 60 );
			}</script>  <script type="text/javascript">/* <![CDATA[ */ var aawp_geotargeting_api = "";
        var aawp_geotargeting_settings = {"store":"com","mode":"title"};
        var aawp_geotargeting_localized_stores = {"ca":"ca","de":"de","at":"de","ch":"de","es":"es","fr":"fr","in":"in","it":"it","jp":"co.jp","gb":"co.uk","ie":"co.uk"};
        var aawp_geotargeting_tracking_ids = {"ca":"itsfoss09-20","de":"itsfoss0e-21","es":"itsfoss04-21","fr":"itsfoss02-21","in":" itsfoss0d-21","it":"itsfoss05-21","co.jp":"itsfoss-22","co.uk":"itsfoss03-21"}; /* ]]> */</script> <script type='text/javascript' src='https://stats.wp.com/e-201930.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.5.3',blog:'37237282',post:'60539',tz:'2',srv:'itsfoss.com'} ]);
	_stq.push([ 'clickTrackerInit', '37237282', '60539' ]);</script> <script type="text/javascript">var omapi_localized = { ajax: 'https://itsfoss.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '1263bebddf', slugs: {"jbvb9zpk6f_sidebar":{"slug":"jbvb9zpk6f_sidebar","mailpoet":false},"cp7zniloxza8mcagx085":{"slug":"cp7zniloxza8mcagx085","mailpoet":false},"by19m9tmzfns6oco":{"slug":"by19m9tmzfns6oco","mailpoet":false},"pztb1uabhcye9ksm":{"slug":"pztb1uabhcye9ksm","mailpoet":false}} };</script> <script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":60539,"object_key":"post","object_type":"post","term_ids":[37,350,2289]};</script> <script>window.lazyLoadOptions = {
                elements_selector: "iframe[data-lazy-src]",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;
        
            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;
                            
                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );
                
                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };
                
                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="https://itsfoss.com/wp-content/plugins/wp-rocket/assets/js/lazyload/11.0.6/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360">',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="https://www.youtube.com/embed/ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.id)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1563915104 -->