How To Fix Ubuntu Update Error: Problem With MergeList

One of the most common error a user encounters while updating is Problem with MergeList. The error could be encountered while using both Ubuntu Update Manager and using the sudo apt-get update in terminal.

The complete error looks something like this:

E:Encountered a section with no Package: header,
E:Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_universe_binary-i386_Packages,
E:The package lists or status file could not be parsed or opened.

It’s the second line that is important here. It tells you that the mentioned file in the second line got corrupted some how and so it cannot be parsed.

Fixing MergeList problem in Ubuntu

The one shot solution of this problem is to run the following two commands, one by one, in the terminal (Ctrl+Alt+T):

sudo rm -r /var/lib/apt/lists/*

You can generate a fresh one with this command:

sudo apt-get clean && sudo apt-get update

Voila! That should solve the “problem with merge list” error. 

Fixing MergeList problem in Debian and Raspbian OS

If you use Debian or Raspbian OS or even Ubuntu, you may see the MergeList error but the corrupted files may be different:

Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.

This time, the issue is with /var/lib/dpkg/status. Handling this error is slightly different and slightly more complicated than the previous one.

Now, you could but you shouldn’t just delete it straightaway. Make a backup first:

mv /var/lib/dpkg/status /var/lib/dpkg/status.old

What you need to do now is to get a backup of this status file and use it. The backup files are stored in /var/backups directory. You can list it out:

ls -l /var/backups/dpkg.status*

Copy the latest backup:

cp /var/backups/dpkg.status.0 /var/lib/dpkg/status

Try to run update now and see if the problem is fixed. If not, you can try with the next backup file. If the file is archived, you need to unzip it first. Once copied, run the update command again and check if it’s fixed.

In other frequent Ubuntu update errors, one is Failed to download repository information. You may want to check them as well. Enjoy Ubuntu :)

Similar Posts

  • I can not update to 22.04 my error:
    File “/usr/lib/python3.8/codecs.py”, line 322, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
    UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xdc in position 24: invalid continuation byte
    What can i do?

  • por favor su ayuda , ya llevo dias con este error; python3-uno : Depends: libreoffice-core (= 1:6.4.7-0ubuntu0.20.04.1) but 1:6.0.7-0ubuntu0.18.04.10 is installed or
    libreoffice-core-nogui (= 1:6.4.7-0ubuntu0.20.04.1) but it is not installed
    Depends: libpython3.8 (>= 3.8.2) but it is not installed
    Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
    Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
    Depends: libuno-sal3 (>= 5.4.0~alpha) but it is not installed
    Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
    Depends: uno-libs-private but it is not installed
    python3-xapian : Depends: libxapian30 (>= 1.4.14~) but 1.4.5-1ubuntu0.1 is installed
    rhythmbox-plugins : Depends: librhythmbox-core10 (= 3.4.4-1ubuntu2) but 3.4.2-4ubuntu1 is installed
    Depends: rhythmbox (= 3.4.4-1ubuntu2) but 3.4.2-4ubuntu1 is installed
    Depends: gir1.2-rb-3.0 (= 3.4.4-1ubuntu2) but 3.4.2-4ubuntu1 is installed
    E: Unmet dependencies. Try ‘apt –fix-broken install’ with no packages (or specify a solution).
    [email protected]:/home/adminsdc# clear
    [email protected]:/home/adminsdc# apt upgrade
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    You might want to run ‘apt –fix-broken install’ to correct these.
    The following packages have unmet dependencies:
    dirmngr : Depends: init-system-helpers (>= 1.52) but 1.51 is installed
    gir1.2-gtk-3.0 : Depends: gir1.2-gdkpixbuf-2.0 (>= 2.40.0) but 2.36.11-2 is installed
    Depends: gir1.2-pango-1.0 (>= 1.41.0) but 1.40.14-1ubuntu0.1 is installed
    Depends: libgtk-3-0 (>= 3.24.7) but 3.22.30-1ubuntu4 is installed
    gnupg : Depends: gpgv (>= 2.2.19-3ubuntu2.1) but 2.2.4-1ubuntu1.4 is installed
    gnupg-utils : Depends: libreadline8 (>= 6.0) but it is not installed
    gpg : Depends: libreadline8 (>= 6.0) but it is not installed
    gpg-agent : Depends: init-system-helpers (>= 1.52) but 1.51 is installed
    gpgconf : Depends: libreadline8 (>= 6.0) but it is not installed
    gpgsm : Depends: libreadline8 (>= 6.0) but it is not installed
    hplip : Depends: hplip-data (= 3.20.3+dfsg0-2) but 3.17.10+repack0-5 is installed
    Depends: libhpmud0 (= 3.20.3+dfsg0-2) but 3.17.10+repack0-5 is installed
    Depends: printer-driver-hpcups (= 3.20.3+dfsg0-2) but 3.17.10+repack0-5 is installed
    Depends: libpython3.8 (>= 3.8.2) but it is not installed
    libpython3.8-stdlib : Depends: libreadline8 (>= 7.0~beta) but it is not installed
    libsane-hpaio : Depends: libhpmud0 (>= 3.20.3+dfsg0) but 3.17.10+repack0-5 is installed
    python3-apt : Depends: libapt-pkg6.0 (>= 1.9.11~) but it is not installed
    python3-brlapi : Depends: libbrlapi0.7 but it is not installed
    python3-dbus.mainloop.pyqt5 : Depends: libqt5core5a (>= 5.12.2) but 5.9.5+dfsg-0ubuntu2.6 is installed
    python3-gi : Depends: libgirepository-1.0-1 (>= 1.62.0-4~) but 1.56.1-1 is installed
    python3-newt : Depends: libnewt0.52 (= 0.52.21-4ubuntu2) but 0.52.20-1ubuntu1 is installed
    python3-pil : Depends: libimagequant0 (>= 2.11.10) but it is not installed
    python3-protobuf : Depends: libprotobuf17 but it is not installed
    python3-pyqt5 : Depends: libpython3.8 (>= 3.8.2) but it is not installed
    Depends: libqt5core5a (>= 5.12.4) but 5.9.5+dfsg-0ubuntu2.6 is installed
    Depends: libqt5dbus5 (>= 5.12.2) but 5.9.5+dfsg-0ubuntu2.6 is installed
    Depends: libqt5gui5 (>= 5.12.2) but 5.9.5+dfsg-0ubuntu2.6 is installed or
    libqt5gui5-gles (>= 5.12.2) but it is not installed
    Depends: libqt5network5 (>= 5.12.2) but 5.9.5+dfsg-0ubuntu2.6 is installed
    Depends: libqt5printsupport5 (>= 5.10.0) but 5.9.5+dfsg-0ubuntu2.6 is installed
    Depends: libqt5test5 (>= 5.11.0~rc1) but 5.9.5+dfsg-0ubuntu2.6 is installed
    Depends: libqt5widgets5 (>= 5.12.2) but 5.9.5+dfsg-0ubuntu2.6 is installed
    Depends: qtbase-abi-5-12-8
    python3-uno : Depends: libreoffice-core (= 1:6.4.7-0ubuntu0.20.04.1) but 1:6.0.7-0ubuntu0.18.04.10 is installed or
    libreoffice-core-nogui (= 1:6.4.7-0ubuntu0.20.04.1) but it is not installed
    Depends: libpython3.8 (>= 3.8.2) but it is not installed
    Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
    Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
    Depends: libuno-sal3 (>= 5.4.0~alpha) but it is not installed
    Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
    Depends: uno-libs-private but it is not installed
    python3-xapian : Depends: libxapian30 (>= 1.4.14~) but 1.4.5-1ubuntu0.1 is installed
    rhythmbox-plugins : Depends: librhythmbox-core10 (= 3.4.4-1ubuntu2) but 3.4.2-4ubuntu1 is installed
    Depends: rhythmbox (= 3.4.4-1ubuntu2) but 3.4.2-4ubuntu1 is installed
    Depends: gir1.2-rb-3.0 (= 3.4.4-1ubuntu2) but 3.4.2-4ubuntu1 is installed
    E: Unmet dependencies. Try ‘apt –fix-broken install’ with no packages (or specify a solution).