How To Fix No Sound in Ubuntu And Linux Mint

Brief: No audio in a fresh Ubuntu install? Only see dummy output? No worries. Here are a few methods that you can try to fix the no sound problem in Ubuntu and other Linux distributions.

As it happens with every Ubuntu release, you install or upgrade to a newer Ubuntu version and run in to a number of problems. But then, there is always a way to overcome these big little problems.

One of the most common problems faced is no sound after installing Ubuntu. While there could be several reasons for no sound in Ubuntu, I will share the tricks that worked for me.

Let’s see in steps how I fixed and how you can fix it.

Various methods to fix no audio in Ubuntu

There could be various reasons why there is no sound in Ubuntu. The fix depends on the kind of problem you have. Before you take the steps to fix it, I suggest get some information about your system, specially about the audio related hardware.

Install inxi tool first:

sudo apt install inxi

Now check the system, machine and audio information with this command:

inxi -SMA

You should see some information like this:

[email protected]:~$ inxi -SMA
System:
  Host: itsfoss Kernel: 5.4.0-18-generic x86_64 bits: 64 
  Desktop: Gnome 3.35.91 Distro: Ubuntu 20.04 LTS (Focal Fossa) 
Machine:
  Type: Laptop System: Dell product: XPS 13 9360 v: N/A 
  serial: <superuser/root required> 
  Mobo: Dell model: 05JK94 v: A00 serial: <superuser/root required> 
  UEFI: Dell v: 2.13.0 date: 11/14/2019 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.4.0-18-generic

Look closely in the audio section of the above output. It tells that it is Intel Sunrise Point-LP HD Audio and it has the Linux driver snd_hda_intel and the sound is served with Alsa. This information maybe useful in some stages of your audio troubleshooting.

Fixing dummy output in sound settings

First step, just to verify, check if the sound is not muted. Once you verify this, go to Sound Settings:

Fix No SOund In Ubuntu 13.04

In the Sound Settings, you’ll find that you have practically nothing here except a dummy output. Quite frustrating. It means that your sound card is not even recognized. Puff!

Fix No Audio after installing Ubuntu 13.04

No worries. The one shot solution which fixed the sound problem for me on my Intel powered Dell Inspiron is to force reload Alsa. To do that, use the following command in terminal (Ctrl+Alt+T):

sudo alsa force-reload

The output will be like this.

No sound in Ubuntu 13.04

You may think that it is hanged or still in processing but it takes only couple of seconds. You can simply close it afterwards by using Ctrl+C.

Now, you need to reboot your computer. Either play some music/video files or check in the system settings to see if it worked for you.

No-Sound-in-Ubuntu-Fixed

First Alternate method to fix no sound in Ubuntu

If the above problem did not fix it for you, try reinstalling Alsa and Pulse audio in the following manner:

sudo apt-get install --reinstall alsa-base pulseaudio

And force reload Alsa again:

sudo alsa force-reload

Restart and check if sound is back or not.

Second alternate method to fix no sound in Ubuntu

Try starting Pulseaudio and see if it works:

 pulseaudio --start

Third alternate method: remove old Pulseaudio config

Go to your home directory and then go to the hidden config directory. Rename the directory named pulse here:

mv ~/.config/pulse ~/.config/old_pulse

Now reboot your system. The pulse directory should be created afresh and you should have sound.

Third alternate method: Try alsamixer

Open a terminal and use the following command to open alsamixer:

alsamixer

You should see a screen like this:

alsamixer in Ubuntu Linux

Check if the speakers or your desired audio output is muted here. MM means mute and OO means unmute. If your desired audio output (mostly it’s speakers) or the Master is muted, unmute it.

You can exit the screen using Esc key.

Note that if alsamixer command returns error, it’s probably because you have more than one sound card. In that case, you need to specify the sound card number (refer to the inxi output I mentioned in the beginning) like this:

alsamixer -c 1

Fourth alternate method to fix no audio in Ubuntu

Speed dispatcher is the feature that allows your system to convert text to speech. Sometimes, it conflicts with other audio settings. If you do not need this feature, you may try disabling it as it may bring your audio back.

Open the terminal and edit speech-dispatcher file by using the following command:

sudo gedit /etc/default/speech-dispatcher

In here, change RUN=yes to RUN=no. Reboot and enjoy the sound.

Fifth alternate method (specially for Lenovo Carbon X1)

A few of It’s FOSS readers mentioned that none of the above methods worked for their Lenovo Thinkpad Carbon X1 7th Gen laptop.

I looked into various places and found that this newer model has issues with Linux. While Linux kernel 5.5 and above versions has improved support for this model, it is still tricky for Ubuntu 18.04 and Mint 19 users because the kernel in use is still 5.3.

Check your Linux kernel version and if it is 5.4 or lower, try this possible workaround that is suggested by Arch Linux and Ubuntu developers.

Open the alsa configuration file (command might be different for Mint because Gedit text editor is not used in Mint):

sudo gedit /etc/modprobe.d/alsa-base.conf

Add the following line to the end of this file:

options snd-hda-intel dmic_detect=0

Save and close the file and reboot your system. You should have the audio back.

If it fixed your sound problem, you may want to fix brightness issue as well. Fixing the sound problem is definitely one of the must do things after installing Ubuntu.

Donate Itsfoss

If one of the above mentioned methods worked for you, please leave a comment below specifying the method that saved your day. Any other suggestions and feedback is also welcomed.

Similar Posts

  • None of the 5 tips mentioned worked for me. But… just inserting a headset and removing did the trick. Dell XPS 15, Ubuntu 20.04

  • Wow. I can’t believe it. The 5th option worked! After trying so many others. It was kind of scary adding that last line after the warnings I got.

  • Dell 700M laptop running Lubuntu 18.04: On my system it turned out that Speed Dispatcher was causing the problem. I had excellent sound with it on, but only through my headphones. Turning Speed Dispatcher off did the trick; now my Mozart is sounding wonderful through my on-board speakers once again. Thank you so much Abhishek! I’d tried countless other suggestions, but after finding your page I was up and running in no time.