How to Create a Bootable Ubuntu USB Drive for Mac in OS X

Here’s the scenario. You have got a Macbook and want to install Ubuntu on it or perhaps on some other system.

I am going to show you two ways of creating a live Linux USB in macOS:

  1. Create live USB using Etcher GUI tool
  2. Create live USB using command line

I’ll also tell you how to boot from a live Linux USB on a MacBook.

For both methods, you need:

  • A USB key (pen drive) of at least 4 GB in size
  • Internet connection for downloading Linux ISO and tools

I am using Ubuntu in this tutorial but it should work for other Linux distributions as well.

Let’s start with the graphical method first.

Method 1: Create live Ubuntu USB in macOS with Etcher

Trust me, the Etcher tool makes live USB creation a painless task. All you need to do is to download Linux ISO, download Etcher, plugin the USB and hit the flash button.

I won’t leave you at that description. Let me show the steps in detail.

Step 1: Download the ISO image of Ubuntu Linux

The first step is to download the ISO of Ubuntu or whichever Linux you want to use. I show the steps for Ubuntu.

Head over to Ubuntu website. You’ll find the latest Ubuntu releases under the download section. Download the one you like.

You can also use torrents to download Ubuntu if you have a slow and/or inconsistent internet.

Step 2: Download and install Etcher on macOS

The next step is to download Etcher. You can get it from the homepage of the project website.

It is downloaded in DMG format. As a macOS user you probably already know how to install DMG file. Double click on the downloaded file and it will open the installer. Drag the Etcher icon to the Applications icon. That’s it.

install etcher macos
Installing Etcher on macOS

Step 3: Using Etcher to create bootable Linux USB

Plugin your USB. Make sure that there is no important data on it because it will be formatted.

Next, start Etcher. It should automatically recognize the plugged in USB (unless there are more than one). If it does not, click on the ‘Target’ button and select the correct USB device.

Browse to the downloaded Linux ISO file and hit the flash button.

using etcher macos
Creating Ubuntu live USB

It will take a few minutes at the most to complete the process. When the process completes, you should see a message that the “disk you inserted was not readable by this computer“.

error message after live usb macos
Ignore this error message

That is okay. It’s just that the USB is now in a format your macOS does not like and hence it complains. Once the purpose of Linux USB is over, you can use Gparted tool in macOS or Linux to format this USB back to normal.

As long as Etcher gives you a success message about flash completion, no need to worry about it.

etcher success message

Step 4: Booting from the live Ubuntu USB on macOS

You should verify if the live USB works. To do that, restart your macOS. At start up when the Apple tune starts up, press and hold option (or alt) key.

You should see a few options. If you see two EFI Boot options, choose either of them.

booting from live ubuntu usb macbook
Choose either of the EFI boot

You should see the grub screen with option to boot into live Ubuntu session (the first option). Select it and enjoy it.

live ubuntu session macbook
The first option is for entering the live Ubuntu session

Method 2: Create bootable Ubuntu USB in macOS using command line

This is an old method but evergreen method. I used this method when Etcher did not exist.

Be careful while using the command. Following all the steps carefully will have you going. Let’s see what you need to for a bootable USB:

Step 1: Format the USB drive

Apple is known for defining its own standards and no surprises that Mac OS X has its own file system type known as Mac OS Extended or HFS Plus. So the first thing you would need to do is to format your USB drive in Mac OS Extended format.

To format the USB drive, plug in the USB key. Go to Disk Utility program from Launchpad (A rocket symboled icon in the bottom plank).

Disk Utility Mac
  • In Disk Utility, from the left hand pane, select the USB drive to format.
  • Click the Partition tab in the right side pane.
  • From the drop-down menu, select 1 Partition.
  • Name this drive anything you desire.
  • Next, change the Format to Mac OS Extended (Journaled)

The screenshot below should help you.

Format USB drive in Mac to  make it bootable

There is one last thing to do before we go with formatting the USB. Click the Options button in the right side pane and make sure that the partition scheme is GUID Partition Table.

Make a bootable USB in Mac

When all is set to go, just hit the Apply button. It will give you a warning message about formatting the USB drive. Of course hit the Partition button to format the USB drive.

Step 2: Download Ubuntu

Of course, you need to download ISO image of Ubuntu desktop. Jump to Ubuntu website to download your favorite Ubuntu desktop OS. Since you are using a Macbook Air, I suggest you to download the 64 Bit version of whichever version you want. Ubuntu 14.04 is the latest LTS version, and this is what I would recommend to you.

Step 3: Convert ISO to IMG

The file you downloaded is in ISO format but we need it to be in IMG format. This can be easily done using hdiutil command tool. Open a terminal, either from Launchpad or from the Spotlight, and then use the following command to convert the ISO to IMG format:

hdiutil convert -format UDRW -o ~/Path-to-IMG-file ~/Path-to-ISO-file

Normally the downloaded file should be in ~/Downloads directory. So for me, the command is like this:

hdiutil convert -format UDRW -o ~/Downloads/ubuntu-14.10-desktop-amd64 ~/Downloads/ubuntu-14.10-desktop-amd64.iso
ISO To IMG conversion

You might notice that I did not put a IMG extension to the newly converted file. It is fine as the extension is symbolic and it is the file type that matters not the file name extension. Also, the converted file may have an additional .dmg extension added to it by Mac OS X. Don’t worry, it’s normal.

Step 4: Get the device number for USB drive

The next thing is to get the device number for the USB drive. Run the following command in terminal:

diskutil list

It will list all the ‘disks’ currently available in the system. You should be able to identify the USB disk by its size. To avoid confusion, I would suggest that you should have just one USB drive plugged in. In my case, the device number is 2 (for a USB of size 8 GB): /dev/disk2

create bootable USB drive in Mac OS X

When you got the disk number, run the following command:

diskutil unmountDisk /dev/diskN

Where N is the device number for the USB you got previously. So, in my case, the above command becomes:

diskutil unmountDisk /dev/disk2

The result should be: Unmount of all volumes on disk2 was successful.

Step 5: Creating the bootable USB drive of Ubuntu in Mac OS X

And finally we come to the final step of creating the bootable USB drive. We shall be using dd command which is a very powerful and must be used with caution. Therefore, do remember the correct device number of your USB drive or else you might end up corrupting Mac OS X.

Use dd command in the following manner to create live USB:

sudo dd if=/Path-to-IMG-DMG-file of=/dev/rdiskN bs=1m

Here, we are using dd (copy and convert) to copy and convert input file (if) IMG to diskN.  I hope you remember where you put the converted IMG file, in step 3. For me the command was like this:

sudo dd if=~/Downloads/ubuntu-14.10-desktop-amd64.dmg of=/dev/rdisk2 bs=1m

As we are running the above command with super user privileges (sudo), it will require you to enter the password. Similar to Linux, you won’t see any asterisks or something to indicate that you have entered some keyboard input, but that’s the way Unix terminal behaves.

Even after you enter the password, you won’t see any immediate output and that’s normal. It will take a few minutes for the process to complete.

Step 6: Complete the bootable USB drive process

Once the dd command finishes its process, you may see a dialogue box saying: The disk you inserted was not readable by this computer.

Bootable USB Mac OS X

Don’t panic. Everything is just fine. Just don’t click either of Initialize, Ignore or Eject just now. Go back to the terminal. You’ll see some information about the last completed process. For me it was:

1109+1 records in
1109+1 records out
1162936320 bytes transferred in 77.611025 secs (14984164 bytes/sec)

Create_bootable_USB_Mac_OSX_1

Now, in the terminal use the following command to eject our USB disk:

diskutil eject /dev/diskN

N is of course the device number we have used previously which is 2 in my case:

diskutil eject /dev/disk2

Once ejected, click on Ignore in the dialogue box that appeared previously. Now your bootable USB disk is ready. Remove it from the system.

Step 7: Checking your newly created bootable USB disk

Once you have completed the mammoth task of creating a live USB of USB in Mac OS X, it is time to test your efforts.

  • Plugin the bootable USB and reboot the system.
  • At start up when the Apple tune starts up, press and hold option (or alt) key.
  • This should present you with the available disks to boot in to. I presume you know what to do next.

For me it showed tow EFI boot:

Booting Ubuntu from USB in Mac OS X

I selected the first one and it took me straight to Grub screen:

Ubuntu grub in Mac OS X

I hope this guide helped you to create a bootable USB disk of Ubuntu for Mac in OS X. We’ll see how to dual boot Ubuntu with OS X in next article. Stay tuned.

About the author
Abhishek Prakash

Abhishek Prakash

Created It's FOSS 11 years ago to share my Linux adventures. Have a Master's degree in Engineering and years of IT industry experience. Huge fan of Agatha Christie detective mysteries ๐Ÿ•ต๏ธโ€โ™‚๏ธ

Become a Better Linux User

With the FOSS Weekly Newsletter, you learn useful Linux tips, discover applications, explore new distros and stay updated with the latest from Linux world

It's FOSS

Great! Youโ€™ve successfully signed up.

Welcome back! You've successfully signed in.

You've successfully subscribed to It's FOSS.

Success! Check your email for magic link to sign-in.

Success! Your billing info has been updated.

Your billing was not updated.